source: projects/specs/trunk/c/compiz-plugins/compiz-plugins-vl.spec @ 521

Revision 521, 7.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define plugins animation colorfilter expo ezoom jpeg mag mousepoll neg opacify put resizeinfo ring scaleaddon session shift snap staticswitcher text thumbnail vpswitch wall winrules workarounds
2
3Name: compiz-plugins
4Version: 0.8.2
5Release: 1%{?_dist_release}
6Summary: Collection of Compiz plugins
7Summary(ja): Compiz プラグイン集
8Group: User Interface/Desktops       
9License: GPLv2+       
10URL: http://compiz.org           
11
12Source0: http://releases.compiz.org/0.8.2/%{name}-main-%{version}.tar.bz2
13# Upstream commit 46960f12a9d213e5f0e841557e2ed2f7ea18cc79
14Patch2: compiz-0.7.8-x_to_glx_workaround.patch
15# Upstream commit 319c3c40ebd0b37c8132ecf60d02154e94299832
16Patch3: compiz-plugin-0.8.2-fix-initialize.patch
17
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20
21# libdrm is not available on these arches
22ExcludeArch: s390 s390x ppc64
23
24BuildRequires: compiz-devel >= %{version}
25BuildRequires: compiz-bcop >= %{version}
26BuildRequires: gettext
27BuildRequires: cairo-devel
28BuildRequires: pango-devel
29BuildRequires: perl(XML::Parser)
30BuildRequires: mesa-libGLU-devel
31BuildRequires: libXrender-devel
32BuildRequires: GConf2
33BuildRequires: libjpeg-devel
34BuildRequires: gawk
35Requires: compiz
36Obsoletes: beryl-plugins
37Obsoletes: compiz-fusion < 0.8.0
38Provides: compiz-fusion = %{version}
39
40%description
41This package contains Compiz plugins (a.k.a. CompizFusion)
42
43
44%package gnome
45Summary: Compiz gnome configuration
46Summary(ja): Compiz gnome configuration
47Group: User Interface/Desktops
48Requires: %{name} = %{version}
49Requires(pre): GConf2
50Requires(post): GConf2
51Requires(preun): GConf2
52Obsoletes: compiz-fusion-gnome < 0.8.0
53
54%description gnome
55This package contains the GNOME configuration for Compiz
56
57%package devel
58Group: Development/Libraries
59Summary: Development files for Compiz
60Summary(ja): Development files for Compiz
61Requires: compiz-devel
62Requires: %{name} = %{version}
63Requires: cairo-devel
64Requires: pango-devel
65Obsoletes: compiz-fusion-devel < 0.8.0
66
67%description devel
68This package contain development files required for developing other plugins
69
70
71%prep
72%setup -q -n %{name}-main-%{version}
73%patch2 -p1 -b .xglx
74%patch3 -p1 -b .fix-init-var
75
76%build
77%configure --enable-schemas
78make %{?_smp_mflags}
79
80
81%install
82rm -rf $RPM_BUILD_ROOT
83make install DESTDIR=$RPM_BUILD_ROOT
84
85rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.la
86rm -f $RPM_BUILD_ROOT%{_libdir}/compiz/*.a
87
88
89%find_lang %{name}-main
90
91
92%post gnome
93export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
94for p in in %{plugins}; do
95    echo %{_sysconfdir}/gconf/schemas/compiz-$p.schemas ;done \
96    | xargs %{_bindir}/gconftool-2 --makefile-install-rule >& /dev/null ||:
97
98%pre gnome
99if [ "$1" -gt 1 ]; then
100  export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
101  for p in in %{plugins}; do
102        echo %{_sysconfdir}/gconf/schemas/compiz-$p.schemas ;done \
103        | xargs %{_bindir}/gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
104fi
105
106%preun gnome
107if [ "$1" -eq 0 ]; then
108  export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
109  for p in in %{plugins}; do
110        echo %{_sysconfdir}/gconf/schemas/compiz-$p.schemas ;done \
111        | xargs %{_bindir}/gconftool-2 --makefile-uninstall-rule >& /dev/null ||:
112fi
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117
118%files -f %{name}-main.lang
119%defattr(-,root,root,-)
120%doc COPYING AUTHORS
121%{_libdir}/compiz/*.so
122%{_datadir}/compiz/*.xml
123%{_datadir}/compiz/filters/
124%{_datadir}/compiz/Oxygen/
125%{_datadir}/compiz/Gnome/
126
127%files  gnome
128%defattr(-,root,root,-)
129%{_sysconfdir}/gconf/schemas/*.schemas
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/compiz/
134%{_libdir}/pkgconfig/compiz-*
135
136
137%changelog
138* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
139- update to 0.8.2
140- compiz-fusion is merged in compiz
141  - rename compiz-fusion to compiz-plugins
142  - add Obsoletes: compiz-fusion < 0.8.0
143  - add Provides: compiz-fusion = %%{version}
144- add Patch3 from upstream
145
146* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
147- fix pre/post scripts for speeding up gconf schema installation
148
149* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
150- add Patch1: fix winrules plugin from upstream
151- add Patch2: fix broken drawing in some windows
152- add Patch3: fix CVS-2008-6514
153
154* Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
155- new upstream release
156
157* Wed Jul 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
158- new upstream release
159
160* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
161- new upstream release
162
163* Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
164- initial build for Vine Linux
165
166* Tue Mar 25 2008 Adel Gadllah <adel.gadllah@gmail.com> 0.7.2-2
167- Fix scriptlet failure
168
169* Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> 0.7.2-1
170- Update to 0.7.2
171
172* Sat Feb 09 2008 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-14
173- Rebuild for gcc-4.3
174
175* Sun Jan 06 2008 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-13
176- Readded accidently dropped memoryleak fix
177
178* Thu Jan 03 2008 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-12
179- Fix build with gcc43
180
181* Sun Dec 30 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-11
182- Fix stupid typo in the patch
183
184* Thu Dec 27 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-10
185- Plug small memory leak
186
187* Thu Dec 27 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-9
188- Don't break legacy apps that want to unfullscreen themselves
189
190* Tue Dec 25 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-8
191- Fix fullscreen for flash windows when legacy fullscreen is
192  enabled.
193
194* Sat Dec 01 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-7
195- Adding the patch isn't enough .. we have to apply it ;)
196
197* Sat Dec 01 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-6
198- Backport upstream openoffice menu fix
199
200* Sun Oct 28 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-5
201- Rediff patch
202
203* Sun Oct 28 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-4
204- Fix previous patch
205
206* Sat Oct 27 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-3
207- Apply patch from upstream to fix RH #354601
208
209* Tue Oct 22 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-2
210- Obsolete beryl-plugins
211
212* Mon Oct 22 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.6.0-1
213- Update to 0.6.0
214
215* Fri Oct 12 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-10.09b700
216- Fix BuildRequries to build missing plugins (RH #327411)
217- Mock isn't broken but the Buildrequires ... remove hack
218
219* Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> 0.5.2-9.09b700
220- >= instead of = to allow compiz upgrade flexibility
221
222* Sun Sep 23 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-8.09b700
223- Fix changelog date
224
225* Sat Sep 22 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-7.09b700
226- Update to 0.6 branch (builds against current compiz)
227
228* Wed Sep 19 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-6
229- Add animation to plugin list
230
231* Sat Sep 15 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-5
232- Fix gconf schemas install (RH #53692)
233
234* Fri Aug 24 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-4
235- Remove redundant buildrequires
236
237* Fri Aug 24 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-3
238- BuildRequire gawk
239
240* Wed Aug 22 2007 Adel Gadllah <adel.gadllag@gmail.com> 0.5.2-2
241- Fix gconf schemas (un)installation
242
243* Sat Aug 18 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-1
244- Initial build
245
Note: See TracBrowser for help on using the repository browser.