source: projects/specs/trunk/c/commoncpp2/commoncpp2-vl.spec @ 9154

Revision 9154, 4.1 KB checked in by inagaki, 9 years ago (diff)

2014-12-14 Ryoichi INAGAKI <ryo1@…>

  • commoncpp2, google-gadgets: updated


Line 
1Summary: GNU Common C++ class framework
2Summary(ja): GNU 共通 C++ クラスフレームワーク
3Name: commoncpp2
4Version: 1.8.1
5Release: 1%{?_dist_release}
6
7License: GPLv2+ with exceptions
8Group: System Environment/Libraries
9URL: http://www.gnu.org/software/commoncpp/
10
11Source0: https://ftp.gnu.org/gnu/commoncpp/commoncpp2-%{version}.tar.gz
12Patch1: commoncpp2-1.8.1-statfix.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libxml2-devel
16BuildRequires: zlib-devel
17BuildRequires: doxygen
18
19%description
20GNU Common C++ is a portable and highly optimized class framework for writing
21C++ applications that need to use threads, sockets, XML parsing,
22serialization, config files, etc. This framework offers a class foundation
23that hides platform differences from your C++ application so that you need
24not write platform specific code. GNU Common C++ has been ported to compile
25natively on most platforms which support posix threads.
26
27%package devel
28Summary: Header files and libraries for %{name} development
29Summary(ja): %{name} での開発に必要なヘッダファイルとライブラリ
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: pkgconfig
33Requires: libxml2-devel
34Requires: zlib-devel
35Requires(post): /sbin/install-info
36Requires(preun): /sbin/install-info
37
38%description devel
39The %{name}-devel package contains the header files and libraries needed
40to develop programs that use the %{name} library.
41
42%package        doc
43Summary:        Documents for the %{name} library
44Group:          Documentation
45Requires:       %{name} = %{version}-%{release}
46BuildArch:      noarch
47
48%description    doc
49The %{name}-doc package provide documents for zinnia library that
50use %{name}.
51
52
53
54%prep
55%setup -q
56#patch0 -p1
57%patch1 -p1
58
59%build
60%configure \
61        --disable-static \
62        --disable-dependency-tracking
63%{__make} #%%{?_smp_mflags} smp building disabled
64
65%install
66rm -rf $RPM_BUILD_ROOT
67make install DESTDIR=%{buildroot}
68rm -f %{buildroot}%{_infodir}/dir
69find %{buildroot} -name '*.la' -exec rm -f {} \;
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post -p /sbin/ldconfig
75
76%post -n %{name}-devel
77/sbin/install-info %{_infodir}/commoncpp2.info %{_infodir}/dir || :
78
79%preun -n %{name}-devel
80if [ $1 = 0 ]; then
81    /sbin/install-info --delete %{_infodir}/commoncpp2.info %{_infodir}/dir || :
82fi
83
84%postun -p /sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc COPYING README ChangeLog
89%{_libdir}/*.so.*
90
91%files devel
92%defattr(-,root,root,-)
93%dir %{_includedir}/cc++
94%{_includedir}/cc++/*
95%{_bindir}/ccgnu2-config
96%{_libdir}/*.so
97%{_libdir}/pkgconfig/libccext2.pc
98%{_libdir}/pkgconfig/libccgnu2.pc
99%{_datadir}/aclocal/ost_check2.m4
100%{_infodir}/commoncpp2.info*
101
102%files doc
103%defattr(-,root,root,-)
104%doc doc/html
105
106%changelog
107* Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 1.8.1-1
108- updated to 1.8.1
109- added Patch1 from FC
110- split documents into subpackage
111
112* Sun Jun  3 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-2
113- rebuilt with rpm-4.8.1-3
114
115* Sat May  8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.8.0-1
116- Initial build for Vine Linux
117
118* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.3-2
119- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
120
121* Mon Apr 06 2009 Andreas Thienemann <andreas@bawue.net> - 1.7.3-1
122- Updated to new upstream version 1.7.3
123
124* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-3
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Tue Jul 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.1-2
128- fix license tag
129
130* Wed Feb 06 2008 Andreas Thienemann <andreas@bawue.net> - 1.6.1-1
131- Updated to new upstream version 1.6.1
132- Reverted the ld-check patch as it's no longer needed
133
134* Fri Nov 10 2006 Andreas Thienemann <andreas@bawue.net> - 1.5.0-1
135- Updated package to 1.5.0
136
137* Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.2-1
138- Updated to 1.4.2
139
140* Sun May 28 2006 Andreas Thienemann <andreas@bawue.net> - 1.4.1-1
141- Updated to 1.4.1
142
143* Sun Feb 05 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.23-1
144- Incorporated suggestions for extras
145
146* Fri Feb 03 2006 Andreas Thienemann <andreas@bawue.net> - 1.3.22-1
147- Initial spec.
Note: See TracBrowser for help on using the repository browser.