source: projects/specs/trunk/c/colord/colord-vl.spec @ 9073

Revision 9073, 8.1 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME 3.14.1

Line 
1%bcond_with firstbuild
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary:   Color daemon
5Name:      colord
6Version:   1.1.7
7Release:   1%{?_dist_release}
8Group:     System Environment/Daemons
9License:   GPLv2+ and LGPLv2+
10URL:       http://gitorious.org/colord
11Source0:   http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
12
13BuildRequires: dbus-devel
14BuildRequires: docbook-utils
15BuildRequires: gettext
16BuildRequires: glib2-devel
17BuildRequires: intltool
18BuildRequires: lcms2-devel
19BuildRequires: libgudev1-devel
20BuildRequires: libgusb-devel
21BuildRequires: polkit-devel
22BuildRequires: sqlite3-devel
23BuildRequires: bash-completion
24%{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
25Requires: shared-color-profiles
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31%description
32colord is a low level system activated daemon that maps color devices
33to color profiles in the system context.
34
35%package devel
36Summary: Development package for %{name}
37Group:   Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: glib2-devel
40Requires: dbus-devel
41Requires: lcms2-devel
42
43%description devel
44Files for development with %{name}.
45
46# compat32
47%package -n compat32-%{name}
48Summary:  Color daemon
49Group:    System Environment/Daemons
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53colord is a low level system activated daemon that maps color devices
54to color profiles in the system context.
55
56%package -n compat32-%{name}-devel
57Summary: Development package for %{name}
58Group:   Development/Libraries
59Requires: compat32-%{name} = %{version}-%{release}
60
61%description -n compat32-%{name}-devel
62Files for development with %{name}.
63
64
65%prep
66%setup -q
67
68%build
69%configure \
70        --disable-static \
71        --disable-rpath \
72        --disable-examples \
73        --disable-dependency-tracking \
74        --disable-systemd-login
75
76make %{?_smp_mflags}
77
78%install
79make install DESTDIR=$RPM_BUILD_ROOT
80
81# Remove static libs and libtool archives.
82find %{buildroot} -name '*.la' -exec rm -f {} ';'
83find %{buildroot} -name '*.a' -exec rm -f {} ';'
84
85# databases
86touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
87touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
88
89%find_lang %{name}
90
91%post -p /sbin/ldconfig
92
93%postun
94/sbin/ldconfig
95if [ $1 -eq 0 ]; then
96  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
97fi
98
99%posttrans
100glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
101
102%post -n compat32-%{name} -p /sbin/ldconfig
103
104%postun -n compat32-%{name} -p /sbin/ldconfig
105
106%files -f %{name}.lang
107%defattr(-,root,root,-)
108%doc README AUTHORS NEWS COPYING
109%{_libexecdir}/colord
110%{_libexecdir}/colord-session
111%dir %{_localstatedir}/lib/colord
112%{_bindir}/*
113%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
114%{_datadir}/bash-completion/completions/colormgr
115%{_datadir}/color
116%{_datadir}/colord
117%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
118%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
119%{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
120%{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
121%{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
122%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
123%{_datadir}/man/man1/*.1.gz
124%{_libdir}/libcolord.so.*
125%{_libdir}/libcolordprivate.so.*
126%{_libdir}/libcolorhug.so.*
127%{_libdir}/colord-plugins/libcd_plugin_camera.so
128%{_libdir}/colord-plugins/libcd_plugin_scanner.so
129%{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
130%{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
131/lib/udev/rules.d/*.rules
132%{_libdir}/colord-sensors
133%ghost %{_localstatedir}/lib/colord/*.db
134
135%files devel
136%defattr(-,root,root,-)
137%{_includedir}/colord-1
138%{_libdir}/libcolord.so
139%{_libdir}/libcolordprivate.so
140%{_libdir}/libcolorhug.so
141%{_libdir}/pkgconfig/colord.pc
142%{_libdir}/pkgconfig/colorhug.pc
143%{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
144%{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
145
146# compat32
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root,-)
150%{_libdir}/libcolord.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-,root,root,-)
154%{_libdir}/libcolord.so
155%endif
156
157%changelog
158* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
159- update to 1.1.7
160
161* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
162- new upstream release
163
164* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
165- new upstream release
166
167* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
168- new upstream release
169
170* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
171- new upstream release
172
173* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
174- new upstream release
175- add BuildRequires: bash-completion
176
177* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
178- new upstream release
179
180* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
181- new upstream release
182
183* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
184- new upstream release
185- remove BuildRequires: sane-devel
186
187* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
188- new upstream release
189- change BuildRequires: libgusb-devel instead of libusb1-devel
190- add BuildRequires: gobject-introspection-devel
191
192* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
193- new upstream release
194
195* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
196- new upstream release
197
198* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
199- new upstream release
200
201* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
202- new upstream release
203
204* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
205- new upstream release
206
207* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
208- new upstream release
209
210* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
211- new upstream release
212
213* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
214- new upstream release
215- create compat32 sub packages
216
217* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
218- initial build for Vine Linux
219
220
221* Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
222- New upstream version
223
224* Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
225- New upstream version
226
227* Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
228- New upstream version
229- Add a webcam device kind
230- Add a timestamp when making profiles default
231- Add support for reading and writing ICC profile metadata
232- Allow the client to pass file descriptors out of band to CreateProfile
233- Prettify the device vendor and model names
234- Split out the sensors into runtime-loadable shared objects
235- Provide some GIO async variants for the methods in CdClient
236- Ensure GPhoto2 devices get added to the device list
237
238* Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
239- New upstream version.
240- Create /var/lib/colord at buildtime not runtime for SELinux
241- Ensure profiles with embedded profile checksums are parsed correctly
242- Move the colorimeter rules to be run before 70-acl.rules
243- Stop watching the client when the sensor is finalized
244- Ensure the source is destroyed when we unref CdUsb to prevent a crash
245- Only enable the volume mount tracking when searching volumes
246
247* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
248- Own /var/lib/colord and /var/lib/colord/*.db
249
250* Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
251- New upstream version.
252
253* Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
254- New upstream version.
255
256* Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
257- New upstream version.
258
259* Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
260- New upstream version.
261
262* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
264
265* Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
266- Rebuild in the vain hope koji isn't broken today.
267
268* Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
269- New upstream version.
270
271* Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
272- Initial version for Fedora package review.
Note: See TracBrowser for help on using the repository browser.