source: projects/specs/trunk/c/colord/colord-vl.spec @ 7633

Revision 7633, 7.6 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%bcond_with firstbuild
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary:   Color daemon
5Name:      colord
6Version:   0.1.33
7Release:   1%{?_dist_release}
8Group:     System Environment/Daemons
9License:   GPLv2+ and LGPLv2+
10URL:       http://gitorious.org/colord
11Source0:   http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
12
13BuildRequires: dbus-devel
14BuildRequires: docbook-utils
15BuildRequires: gettext
16BuildRequires: glib2-devel
17BuildRequires: intltool
18BuildRequires: lcms2-devel
19BuildRequires: libgudev1-devel
20BuildRequires: libgusb-devel
21BuildRequires: polkit-devel
22BuildRequires: sqlite3-devel
23%{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
24Requires: shared-color-profiles
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30%description
31colord is a low level system activated daemon that maps color devices
32to color profiles in the system context.
33
34%package devel
35Summary: Development package for %{name}
36Group:   Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: glib2-devel
39Requires: dbus-devel
40Requires: lcms2-devel
41
42%description devel
43Files for development with %{name}.
44
45# compat32
46%package -n compat32-%{name}
47Summary:  Color daemon
48Group:    System Environment/Daemons
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52colord is a low level system activated daemon that maps color devices
53to color profiles in the system context.
54
55%package -n compat32-%{name}-devel
56Summary: Development package for %{name}
57Group:   Development/Libraries
58Requires: compat32-%{name} = %{version}-%{release}
59
60%description -n compat32-%{name}-devel
61Files for development with %{name}.
62
63
64%prep
65%setup -q
66
67%build
68%configure \
69        --disable-static \
70        --disable-rpath \
71        --disable-examples \
72        --disable-dependency-tracking \
73        --disable-systemd-login
74
75make %{?_smp_mflags}
76
77%install
78make install DESTDIR=$RPM_BUILD_ROOT
79
80# Remove static libs and libtool archives.
81find %{buildroot} -name '*.la' -exec rm -f {} ';'
82find %{buildroot} -name '*.a' -exec rm -f {} ';'
83
84# databases
85touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
86touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
87
88%find_lang %{name}
89
90%post -p /sbin/ldconfig
91
92%postun
93/sbin/ldconfig
94if [ $1 -eq 0 ]; then
95  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
96fi
97
98%posttrans
99glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
100
101%post -n compat32-%{name} -p /sbin/ldconfig
102
103%postun -n compat32-%{name} -p /sbin/ldconfig
104
105%files -f %{name}.lang
106%defattr(-,root,root,-)
107%doc README AUTHORS NEWS COPYING
108%{_libexecdir}/colord
109%{_libexecdir}/colord-session
110%dir %{_localstatedir}/lib/colord
111%{_bindir}/*
112%{_sysconfdir}/bash_completion.d/colormgr-completion.bash
113%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
114%{_datadir}/color
115%{_datadir}/colord
116%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
117%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
118%{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
119%{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
120%{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
121%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
122%{_datadir}/man/man1/*.1.gz
123%{_libdir}/libcolord.so.*
124%{_libdir}/libcolordprivate.so.*
125%{_libdir}/libcolorhug.so.*
126%{_libdir}/colord-plugins/libcd_plugin_camera.so
127%{_libdir}/colord-plugins/libcd_plugin_scanner.so
128%{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
129%{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
130%config %{_sysconfdir}/colord.conf
131/lib/udev/rules.d/*.rules
132%{_libdir}/colord-sensors
133%ghost %{_localstatedir}/lib/colord/*.db
134
135%files devel
136%defattr(-,root,root,-)
137%{_includedir}/colord-1
138%{_libdir}/libcolord.so
139%{_libdir}/libcolordprivate.so
140%{_libdir}/libcolorhug.so
141%{_libdir}/pkgconfig/colord.pc
142%{_libdir}/pkgconfig/colorhug.pc
143%{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
144%{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
145
146# compat32
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-,root,root,-)
150%{_libdir}/libcolord.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-,root,root,-)
154%{_libdir}/libcolord.so
155%endif
156
157%changelog
158* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.33-1
159- new upstream release
160
161* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.26-1
162- new upstream release
163
164* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.24-1
165- new upstream release
166- remove BuildRequires: sane-devel
167
168* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.23-1
169- new upstream release
170- change BuildRequires: libgusb-devel instead of libusb1-devel
171- add BuildRequires: gobject-introspection-devel
172
173* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.21-1
174- new upstream release
175
176* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.19-1
177- new upstream release
178
179* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.18-1
180- new upstream release
181
182* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.15-1
183- new upstream release
184
185* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.14-1
186- new upstream release
187
188* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.13-1
189- new upstream release
190
191* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.12-1
192- new upstream release
193
194* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.11-1
195- new upstream release
196- create compat32 sub packages
197
198* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.10-1
199- initial build for Vine Linux
200
201
202* Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
203- New upstream version
204
205* Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
206- New upstream version
207
208* Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
209- New upstream version
210- Add a webcam device kind
211- Add a timestamp when making profiles default
212- Add support for reading and writing ICC profile metadata
213- Allow the client to pass file descriptors out of band to CreateProfile
214- Prettify the device vendor and model names
215- Split out the sensors into runtime-loadable shared objects
216- Provide some GIO async variants for the methods in CdClient
217- Ensure GPhoto2 devices get added to the device list
218
219* Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
220- New upstream version.
221- Create /var/lib/colord at buildtime not runtime for SELinux
222- Ensure profiles with embedded profile checksums are parsed correctly
223- Move the colorimeter rules to be run before 70-acl.rules
224- Stop watching the client when the sensor is finalized
225- Ensure the source is destroyed when we unref CdUsb to prevent a crash
226- Only enable the volume mount tracking when searching volumes
227
228* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
229- Own /var/lib/colord and /var/lib/colord/*.db
230
231* Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
232- New upstream version.
233
234* Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
235- New upstream version.
236
237* Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
238- New upstream version.
239
240* Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
241- New upstream version.
242
243* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
245
246* Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
247- Rebuild in the vain hope koji isn't broken today.
248
249* Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
250- New upstream version.
251
252* Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
253- Initial version for Fedora package review.
Note: See TracBrowser for help on using the repository browser.