source: projects/specs/trunk/c/colord/colord-vl.spec @ 7294

Revision 7294, 6.9 KB checked in by Takemikaduchi, 11 years ago (diff)

KDE-4.9.5

Line 
1%bcond_with firstbuild
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
4Summary:   Color daemon
5Name:      colord
6Version:   0.1.26
7Release:   1%{?_dist_release}
8Group:     System Environment/Daemons
9License:   GPLv2+ and LGPLv2+
10URL:       http://gitorious.org/colord
11Source0:   http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
12
13BuildRequires: dbus-devel
14BuildRequires: docbook-utils
15BuildRequires: gettext
16BuildRequires: glib2-devel
17BuildRequires: intltool
18BuildRequires: lcms2-devel
19BuildRequires: libgudev1-devel
20BuildRequires: libgusb-devel
21BuildRequires: polkit-devel
22BuildRequires: sqlite3-devel
23%{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
24Requires: shared-color-profiles
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: Takemikaduchi
29
30%description
31colord is a low level system activated daemon that maps color devices
32to color profiles in the system context.
33
34%package devel
35Summary: Development package for %{name}
36Group:   Development/Libraries
37Requires: %{name} = %{version}-%{release}
38Requires: glib2-devel
39Requires: dbus-devel
40Requires: lcms2-devel
41
42%description devel
43Files for development with %{name}.
44
45# compat32
46%package -n compat32-%{name}
47Summary:  Color daemon
48Group:    System Environment/Daemons
49Requires: %{name} = %{version}-%{release}
50
51%description -n compat32-%{name}
52colord is a low level system activated daemon that maps color devices
53to color profiles in the system context.
54
55%package -n compat32-%{name}-devel
56Summary: Development package for %{name}
57Group:   Development/Libraries
58Requires: compat32-%{name} = %{version}-%{release}
59
60%description -n compat32-%{name}-devel
61Files for development with %{name}.
62
63
64%prep
65%setup -q
66
67%build
68%configure \
69        --disable-static \
70        --disable-rpath \
71        --disable-examples \
72        --disable-dependency-tracking
73
74sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
75sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
76
77make %{?_smp_mflags}
78
79%install
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# Remove static libs and libtool archives.
83find %{buildroot} -name '*.la' -exec rm -f {} ';'
84find %{buildroot} -name '*.a' -exec rm -f {} ';'
85
86# databases
87touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
88touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
89
90%find_lang %{name}
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%post -n compat32-%{name} -p /sbin/ldconfig
97
98%postun -n compat32-%{name} -p /sbin/ldconfig
99
100%files -f %{name}.lang
101%defattr(-,root,root,-)
102%doc README AUTHORS NEWS COPYING
103%{_libexecdir}/colord
104%dir %{_localstatedir}/lib/colord
105%{_bindir}/*
106%{_sysconfdir}/bash_completion.d/colormgr-completion.bash
107%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
108%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
109%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
110%{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
111%{_datadir}/man/man1/*.1.gz
112%{_libdir}/libcolord.so.*
113%{_libdir}/colord-plugins/libcd_plugin_camera.so
114%{_libdir}/colord-plugins/libcd_plugin_scanner.so
115%{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
116%config %{_sysconfdir}/colord.conf
117/lib/udev/rules.d/*.rules
118%{_libdir}/colord-sensors
119%ghost %{_localstatedir}/lib/colord/*.db
120
121%files devel
122%defattr(-,root,root,-)
123%{_includedir}/colord-1
124%{_libdir}/libcolord.so
125%{_libdir}/pkgconfig/colord.pc
126%{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
127
128# compat32
129%if %{build_compat32}
130%files -n compat32-%{name}
131%defattr(-,root,root,-)
132%{_libdir}/libcolord.so.*
133
134%files -n compat32-%{name}-devel
135%defattr(-,root,root,-)
136%{_libdir}/libcolord.so
137%endif
138
139%changelog
140* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.26-1
141- new upstream release
142
143* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.24-1
144- new upstream release
145- remove BuildRequires: sane-devel
146
147* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.23-1
148- new upstream release
149- change BuildRequires: libgusb-devel instead of libusb1-devel
150- add BuildRequires: gobject-introspection-devel
151
152* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.21-1
153- new upstream release
154
155* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.19-1
156- new upstream release
157
158* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.18-1
159- new upstream release
160
161* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.15-1
162- new upstream release
163
164* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.14-1
165- new upstream release
166
167* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.13-1
168- new upstream release
169
170* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.12-1
171- new upstream release
172
173* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.11-1
174- new upstream release
175- create compat32 sub packages
176
177* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp 0.1.10-1
178- initial build for Vine Linux
179
180
181* Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
182- New upstream version
183
184* Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
185- New upstream version
186
187* Fri Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
188- New upstream version
189- Add a webcam device kind
190- Add a timestamp when making profiles default
191- Add support for reading and writing ICC profile metadata
192- Allow the client to pass file descriptors out of band to CreateProfile
193- Prettify the device vendor and model names
194- Split out the sensors into runtime-loadable shared objects
195- Provide some GIO async variants for the methods in CdClient
196- Ensure GPhoto2 devices get added to the device list
197
198* Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
199- New upstream version.
200- Create /var/lib/colord at buildtime not runtime for SELinux
201- Ensure profiles with embedded profile checksums are parsed correctly
202- Move the colorimeter rules to be run before 70-acl.rules
203- Stop watching the client when the sensor is finalized
204- Ensure the source is destroyed when we unref CdUsb to prevent a crash
205- Only enable the volume mount tracking when searching volumes
206
207* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
208- Own /var/lib/colord and /var/lib/colord/*.db
209
210* Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
211- New upstream version.
212
213* Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
214- New upstream version.
215
216* Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
217- New upstream version.
218
219* Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
220- New upstream version.
221
222* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
224
225* Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
226- Rebuild in the vain hope koji isn't broken today.
227
228* Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
229- New upstream version.
230
231* Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
232- Initial version for Fedora package review.
Note: See TracBrowser for help on using the repository browser.