source: projects/specs/trunk/c/colord/colord-vl.spec @ 9145

Revision 9145, 8.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-12 Ryoichi INAGAKI <ryo1@…>

  • colord, nettle: fixed compat32-* subpackage
  • hyperestraier: rebuilt
  • pcsc-perl, rcs: updated
  • sbc: added Group


RevLine 
[6890]1%bcond_with firstbuild
[4632]2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
[4616]4Summary:   Color daemon
5Name:      colord
[9097]6Version:   1.1.8
[9145]7Release:   2%{?_dist_release}
[4632]8Group:     System Environment/Daemons
[4616]9License:   GPLv2+ and LGPLv2+
10URL:       http://gitorious.org/colord
[6890]11Source0:   http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
[4616]12
[9145]13BuildRoot:     %{_tmppath}/%{name}-%{version}-root
[4616]14BuildRequires: dbus-devel
15BuildRequires: docbook-utils
16BuildRequires: gettext
17BuildRequires: glib2-devel
18BuildRequires: intltool
19BuildRequires: lcms2-devel
20BuildRequires: libgudev1-devel
[6890]21BuildRequires: libgusb-devel
[4616]22BuildRequires: polkit-devel
23BuildRequires: sqlite3-devel
[7681]24BuildRequires: bash-completion
[6890]25%{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
[4616]26Requires: shared-color-profiles
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: Takemikaduchi
31
32%description
33colord is a low level system activated daemon that maps color devices
34to color profiles in the system context.
35
36%package devel
37Summary: Development package for %{name}
[4632]38Group:   Development/Libraries
[4616]39Requires: %{name} = %{version}-%{release}
[4704]40Requires: glib2-devel
41Requires: dbus-devel
42Requires: lcms2-devel
[4616]43
44%description devel
45Files for development with %{name}.
46
[4632]47# compat32
48%package -n compat32-%{name}
49Summary:  Color daemon
50Group:    System Environment/Daemons
51Requires: %{name} = %{version}-%{release}
52
53%description -n compat32-%{name}
54colord is a low level system activated daemon that maps color devices
55to color profiles in the system context.
56
57%package -n compat32-%{name}-devel
58Summary: Development package for %{name}
59Group:   Development/Libraries
60Requires: compat32-%{name} = %{version}-%{release}
61
62%description -n compat32-%{name}-devel
63Files for development with %{name}.
64
65
[4616]66%prep
67%setup -q
68
69%build
70%configure \
71        --disable-static \
72        --disable-rpath \
73        --disable-examples \
[7633]74        --disable-dependency-tracking \
75        --disable-systemd-login
[4616]76
77make %{?_smp_mflags}
78
79%install
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# Remove static libs and libtool archives.
83find %{buildroot} -name '*.la' -exec rm -f {} ';'
84find %{buildroot} -name '*.a' -exec rm -f {} ';'
85
86# databases
87touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
88touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
89
90%find_lang %{name}
91
92%post -p /sbin/ldconfig
93
[7633]94%postun
95/sbin/ldconfig
96if [ $1 -eq 0 ]; then
97  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
98fi
[4616]99
[7633]100%posttrans
101glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
102
[4632]103%post -n compat32-%{name} -p /sbin/ldconfig
104
105%postun -n compat32-%{name} -p /sbin/ldconfig
106
[4616]107%files -f %{name}.lang
108%defattr(-,root,root,-)
[9145]109%doc AUTHORS COPYING NEWS README.md
[4616]110%{_libexecdir}/colord
[7633]111%{_libexecdir}/colord-session
[4616]112%dir %{_localstatedir}/lib/colord
113%{_bindir}/*
114%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
[7681]115%{_datadir}/bash-completion/completions/colormgr
[7633]116%{_datadir}/color
117%{_datadir}/colord
118%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
[4616]119%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
[7633]120%{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
121%{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
122%{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
[4616]123%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
124%{_datadir}/man/man1/*.1.gz
125%{_libdir}/libcolord.so.*
[7633]126%{_libdir}/libcolordprivate.so.*
127%{_libdir}/libcolorhug.so.*
[7111]128%{_libdir}/colord-plugins/libcd_plugin_camera.so
129%{_libdir}/colord-plugins/libcd_plugin_scanner.so
[6890]130%{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
[7633]131%{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
[4616]132/lib/udev/rules.d/*.rules
133%{_libdir}/colord-sensors
134%ghost %{_localstatedir}/lib/colord/*.db
135
136%files devel
137%defattr(-,root,root,-)
138%{_includedir}/colord-1
139%{_libdir}/libcolord.so
[7633]140%{_libdir}/libcolordprivate.so
141%{_libdir}/libcolorhug.so
[4616]142%{_libdir}/pkgconfig/colord.pc
[7633]143%{_libdir}/pkgconfig/colorhug.pc
[6890]144%{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
[7633]145%{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
[4616]146
[4632]147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root,-)
151%{_libdir}/libcolord.so.*
[9145]152%{_libdir}/libcolordprivate.so.*
153%{_libdir}/libcolorhug.so.*
[4632]154
155%files -n compat32-%{name}-devel
156%defattr(-,root,root,-)
157%{_libdir}/libcolord.so
[9145]158%{_libdir}/libcolordprivate.so
159%{_libdir}/libcolorhug.so
[4632]160%endif
161
[4616]162%changelog
[9145]163* Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.8-2
164- added libcolordprivate and libcolorhug to compat32-* subpackages
165
[9097]166* Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.8-1
167- new upstream release
168
[9073]169* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
170- update to 1.1.7
171
[8622]172* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
173- new upstream release
174
[8353]175* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
176- new upstream release
177
[8064]178* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
179- new upstream release
180
[7786]181* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
182- new upstream release
183
[7681]184* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
[7633]185- new upstream release
[7681]186- add BuildRequires: bash-completion
[7633]187
[7681]188* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
[7294]189- new upstream release
190
[7681]191* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
[7111]192- new upstream release
[7681]193
194* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
195- new upstream release
[7111]196- remove BuildRequires: sane-devel
197
[7681]198* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
[6890]199- new upstream release
200- change BuildRequires: libgusb-devel instead of libusb1-devel
201- add BuildRequires: gobject-introspection-devel
202
[7681]203* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
[6431]204- new upstream release
205
[7681]206* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
[6086]207- new upstream release
208
[7681]209* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
[6011]210- new upstream release
211
[7681]212* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
[5316]213- new upstream release
214
[7681]215* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
[5168]216- new upstream release
217
[7681]218* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
[4881]219- new upstream release
220
[7681]221* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
[4704]222- new upstream release
223
[7681]224* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
[4632]225- new upstream release
226- create compat32 sub packages
227
[7681]228* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
[4616]229- initial build for Vine Linux
230
231
232* Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
233- New upstream version
234
235* Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
236- New upstream version
237
[7633]238* Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
[4616]239- New upstream version
240- Add a webcam device kind
241- Add a timestamp when making profiles default
242- Add support for reading and writing ICC profile metadata
243- Allow the client to pass file descriptors out of band to CreateProfile
244- Prettify the device vendor and model names
245- Split out the sensors into runtime-loadable shared objects
246- Provide some GIO async variants for the methods in CdClient
247- Ensure GPhoto2 devices get added to the device list
248
249* Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
250- New upstream version.
251- Create /var/lib/colord at buildtime not runtime for SELinux
252- Ensure profiles with embedded profile checksums are parsed correctly
253- Move the colorimeter rules to be run before 70-acl.rules
254- Stop watching the client when the sensor is finalized
255- Ensure the source is destroyed when we unref CdUsb to prevent a crash
256- Only enable the volume mount tracking when searching volumes
257
258* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
259- Own /var/lib/colord and /var/lib/colord/*.db
260
261* Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
262- New upstream version.
263
264* Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
265- New upstream version.
266
267* Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
268- New upstream version.
269
270* Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
271- New upstream version.
272
273* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
274- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
275
276* Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
277- Rebuild in the vain hope koji isn't broken today.
278
279* Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
280- New upstream version.
281
282* Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
283- Initial version for Fedora package review.
Note: See TracBrowser for help on using the repository browser.