source: projects/specs/trunk/c/colord/colord-vl.spec @ 8622

Revision 8622, 8.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

RevLine 
[6890]1%bcond_with firstbuild
[4632]2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3
[4616]4Summary:   Color daemon
5Name:      colord
[8622]6Version:   1.0.7
[4616]7Release:   1%{?_dist_release}
[4632]8Group:     System Environment/Daemons
[4616]9License:   GPLv2+ and LGPLv2+
10URL:       http://gitorious.org/colord
[6890]11Source0:   http://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
[4616]12
13BuildRequires: dbus-devel
14BuildRequires: docbook-utils
15BuildRequires: gettext
16BuildRequires: glib2-devel
17BuildRequires: intltool
18BuildRequires: lcms2-devel
19BuildRequires: libgudev1-devel
[6890]20BuildRequires: libgusb-devel
[4616]21BuildRequires: polkit-devel
22BuildRequires: sqlite3-devel
[7681]23BuildRequires: bash-completion
[6890]24%{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
[4616]25Requires: shared-color-profiles
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: Takemikaduchi
30
31%description
32colord is a low level system activated daemon that maps color devices
33to color profiles in the system context.
34
35%package devel
36Summary: Development package for %{name}
[4632]37Group:   Development/Libraries
[4616]38Requires: %{name} = %{version}-%{release}
[4704]39Requires: glib2-devel
40Requires: dbus-devel
41Requires: lcms2-devel
[4616]42
43%description devel
44Files for development with %{name}.
45
[4632]46# compat32
47%package -n compat32-%{name}
48Summary:  Color daemon
49Group:    System Environment/Daemons
50Requires: %{name} = %{version}-%{release}
51
52%description -n compat32-%{name}
53colord is a low level system activated daemon that maps color devices
54to color profiles in the system context.
55
56%package -n compat32-%{name}-devel
57Summary: Development package for %{name}
58Group:   Development/Libraries
59Requires: compat32-%{name} = %{version}-%{release}
60
61%description -n compat32-%{name}-devel
62Files for development with %{name}.
63
64
[4616]65%prep
66%setup -q
67
68%build
69%configure \
70        --disable-static \
71        --disable-rpath \
72        --disable-examples \
[7633]73        --disable-dependency-tracking \
74        --disable-systemd-login
[4616]75
76make %{?_smp_mflags}
77
78%install
79make install DESTDIR=$RPM_BUILD_ROOT
80
81# Remove static libs and libtool archives.
82find %{buildroot} -name '*.la' -exec rm -f {} ';'
83find %{buildroot} -name '*.a' -exec rm -f {} ';'
84
85# databases
86touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
87touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
88
89%find_lang %{name}
90
91%post -p /sbin/ldconfig
92
[7633]93%postun
94/sbin/ldconfig
95if [ $1 -eq 0 ]; then
96  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
97fi
[4616]98
[7633]99%posttrans
100glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
101
[4632]102%post -n compat32-%{name} -p /sbin/ldconfig
103
104%postun -n compat32-%{name} -p /sbin/ldconfig
105
[4616]106%files -f %{name}.lang
107%defattr(-,root,root,-)
108%doc README AUTHORS NEWS COPYING
109%{_libexecdir}/colord
[7633]110%{_libexecdir}/colord-session
[4616]111%dir %{_localstatedir}/lib/colord
112%{_bindir}/*
113%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
[7681]114%{_datadir}/bash-completion/completions/colormgr
[7633]115%{_datadir}/color
116%{_datadir}/colord
117%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
[4616]118%{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
[7633]119%{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
120%{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
121%{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
[4616]122%{_datadir}/polkit-1/actions/org.freedesktop.color.policy
123%{_datadir}/man/man1/*.1.gz
124%{_libdir}/libcolord.so.*
[7633]125%{_libdir}/libcolordprivate.so.*
126%{_libdir}/libcolorhug.so.*
[7111]127%{_libdir}/colord-plugins/libcd_plugin_camera.so
128%{_libdir}/colord-plugins/libcd_plugin_scanner.so
[6890]129%{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
[7633]130%{!?with_firstbuild:%{_libdir}/girepository-1.0/ColorHug-1.0.typelib}
[4616]131%config %{_sysconfdir}/colord.conf
132/lib/udev/rules.d/*.rules
133%{_libdir}/colord-sensors
134%ghost %{_localstatedir}/lib/colord/*.db
135
136%files devel
137%defattr(-,root,root,-)
138%{_includedir}/colord-1
139%{_libdir}/libcolord.so
[7633]140%{_libdir}/libcolordprivate.so
141%{_libdir}/libcolorhug.so
[4616]142%{_libdir}/pkgconfig/colord.pc
[7633]143%{_libdir}/pkgconfig/colorhug.pc
[6890]144%{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
[7633]145%{!?with_firstbuild:%{_datadir}/gir-1.0/ColorHug-1.0.gir}
[4616]146
[4632]147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root,-)
151%{_libdir}/libcolord.so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root,-)
155%{_libdir}/libcolord.so
156%endif
157
[4616]158%changelog
[8622]159* Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
160- new upstream release
161
[8353]162* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
163- new upstream release
164
[8064]165* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
166- new upstream release
167
[7786]168* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
169- new upstream release
170
[7681]171* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
[7633]172- new upstream release
[7681]173- add BuildRequires: bash-completion
[7633]174
[7681]175* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
[7294]176- new upstream release
177
[7681]178* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
[7111]179- new upstream release
[7681]180
181* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
182- new upstream release
[7111]183- remove BuildRequires: sane-devel
184
[7681]185* Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
[6890]186- new upstream release
187- change BuildRequires: libgusb-devel instead of libusb1-devel
188- add BuildRequires: gobject-introspection-devel
189
[7681]190* Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
[6431]191- new upstream release
192
[7681]193* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
[6086]194- new upstream release
195
[7681]196* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
[6011]197- new upstream release
198
[7681]199* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
[5316]200- new upstream release
201
[7681]202* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
[5168]203- new upstream release
204
[7681]205* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
[4881]206- new upstream release
207
[7681]208* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
[4704]209- new upstream release
210
[7681]211* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
[4632]212- new upstream release
213- create compat32 sub packages
214
[7681]215* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
[4616]216- initial build for Vine Linux
217
218
219* Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
220- New upstream version
221
222* Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
223- New upstream version
224
[7633]225* Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
[4616]226- New upstream version
227- Add a webcam device kind
228- Add a timestamp when making profiles default
229- Add support for reading and writing ICC profile metadata
230- Allow the client to pass file descriptors out of band to CreateProfile
231- Prettify the device vendor and model names
232- Split out the sensors into runtime-loadable shared objects
233- Provide some GIO async variants for the methods in CdClient
234- Ensure GPhoto2 devices get added to the device list
235
236* Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
237- New upstream version.
238- Create /var/lib/colord at buildtime not runtime for SELinux
239- Ensure profiles with embedded profile checksums are parsed correctly
240- Move the colorimeter rules to be run before 70-acl.rules
241- Stop watching the client when the sensor is finalized
242- Ensure the source is destroyed when we unref CdUsb to prevent a crash
243- Only enable the volume mount tracking when searching volumes
244
245* Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
246- Own /var/lib/colord and /var/lib/colord/*.db
247
248* Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
249- New upstream version.
250
251* Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
252- New upstream version.
253
254* Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
255- New upstream version.
256
257* Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
258- New upstream version.
259
260* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
261- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
262
263* Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
264- Rebuild in the vain hope koji isn't broken today.
265
266* Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
267- New upstream version.
268
269* Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
270- Initial version for Fedora package review.
Note: See TracBrowser for help on using the repository browser.