source: projects/specs/trunk/c/color-mate/color-mate-vl.spec @ 521

Revision 521, 5.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define prereq_ge()     %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
2%define emacsen_pkgdir /usr/lib/emacsen-common/packages
3
4Summary:      colorize emacsens' window
5Name:         color-mate
6Version:      10.6.3
7Release:      1%{?_dist_release}
8Group:        Applications/Editors/Emacs
9License:      distributable
10Url:          http://www.netlab.is.tsukuba.ac.jp/~yokota/izumi/color_mate/
11Source0:      color-mate-%{version}.tar.gz
12Source1:      cm_select.sh
13Source2:      emacs-color.sh
14Patch0:       color-mate-fontset.patch
15Patch1:       color-mate-10.6.3-color-mate-fontset-emacs.patch
16Patch2:       color-mate-10.6.3-color-mate-fontset-xemacs.patch
17Patch3:       color-mate-face-nound.patch
18Patch4:       color-mate-SunnyDay-LCD.patch
19Patch5:       color-mate-10.6.3-tail.patch
20
21Source10:     color-mate-install.sh
22Source11:     color-mate-remove.sh
23
24BuildArch:    noarch
25Buildroot:    %{_tmppath}/%{name}-%{version}-root
26
27PreReq:       emacsen
28BuildPreReq:  emacsen-common
29%prereq_ge    emacsen-common
30Obsoletes:    color-mate-emacs, color-mate-xemacs
31
32Vendor:       Project Vine
33Distribution: Vine Linux
34
35%description
36Color-Mate is a colorize tool for emacs/xemacs.
37
38%description -l ja
39Color-Mate とは、 emacs/xemacs のカラー表示機能を使ってXウィンドウ版
40emacs/xemacs 画面を見やすくするものです。
41
42
43%prep
44%setup -q
45%patch -p0
46%patch1 -p1
47%patch2 -p1
48%patch3 -p0
49%patch4 -p1
50%patch5 -p1
51
52%build
53
54#just adding annoying file to the rpm filelist
55./configure
56
57%install
58[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
59
60mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
61#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
62#mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
63mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
64mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
65
66# install el files
67cp -ar Makefile* configure* *.el *.pl install-sh* kanakan-cursor contrib theme/\
68        ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/color-mate
69
70# install contrib
71mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
72install -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_bindir}/cm_select
73install -m 755 %{SOURCE2} ${RPM_BUILD_ROOT}%{_bindir}/emacs-color
74pushd ${RPM_BUILD_ROOT}%{_bindir}/
75ln -s emacs-color xemacs-color
76popd
77
78# prepare docs
79mv contrib/README README.cm_select
80
81## install script (bytecompile el and install elc, remove elc)
82
83%_installemacsenscript color-mate %{SOURCE10}
84
85%_removeemacsenscript  color-mate %{SOURCE11}
86
87
88%clean
89[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
90
91
92%post
93
94## bytecompile el and install elc
95
96if [ "$1" = 2 ] ; then
97
98%_emacsenPackageRemove color-mate
99
100fi
101
102%_addemacsenlist color-mate
103
104%_emacsenPackageInstall color-mate
105
106
107%preun
108
109if [ "$1" = 0 ] ; then
110
111%_emacsenPackageRemove color-mate
112
113%_removeemacsenlist color-mate
114
115fi
116
117
118%files
119%defattr(-,root,root)
120%doc Q_and_A.color-mate QuickStart.color-mate README.color-mate*
121%doc Customize* ChangeLog Dot*
122%doc kanakan-cursor/org-doc/* kanakan-cursor/README* contrib/
123%{_bindir}/cm_select
124%{_bindir}/emacs-color
125%{_bindir}/xemacs-color
126%{_datadir}/emacs/site-lisp/color-mate/
127#/usr/lib/emacsen-common/packages/*/*
128%{emacsen_pkgdir}/*/*
129
130
131%changelog
132* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 10.6.3-1vl5
133- applied new versioning policy, spec in utf-8
134- added macro %%emacsen_pkgdir
135
136* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.6.3-0vl3
137- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
138
139* Sun Aug 13 2006 IWAI, Masaharu <iwai@alib.jp> 10.6.3-0vl2
140- update color-mate-install.sh for Emacs 22
141- using Licenes tag
142- add tail option patch ( Patch5 )
143
144* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 10.6.3-0vl1
145- version up to 10.6.3
146- update color-mate-fontset-emacs.patch (Patch1)
147- update color-mate-fontset-xemacs.patch (Patch2)
148
149* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl8
150- fix color-mate-{install,remove}.sh
151
152* Fri Mar 29 2002 Jun Nishii <jun@vinelinux.org> 10.1.1-0vl7
153- install missing .X files
154- use symlink for color-xemacs
155- update cm_select
156
157* Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl6
158- install script (SOURCE10) modified a little
159
160* Sun Dec 16 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 10.1.1-0vl5
161- emacsen-common aware
162
163* Sun Dec 03 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
164- 10.1.1-0vl4
165- fixed description
166- added BuildRequires and %%{emacs} / %%{xemacs} for each package to be
167  built on anti-BuildRequired host (both set to be 1 by default).
168- cp -a for egg-cursor.el to work around with emacs's murmur :-)
169
170* Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
171- 10.1.1-0vl3
172- with egg-cursor
173
174* Wed Sep 20 2000 Jun Nishii <jun@vinelinux.org>
175- 10.1.1-0vl2
176- modify emacs-color
177
178* Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
179- 9.1.1-0vl1
180- enable to set default fontset in .emacs
181- obsletes SunnyDay-LCD 12
182- added cm_select in bins
183- added emacs-color, xemacs-color
184
185* Mon Sep 11 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
186- 10.0.1-8
187- added SunnyDay-LCD 12 dots fontset theme
188
189* Fri Feb 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
190- 10.0.1-7
191- added %defattr(-,root,root)
192- added %clean section
193
194* Wed Jan 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
195- 10.0.1-6
196- fixed SunnyDay-LCD.el for "wrong type argument" problem
197
198* Fri Dec  3 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
199- 10.0.1-5
200- %files xemacs section modified for correct load-path
201  to /usr/lib/xemacs/site-packages/lisp/color-mate
202
203* Wed Dec  1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
204- change Group to Applications/Editors/EmacsLisp
205
206* Wed Nov 17 1999 Jun NISHII <jun@vinelinux.org>
207- build for Vine-2.0
Note: See TracBrowser for help on using the repository browser.