source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 9475

Revision 9475, 4.9 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME-3.16.0

Line 
1%define         cogl_version 1.20.0
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.20/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  libXrandr-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  mesa-libEGL-devel
21BuildRequires:  pango-devel
22BuildRequires:  gdk-pixbuf2-devel
23BuildRequires:  gstreamer1-plugins-base-devel
24BuildRequires:  gtk-doc
25
26Vendor:         Project Vine
27Distribution:   Vine Linux
28Packager:       Takemikaduchi
29
30%description
31Cogl is a small open source library for using 3D graphics hardware to draw
32pretty pictures. The API departs from the flat state machine style of
33OpenGL and is designed to make it easy to write orthogonal components that
34can render without stepping on each others toes.
35
36
37%package                devel
38Summary:        Development tools for cogl
39Summary(ja):    cogl の開発環境
40Group:          Development/Libraries
41Requires:       %{name} = %{version}-%{release}
42Requires:       pkgconfig
43
44%description    devel
45Header files and libraries for building a extension library for the
46cogl.
47
48
49%package                gstreamer
50Summary:        Cogl GStreamer library
51Summary(ja):    cogl gstreamer ライブラリ
52Group:          System Environment/Libraries
53Requires:       %{name} = %{version}-%{release}
54
55%description    gstreamer
56%{summary}
57
58
59%package        docs
60Summary:        Documentation for cogl
61Summary(ja):    cogl 用のドキュメント
62Group:          Documentation
63Provides:       %{name}-doc = %{version}-%{release}
64BuildArch:              noarch
65
66
67%description    docs
68This package contains documentation for cogl.
69
70
71%prep
72%setup -q
73
74for i in `grep -rl "<note>" ./`;
75do
76  sed -i 's/<note>//' $i
77done
78
79for i in `grep -rl "<\/note>" ./`;
80do
81  sed -i 's/<\/note>//' $i
82done
83
84%build
85
86%configure \
87        --enable-gtk-doc \
88        --disable-static \
89        --enable-cairo=yes \
90        --enable-gdk-pixbuf=yes \
91        --enable-cogl-gst=yes \
92        --enable-cogl-pango=yes \
93        --enable-glx=yes \
94        --enable-introspection=yes \
95        --enable-xlib-egl-platform=yes
96
97make V=1
98
99%install
100rm -rf $RPM_BUILD_ROOT
101#make DESTDIR=$RPM_BUILD_ROOT install
102make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
103
104find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
105
106%find_lang %{name}
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%post -p /sbin/ldconfig
112%postun -p /sbin/ldconfig
113
114%files -f %{name}.lang
115%defattr(-,root,root,-)
116%doc ChangeLog AUTHORS COPYING NEWS README
117%{_libdir}/*.so.*
118%{_libdir}/girepository-1.0/*.typelib
119%{_datadir}/%{name}/examples-data/crate.jpg
120
121%files devel
122%defattr(-,root,root,-)
123%{_includedir}/cogl
124%{_libdir}/*.so
125%{_libdir}/pkgconfig/*.pc
126%{_datadir}/gir-1.0/*.gir
127
128%files gstreamer
129%defattr(-,root,root,-)
130%{_libdir}/gstreamer-1.0/libgstcogl.so
131
132%files docs
133%defattr(-,root,root,-)
134%{_datadir}/gtk-doc/html/cogl
135%{_datadir}/gtk-doc/html/cogl-gst
136%{_datadir}/gtk-doc/html/cogl-2.0-experimental
137
138%changelog
139* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
140- new upstream release
141
142* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
143- new upstream release
144- add BuildRequires: mesa-libEGL-devel
145
146* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
147- new upstream release
148
149* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
150- new upstream release
151
152* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
153- rebuild with VineSeed environment
154
155* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
156- new upstream release
157- add BuildRequire: gstreamer1-plugins-base-devel
158
159* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
160- new upstream release
161- add BuildRequires: libXrandr-devel
162
163* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
164- new upstream release
165
166* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
167- new upstream release
168- remove Patch0 (04_fix_crash_on_free.patch)
169
170* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
171- new upstream release
172
173* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
174- add Patch0 (04_fix_crash_on_free.patch)
175
176* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
177- new upstream release
178
179* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
180- new upstream release
181
182* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
183- new upstream release
184
185* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
186- new upstream release
187- remove Patch0
188
189* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
190- new upstream release
191- add Patch0 (cogl-1.7.6-configure.patch)
192
193* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
194- initial build for Vine Linux
195
Note: See TracBrowser for help on using the repository browser.