source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 7633

Revision 7633, 3.8 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define         cogl_version 1.14.0
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.14/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  libXrandr-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  pango-devel
21BuildRequires:  gdk-pixbuf2-devel
22BuildRequires:  gtk-doc
23
24Vendor:         Project Vine
25Distribution:   Vine Linux
26Packager:       Takemikaduchi
27
28%description
29Cogl is a small open source library for using 3D graphics hardware to draw
30pretty pictures. The API departs from the flat state machine style of
31OpenGL and is designed to make it easy to write orthogonal components that
32can render without stepping on each others toes.
33
34%package devel
35Summary:        Development tools for cogl
36Summary(ja):    cogl の開発環境
37Group:          Development/Libraries
38Requires:       %{name} = %{version}-%{release}
39Requires:       pkgconfig
40
41%description devel
42Header files and libraries for building a extension library for the
43cogl.
44
45
46%package        doc
47Summary:        Documentation for cogl
48Summary(ja):    cogl 用のドキュメント
49Group:          Documentation
50Requires:       %{name} = %{version}-%{release}
51BuildArch:      noarch
52
53
54%description    doc
55This package contains documentation for cogl.
56
57
58%prep
59%setup -q
60
61for i in `grep -rl "<note>" ./`;
62do
63  sed -i 's/<note>//' $i
64done
65
66for i in `grep -rl "<\/note>" ./`;
67do
68  sed -i 's/<\/note>//' $i
69done
70
71%build
72
73%configure \
74        --enable-gtk-doc \
75        --disable-static \
76        --enable-cairo=yes \
77        --enable-gdk-pixbuf=yes \
78        --enable-cogl-pango=yes \
79        --enable-glx=yes \
80        --enable-introspection=yes
81
82make V=1
83
84%install
85rm -rf $RPM_BUILD_ROOT
86#make DESTDIR=$RPM_BUILD_ROOT install
87make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
88
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90
91%find_lang %{name}
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%post -p /sbin/ldconfig
97%postun -p /sbin/ldconfig
98
99%files -f %{name}.lang
100%defattr(-,root,root,-)
101%doc ChangeLog AUTHORS COPYING NEWS README
102%{_libdir}/*.so.*
103%{_libdir}/girepository-1.0/*.typelib
104%{_datadir}/%{name}/examples-data/crate.jpg
105
106%files devel
107%defattr(-, root, root)
108%{_includedir}/cogl
109%{_libdir}/*.so
110%{_libdir}/pkgconfig/*.pc
111%{_datadir}/gir-1.0/*.gir
112
113%files doc
114%defattr(-, root, root)
115%{_datadir}/gtk-doc/html/cogl
116%{_datadir}/gtk-doc/html/cogl-2.0-experimental
117
118%changelog
119* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
120- new upstream release
121- add BuildRequires: libXrandr-devel
122
123* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
124- new upstream release
125
126* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
127- new upstream release
128- remove Patch0 (04_fix_crash_on_free.patch)
129
130* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
131- new upstream release
132
133* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
134- add Patch0 (04_fix_crash_on_free.patch)
135
136* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
137- new upstream release
138
139* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
140- new upstream release
141
142* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
143- new upstream release
144
145* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
146- new upstream release
147- remove Patch0
148
149* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
150- new upstream release
151- add Patch0 (cogl-1.7.6-configure.patch)
152
153* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
154- initial build for Vine Linux
155
Note: See TracBrowser for help on using the repository browser.