source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 6890

Revision 6890, 3.6 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define         cogl_version 1.12.0
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.12/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  mesa-libGL-devel
19BuildRequires:  pango-devel
20BuildRequires:  gdk-pixbuf2-devel
21BuildRequires:  gtk-doc
22
23Vendor:         Project Vine
24Distribution:   Vine Linux
25Packager:       Takemikaduchi
26
27%description
28Cogl is a small open source library for using 3D graphics hardware to draw
29pretty pictures. The API departs from the flat state machine style of
30OpenGL and is designed to make it easy to write orthogonal components that
31can render without stepping on each others toes.
32
33%package devel
34Summary:        Development tools for cogl
35Summary(ja):    cogl の開発環境
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       pkgconfig
39
40%description devel
41Header files and libraries for building a extension library for the
42cogl.
43
44
45%package        doc
46Summary:        Documentation for cogl
47Summary(ja):    cogl 用のドキュメント
48Group:          Documentation
49Requires:       %{name} = %{version}-%{release}
50BuildArch:      noarch
51
52
53%description    doc
54This package contains documentation for cogl.
55
56
57%prep
58%setup -q
59
60for i in `grep -rl "<note>" ./`;
61do
62  sed -i 's/<note>//' $i
63done
64
65for i in `grep -rl "<\/note>" ./`;
66do
67  sed -i 's/<\/note>//' $i
68done
69
70%build
71
72%configure \
73        --enable-gtk-doc \
74        --disable-static \
75        --enable-cairo=yes \
76        --enable-gdk-pixbuf=yes \
77        --enable-cogl-pango=yes \
78        --enable-glx=yes \
79        --enable-introspection=yes
80
81make V=1
82
83%install
84rm -rf $RPM_BUILD_ROOT
85#make DESTDIR=$RPM_BUILD_ROOT install
86make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
87
88rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
89
90%find_lang %{name}
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
98%files -f %{name}.lang
99%defattr(-,root,root,-)
100%doc ChangeLog AUTHORS COPYING NEWS README
101%{_libdir}/*.so.*
102%{_libdir}/girepository-1.0/*.typelib
103%{_datadir}/%{name}/examples-data/crate.jpg
104
105%files devel
106%defattr(-, root, root)
107%{_includedir}/cogl
108%{_libdir}/*.so
109%{_libdir}/pkgconfig/*.pc
110%{_datadir}/gir-1.0/*.gir
111
112%files doc
113%defattr(-, root, root)
114%{_datadir}/gtk-doc/html/cogl
115%{_datadir}/gtk-doc/html/cogl-2.0-experimental
116
117%changelog
118* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
119- new upstream release
120- remove Patch0 (04_fix_crash_on_free.patch)
121
122* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
123- new upstream release
124
125* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
126- add Patch0 (04_fix_crash_on_free.patch)
127
128* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
129- new upstream release
130
131* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
132- new upstream release
133
134* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
135- new upstream release
136
137* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
138- new upstream release
139- remove Patch0
140
141* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
142- new upstream release
143- add Patch0 (cogl-1.7.6-configure.patch)
144
145* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
146- initial build for Vine Linux
147
Note: See TracBrowser for help on using the repository browser.