source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 6581

Revision 6581, 3.3 KB checked in by Takemikaduchi, 12 years ago (diff)

cogl: bug fix
others: new upstream release

Line 
1%define         cogl_version 1.10.2
2%define         cogl_release 2%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.10/%{name}-%{version}.tar.xz
13
14# fron redhat
15Patch0:         04_fix_crash_on_free.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  gobject-introspection-devel
20BuildRequires:  libXcomposite-devel
21BuildRequires:  mesa-libGL-devel
22BuildRequires:  pango-devel
23BuildRequires:  gtk-doc
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27Packager:       Takemikaduchi
28
29%description
30Cogl is a small open source library for using 3D graphics hardware to draw
31pretty pictures. The API departs from the flat state machine style of
32OpenGL and is designed to make it easy to write orthogonal components that
33can render without stepping on each others toes.
34
35%package devel
36Summary:        Development tools for cogl
37Summary(ja):    cogl の開発環境
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       pkgconfig
41
42%description devel
43Header files and libraries for building a extension library for the
44cogl.
45
46
47%package        doc
48Summary:        Documentation for cogl
49Summary(ja):    cogl 用のドキュメント
50Group:          Documentation
51Requires:       %{name} = %{version}-%{release}
52BuildArch:      noarch
53
54
55%description    doc
56This package contains documentation for cogl.
57
58
59%prep
60%setup -q
61%patch0 -p1 -b .crash
62
63%build
64autoreconf -if
65%configure --enable-gtk-doc \
66        --disable-static \
67        --enable-cairo=yes \
68        --enable-gdk-pixbuf=yes \
69        --enable-cogl-pango=yes \
70        --enable-glx=yes \
71        --enable-introspection=yes
72
73make V=1
74
75%install
76rm -rf $RPM_BUILD_ROOT
77#make DESTDIR=$RPM_BUILD_ROOT install
78make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
79
80rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
81
82%find_lang %{name}
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files -f %{name}.lang
91%defattr(-,root,root,-)
92%doc ChangeLog AUTHORS COPYING NEWS README
93%{_libdir}/*.so.*
94%{_libdir}/girepository-1.0/*.typelib
95%{_datadir}/%{name}/examples-data/crate.jpg
96
97%files devel
98%defattr(-, root, root)
99%{_includedir}/cogl
100%{_libdir}/*.so
101%{_libdir}/pkgconfig/*.pc
102%{_datadir}/gir-1.0/*.gir
103
104%files doc
105%defattr(-, root, root)
106%{_datadir}/gtk-doc/html/cogl
107%{_datadir}/gtk-doc/html/cogl-2.0-experimental
108
109%changelog
110* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
111- add Patch0 (04_fix_crash_on_free.patch)
112
113* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
114- new upstream release
115
116* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
117- new upstream release
118
119* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
120- new upstream release
121
122* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
123- new upstream release
124- remove Patch0
125
126* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
127- new upstream release
128- add Patch0 (cogl-1.7.6-configure.patch)
129
130* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
131- initial build for Vine Linux
132
Note: See TracBrowser for help on using the repository browser.