source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 12005

Revision 12005, 5.4 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define         cogl_version 1.22.2
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.22/%{name}-%{version}.tar.xz
13Patch0:         cogl-1.22.2-Fix-an-incorrect-preprocessor-conditional.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  gobject-introspection-devel
18BuildRequires:  libXcomposite-devel
19BuildRequires:  libXrandr-devel
20BuildRequires:  mesa-libGL-devel
21BuildRequires:  mesa-libEGL-devel
22BuildRequires:  mesa-libgbm-devel
23BuildRequires:  pango-devel
24BuildRequires:  gdk-pixbuf2-devel
25BuildRequires:  gstreamer1-plugins-base-devel
26BuildRequires:  gtk-doc
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32Cogl is a small open source library for using 3D graphics hardware to draw
33pretty pictures. The API departs from the flat state machine style of
34OpenGL and is designed to make it easy to write orthogonal components that
35can render without stepping on each others toes.
36
37
38%package                devel
39Summary:        Development tools for cogl
40Summary(ja):    cogl の開発環境
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44
45%description    devel
46Header files and libraries for building a extension library for the
47cogl.
48
49
50%package                gstreamer
51Summary:        Cogl GStreamer library
52Summary(ja):    cogl gstreamer ライブラリ
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55
56%description    gstreamer
57%{summary}
58
59
60%package        docs
61Summary:        Documentation for cogl
62Summary(ja):    cogl 用のドキュメント
63Group:          Documentation
64Provides:       %{name}-doc = %{version}-%{release}
65BuildArch:              noarch
66
67
68%description    docs
69This package contains documentation for cogl.
70
71
72%prep
73%setup -q
74%patch0 -p1
75
76for i in `grep -rl "<note>" ./`;
77do
78  sed -i 's/<note>//' $i
79done
80
81for i in `grep -rl "<\/note>" ./`;
82do
83  sed -i 's/<\/note>//' $i
84done
85
86%build
87
88%configure \
89        --enable-gtk-doc \
90        --disable-static \
91        --enable-cairo=yes \
92        --enable-gdk-pixbuf=yes \
93        --enable-cogl-gst=yes \
94        --enable-cogl-pango=yes \
95        --enable-glx=yes \
96        --enable-introspection=yes \
97        --enable-kms-egl-platform=yes \
98        --enable-xlib-egl-platform=yes
99
100make V=1
101
102%install
103rm -rf $RPM_BUILD_ROOT
104#make DESTDIR=$RPM_BUILD_ROOT install
105make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
106
107find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
108
109%find_lang %{name}
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115%postun -p /sbin/ldconfig
116
117%files -f %{name}.lang
118%defattr(-,root,root,-)
119%doc ChangeLog AUTHORS COPYING NEWS README
120%{_libdir}/*.so.*
121%{_libdir}/girepository-1.0/*.typelib
122%{_datadir}/%{name}/examples-data/crate.jpg
123
124%files devel
125%defattr(-,root,root,-)
126%{_includedir}/cogl
127%{_libdir}/*.so
128%{_libdir}/pkgconfig/*.pc
129%{_datadir}/gir-1.0/*.gir
130
131%files gstreamer
132%defattr(-,root,root,-)
133%{_libdir}/gstreamer-1.0/libgstcogl.so
134
135%files docs
136%defattr(-,root,root,-)
137%{_datadir}/gtk-doc/html/cogl
138%{_datadir}/gtk-doc/html/cogl-gst
139%{_datadir}/gtk-doc/html/cogl-2.0-experimental
140
141%changelog
142* Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.2-1
143- new upstream release.
144- added Patch0.
145
146* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
147- new upstream release
148- remove Patch0
149
150* Wed May 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-2
151- add Patch0 (cogl-1.20.0-git20150508.patch)
152- add BuildRequires: mesa-libgbm-devel
153
154* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
155- new upstream release
156
157* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
158- new upstream release
159- add BuildRequires: mesa-libEGL-devel
160
161* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
162- new upstream release
163
164* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
165- new upstream release
166
167* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
168- rebuild with VineSeed environment
169
170* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
171- new upstream release
172- add BuildRequire: gstreamer1-plugins-base-devel
173
174* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
175- new upstream release
176- add BuildRequires: libXrandr-devel
177
178* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
179- new upstream release
180
181* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
182- new upstream release
183- remove Patch0 (04_fix_crash_on_free.patch)
184
185* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
186- new upstream release
187
188* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
189- add Patch0 (04_fix_crash_on_free.patch)
190
191* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
192- new upstream release
193
194* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
195- new upstream release
196
197* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
198- new upstream release
199
200* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
201- new upstream release
202- remove Patch0
203
204* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
205- new upstream release
206- add Patch0 (cogl-1.7.6-configure.patch)
207
208* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
209- initial build for Vine Linux
210
Note: See TracBrowser for help on using the repository browser.