source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 9791

Revision 9791, 5.3 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define         cogl_version 1.22.0
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.22/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  libXrandr-devel
19BuildRequires:  mesa-libGL-devel
20BuildRequires:  mesa-libEGL-devel
21BuildRequires:  mesa-libgbm-devel
22BuildRequires:  pango-devel
23BuildRequires:  gdk-pixbuf2-devel
24BuildRequires:  gstreamer1-plugins-base-devel
25BuildRequires:  gtk-doc
26
27Vendor:         Project Vine
28Distribution:   Vine Linux
29Packager:       Takemikaduchi
30
31%description
32Cogl is a small open source library for using 3D graphics hardware to draw
33pretty pictures. The API departs from the flat state machine style of
34OpenGL and is designed to make it easy to write orthogonal components that
35can render without stepping on each others toes.
36
37
38%package                devel
39Summary:        Development tools for cogl
40Summary(ja):    cogl の開発環境
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       pkgconfig
44
45%description    devel
46Header files and libraries for building a extension library for the
47cogl.
48
49
50%package                gstreamer
51Summary:        Cogl GStreamer library
52Summary(ja):    cogl gstreamer ライブラリ
53Group:          System Environment/Libraries
54Requires:       %{name} = %{version}-%{release}
55
56%description    gstreamer
57%{summary}
58
59
60%package        docs
61Summary:        Documentation for cogl
62Summary(ja):    cogl 用のドキュメント
63Group:          Documentation
64Provides:       %{name}-doc = %{version}-%{release}
65BuildArch:              noarch
66
67
68%description    docs
69This package contains documentation for cogl.
70
71
72%prep
73%setup -q
74
75for i in `grep -rl "<note>" ./`;
76do
77  sed -i 's/<note>//' $i
78done
79
80for i in `grep -rl "<\/note>" ./`;
81do
82  sed -i 's/<\/note>//' $i
83done
84
85%build
86
87%configure \
88        --enable-gtk-doc \
89        --disable-static \
90        --enable-cairo=yes \
91        --enable-gdk-pixbuf=yes \
92        --enable-cogl-gst=yes \
93        --enable-cogl-pango=yes \
94        --enable-glx=yes \
95        --enable-introspection=yes \
96        --enable-kms-egl-platform=yes \
97        --enable-xlib-egl-platform=yes
98
99make V=1
100
101%install
102rm -rf $RPM_BUILD_ROOT
103#make DESTDIR=$RPM_BUILD_ROOT install
104make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
105
106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
107
108%find_lang %{name}
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files -f %{name}.lang
117%defattr(-,root,root,-)
118%doc ChangeLog AUTHORS COPYING NEWS README
119%{_libdir}/*.so.*
120%{_libdir}/girepository-1.0/*.typelib
121%{_datadir}/%{name}/examples-data/crate.jpg
122
123%files devel
124%defattr(-,root,root,-)
125%{_includedir}/cogl
126%{_libdir}/*.so
127%{_libdir}/pkgconfig/*.pc
128%{_datadir}/gir-1.0/*.gir
129
130%files gstreamer
131%defattr(-,root,root,-)
132%{_libdir}/gstreamer-1.0/libgstcogl.so
133
134%files docs
135%defattr(-,root,root,-)
136%{_datadir}/gtk-doc/html/cogl
137%{_datadir}/gtk-doc/html/cogl-gst
138%{_datadir}/gtk-doc/html/cogl-2.0-experimental
139
140%changelog
141* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
142- new upstream release
143- remove Patch0
144
145* Wed May 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-2
146- add Patch0 (cogl-1.20.0-git20150508.patch)
147- add BuildRequires: mesa-libgbm-devel
148
149* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
150- new upstream release
151
152* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
153- new upstream release
154- add BuildRequires: mesa-libEGL-devel
155
156* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
157- new upstream release
158
159* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
160- new upstream release
161
162* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
163- rebuild with VineSeed environment
164
165* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
166- new upstream release
167- add BuildRequire: gstreamer1-plugins-base-devel
168
169* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
170- new upstream release
171- add BuildRequires: libXrandr-devel
172
173* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
174- new upstream release
175
176* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
177- new upstream release
178- remove Patch0 (04_fix_crash_on_free.patch)
179
180* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
181- new upstream release
182
183* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
184- add Patch0 (04_fix_crash_on_free.patch)
185
186* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
187- new upstream release
188
189* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
190- new upstream release
191
192* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
193- new upstream release
194
195* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
196- new upstream release
197- remove Patch0
198
199* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
200- new upstream release
201- add Patch0 (cogl-1.7.6-configure.patch)
202
203* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
204- initial build for Vine Linux
205
Note: See TracBrowser for help on using the repository browser.