source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 9569

Revision 9569, 5.2 KB checked in by Takemikaduchi, 9 years ago (diff)

cogl: add patch
others: new upstream release

Line 
1%define         cogl_version 1.20.0
2%define         cogl_release 2%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.20/%{name}-%{version}.tar.xz
13
14Patch0:         cogl-1.20.0-git20150508.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  gobject-introspection-devel
19BuildRequires:  libXcomposite-devel
20BuildRequires:  libXrandr-devel
21BuildRequires:  mesa-libGL-devel
22BuildRequires:  mesa-libEGL-devel
23BuildRequires:  mesa-libgbm-devel
24BuildRequires:  pango-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  gstreamer1-plugins-base-devel
27BuildRequires:  gtk-doc
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       Takemikaduchi
32
33%description
34Cogl is a small open source library for using 3D graphics hardware to draw
35pretty pictures. The API departs from the flat state machine style of
36OpenGL and is designed to make it easy to write orthogonal components that
37can render without stepping on each others toes.
38
39
40%package                devel
41Summary:        Development tools for cogl
42Summary(ja):    cogl の開発環境
43Group:          Development/Libraries
44Requires:       %{name} = %{version}-%{release}
45Requires:       pkgconfig
46
47%description    devel
48Header files and libraries for building a extension library for the
49cogl.
50
51
52%package                gstreamer
53Summary:        Cogl GStreamer library
54Summary(ja):    cogl gstreamer ライブラリ
55Group:          System Environment/Libraries
56Requires:       %{name} = %{version}-%{release}
57
58%description    gstreamer
59%{summary}
60
61
62%package        docs
63Summary:        Documentation for cogl
64Summary(ja):    cogl 用のドキュメント
65Group:          Documentation
66Provides:       %{name}-doc = %{version}-%{release}
67BuildArch:              noarch
68
69
70%description    docs
71This package contains documentation for cogl.
72
73
74%prep
75%setup -q
76%patch0 -p1
77
78for i in `grep -rl "<note>" ./`;
79do
80  sed -i 's/<note>//' $i
81done
82
83for i in `grep -rl "<\/note>" ./`;
84do
85  sed -i 's/<\/note>//' $i
86done
87
88%build
89
90%configure \
91        --enable-gtk-doc \
92        --disable-static \
93        --enable-cairo=yes \
94        --enable-gdk-pixbuf=yes \
95        --enable-cogl-gst=yes \
96        --enable-cogl-pango=yes \
97        --enable-glx=yes \
98        --enable-introspection=yes \
99        --enable-kms-egl-platform=yes \
100        --enable-xlib-egl-platform=yes
101
102make V=1
103
104%install
105rm -rf $RPM_BUILD_ROOT
106#make DESTDIR=$RPM_BUILD_ROOT install
107make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
110
111%find_lang %{name}
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc ChangeLog AUTHORS COPYING NEWS README
122%{_libdir}/*.so.*
123%{_libdir}/girepository-1.0/*.typelib
124%{_datadir}/%{name}/examples-data/crate.jpg
125
126%files devel
127%defattr(-,root,root,-)
128%{_includedir}/cogl
129%{_libdir}/*.so
130%{_libdir}/pkgconfig/*.pc
131%{_datadir}/gir-1.0/*.gir
132
133%files gstreamer
134%defattr(-,root,root,-)
135%{_libdir}/gstreamer-1.0/libgstcogl.so
136
137%files docs
138%defattr(-,root,root,-)
139%{_datadir}/gtk-doc/html/cogl
140%{_datadir}/gtk-doc/html/cogl-gst
141%{_datadir}/gtk-doc/html/cogl-2.0-experimental
142
143%changelog
144* Wed May 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-2
145- add Patch0 (cogl-1.20.0-git20150508.patch)
146- add BuildRequires: mesa-libgbm-devel
147
148* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
149- new upstream release
150
151* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
152- new upstream release
153- add BuildRequires: mesa-libEGL-devel
154
155* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
156- new upstream release
157
158* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
159- new upstream release
160
161* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-2
162- rebuild with VineSeed environment
163
164* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
165- new upstream release
166- add BuildRequire: gstreamer1-plugins-base-devel
167
168* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
169- new upstream release
170- add BuildRequires: libXrandr-devel
171
172* Sun Jan 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
173- new upstream release
174
175* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
176- new upstream release
177- remove Patch0 (04_fix_crash_on_free.patch)
178
179* Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
180- new upstream release
181
182* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-2
183- add Patch0 (04_fix_crash_on_free.patch)
184
185* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
186- new upstream release
187
188* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
189- new upstream release
190
191* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
192- new upstream release
193
194* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.8-1
195- new upstream release
196- remove Patch0
197
198* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
199- new upstream release
200- add Patch0 (cogl-1.7.6-configure.patch)
201
202* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
203- initial build for Vine Linux
204
Note: See TracBrowser for help on using the repository browser.