source: projects/specs/trunk/c/cogl/cogl-vl.spec @ 4616

Revision 4616, 2.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define         cogl_version 1.7.4
2%define         cogl_release 1%{?_dist_release}
3
4Name:           cogl
5Version:        %{cogl_version}
6Release:        %{cogl_release}
7Summary:        A small open source library for using 3D graphics hardware to draw pretty pictures
8
9Group:          System Environment/Libraries
10License:        LGPLv2+
11URL:            http://www.clutter-project.org/
12Source0:        http://www.clutter-project.org/sources/%{name}/1.7/%{name}-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:  gobject-introspection-devel
17BuildRequires:  libXcomposite-devel
18BuildRequires:  mesa-libGL-devel
19BuildRequires:  pango-devel
20BuildRequires:  gtk-doc
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: Takemikaduchi
25
26%description
27Cogl is a small open source library for using 3D graphics hardware to draw
28pretty pictures. The API departs from the flat state machine style of
29OpenGL and is designed to make it easy to write orthogonal components that
30can render without stepping on each others toes.
31
32%package devel
33Summary:        Development tools for cogl
34Summary(ja):    cogl の開発環境
35Group:          Development/Libraries
36Requires:       %{name} = %{version}-%{release}
37Requires:       pkgconfig
38
39%description devel
40Header files and libraries for building a extension library for the
41cogl.
42
43
44%package        doc
45Summary:        Documentation for cogl
46Summary(ja):    cogl 用のドキュメント
47Group:          Documentation
48Requires:       %{name} = %{version}-%{release}
49BuildArch:      noarch
50
51
52%description    doc
53This package contains documentation for cogl.
54
55
56%prep
57%setup -q
58
59%build
60%configure --enable-gtk-doc \
61        --disable-static \
62        --enable-cairo=yes \
63        --enable-gdk-pixbuf=yes \
64        --enable-cogl-pango=yes \
65        --enable-glx=yes \
66        --enable-introspection=yes
67
68make V=0
69
70%install
71rm -rf $RPM_BUILD_ROOT
72#make DESTDIR=$RPM_BUILD_ROOT install
73make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
74
75rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
76
77%find_lang %{name}
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82%post -p /sbin/ldconfig
83%postun -p /sbin/ldconfig
84
85%files -f %{name}.lang
86%defattr(-,root,root,-)
87%doc ChangeLog AUTHORS COPYING NEWS README
88%{_libdir}/*.so.*
89%{_libdir}/girepository-1.0/*.typelib
90
91%files devel
92%defattr(-, root, root)
93%{_includedir}/cogl
94%{_libdir}/*.so
95%{_libdir}/pkgconfig/*.pc
96%{_datadir}/gir-1.0/*.gir
97
98%files doc
99%defattr(-, root, root)
100%{_datadir}/gtk-doc/html/cogl
101%{_datadir}/gtk-doc/html/cogl-2.0-experimental
102
103%changelog
104* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.4-1
105- initial build for Vine Linux
106
Note: See TracBrowser for help on using the repository browser.