source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define         clutter_version 1.2.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.0/%{name}-%{version}.tar.bz2
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15
16Requires:       gobject-introspection
17# FIXME to remove when all the bits have been merged into their
18# libraries
19Requires:       gir-repository
20
21BuildRequires:  glib2-devel
22BuildRequires:  mesa-libGL-devel
23BuildRequires:  gtk2-devel
24BuildRequires:  pkgconfig
25BuildRequires:  pango-devel
26BuildRequires:  libXdamage-devel
27BuildRequires:  gettext
28BuildRequires:  gtk-doc
29BuildRequires:  gobject-introspection-devel >= 0.6.4
30BuildRequires:  gir-repository-devel
31
32%description
33Clutter is an open source software library for creating fast,
34visually rich graphical user interfaces. The most obvious example
35of potential usage is in media center type applications.
36We hope however it can be used for a lot more.
37
38%description -l ja
39Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
40最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
41しかしながら、我々はいろいろな分野で使用されることを願っています。
42
43%package devel
44Summary:        Clutter development environment
45Summary(ja):    Clutterの開発環境
46Group:          Development/Libraries
47Requires:       %{name} = %{version}-%{release}
48Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gtk2-devel
49Requires:       mesa-libGL-devel
50Requires:       gobject-introspection-devel
51
52%description devel
53Header files and libraries for building a extension library for the
54clutter
55
56
57%package        doc
58Summary:        Documentation for %{name}
59Summary(ja):    %{name}用のドキュメント
60Group:          Documentation
61Requires:       %{name} = %{version}-%{release}
62
63%description    doc
64Clutter is an open source software library for creating fast,
65visually rich graphical user interfaces. The most obvious example
66of potential usage is in media center type applications.
67We hope however it can be used for a lot more.
68
69This package contains documentation for clutter.
70
71
72%prep
73%setup -q
74
75%build
76%configure --enable-gtk-doc --enable-introspection
77make %{?_smp_mflags}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81#make DESTDIR=$RPM_BUILD_ROOT install
82make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root,-)
92%doc AUTHORS COPYING NEWS README
93%exclude %{_libdir}/*.la
94%{_libdir}/*.so.0
95%{_libdir}/*.so.0.*
96%{_libdir}/girepository-1.0/*.typelib
97
98%files devel
99%defattr(-, root, root)
100%doc ChangeLog
101%{_includedir}/*
102%{_libdir}/*.so
103%{_libdir}/pkgconfig/*.pc
104%{_datadir}/gir-1.0/*.gir
105
106%files doc
107%defattr(-, root, root)
108#%dir %{_datadir}/gtk-doc/html/clutter
109%{_datadir}/gtk-doc/html/clutter
110#%dir %{_datadir}/gtk-doc/html/cogl
111%{_datadir}/gtk-doc/html/cogl
112
113
114%changelog
115* Sun Mar 07 2010 Takemikaduchi <bsyamato@sea.plala.or.jp> 1.2.0-1
116- new upstream release
117
118* Sat Jan 23 2010 Takemikaduchi <bsyamato@sea.plala.or.jp> 1.0.10-1
119- new upstream release
120
121* Tue Dec  1 2009 Takemikaduchi <bsyamato@sea.plala.or.jp> 1.0.8-1
122- new upstream release
123- build for Vine Linux
124- add Summary(ja)
125- fix BuildRoot
126- remove Obsolete and Provides
127
128* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
129- Update to 1.0.6
130
131* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
132- Update to 1.0.4, update gobject-introspection requirement
133
134* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
135- Update to 1.0.2
136
137* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
138- Move ChangeLog to -devel to save some space
139
140* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
141- Drop the gir-repository-devel dep, which pulls a bunch of -devel
142  onto the live cd
143
144* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
145- Update to 1.0.0
146
147* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
148- fix bz #507389
149
150* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
152
153* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
154- Update to 0.9.8
155
156* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
157- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
158  introspection support to clutter (#512260)
159
160* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
161- Update to 0.9.6
162
163* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
164- Update to 0.9.4
165
166* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
167- Update to 0.9.2
168
169* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
170- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
171
172
173* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
174- Remove noarch from doc subpackage
175
176* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
177- Added gtk-doc for cogl
178- Created doc subpackage
179
180* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
181- Update to 0.8.6
182
183* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
184- Update to 0.8.2
185- Removed clutter-0.8.0-clutter-fixed.patch
186
187* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
188- Update to 0.8.0
189- Added clutter-0.8.0-clutter-fixed.patch
190
191* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
192- Update to 0.6.4
193
194* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
195- Update to 0.6.2
196
197* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
198- Update to 0.6.0
199
200* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
201- Autorebuild for GCC 4.3
202
203* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
204- Update to 0.4.2
205
206* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
207- Update to 0.4.1
208
209* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
210- Update to 0.3.1
211
212* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
213- Update to 0.2.3
214
215* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
216- Changed buildrequires and requires
217
218* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
219- Fix .spec
220
221* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
222- Fix .spec
223
224* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
225- Initial RPM release
Note: See TracBrowser for help on using the repository browser.