source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 6951

Revision 6951, 10.4 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.1

Line 
1%define         clutter_version 1.12.2
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.12/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36BuildRequires:  cogl-devel >= 1.12.0
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
41
42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
61Requires:       json-glib-devel
62Requires:       libXcomposite-devel
63Requires:       libXi-devel
64
65%description devel
66Header files and libraries for building a extension library for the
67clutter
68
69
70%package        doc
71Summary:        Documentation for %{name}
72Summary(ja):    %{name}用のドキュメント
73Group:          Documentation
74Requires:       %{name} = %{version}-%{release}
75BuildArch:      noarch
76
77%description    doc
78Clutter is an open source software library for creating fast,
79visually rich graphical user interfaces. The most obvious example
80of potential usage is in media center type applications.
81We hope however it can be used for a lot more.
82
83This package contains documentation for clutter.
84
85
86%prep
87%setup -q
88%patch0 -p1 -b .dso
89
90
91%build
92#%configure --enable-gtk-doc \
93#       --enable-introspection=yes \
94#       --disable-silent-rules \
95#       --enable-xinput \
96#       --disable-static
97(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
98 %configure $CONFIGFLAGS \
99        --enable-introspection=yes \
100        --disable-silent-rules \
101        --enable-xinput \
102        --disable-static
103 # clutter git ships with some magic to put the git log in shipped tarballs
104 # which gets listed in files; don't blow up if it's missing
105 if ! test -f ChangeLog; then
106   echo "Created from snapshot" > ChangeLog
107 fi
108)
109
110make V=0
111
112%install
113rm -rf $RPM_BUILD_ROOT
114#make DESTDIR=$RPM_BUILD_ROOT install
115make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118
119%find_lang %{name}-1.0
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files -f %{name}-1.0.lang
128%defattr(-,root,root,-)
129%doc AUTHORS COPYING NEWS README
130%{_libdir}/*.so.*
131%{_libdir}/girepository-1.0/*.typelib
132
133%files devel
134%defattr(-, root, root)
135%doc ChangeLog
136%{_includedir}/clutter-1.0
137%{_libdir}/*.so
138%{_libdir}/pkgconfig/*.pc
139%{_datadir}/gir-1.0/*.gir
140
141%files doc
142%defattr(-, root, root)
143%{_datadir}/gtk-doc/html/clutter
144%{_datadir}/gtk-doc/html/cally
145
146
147%changelog
148* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
149- new upstream release
150
151* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
152- new upstream release
153
154* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
155- new upstream release
156
157* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
158- new upstream release
159
160* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
161- new upstream release
162
163* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
164- new upstream release
165
166* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
167- new upstream release
168
169* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
170- new upstream release
171
172* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
173- new upstream release
174- add Requires: libXcomposite-devel, libXi-devel (-devel package)
175
176* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
177- new upstream release
178
179* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
180- new upstream release
181
182* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
183- new upstream release
184
185* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
186- new upstream release
187- add BuildRequires: cogl-devel
188- add "BuildArch: noarch" to doc sub package
189- add Patch0 (clutter-fixdso.patch)
190
191* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
192- new upstream release
193
194* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
195- new upstream release
196
197* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
198- new upstream release
199
200* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
201- new upstream release
202
203* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
204- new upstream release
205- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
206- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
207- drop Patch0
208
209* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
210- new upstream release
211- drop Patch1
212
213* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
214- new upstream release
215- add BuildRequires: json-glib-devel
216- delete Requires: gir-repository
217- delete BuildRequires: gir-repository-devel
218- add Requires: json-glib-devel (devel package)
219- add Patch0, Patch1
220- fix %build
221
222* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
223- rebuild with rpm-4.8.1 for pkg-config file
224
225* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
226- new upstream release
227
228* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
229- new upstream release
230
231* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
232- new upstream release
233- add configure option (--enable-xinput)
234
235* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
236- new upstream release
237
238* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
239- new upstream release
240
241* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
242- new upstream release
243
244* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
245- new upstream release
246
247* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
248- new upstream release
249- build for Vine Linux
250- add Summary(ja)
251- fix BuildRoot
252- remove Obsolete and Provides
253
254* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
255- Update to 1.0.6
256
257* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
258- Update to 1.0.4, update gobject-introspection requirement
259
260* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
261- Update to 1.0.2
262
263* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
264- Move ChangeLog to -devel to save some space
265
266* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
267- Drop the gir-repository-devel dep, which pulls a bunch of -devel
268  onto the live cd
269
270* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
271- Update to 1.0.0
272
273* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
274- fix bz #507389
275
276* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
277- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
278
279* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
280- Update to 0.9.8
281
282* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
283- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
284  introspection support to clutter (#512260)
285
286* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
287- Update to 0.9.6
288
289* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
290- Update to 0.9.4
291
292* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
293- Update to 0.9.2
294
295* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
296- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
297
298
299* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
300- Remove noarch from doc subpackage
301
302* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
303- Added gtk-doc for cogl
304- Created doc subpackage
305
306* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
307- Update to 0.8.6
308
309* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
310- Update to 0.8.2
311- Removed clutter-0.8.0-clutter-fixed.patch
312
313* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
314- Update to 0.8.0
315- Added clutter-0.8.0-clutter-fixed.patch
316
317* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
318- Update to 0.6.4
319
320* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
321- Update to 0.6.2
322
323* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
324- Update to 0.6.0
325
326* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
327- Autorebuild for GCC 4.3
328
329* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
330- Update to 0.4.2
331
332* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
333- Update to 0.4.1
334
335* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
336- Update to 0.3.1
337
338* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
339- Update to 0.2.3
340
341* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
342- Changed buildrequires and requires
343
344* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
345- Fix .spec
346
347* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
348- Fix .spec
349
350* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
351- Initial RPM release
Note: See TracBrowser for help on using the repository browser.