source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 6123

Revision 6123, 10.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define         clutter_version 1.10.4
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.10/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  gdk-pixbuf2-devel
26BuildRequires:  atk-devel
27BuildRequires:  pkgconfig
28BuildRequires:  pango-devel
29BuildRequires:  libXdamage-devel
30BuildRequires:  libXcomposite-devel
31BuildRequires:  libXi-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36BuildRequires:  cogl-devel >= 1.10.0
37
38Vendor:         Project Vine
39Distribution:   Vine Linux
40Packager:       Takemikaduchi
41
42%description
43Clutter is an open source software library for creating fast,
44visually rich graphical user interfaces. The most obvious example
45of potential usage is in media center type applications.
46We hope however it can be used for a lot more.
47
48%description -l ja
49Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
50最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
51しかしながら、我々はいろいろな分野で使用されることを願っています。
52
53%package devel
54Summary:        Clutter development environment
55Summary(ja):    Clutterの開発環境
56Group:          Development/Libraries
57Requires:       %{name} = %{version}-%{release}
58Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
59Requires:       mesa-libGL-devel
60Requires:       gobject-introspection-devel
61Requires:       json-glib-devel
62Requires:       libXcomposite-devel
63Requires:       libXi-devel
64
65%description devel
66Header files and libraries for building a extension library for the
67clutter
68
69
70%package        doc
71Summary:        Documentation for %{name}
72Summary(ja):    %{name}用のドキュメント
73Group:          Documentation
74Requires:       %{name} = %{version}-%{release}
75BuildArch:      noarch
76
77%description    doc
78Clutter is an open source software library for creating fast,
79visually rich graphical user interfaces. The most obvious example
80of potential usage is in media center type applications.
81We hope however it can be used for a lot more.
82
83This package contains documentation for clutter.
84
85
86%prep
87%setup -q
88%patch0 -p1 -b .dso
89
90
91%build
92#%configure --enable-gtk-doc \
93#       --enable-introspection=yes \
94#       --disable-silent-rules \
95#       --enable-xinput \
96#       --disable-static
97(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
98 %configure $CONFIGFLAGS \
99        --enable-introspection=yes \
100        --disable-silent-rules \
101        --enable-xinput \
102        --disable-static
103 # clutter git ships with some magic to put the git log in shipped tarballs
104 # which gets listed in files; don't blow up if it's missing
105 if ! test -f ChangeLog; then
106   echo "Created from snapshot" > ChangeLog
107 fi
108)
109
110make V=0
111
112%install
113rm -rf $RPM_BUILD_ROOT
114#make DESTDIR=$RPM_BUILD_ROOT install
115make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
116
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
118
119%find_lang %{name}-1.0
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127%files -f %{name}-1.0.lang
128%defattr(-,root,root,-)
129%doc AUTHORS COPYING NEWS README
130%{_libdir}/*.so.*
131%{_libdir}/girepository-1.0/*.typelib
132
133%files devel
134%defattr(-, root, root)
135%doc ChangeLog
136%{_includedir}/clutter-1.0
137%{_libdir}/*.so
138%{_libdir}/pkgconfig/*.pc
139%{_datadir}/gir-1.0/*.gir
140
141%files doc
142%defattr(-, root, root)
143%{_datadir}/gtk-doc/html/clutter
144%{_datadir}/gtk-doc/html/cally
145
146
147%changelog
148* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
149- new upstream release
150
151* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
152- new upstream release
153
154* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
155- new upstream release
156
157* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
158- new upstream release
159
160* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
161- new upstream release
162- add Requires: libXcomposite-devel, libXi-devel (-devel package)
163
164* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
165- new upstream release
166
167* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
168- new upstream release
169
170* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
171- new upstream release
172
173* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
174- new upstream release
175- add BuildRequires: cogl-devel
176- add "BuildArch: noarch" to doc sub package
177- add Patch0 (clutter-fixdso.patch)
178
179* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
180- new upstream release
181
182* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
183- new upstream release
184
185* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
186- new upstream release
187
188* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
189- new upstream release
190
191* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
192- new upstream release
193- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
194- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
195- drop Patch0
196
197* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
198- new upstream release
199- drop Patch1
200
201* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
202- new upstream release
203- add BuildRequires: json-glib-devel
204- delete Requires: gir-repository
205- delete BuildRequires: gir-repository-devel
206- add Requires: json-glib-devel (devel package)
207- add Patch0, Patch1
208- fix %build
209
210* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
211- rebuild with rpm-4.8.1 for pkg-config file
212
213* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
214- new upstream release
215
216* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
217- new upstream release
218
219* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
220- new upstream release
221- add configure option (--enable-xinput)
222
223* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
224- new upstream release
225
226* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
227- new upstream release
228
229* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
230- new upstream release
231
232* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
233- new upstream release
234
235* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
236- new upstream release
237- build for Vine Linux
238- add Summary(ja)
239- fix BuildRoot
240- remove Obsolete and Provides
241
242* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
243- Update to 1.0.6
244
245* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
246- Update to 1.0.4, update gobject-introspection requirement
247
248* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
249- Update to 1.0.2
250
251* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
252- Move ChangeLog to -devel to save some space
253
254* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
255- Drop the gir-repository-devel dep, which pulls a bunch of -devel
256  onto the live cd
257
258* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
259- Update to 1.0.0
260
261* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
262- fix bz #507389
263
264* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
265- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
266
267* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
268- Update to 0.9.8
269
270* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
271- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
272  introspection support to clutter (#512260)
273
274* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
275- Update to 0.9.6
276
277* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
278- Update to 0.9.4
279
280* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
281- Update to 0.9.2
282
283* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
284- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
285
286
287* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
288- Remove noarch from doc subpackage
289
290* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
291- Added gtk-doc for cogl
292- Created doc subpackage
293
294* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
295- Update to 0.8.6
296
297* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
298- Update to 0.8.2
299- Removed clutter-0.8.0-clutter-fixed.patch
300
301* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
302- Update to 0.8.0
303- Added clutter-0.8.0-clutter-fixed.patch
304
305* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
306- Update to 0.6.4
307
308* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
309- Update to 0.6.2
310
311* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
312- Update to 0.6.0
313
314* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
315- Autorebuild for GCC 4.3
316
317* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
318- Update to 0.4.2
319
320* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
321- Update to 0.4.1
322
323* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
324- Update to 0.3.1
325
326* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
327- Update to 0.2.3
328
329* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
330- Changed buildrequires and requires
331
332* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
333- Fix .spec
334
335* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
336- Fix .spec
337
338* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
339- Initial RPM release
Note: See TracBrowser for help on using the repository browser.