source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 3003

Revision 3003, 8.9 KB checked in by Takemikaduchi, 13 years ago (diff)

glib2,gtk3,clutter: new upstream release, PyQt4, net-snmp: fix package

Line 
1%define         clutter_version 1.6.8
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.6/%{name}-%{version}.tar.bz2
14
15# http://bugzilla.openedhand.com/show_bug.cgi?id=2100
16Patch0:         Use-a-native-format-for-atlas-textures.patch
17# http://bugzilla.clutter-project.org/show_bug.cgi?id=2324
18Patch1:         cogl-x11-Trap-glXDestroyPixmap.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22Requires:       gobject-introspection
23# FIXME to remove when all the bits have been merged into their
24# libraries
25
26BuildRequires:  glib2-devel
27BuildRequires:  mesa-libGL-devel
28BuildRequires:  gdk-pixbuf2-devel
29BuildRequires:  atk-devel
30BuildRequires:  pkgconfig
31BuildRequires:  pango-devel
32BuildRequires:  libXdamage-devel
33BuildRequires:  libXcomposite-devel
34BuildRequires:  libXi-devel
35BuildRequires:  gettext
36BuildRequires:  gtk-doc
37BuildRequires:  gobject-introspection-devel >= 0.9.5
38BuildRequires:  json-glib-devel
39
40%description
41Clutter is an open source software library for creating fast,
42visually rich graphical user interfaces. The most obvious example
43of potential usage is in media center type applications.
44We hope however it can be used for a lot more.
45
46%description -l ja
47Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
48最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
49しかしながら、我々はいろいろな分野で使用されることを願っています。
50
51%package devel
52Summary:        Clutter development environment
53Summary(ja):    Clutterの開発環境
54Group:          Development/Libraries
55Requires:       %{name} = %{version}-%{release}
56Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
57Requires:       mesa-libGL-devel
58Requires:       gobject-introspection-devel
59Requires:       json-glib-devel
60
61%description devel
62Header files and libraries for building a extension library for the
63clutter
64
65
66%package        doc
67Summary:        Documentation for %{name}
68Summary(ja):    %{name}用のドキュメント
69Group:          Documentation
70Requires:       %{name} = %{version}-%{release}
71
72%description    doc
73Clutter is an open source software library for creating fast,
74visually rich graphical user interfaces. The most obvious example
75of potential usage is in media center type applications.
76We hope however it can be used for a lot more.
77
78This package contains documentation for clutter.
79
80
81%prep
82%setup -q
83#%patch0 -p0 -b .atlas-textures
84#%patch1 -p1 -b .glXDestroyPixmap
85
86
87%build
88#%configure --enable-gtk-doc \
89#       --enable-introspection=yes \
90#       --disable-silent-rules \
91#       --enable-xinput \
92#       --disable-static
93(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
94 %configure $CONFIGFLAGS \
95        --enable-introspection=yes \
96        --disable-silent-rules \
97        --enable-xinput \
98        --disable-static
99 # clutter git ships with some magic to put the git log in shipped tarballs
100 # which gets listed in files; don't blow up if it's missing
101 if ! test -f ChangeLog; then
102   echo "Created from snapshot" > ChangeLog
103 fi
104)
105
106make V=0
107
108%install
109rm -rf $RPM_BUILD_ROOT
110#make DESTDIR=$RPM_BUILD_ROOT install
111make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117%postun -p /sbin/ldconfig
118
119%files
120%defattr(-,root,root,-)
121%doc AUTHORS COPYING NEWS README
122%exclude %{_libdir}/*.la
123%{_libdir}/*.so.0
124%{_libdir}/*.so.0.*
125%{_libdir}/girepository-1.0/*.typelib
126%{_datadir}/locale/*/LC_MESSAGES/*
127
128%files devel
129%defattr(-, root, root)
130%doc ChangeLog
131%{_includedir}/*
132%{_libdir}/*.so
133%{_libdir}/pkgconfig/*.pc
134%{_datadir}/gir-1.0/*.gir
135
136%files doc
137%defattr(-, root, root)
138%{_datadir}/gtk-doc/html/clutter
139%{_datadir}/gtk-doc/html/cogl
140%{_datadir}/gtk-doc/html/cally
141
142
143%changelog
144* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
145- new upstream release
146
147* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
148- new upstream release
149
150* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
151- new upstream release
152- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
153- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
154- drop Patch0
155
156* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
157- new upstream release
158- drop Patch1
159
160* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
161- new upstream release
162- add BuildRequires: json-glib-devel
163- delete Requires: gir-repository
164- delete BuildRequires: gir-repository-devel
165- add Requires: json-glib-devel (devel package)
166- add Patch0, Patch1
167- fix %build
168
169* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
170- rebuild with rpm-4.8.1 for pkg-config file
171
172* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
173- new upstream release
174
175* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
176- new upstream release
177
178* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
179- new upstream release
180- add configure option (--enable-xinput)
181
182* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
183- new upstream release
184
185* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
186- new upstream release
187
188* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
189- new upstream release
190
191* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
192- new upstream release
193
194* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
195- new upstream release
196- build for Vine Linux
197- add Summary(ja)
198- fix BuildRoot
199- remove Obsolete and Provides
200
201* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
202- Update to 1.0.6
203
204* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
205- Update to 1.0.4, update gobject-introspection requirement
206
207* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
208- Update to 1.0.2
209
210* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
211- Move ChangeLog to -devel to save some space
212
213* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
214- Drop the gir-repository-devel dep, which pulls a bunch of -devel
215  onto the live cd
216
217* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
218- Update to 1.0.0
219
220* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
221- fix bz #507389
222
223* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
225
226* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
227- Update to 0.9.8
228
229* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
230- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
231  introspection support to clutter (#512260)
232
233* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
234- Update to 0.9.6
235
236* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
237- Update to 0.9.4
238
239* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
240- Update to 0.9.2
241
242* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
244
245
246* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
247- Remove noarch from doc subpackage
248
249* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
250- Added gtk-doc for cogl
251- Created doc subpackage
252
253* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
254- Update to 0.8.6
255
256* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
257- Update to 0.8.2
258- Removed clutter-0.8.0-clutter-fixed.patch
259
260* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
261- Update to 0.8.0
262- Added clutter-0.8.0-clutter-fixed.patch
263
264* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
265- Update to 0.6.4
266
267* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
268- Update to 0.6.2
269
270* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
271- Update to 0.6.0
272
273* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
274- Autorebuild for GCC 4.3
275
276* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
277- Update to 0.4.2
278
279* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
280- Update to 0.4.1
281
282* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
283- Update to 0.3.1
284
285* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
286- Update to 0.2.3
287
288* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
289- Changed buildrequires and requires
290
291* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
292- Fix .spec
293
294* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
295- Fix .spec
296
297* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
298- Initial RPM release
Note: See TracBrowser for help on using the repository browser.