source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 2041

Revision 2041, 8.3 KB checked in by Takemikaduchi, 14 years ago (diff)

update to GNOME-2.32.0

Line 
1%define         clutter_version 1.4.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.4/%{name}-%{version}.tar.bz2
14
15# http://bugzilla.openedhand.com/show_bug.cgi?id=2100
16Patch0:         Use-a-native-format-for-atlas-textures.patch
17# http://bugzilla.clutter-project.org/show_bug.cgi?id=2324
18Patch1:         cogl-x11-Trap-glXDestroyPixmap.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22Requires:       gobject-introspection
23# FIXME to remove when all the bits have been merged into their
24# libraries
25
26BuildRequires:  glib2-devel
27BuildRequires:  mesa-libGL-devel
28BuildRequires:  gtk2-devel
29BuildRequires:  pkgconfig
30BuildRequires:  pango-devel
31BuildRequires:  libXdamage-devel
32BuildRequires:  gettext
33BuildRequires:  gtk-doc
34BuildRequires:  gobject-introspection-devel >= 0.9.5
35BuildRequires:  json-glib-devel
36
37%description
38Clutter is an open source software library for creating fast,
39visually rich graphical user interfaces. The most obvious example
40of potential usage is in media center type applications.
41We hope however it can be used for a lot more.
42
43%description -l ja
44Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
45最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
46しかしながら、我々はいろいろな分野で使用されることを願っています。
47
48%package devel
49Summary:        Clutter development environment
50Summary(ja):    Clutterの開発環境
51Group:          Development/Libraries
52Requires:       %{name} = %{version}-%{release}
53Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gtk2-devel
54Requires:       mesa-libGL-devel
55Requires:       gobject-introspection-devel
56Requires:       json-glib-devel
57
58%description devel
59Header files and libraries for building a extension library for the
60clutter
61
62
63%package        doc
64Summary:        Documentation for %{name}
65Summary(ja):    %{name}用のドキュメント
66Group:          Documentation
67Requires:       %{name} = %{version}-%{release}
68
69%description    doc
70Clutter is an open source software library for creating fast,
71visually rich graphical user interfaces. The most obvious example
72of potential usage is in media center type applications.
73We hope however it can be used for a lot more.
74
75This package contains documentation for clutter.
76
77
78%prep
79%setup -q
80%patch0 -p0 -b .atlas-textures
81%patch1 -p1 -b .glXDestroyPixmap
82
83
84%build
85#%configure --enable-gtk-doc \
86#       --enable-introspection=yes \
87#       --disable-silent-rules \
88#       --enable-xinput \
89#       --disable-static
90(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
91 %configure $CONFIGFLAGS \
92        --enable-introspection=yes \
93        --disable-silent-rules \
94        --enable-xinput \
95        --disable-static
96 # clutter git ships with some magic to put the git log in shipped tarballs
97 # which gets listed in files; don't blow up if it's missing
98 if ! test -f ChangeLog; then
99   echo "Created from snapshot" > ChangeLog
100 fi
101)
102
103make V=0
104
105%install
106rm -rf $RPM_BUILD_ROOT
107#make DESTDIR=$RPM_BUILD_ROOT install
108make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%post -p /sbin/ldconfig
114%postun -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root,-)
118%doc AUTHORS COPYING NEWS README
119%exclude %{_libdir}/*.la
120%{_libdir}/*.so.0
121%{_libdir}/*.so.0.*
122%{_libdir}/girepository-1.0/*.typelib
123%{_datadir}/locale/*/LC_MESSAGES/*
124
125%files devel
126%defattr(-, root, root)
127%doc ChangeLog
128%{_includedir}/*
129%{_libdir}/*.so
130%{_libdir}/pkgconfig/*.pc
131%{_datadir}/gir-1.0/*.gir
132
133%files doc
134%defattr(-, root, root)
135%{_datadir}/gtk-doc/html/clutter
136%{_datadir}/gtk-doc/html/cogl
137%{_datadir}/gtk-doc/html/cally
138
139
140%changelog
141* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
142- new upstream release
143- add BuildRequires: json-glib-devel
144- delete Requires: gir-repository
145- delete BuildRequires: gir-repository-devel
146- add Requires: json-glib-devel (devel package)
147- add Patch0, Patch1
148- fix %build
149
150* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
151- rebuild with rpm-4.8.1 for pkg-config file
152
153* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
154- new upstream release
155
156* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
157- new upstream release
158
159* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
160- new upstream release
161- add configure option (--enable-xinput)
162
163* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
164- new upstream release
165
166* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
167- new upstream release
168
169* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
170- new upstream release
171
172* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
173- new upstream release
174
175* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
176- new upstream release
177- build for Vine Linux
178- add Summary(ja)
179- fix BuildRoot
180- remove Obsolete and Provides
181
182* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
183- Update to 1.0.6
184
185* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
186- Update to 1.0.4, update gobject-introspection requirement
187
188* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
189- Update to 1.0.2
190
191* Sun Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
192- Move ChangeLog to -devel to save some space
193
194* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
195- Drop the gir-repository-devel dep, which pulls a bunch of -devel
196  onto the live cd
197
198* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
199- Update to 1.0.0
200
201* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
202- fix bz #507389
203
204* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
205- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
206
207* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
208- Update to 0.9.8
209
210* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
211- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
212  introspection support to clutter (#512260)
213
214* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
215- Update to 0.9.6
216
217* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
218- Update to 0.9.4
219
220* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
221- Update to 0.9.2
222
223* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
224- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
225
226
227* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
228- Remove noarch from doc subpackage
229
230* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
231- Added gtk-doc for cogl
232- Created doc subpackage
233
234* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
235- Update to 0.8.6
236
237* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
238- Update to 0.8.2
239- Removed clutter-0.8.0-clutter-fixed.patch
240
241* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
242- Update to 0.8.0
243- Added clutter-0.8.0-clutter-fixed.patch
244
245* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
246- Update to 0.6.4
247
248* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
249- Update to 0.6.2
250
251* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
252- Update to 0.6.0
253
254* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
255- Autorebuild for GCC 4.3
256
257* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
258- Update to 0.4.2
259
260* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
261- Update to 0.4.1
262
263* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
264- Update to 0.3.1
265
266* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
267- Update to 0.2.3
268
269* Sun Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
270- Changed buildrequires and requires
271
272* Sun Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
273- Fix .spec
274
275* Sun Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
276- Fix .spec
277
278* Sun Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
279- Initial RPM release
Note: See TracBrowser for help on using the repository browser.