source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 12005

Revision 12005, 12.1 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define         clutter_version 1.26.2
2%define         clutter_release 2%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.26/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  mesa-libEGL-devel
26BuildRequires:  gdk-pixbuf2-devel
27BuildRequires:  atk-devel
28BuildRequires:  gtk3-devel
29BuildRequires:  pkgconfig
30BuildRequires:  pango-devel
31BuildRequires:  libXdamage-devel
32BuildRequires:  libXcomposite-devel
33BuildRequires:  libXi-devel
34BuildRequires:  gettext
35BuildRequires:  gtk-doc
36BuildRequires:  gobject-introspection-devel >= 0.9.5
37BuildRequires:  json-glib-devel
38BuildRequires:  cogl-devel >= 1.20.0
39BuildRequires:  libinput-devel
40BuildRequires:  libxkbcommon-devel
41BuildRequires:  eudev-libudev-devel
42BuildRequires:  libgudev-devel
43
44Vendor:         Project Vine
45Distribution:   Vine Linux
46
47%description
48Clutter is an open source software library for creating fast,
49visually rich graphical user interfaces. The most obvious example
50of potential usage is in media center type applications.
51We hope however it can be used for a lot more.
52
53%description -l ja
54Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
55最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
56しかしながら、我々はいろいろな分野で使用されることを願っています。
57
58%package                devel
59Summary:        Clutter development environment
60Summary(ja):    Clutterの開発環境
61Group:          Development/Libraries
62Requires:       %{name} = %{version}-%{release}
63Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
64Requires:       mesa-libGL-devel
65Requires:       mesa-libEGL-devel
66Requires:       gobject-introspection-devel
67Requires:               json-glib-devel
68Requires:               libXcomposite-devel
69Requires:               libXi-devel
70
71%description    devel
72Header files and libraries for building a extension library for the
73clutter
74
75
76%package        docs
77Summary:        Documentation for %{name}
78Summary(ja):    %{name}用のドキュメント
79Group:          Documentation
80Provides:               %{name}-doc = %{version}-%{release}
81BuildArch:              noarch
82
83%description    docs
84Clutter is an open source software library for creating fast,
85visually rich graphical user interfaces. The most obvious example
86of potential usage is in media center type applications.
87We hope however it can be used for a lot more.
88
89This package contains documentation for clutter.
90
91
92%prep
93%setup -q
94%patch0 -p1 -b .dso
95
96
97%build
98#%configure --enable-gtk-doc \
99#       --enable-introspection=yes \
100#       --disable-silent-rules \
101#       --enable-xinput \
102#       --disable-static
103(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
104 %configure $CONFIGFLAGS \
105        --disable-static \
106        --disable-silent-rules \
107        --enable-introspection=yes \
108        --enable-xinput \
109        --enable-x11-backend=yes \
110        --enable-gdk-backend=no \
111        --enable-egl-backend=yes \
112        --enable-evdev-input=yes
113 # clutter git ships with some magic to put the git log in shipped tarballs
114 # which gets listed in files; don't blow up if it's missing
115 if ! test -f ChangeLog; then
116   echo "Created from snapshot" > ChangeLog
117 fi
118)
119
120make V=0
121
122%install
123rm -rf $RPM_BUILD_ROOT
124#make DESTDIR=$RPM_BUILD_ROOT install
125make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
126
127rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
128
129%find_lang %{name}-1.0
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%post -p /sbin/ldconfig
135%postun -p /sbin/ldconfig
136
137%files -f %{name}-1.0.lang
138%defattr(-,root,root,-)
139%doc AUTHORS COPYING NEWS README
140%{_libdir}/*.so.*
141%{_libdir}/girepository-1.0/*.typelib
142
143%files devel
144%defattr(-, root, root)
145%doc ChangeLog
146%{_includedir}/clutter-1.0
147%{_libdir}/*.so
148%{_libdir}/pkgconfig/*.pc
149%{_datadir}/gir-1.0/*.gir
150
151%files docs
152%defattr(-, root, root)
153%{_datadir}/gtk-doc/html/clutter
154
155
156%changelog
157* Fri Jan 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-2
158- disabled gdk backend.
159
160* Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.26.2-1
161- new upstream release.
162
163* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.0-1
164- new upstream release
165
166* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.24.2-1
167- new upstream release
168
169* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
170- new upstream release
171
172* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
173- new upstream release
174
175* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
176- new upstream release
177
178* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
179- new upstream release
180- add BuildRequires: mesa-libEGL-devel
181
182* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
183- new upstream release
184
185* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
186- new upstream release
187
188* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
189- new upstream release
190
191* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
192- new upstream release
193
194* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
195- new upstream release
196
197* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
198- new upstream release
199
200* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
201- new upstream release
202
203* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
204- new upstream release
205
206* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
207- new upstream release
208
209* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
210- new upstream release
211
212* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
213- new upstream release
214
215* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
216- new upstream release
217
218* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
219- new upstream release
220
221* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
222- new upstream release
223
224* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
225- new upstream release
226
227* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
228- new upstream release
229
230* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
231- new upstream release
232- add Requires: libXcomposite-devel, libXi-devel (-devel package)
233
234* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
235- new upstream release
236
237* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
238- new upstream release
239
240* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
241- new upstream release
242
243* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
244- new upstream release
245- add BuildRequires: cogl-devel
246- add "BuildArch: noarch" to doc sub package
247- add Patch0 (clutter-fixdso.patch)
248
249* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
250- new upstream release
251
252* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
253- new upstream release
254
255* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
256- new upstream release
257
258* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
259- new upstream release
260
261* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
262- new upstream release
263- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
264- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
265- drop Patch0
266
267* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
268- new upstream release
269- drop Patch1
270
271* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
272- new upstream release
273- add BuildRequires: json-glib-devel
274- delete Requires: gir-repository
275- delete BuildRequires: gir-repository-devel
276- add Requires: json-glib-devel (devel package)
277- add Patch0, Patch1
278- fix %build
279
280* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
281- rebuild with rpm-4.8.1 for pkg-config file
282
283* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
284- new upstream release
285
286* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
287- new upstream release
288
289* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
290- new upstream release
291- add configure option (--enable-xinput)
292
293* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
294- new upstream release
295
296* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
297- new upstream release
298
299* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
300- new upstream release
301
302* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
303- new upstream release
304
305* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
306- new upstream release
307- build for Vine Linux
308- add Summary(ja)
309- fix BuildRoot
310- remove Obsolete and Provides
311
312* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
313- Update to 1.0.6
314
315* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
316- Update to 1.0.4, update gobject-introspection requirement
317
318* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
319- Update to 1.0.2
320
321* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
322- Move ChangeLog to -devel to save some space
323
324* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
325- Drop the gir-repository-devel dep, which pulls a bunch of -devel
326  onto the live cd
327
328* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
329- Update to 1.0.0
330
331* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
332- fix bz #507389
333
334* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
335- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
336
337* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
338- Update to 0.9.8
339
340* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
341- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
342  introspection support to clutter (#512260)
343
344* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
345- Update to 0.9.6
346
347* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
348- Update to 0.9.4
349
350* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
351- Update to 0.9.2
352
353* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
354- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
355
356
357* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
358- Remove noarch from doc subpackage
359
360* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
361- Added gtk-doc for cogl
362- Created doc subpackage
363
364* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
365- Update to 0.8.6
366
367* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
368- Update to 0.8.2
369- Removed clutter-0.8.0-clutter-fixed.patch
370
371* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
372- Update to 0.8.0
373- Added clutter-0.8.0-clutter-fixed.patch
374
375* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
376- Update to 0.6.4
377
378* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
379- Update to 0.6.2
380
381* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
382- Update to 0.6.0
383
384* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
385- Autorebuild for GCC 4.3
386
387* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
388- Update to 0.4.2
389
390* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
391- Update to 0.4.1
392
393* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
394- Update to 0.3.1
395
396* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
397- Update to 0.2.3
398
399* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
400- Changed buildrequires and requires
401
402* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
403- Fix .spec
404
405* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
406- Fix .spec
407
408* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
409- Initial RPM release
Note: See TracBrowser for help on using the repository browser.