source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 10716

Revision 10716, 11.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define         clutter_version 1.26.0
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.26/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  mesa-libEGL-devel
26BuildRequires:  gdk-pixbuf2-devel
27BuildRequires:  atk-devel
28BuildRequires:  pkgconfig
29BuildRequires:  pango-devel
30BuildRequires:  libXdamage-devel
31BuildRequires:  libXcomposite-devel
32BuildRequires:  libXi-devel
33BuildRequires:  gettext
34BuildRequires:  gtk-doc
35BuildRequires:  gobject-introspection-devel >= 0.9.5
36BuildRequires:  json-glib-devel
37BuildRequires:  cogl-devel >= 1.20.0
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       Takemikaduchi
42
43%description
44Clutter is an open source software library for creating fast,
45visually rich graphical user interfaces. The most obvious example
46of potential usage is in media center type applications.
47We hope however it can be used for a lot more.
48
49%description -l ja
50Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
51最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
52しかしながら、我々はいろいろな分野で使用されることを願っています。
53
54%package                devel
55Summary:        Clutter development environment
56Summary(ja):    Clutterの開発環境
57Group:          Development/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
60Requires:       mesa-libGL-devel
61Requires:       mesa-libEGL-devel
62Requires:       gobject-introspection-devel
63Requires:               json-glib-devel
64Requires:               libXcomposite-devel
65Requires:               libXi-devel
66
67%description    devel
68Header files and libraries for building a extension library for the
69clutter
70
71
72%package        docs
73Summary:        Documentation for %{name}
74Summary(ja):    %{name}用のドキュメント
75Group:          Documentation
76Provides:               %{name}-doc = %{version}-%{release}
77BuildArch:              noarch
78
79%description    docs
80Clutter is an open source software library for creating fast,
81visually rich graphical user interfaces. The most obvious example
82of potential usage is in media center type applications.
83We hope however it can be used for a lot more.
84
85This package contains documentation for clutter.
86
87
88%prep
89%setup -q
90%patch0 -p1 -b .dso
91
92
93%build
94#%configure --enable-gtk-doc \
95#       --enable-introspection=yes \
96#       --disable-silent-rules \
97#       --enable-xinput \
98#       --disable-static
99(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
100 %configure $CONFIGFLAGS \
101        --enable-introspection=yes \
102        --disable-silent-rules \
103        --enable-xinput \
104        --disable-static \
105        --enable-egl-backend=yes
106 # clutter git ships with some magic to put the git log in shipped tarballs
107 # which gets listed in files; don't blow up if it's missing
108 if ! test -f ChangeLog; then
109   echo "Created from snapshot" > ChangeLog
110 fi
111)
112
113make V=0
114
115%install
116rm -rf $RPM_BUILD_ROOT
117#make DESTDIR=$RPM_BUILD_ROOT install
118make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
121
122%find_lang %{name}-1.0
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files -f %{name}-1.0.lang
131%defattr(-,root,root,-)
132%doc AUTHORS COPYING NEWS README
133%{_libdir}/*.so.*
134%{_libdir}/girepository-1.0/*.typelib
135
136%files devel
137%defattr(-, root, root)
138%doc ChangeLog
139%{_includedir}/clutter-1.0
140%{_libdir}/*.so
141%{_libdir}/pkgconfig/*.pc
142%{_datadir}/gir-1.0/*.gir
143
144%files docs
145%defattr(-, root, root)
146%{_datadir}/gtk-doc/html/clutter
147
148
149%changelog
150* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.0-1
151- new upstream release
152
153* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.24.2-1
154- new upstream release
155
156* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
157- new upstream release
158
159* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
160- new upstream release
161
162* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
163- new upstream release
164
165* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
166- new upstream release
167- add BuildRequires: mesa-libEGL-devel
168
169* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
170- new upstream release
171
172* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
173- new upstream release
174
175* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
176- new upstream release
177
178* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
179- new upstream release
180
181* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
182- new upstream release
183
184* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
185- new upstream release
186
187* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
188- new upstream release
189
190* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
191- new upstream release
192
193* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
194- new upstream release
195
196* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
197- new upstream release
198
199* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
200- new upstream release
201
202* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
203- new upstream release
204
205* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
206- new upstream release
207
208* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
209- new upstream release
210
211* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
212- new upstream release
213
214* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
215- new upstream release
216
217* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
218- new upstream release
219- add Requires: libXcomposite-devel, libXi-devel (-devel package)
220
221* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
222- new upstream release
223
224* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
225- new upstream release
226
227* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
228- new upstream release
229
230* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
231- new upstream release
232- add BuildRequires: cogl-devel
233- add "BuildArch: noarch" to doc sub package
234- add Patch0 (clutter-fixdso.patch)
235
236* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
237- new upstream release
238
239* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
240- new upstream release
241
242* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
243- new upstream release
244
245* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
246- new upstream release
247
248* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
249- new upstream release
250- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
251- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
252- drop Patch0
253
254* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
255- new upstream release
256- drop Patch1
257
258* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
259- new upstream release
260- add BuildRequires: json-glib-devel
261- delete Requires: gir-repository
262- delete BuildRequires: gir-repository-devel
263- add Requires: json-glib-devel (devel package)
264- add Patch0, Patch1
265- fix %build
266
267* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
268- rebuild with rpm-4.8.1 for pkg-config file
269
270* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
271- new upstream release
272
273* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
274- new upstream release
275
276* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
277- new upstream release
278- add configure option (--enable-xinput)
279
280* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
281- new upstream release
282
283* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
284- new upstream release
285
286* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
287- new upstream release
288
289* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
290- new upstream release
291
292* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
293- new upstream release
294- build for Vine Linux
295- add Summary(ja)
296- fix BuildRoot
297- remove Obsolete and Provides
298
299* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
300- Update to 1.0.6
301
302* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
303- Update to 1.0.4, update gobject-introspection requirement
304
305* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
306- Update to 1.0.2
307
308* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
309- Move ChangeLog to -devel to save some space
310
311* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
312- Drop the gir-repository-devel dep, which pulls a bunch of -devel
313  onto the live cd
314
315* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
316- Update to 1.0.0
317
318* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
319- fix bz #507389
320
321* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
322- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
323
324* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
325- Update to 0.9.8
326
327* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
328- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
329  introspection support to clutter (#512260)
330
331* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
332- Update to 0.9.6
333
334* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
335- Update to 0.9.4
336
337* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
338- Update to 0.9.2
339
340* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
341- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
342
343
344* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
345- Remove noarch from doc subpackage
346
347* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
348- Added gtk-doc for cogl
349- Created doc subpackage
350
351* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
352- Update to 0.8.6
353
354* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
355- Update to 0.8.2
356- Removed clutter-0.8.0-clutter-fixed.patch
357
358* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
359- Update to 0.8.0
360- Added clutter-0.8.0-clutter-fixed.patch
361
362* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
363- Update to 0.6.4
364
365* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
366- Update to 0.6.2
367
368* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
369- Update to 0.6.0
370
371* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
372- Autorebuild for GCC 4.3
373
374* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
375- Update to 0.4.2
376
377* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
378- Update to 0.4.1
379
380* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
381- Update to 0.3.1
382
383* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
384- Update to 0.2.3
385
386* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
387- Changed buildrequires and requires
388
389* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
390- Fix .spec
391
392* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
393- Fix .spec
394
395* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
396- Initial RPM release
Note: See TracBrowser for help on using the repository browser.