source: projects/specs/trunk/c/clutter/clutter-vl.spec @ 9646

Revision 9646, 11.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define         clutter_version 1.22.4
2%define         clutter_release 1%{?_dist_release}
3
4Name:           clutter
5Version:        %{clutter_version}
6Release:        %{clutter_release}
7Summary:        Open Source software library for creating rich graphical user interfaces
8Summary(ja):    リッチなGUIを作成するためのオープンソースライブラリ
9
10Group:          System Environment/Libraries
11License:        LGPLv2+
12URL:            http://www.clutter-project.org/
13Source0:        http://www.clutter-project.org/sources/%{name}/1.22/%{name}-%{version}.tar.xz
14
15Patch0:         clutter-fixdso.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19Requires:       gobject-introspection
20# FIXME to remove when all the bits have been merged into their
21# libraries
22
23BuildRequires:  glib2-devel
24BuildRequires:  mesa-libGL-devel
25BuildRequires:  mesa-libEGL-devel
26BuildRequires:  gdk-pixbuf2-devel
27BuildRequires:  atk-devel
28BuildRequires:  pkgconfig
29BuildRequires:  pango-devel
30BuildRequires:  libXdamage-devel
31BuildRequires:  libXcomposite-devel
32BuildRequires:  libXi-devel
33BuildRequires:  gettext
34BuildRequires:  gtk-doc
35BuildRequires:  gobject-introspection-devel >= 0.9.5
36BuildRequires:  json-glib-devel
37BuildRequires:  cogl-devel >= 1.20.0
38
39Vendor:         Project Vine
40Distribution:   Vine Linux
41Packager:       Takemikaduchi
42
43%description
44Clutter is an open source software library for creating fast,
45visually rich graphical user interfaces. The most obvious example
46of potential usage is in media center type applications.
47We hope however it can be used for a lot more.
48
49%description -l ja
50Clutterは高速で視覚的にリッチなGUIを作成するためのオープンソースライブラリです。
51最も明白な使用例は、メディアセンター型アプリケーションでの使用です。
52しかしながら、我々はいろいろな分野で使用されることを願っています。
53
54%package                devel
55Summary:        Clutter development environment
56Summary(ja):    Clutterの開発環境
57Group:          Development/Libraries
58Requires:       %{name} = %{version}-%{release}
59Requires:       pkgconfig glib2-devel pango-devel fontconfig-devel gdk-pixbuf2-devel
60Requires:       mesa-libGL-devel
61Requires:       mesa-libEGL-devel
62Requires:       gobject-introspection-devel
63Requires:               json-glib-devel
64Requires:               libXcomposite-devel
65Requires:               libXi-devel
66
67%description    devel
68Header files and libraries for building a extension library for the
69clutter
70
71
72%package        docs
73Summary:        Documentation for %{name}
74Summary(ja):    %{name}用のドキュメント
75Group:          Documentation
76Provides:               %{name}-doc = %{version}-%{release}
77BuildArch:              noarch
78
79%description    docs
80Clutter is an open source software library for creating fast,
81visually rich graphical user interfaces. The most obvious example
82of potential usage is in media center type applications.
83We hope however it can be used for a lot more.
84
85This package contains documentation for clutter.
86
87
88%prep
89%setup -q
90%patch0 -p1 -b .dso
91
92
93%build
94#%configure --enable-gtk-doc \
95#       --enable-introspection=yes \
96#       --disable-silent-rules \
97#       --enable-xinput \
98#       --disable-static
99(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
100 %configure $CONFIGFLAGS \
101        --enable-introspection=yes \
102        --disable-silent-rules \
103        --enable-xinput \
104        --disable-static \
105        --enable-egl-backend=yes
106 # clutter git ships with some magic to put the git log in shipped tarballs
107 # which gets listed in files; don't blow up if it's missing
108 if ! test -f ChangeLog; then
109   echo "Created from snapshot" > ChangeLog
110 fi
111)
112
113make V=0
114
115%install
116rm -rf $RPM_BUILD_ROOT
117#make DESTDIR=$RPM_BUILD_ROOT install
118make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
121
122%find_lang %{name}-1.0
123
124%clean
125rm -rf $RPM_BUILD_ROOT
126
127%post -p /sbin/ldconfig
128%postun -p /sbin/ldconfig
129
130%files -f %{name}-1.0.lang
131%defattr(-,root,root,-)
132%doc AUTHORS COPYING NEWS README
133%{_libdir}/*.so.*
134%{_libdir}/girepository-1.0/*.typelib
135
136%files devel
137%defattr(-, root, root)
138%doc ChangeLog
139%{_includedir}/clutter-1.0
140%{_libdir}/*.so
141%{_libdir}/pkgconfig/*.pc
142%{_datadir}/gir-1.0/*.gir
143
144%files docs
145%defattr(-, root, root)
146%{_datadir}/gtk-doc/html/clutter
147%{_datadir}/gtk-doc/html/cally
148
149
150%changelog
151* Sun Jul 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.4-1
152- new upstream release
153
154* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.2-1
155- new upstream release
156
157* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.22.0-1
158- new upstream release
159
160* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.20.0-1
161- new upstream release
162- add BuildRequires: mesa-libEGL-devel
163
164* Wed Aug 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.4-1
165- new upstream release
166
167* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.2-1
168- new upstream release
169
170* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.18.0-1
171- new upstream release
172
173* Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.4-1
174- new upstream release
175
176* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.2-1
177- new upstream release
178
179* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16.0-1
180- new upstream release
181
182* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
183- new upstream release
184
185* Thu Apr 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
186- new upstream release
187
188* Wed Oct 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
189- new upstream release
190
191* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
192- new upstream release
193
194* Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.8-1
195- new upstream release
196
197* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.6-1
198- new upstream release
199
200* Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.4-1
201- new upstream release
202
203* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
204- new upstream release
205
206* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.4-1
207- new upstream release
208
209* Fri Oct 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.2-1
210- new upstream release
211
212* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
213- new upstream release
214- add Requires: libXcomposite-devel, libXi-devel (-devel package)
215
216* Tue Sep 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.14-1
217- new upstream release
218
219* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.12-1
220- new upstream release
221
222* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.10-1
223- new upstream release
224
225* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.6-1
226- new upstream release
227- add BuildRequires: cogl-devel
228- add "BuildArch: noarch" to doc sub package
229- add Patch0 (clutter-fixdso.patch)
230
231* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
232- new upstream release
233
234* Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
235- new upstream release
236
237* Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
238- new upstream release
239
240* Tue Feb 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.6-1
241- new upstream release
242
243* Fri Feb 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.4-1
244- new upstream release
245- change BuildRequires: gdk-pixbuf2-devel instead of gtk2-devel
246- add BuildRequires: atk-devel, libXcomposite-devel, libXi-devel
247- drop Patch0
248
249* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
250- new upstream release
251- drop Patch1
252
253* Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
254- new upstream release
255- add BuildRequires: json-glib-devel
256- delete Requires: gir-repository
257- delete BuildRequires: gir-repository-devel
258- add Requires: json-glib-devel (devel package)
259- add Patch0, Patch1
260- fix %build
261
262* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-2
263- rebuild with rpm-4.8.1 for pkg-config file
264
265* Mon Jul 19 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.12-1
266- new upstream release
267
268* Sat Jul 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.10-1
269- new upstream release
270
271* Thu May 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
272- new upstream release
273- add configure option (--enable-xinput)
274
275* Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.6-1
276- new upstream release
277
278* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
279- new upstream release
280
281* Sun Mar 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
282- new upstream release
283
284* Sat Jan 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.10-1
285- new upstream release
286
287* Tue Dec  1 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.8-1
288- new upstream release
289- build for Vine Linux
290- add Summary(ja)
291- fix BuildRoot
292- remove Obsolete and Provides
293
294* Tue Sep 22 2009 Bastien Nocera <bnocera@redhat.com> 1.0.6-1
295- Update to 1.0.6
296
297* Sun Aug 30 2009 Owen Taylor <otaylor@redhat.com> - 1.0.4-1
298- Update to 1.0.4, update gobject-introspection requirement
299
300* Fri Aug 14 2009 Bastien Nocera <bnocera@redhat.com> 1.0.2-1
301- Update to 1.0.2
302
303* Sat Aug  1 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-4
304- Move ChangeLog to -devel to save some space
305
306* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com> 1.0.0-3
307- Drop the gir-repository-devel dep, which pulls a bunch of -devel
308  onto the live cd
309
310* Wed Jul 29 2009 Bastien Nocera <bnocera@redhat.com> 1.0.0-1
311- Update to 1.0.0
312
313* Tue Jul 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 0.9.8-3
314- fix bz #507389
315
316* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.8-2
317- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
318
319* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.8-1
320- Update to 0.9.8
321
322* Fri Jul 17 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-2
323- Patch from Owen Taylor <otaylor@redhat.com> to add gobject-
324  introspection support to clutter (#512260)
325
326* Fri Jul 10 2009 Bastien Nocera <bnocera@redhat.com> 0.9.6-1
327- Update to 0.9.6
328
329* Sat Jun 20 2009 Bastien Nocera <bnocera@redhat.com> 0.9.4-1
330- Update to 0.9.4
331
332* Mon May 18 2009 Bastien Nocera <bnocera@redhat.com> 0.9.2-1
333- Update to 0.9.2
334
335* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.6-4
336- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
337
338
339* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-3
340- Remove noarch from doc subpackage
341
342* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-2
343- Added gtk-doc for cogl
344- Created doc subpackage
345
346* Wed Jan 21 2009 Allisson Azevedo <allisson@gmail.com> 0.8.6-1
347- Update to 0.8.6
348
349* Mon Oct  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.2-1
350- Update to 0.8.2
351- Removed clutter-0.8.0-clutter-fixed.patch
352
353* Sat Sep  6 2008 Allisson Azevedo <allisson@gmail.com> 0.8.0-1
354- Update to 0.8.0
355- Added clutter-0.8.0-clutter-fixed.patch
356
357* Sat Jun 14 2008 Allisson Azevedo <allisson@gmail.com> 0.6.4-1
358- Update to 0.6.4
359
360* Sat May 17 2008 Allisson Azevedo <allisson@gmail.com> 0.6.2-1
361- Update to 0.6.2
362
363* Tue Feb 19 2008 Allisson Azevedo <allisson@gmail.com> 0.6.0-1
364- Update to 0.6.0
365
366* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
367- Autorebuild for GCC 4.3
368
369* Wed Oct  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.2-1
370- Update to 0.4.2
371
372* Mon Sep  3 2007 Allisson Azevedo <allisson@gmail.com> 0.4.1-1
373- Update to 0.4.1
374
375* Sat Jul 21 2007 Allisson Azevedo <allisson@gmail.com> 0.3.1-1
376- Update to 0.3.1
377
378* Thu Apr 12 2007 Allisson Azevedo <allisson@gmail.com> 0.2.3-1
379- Update to 0.2.3
380
381* Wed Mar 28 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-4
382- Changed buildrequires and requires
383
384* Tue Mar 27 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-3
385- Fix .spec
386
387* Sat Mar 24 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-2
388- Fix .spec
389
390* Fri Mar 23 2007 Allisson Azevedo <allisson@gmail.com> 0.2.2-1
391- Initial RPM release
Note: See TracBrowser for help on using the repository browser.