source: projects/specs/trunk/c/cluster-glue/cluster-glue-vl.spec @ 1319

Revision 1319, 11.4 KB checked in by daisuke, 14 years ago (diff)

cluster-glue: new package,1.0.2-2, obsolete stonith and pils (part of heartbeat2)

Line 
1%global gname haclient
2%global uname hacluster
3%global nogroup nobody
4
5# When downloading directly from Mercurial, it will automatically add this prefix
6# Invoking 'hg archive' wont but you can add one with: hg archive -t tgz -p "Reusable-Cluster-Components-" -r $upstreamversion $upstreamversion.tar.gz
7%global specversion 1
8%global upstreamprefix Reusable-Cluster-Components-
9%global upstreamversion aa1f9dee2793
10
11# Keep around for when/if required
12#global alphatag %{upstreamversion}.hg
13
14Name:           cluster-glue
15Summary:        Reusable cluster components
16Summary(ja):    再利用可能なクラスタコンポーネント
17Version:        1.0.2
18Release:        2%{?_dist_release}
19License:        GPLv2+ and LGPLv2+
20Url:            http://linux-ha.org/wiki/Cluster_Glue
21Group:          System Environment/Base
22Source0:        http://hg.linux-ha.org/glue/archive/%{upstreamversion}.tar.bz2
23
24Provides:       stonith = 3.0.0-1
25Provides:       pils = 3.0.0-1
26Obsoletes:      stonith < 3.0.0-1
27Obsoletes:      pils < 3.0.0-1
28
29## Setup/build bits
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32
33# Build dependencies
34Requires: perl-TimeDate
35BuildRequires: automake autoconf libtool pkgconfig chrpath libtool-ltdl-devel
36BuildRequires: bzip2-devel glib2-devel python-devel libxml2-devel
37
38# For documentation
39BuildRequires: libxslt docbook-style-xsl
40
41# For additional Stonith plugins
42BuildRequires: net-snmp-devel OpenIPMI-devel openhpi-devel curl-devel
43
44%if 0%{?fedora} > 11 || 0%{?rhel} > 5
45BuildRequires: libuuid-devel
46%else
47BuildRequires: e2fsprogs-devel
48%endif
49
50%prep
51%setup -q -n %{upstreamprefix}%{upstreamversion}
52
53./autogen.sh
54
55%{configure}    CFLAGS="${CFLAGS} $(echo '%{optflags}')" \
56                --enable-fatal-warnings=no   \
57                --localstatedir=%{_var}      \
58                --with-daemon-group=%{gname} \
59                --with-daemon-user=%{uname}
60
61%build
62make %{_smp_mflags}
63
64%install
65rm -rf %{buildroot}
66make install DESTDIR=%{buildroot}
67
68## tree fix up
69# Dont package static libs
70find %{buildroot} -name '*.a' -exec rm {} \;
71find %{buildroot} -name '*.la' -exec rm {} \;
72
73# Don't package things we wont support
74rm -f %{buildroot}/%{_libdir}/stonith/plugins/stonith2/rhcs.*
75
76%clean
77rm -rf %{buildroot}
78
79# cluster-glue
80
81%description
82A collection of common tools that are useful for writing cluster managers
83such as Pacemaker.
84Provides a local resource manager that understands the OCF and LSB
85standards, and an interface to common STONITH devices.
86
87%files
88%defattr(-,root,root)
89%{_sbindir}/ha_logger
90%{_sbindir}/hb_report
91%{_sbindir}/lrmadmin
92%{_sbindir}/meatclient
93%{_sbindir}/sbd
94%{_sbindir}/stonith
95%{_sysconfdir}/init.d/logd
96
97%dir %{_libdir}/heartbeat
98%dir %{_libdir}/heartbeat/plugins
99%dir %{_libdir}/heartbeat/plugins/RAExec
100%dir %{_libdir}/heartbeat/plugins/InterfaceMgr
101%{_libdir}/heartbeat/lrmd
102%{_libdir}/heartbeat/ha_logd
103%{_libdir}/heartbeat/plugins/RAExec/*.so
104%{_libdir}/heartbeat/plugins/InterfaceMgr/*.so
105
106%dir %{_libdir}/stonith
107%dir %{_libdir}/stonith/plugins
108%dir %{_libdir}/stonith/plugins/stonith2
109%{_datadir}/cluster-glue/ha_log.sh
110%{_libdir}/stonith/plugins/external
111%{_libdir}/stonith/plugins/stonith2/*.so
112%{_libdir}/stonith/plugins/stonith2/*.py*
113%{_libdir}/stonith/plugins/xen0-ha-dom0-stonith-helper
114
115%dir %{_datadir}/cluster-glue
116%{_datadir}/cluster-glue/ha_cf_support.sh
117%{_datadir}/cluster-glue/openais_conf_support.sh
118%{_datadir}/cluster-glue/utillib.sh
119%{_datadir}/cluster-glue/combine-logs.pl
120
121%dir %{_var}/lib/heartbeat
122%dir %{_var}/lib/heartbeat/cores
123%dir %attr (0700, root, root)           %{_var}/lib/heartbeat/cores/root
124%dir %attr (0700, nobody, %{nogroup})   %{_var}/lib/heartbeat/cores/nobody
125%dir %attr (0700, %{uname}, %{gname})   %{_var}/lib/heartbeat/cores/%{uname}
126
127%doc %{_datadir}/doc/cluster-glue/stonith
128%doc %{_mandir}/man1/*
129%doc %{_mandir}/man8/*
130%doc AUTHORS
131%doc COPYING
132
133# cluster-glue-libs
134
135%package -n cluster-glue-libs
136Summary:        Reusable cluster libraries
137Summary(ja):    Reusable cluster libraries
138Group:          Development/Libraries
139Requires:       %{name} = %{version}-%{release}
140
141%description -n cluster-glue-libs
142A collection of libraries that are useful for writing cluster managers
143such as Pacemaker.
144
145%pre
146getent group %{gname} >/dev/null || groupadd -r %{gname}
147getent passwd %{uname} >/dev/null || \
148useradd -r -g %{gname} -d %{_var}/lib/heartbeat/cores/hacluster -s /sbin/nologin \
149-c "heartbeat user" %{uname}
150exit 0
151
152%post -n cluster-glue-libs -p /sbin/ldconfig
153
154%postun -n cluster-glue-libs -p /sbin/ldconfig
155
156%files -n cluster-glue-libs
157%defattr(-,root,root)
158%{_libdir}/lib*.so.*
159%doc AUTHORS
160%doc COPYING.LIB
161
162# cluster-glue-libs-devel
163
164%package -n cluster-glue-libs-devel
165Summary:        Headers and libraries for writing cluster managers
166Summary(ja):    Headers and libraries for writing cluster managers
167Group:          Development/Libraries
168Requires:       cluster-glue-libs = %{version}-%{release}
169
170%description -n cluster-glue-libs-devel
171Headers and shared libraries for a useful for writing cluster managers
172such as Pacemaker.
173
174%files -n cluster-glue-libs-devel
175%defattr(-,root,root)
176%dir %{_libdir}/heartbeat
177%dir %{_libdir}/heartbeat/plugins
178%dir %{_libdir}/heartbeat/plugins/test
179%dir %{_datadir}/cluster-glue
180%{_libdir}/lib*.so
181%{_libdir}/heartbeat/ipctest
182%{_libdir}/heartbeat/ipctransientclient
183%{_libdir}/heartbeat/ipctransientserver
184%{_libdir}/heartbeat/transient-test.sh
185%{_libdir}/heartbeat/base64_md5_test
186%{_libdir}/heartbeat/logtest
187%{_includedir}/clplumbing
188%{_includedir}/heartbeat
189%{_includedir}/stonith
190%{_includedir}/pils
191%{_datadir}/cluster-glue/lrmtest
192%{_libdir}/heartbeat/plugins/test/test.so
193
194%doc AUTHORS
195%doc COPYING
196%doc COPYING.LIB
197
198%changelog
199* Mon Jul 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.2-2
200- Obsoletes/Provides: stonith, pils
201
202* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.0.2-1
203- initial build for Vine Linux
204
205* Mon Jan 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.0.2-1
206- Suppress unsupported stonith plugins
207- Update to latest upstream release: aa1f9dee2793
208  + High: stonith: add ha_log.sh for external plugins (LF 1971)
209  + High: stonith: external plugins log using ha_log.sh (LF 2294)
210  + High: stonith: external/dracmc-telnet: new stonith plugin for Dell Drac/MC Blade Enclosure and Cyclades terminal server
211  + High: stonith: external/riloe: workaround for the iLO double close of RIBCL element (bnc#553340)
212  + High: stonith: external: log messages immediately on manage and status calls
213  + High: stonith: external: log output of plugins (bnc#548699,553340)
214  + Medium: LRM: lrmd: log outcome of monitor once an hour
215  + Medium: LRM: lrmd: remove operation history on client unregister and flushing all operations (LF 2161)
216  + Medium: LRM: lrmd: restore reset scheduler for children (bnc#551971, lf#2296)
217  + Medium: LRM: raexec: close the logd fd too when executing agents (LF 2267)
218  + Medium: Tools: hb_report: add -V (version) option and add support for corosync
219  + Medium: external STONITH plugins: remove dependency on .ocf-shellfuncs (LF2249)
220  + Medium: stonith: cyclades: fix for support for newer PM10 firmware (LF 1938)
221  + Medium: stonith: external/ipmi: add explanation on reset and power off (LF 2071)
222  + Medium: stonith: external/riloe: make sure that host is turned on after power off/on reset (LF 2282)
223  + Medium: stonith: meatclient: add -w option to wait until it can connect
224  + Medium: stonith: print complete metadata for -m (LF 2279)
225  + Medium: stonith: stonith: add -m option to display metadata
226
227* Mon Nov 23 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.12.b79635605337.hg
228- Correctly select libuuid for building on rhel >=6
229
230* Mon Oct 12 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.11.b79635605337.hg
231- Add install dependancy on perl-TimeDate for hb_report
232- Update to upstream version b79635605337
233  + Build: fix defines for pacemaker-pygui compatibility.
234  + High: Tools: hb_report: log/events combining
235  + High: doc: new README for wti_mpc
236  + High: hb_report: add man page hb_report.8
237  + High: hb_report: extract important events from the logs
238  + High: stonith: external/ibmrsa-telnet: add support for later RSA cards
239  + High: stonith: wti_mpc: support for MIB versions 1 and 3
240  + Logd: Start/stop priorities are not created by configure
241  + Med: sbd: Fix definition of size_t.
242  + Med: sbd: Nodename comparison should be case insensitive (bnc#534445)
243  + Med: wti_nps: add support for internet power switch model (bnc#539912)
244  + Medium (LF 2194): LRM: fix return code on RA exec failure
245  + Medium: Tools: hb_report: add -v option (debugging)
246  + Medium: Tools: hb_report: options -C and -D are obsoleted
247  + ha_logd: Fix a compile error/warning.
248  + hb_report: report corosync packages too.
249  + sbd: Accept -h (bnc#529574)
250  + sbd: really fix the sector_size type.
251
252* Fri Oct  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0-0.10.d97b9dea436e.hg.1
253- rebuild with new net-snmp
254
255* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-0.9.d97b9dea436e.hg.1
256- rebuilt with new openssl
257
258* Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.9.d97b9dea436e.hg
259- Include relevant provides: and obsoletes: directives for heartbeat
260- Update the tarball from upstream to version d97b9dea436e
261  + Include license files
262  + Fix error messages in autogen.sh
263  + High (bnc#501723): Tools: hb_report: collect archived logs too
264  + Medium: clplumbing: check input when creating IPC channels
265  + Medium (bnc#510299): stonith: set G_SLICE to always-malloc to avoid bad interaction with the threaded openhpi
266  + Med: hb_report: report on more packages and with more state.
267  + The -E option to lrmadmin does not take an argument
268  + Provide a default value for docdir and ensure it is expanded
269  + Low: clplumbing: fix a potential resource leak in cl_random (bnc#525393).
270  + Med: hb_report: Include dlm_tool debugging information if available.
271  + hb_report: Include more possible error output.
272  + Medium: logd: add init script and example configuration file.
273  + High: logd: Fix init script. Remove apphbd references.
274  + logd: configuration file is optional.
275  + logd: print status on finished operations.
276  + High: sbd: actually install the binary.
277  + Medium: stonith: remove references to heartbeat artifacts.
278  + High: hb_report: define HA_NOARCHBIN
279  + hb_report: correct syntax error.
280  + hb_report: Include details about more packages even.
281  + hb_report: report corosync packages too.
282
283* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0-0.8.75cab275433e.hg
284- Use bzipped upstream tarball.
285
286* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.7.75cab275433e.hg
287- Add a leading zero to the revision when alphatag is used
288
289* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0-0.6.75cab275433e.hg
290- Incorporate results of Fedora review
291  - Use global instead of define
292  - Remove unused rpm variable
293  - Remove redundant configure options
294  - Change version to 1.0.0 pre-release and include Mercurial tag in version
295
296* Mon Jul  27 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-5
297- Use linux-ha.org for Source0
298- Remove Requires: $name from -devel as its implied
299- Instead of 'daemon', use the user and group from Heartbeat and create it
300  if necessary
301
302* Fri Jul  24 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-4
303- Update the tarball from upstream to version 75cab275433e
304- Include an AUTHORS and license file in each package
305- Change the library package name to cluster-glue-libs to be more
306  Fedora compliant
307
308* Mon Jul  20 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-3
309- Package the project AUTHORS file
310- Have Source0 reference the upstream Mercurial repo
311
312* Tue Jul  14 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-2
313- More cleanups
314
315* Fri Jul  3 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 0.9-1
316- Fedora-ize the spec file
317
318* Fri Jun  5 2009 Andrew Beekhof <andrew@beekhof.net> - 0.9-0
319- Initial checkin
Note: See TracBrowser for help on using the repository browser.