source: projects/specs/trunk/c/clucene-core/clucene-core-vl.spec @ 4825

Revision 4825, 2.9 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, clucene-core, strigi, soprano

Line 
1Name: clucene-core
2Summary: A C++ port of Lucene
3Version: 2.3.3.4
4Release: 1%{?_dist_release}
5
6License: LGPLv2+ or ASL 2.0
7Group: System Environment/Libraries
8URL: http://sourceforge.net/projects/clucene
9
10Source: %{name}-%{version}.tar.gz
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: cmake
14BuildRequires: gawk
15BuildRequires: libboost-devel
16BuildRequires: zlib-devel
17
18%description
19CLucene is a C++ port of the popular Apache Lucene search engine
20(http://lucene.apache.org/java).
21CLucene aims to be a high-speed alternative to Java Lucene, its API is very
22similar to that of the Java version. CLucene has recently been brought up to
23date with Lucene 2.3.2. It contains most of the same functionality as the Java version.
24
25%package devel
26Summary: Headers for developing programs that will use %{name}
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31This package contains the static libraries and header files needed for
32developing with clucene
33
34%prep
35%setup -q
36
37%build
38mkdir -p %{_target_platform}
39pushd %{_target_platform}
40export CFLAGS="%{optflags}"
41export CXXFLAGS="%{optflags}"
42export FFLAGS="%{optflags}"
43%ifarch x86_64 ppc64
44%define lib_suffix 64
45%else
46%define lib_suffix %{nil}
47%endif
48%cmake \
49    -DCMAKE_INSTALL_PREFIX=%{_prefix}                           \
50    -DLIB_DESTINATION=%{_libdir}  -DLIB_SUFFIX=%{lib_suffix}    \
51    -DLUCENE_SYS_INCLUDES=%{_libdir}                            \
52    ..
53popd
54
55make VERBOSE=1 %{?_smp_mflags} -C %{_target_platform}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make DESTDIR=$RPM_BUILD_ROOT install -C %{_target_platform}
60
61rm -rf $RPM_BUILD_ROOT%{_libdir}/CLuceneConfig.cmake
62#rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
63
64#check
65#cd %{_target_platform}
66#make cl_test
67#make test
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post -p /sbin/ldconfig
73
74%postun -p /sbin/ldconfig
75
76%files
77%defattr(-,root,root)
78%doc APACHE.license AUTHORS ChangeLog COPYING LGPL.license README
79%{_libdir}/libclucene*.so.*
80
81%files devel
82%defattr(-,root,root)
83%dir %{_includedir}/CLucene
84%dir %{_libdir}/CLucene
85%{_includedir}/CLucene/*
86%{_includedir}/CLucene.h
87%{_libdir}/libclucene*.so
88%{_libdir}/CLucene/clucene-config.h
89%{_libdir}/CLucene/CLuceneConfig.cmake
90%{_libdir}/pkgconfig/libclucene-core.pc
91
92%changelog
93* Sat Sep 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.3.4-1
94- new upstream release
95
96* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.21b-2
97- run make check at %%check
98
99* Tue Dec  9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.21b-1
100- new upstream release
101
102* Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-1
103- fix release
104
105* Mon Nov 19 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-0vl2
106- stop moving clucene-config.h from %%{_libdir}/CLucene
107
108* Thu Oct 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.20-0vl1
109- new upstream release
110
111* Sat Jul 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.19-0vl1
112- new upstream release
113
114* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.9.16a-0vl1
115- initial release
Note: See TracBrowser for help on using the repository browser.