source: projects/specs/trunk/c/cln/cln-vl.spec @ 521

Revision 521, 5.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           cln
2Version:        1.3.1
3Release:        1%{?_dist_release}
4Summary:        Class Library for Numbers
5
6Group:          System Environment/Libraries
7License:        GPLv2+
8URL:            http://www.ginac.de/CLN/
9Source0:        http://www.ginac.de/CLN/%{name}-%{version}.tar.bz2
10Patch0:         cln-1.2.2-s390x.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13BuildRequires:  gmp-devel
14BuildRequires:  texi2html texinfo
15Requires(post): /sbin/install-info
16Requires(preun): /sbin/install-info
17
18%description
19A collection of C++ math classes and functions, which are designed for
20memory and speed efficiency, and enable type safety and algebraic
21syntax.
22
23%package devel
24Summary:        Development files for programs using the CLN library
25Group:          Development/Libraries
26Requires:       %{name} = %{version}-%{release}
27Requires:       gmp-devel
28Requires:       pkgconfig
29
30%description devel
31A collection of C++ math classes and functions, which are designed for
32memory and speed efficiency, and enable type safety and algebraic
33syntax.
34
35This package is necessary if you wish to develop software based on
36the CLN library.
37
38%prep
39%setup -q
40%patch0 -p1 -b .s390x
41
42%build
43%configure --disable-static
44make %{?_smp_mflags}
45make pdf
46make html
47
48%install
49rm -rf %{buildroot}
50make DESTDIR=%{buildroot} install
51
52mkdir -p %{buildroot}%{_docdir}/%{name}-devel-%{version}
53cp -p doc/cln.pdf doc/cln.html %{buildroot}%{_docdir}/%{name}-devel-%{version}/
54
55find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
56rm -f %{buildroot}%{_infodir}/dir
57rm -rf %{buildroot}%{_bindir} %{buildroot}%{_mandir}/man1/pi.*
58
59%check
60make %{?_smp_mflags} check
61
62%clean
63rm -rf %{buildroot}
64
65%post -p /sbin/ldconfig
66
67%postun -p /sbin/ldconfig
68
69%post devel
70/sbin/install-info --section="Math" %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
71
72%preun devel
73if [ "$1" = 0 ]; then
74  /sbin/install-info --delete %{_infodir}/cln.info.gz %{_infodir}/dir 2>/dev/null || :
75fi
76
77%files
78%defattr(-,root,root)
79%doc COPYING ChangeLog NEWS README TODO*
80%{_libdir}/*.so.*
81
82%files devel
83%defattr(-,root,root)
84%{_libdir}/*.so
85%{_libdir}/pkgconfig/cln.pc
86%{_includedir}/cln
87%{_infodir}/*.info*
88%{_docdir}/%{name}-devel-%{version}
89
90%changelog
91* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
92- new upstream release
93- built with new toolchain
94
95* Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.0-3
96- Initial build for Vine Linux
97
98* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-2
99- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
100
101* Thu Jul 02 2009 Deji Akingunola <dakingun@gmail.com> - 1.3.0-1
102- Update to latest upstream release 1.3.0
103
104* Thu May 28 2009 Dan Horak <dan[at]danny.cz> - 1.2.2-5
105- fix build on s390x
106- run the test-suite during build
107
108* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-4
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
110
111* Wed Feb 04 2009 Deji Akingunola <dakingun@gmail.com> - 1.2.2-3
112- Add upstream patch to build with gcc-4.4
113
114* Fri Jan 16 2009 Rakesh Pandit <rakesh@fedoraproject.org> 1.2.2-2
115- Bump to solve dependency for ginac-devel
116
117* Tue Apr 29 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.2-1
118- Update to 1.2.2.
119
120* Mon Feb 25 2008 Quentin Spencer <qspencer@users.sf.net> 1.2.0-1
121- Update to 1.2.0.
122- Update License tag.
123
124* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.13-5
125- Autorebuild for GCC 4.3
126
127* Thu Sep 13 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-4
128- Add pkgconfig as a dependency of -devel.
129
130* Tue Aug 21 2007 Quentin Spencer <qspencer@users.sf.net> 1.1.13-3
131- Rebuild for F8.
132
133* Mon Aug 28 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-2
134- Rebuild for FC-6.
135
136* Thu Aug 17 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.13-1
137- New release.
138
139* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-5
140- Disable static build.
141- Enable parallel build.
142
143* Mon Feb 13 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-4
144- Rebuild for Fedora Extras 5.
145- Remove /usr/share/info/dir after install.
146- Exclude static libs.
147
148* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-3
149- Exclude /usr/share/info/dir from package (bug 178660).
150
151* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-2
152- Update source URL.
153
154* Mon Jan 16 2006 Quentin Spencer <qspencer@users.sf.net> 1.1.11-1
155- New upstream release.
156
157* Mon Oct 31 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.10-1
158- New upstream release, incorporating previous patch.
159
160* Mon Jun 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-8
161- Rebuild
162
163* Mon Jun 13 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-4
164- Patched include/cln/string.h to correctly compile on gcc-c++-4.0.0-9
165
166* Fri May 27 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-3
167- Added gmp-devel to Requires for devel
168
169* Fri May 20 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-2
170- Added dist tag.
171
172* Wed May 11 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
173- Excluded .la file
174
175* Fri Apr 22 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
176- Added gmp-devel in BuildRequires, fixes in files
177- Added release to name in Requires for devel
178
179* Mon Mar 21 2005 Quentin Spencer <qspencer@users.sf.net> 1.1.9-1
180- Adapted spec file for Fedora Extras
181
182* Thu Nov 20 2003 Christian Bauer <Christian.Bauer@uni-mainz.de>
183  Added pkg-config metadata file to devel package
184
185* Wed Nov  6 2002 Christian Bauer <Christian.Bauer@uni-mainz.de>
186  Added HTML and DVI docs to devel package
187
188* Tue Nov  5 2001 Christian Bauer <Christian.Bauer@uni-mainz.de>
189  Added Packager
Note: See TracBrowser for help on using the repository browser.