source: projects/specs/trunk/c/clisp/clisp-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define year            2002
2%define month           07
3%define day             25
4%define name            clisp
5%define version         2.48
6%define release         1%{?_dist_release}
7%define clisp_build     vine
8
9Summary:      Common Lisp (ANSI CL) implementation
10Summary(ja):  関数型言語 Common Lisp (ANSI CL) の実装
11Name:         clisp
12Version:      %{version}
13Release:      %{release}
14Icon:         clisp.gif
15License:      GPL
16Group:        Development/Languages
17Source:       ftp://ftp.gnu.org/pub/gnu/clisp/release/2.48/%{name}-%{version}.tar.bz2
18Patch0:         clisp-2.47-cpp.patch
19#Patch:       %{name}-2.32-hfs.patch
20#Patch1:              %{name}-2.27-dvi.patch
21
22URL:          http://clisp.cons.org/
23Provides:     clisp, ansi-cl
24BuildRoot:    %{_tmppath}/%{name}-%{version}-root
25BuildRequires:  imake
26BuildRequires:  libsigsegv-devel
27BuildRequires:  readline-devel
28BuildRequires:  dbus-devel
29BuildRequires:  diffutils
30BuildRequires:  fcgi-devel
31BuildRequires:  ffcall
32BuildRequires:  gdbm-devel
33BuildRequires:  gettext
34BuildRequires:  gtk2-devel
35BuildRequires:  libICE-devel
36BuildRequires:  libSM-devel
37BuildRequires:  libX11-devel
38BuildRequires:  libXaw-devel
39BuildRequires:  libXext-devel
40BuildRequires:  libXft-devel
41BuildRequires:  libXmu-devel
42BuildRequires:  libXrender-devel
43BuildRequires:  libXt-devel
44BuildRequires:  libglade2-devel
45BuildRequires:  pcre-devel
46BuildRequires:  postgresql-devel
47BuildRequires:  zlib-devel
48
49%description
50Common Lisp is a high-level, general-purpose, object-oriented, dynamic,
51functional programming language.
52
53CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
54University, and Michael Stoll, then of Munich University, both in Germany.
55It supports the Lisp described in the ANSI Common Lisp standard plus many
56extensions.
57
58CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign
59language interface, i18n, regular expressions, a socket interface, and more.
60An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line
61editing is provided by readline. CLISP runs Maxima, ACL2 and many other
62Common Lisp packages.
63
64CLISP runs on most GNU and Unix systems (Linux, FreeBSD, NetBSD, OpenBSD,
65Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on other
66systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only 4 MB of RAM.
67
68CLISP is Free Software and may be distributed under the terms of GNU GPL.
69You may distribute commercial proprietary applications compiled with CLISP,
70see file COPYRIGHT in the CLISP distribution.
71
72The user interface comes in English, German, French, Spanish, Dutch, Russian
73and Danish, and can be changed at run time.
74
75%prep
76%setup -q
77sed -i 's|http://www.lisp.org/HyperSpec/|http://www.lispworks.com/documentation/HyperSpec/|g' \
78    doc/* src/*.d src/*.lisp
79
80%build
81%ifarch ppc ppc64
82%define opt_flags "$RPM_OPT_FLAGS -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
83ulimit -s unlimited
84%else
85%define opt_flags "$RPM_OPT_FLAGS"
86%endif
87
88./configure --prefix=%{_prefix} \
89            --libdir=%{_libdir} \
90            --mandir=%{_mandir} \
91            --docdir=%{_docdir}/clisp-%{version} \
92            --fsstnd=redhat \
93            --hyperspec=http://www.lispworks.com/documentation/HyperSpec/ \
94            --with-module=bindings/glibc \
95            --with-module=clx/new-clx \
96            --with-module=dbus \
97            --with-module=fastcgi \
98            --with-module=gdbm \
99            --with-module=gtk2 \
100            --with-module=i18n \
101            --with-module=pcre \
102            --with-module=postgresql \
103            --with-module=rawsock \
104            --with-module=regexp \
105            --with-module=syscalls \
106            --with-module=wildcard \
107            --with-module=zlib \
108            --with-readline \
109            --cbc \
110            build CFLAGS=%opt_flags
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make -C build DESTDIR=$RPM_BUILD_ROOT install
115rm -f $RPM_BUILD_ROOT%{_docdir}/clisp-%{version}/doc/clisp.{dvi,1,ps}
116cp -p doc/mop-spec.pdf $RPM_BUILD_ROOT%{_docdir}/clisp-%{version}/doc
117cp -p doc/*.png $RPM_BUILD_ROOT%{_docdir}/clisp-%{version}/doc
118cp -p doc/Why-CLISP* $RPM_BUILD_ROOT%{_docdir}/clisp-%{version}/doc
119cp -p doc/regexp.html $RPM_BUILD_ROOT%{_docdir}/clisp-%{version}/doc
120find $RPM_BUILD_ROOT%{_libdir} -name '*.dvi' | xargs rm -f
121%find_lang %{name}
122%find_lang %{name}low
123cat %{name}low.lang >> %{name}.lang
124
125
126%clean
127rm -rf %{buildroot}
128
129
130%files -f %{name}.lang
131%defattr(-,root,root,-)
132%{_bindir}/%{name}
133%{_mandir}/man1/*
134%{_libdir}/%{name}-%{version}
135%{_datadir}/aclocal/*.m4
136%{_datadir}/emacs/site-lisp/*
137%{_datadir}/vim/vimfiles/after/syntax/lisp.vim
138%doc %{_docdir}/clisp-%{version}
139
140%changelog
141* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.48-1
142- new upstream release
143- built with new toolchain, libsigsegv-2.8
144- updated build dependencies
145
146* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.43-1vl5
147- applied new versioning policy, spec in utf-8
148
149* Mon Nov 26 2007 Shu KONNO <owa@bg.wakwak.ne.jp> 2.43-0vl1
150- version up to 2.43
151- updated source url
152- changed %%{_libdir}/clisp to %%{_libdir}/clisp-%%{version}
153- added option "--libdir=%%{_libdir}" to configure for lib64
154
155* Sun Mar 18 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 2.41-0vl1
156- version up to 2.41
157- add BuildRequires : readline-devel, gettext, libsigsegv-devel
158- update %%description, %%files, configure options
159- drop hfs patch
160
161* Tue Jan  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl1
162- version up to 2.32
163- rebuild with new toolchains
164- updated hfs patch
165
166* Sat Aug 25 2002 Yoshihiro Ota <ota@j.email.ne.jp>
167- version up to 2.29
168
169* Sat Mar 9 2002 Yoshihiro Ota <ota@j.email.ne.jp>
170- version up to 2.28
171- added BuildRequires : ncurses-devel and removed groff patch
172
173* Fri Jan 18 2002 Yoshihiro Ota <ota@j.email.ne.jp>
174- create rpm for release 2.27
Note: See TracBrowser for help on using the repository browser.