source: projects/specs/trunk/c/clisp/clisp-vl.spec @ 9684

Revision 9684, 6.6 KB checked in by Takemikaduchi, 9 years ago (diff)

gnumeric, goffice, libgsf, maxima, gnupg: update
others: rebuild

Line 
1%define year            2002
2%define month           07
3%define day             25
4%define name            clisp
5%define version         2.49
6%define release         3%{?_dist_release}
7%define clisp_build     vine
8
9Summary:      Common Lisp (ANSI CL) implementation
10Summary(ja):  関数型言語 Common Lisp (ANSI CL) の実装
11Name:         clisp
12Version:      %{version}
13Release:      %{release}
14Icon:         clisp.gif
15License:      GPL
16Group:        Development/Languages
17Source:       ftp://ftp.gnu.org/pub/gnu/clisp/release/%{version}/%{name}-%{version}.tar.bz2
18
19# patch from suse
20# PATCH-FIX-OPENSUSE Correct path for header for System V IPC system calls
21Patch0:       clisp-linux.patch
22# PATCH-FIX-OPENSUSE Glibc got rid of unused __swblk_t type therefore update linux.lisp
23Patch1:       clisp-glibc-fix.patch
24#PATCH-FIX-UPSTREAM  patch#3474660  changeset 15557     4f5985f83127
25Patch2:       clisp-hostname.patch
26
27URL:          http://www.clisp.org/
28Provides:     clisp, ansi-cl
29BuildRoot:    %{_tmppath}/%{name}-%{version}-root
30BuildRequires:  imake
31BuildRequires:  libsigsegv-devel
32BuildRequires:  readline-devel
33BuildRequires:  dbus-devel
34BuildRequires:  diffutils
35BuildRequires:  fcgi-devel
36BuildRequires:  ffcall
37BuildRequires:  gdbm-devel
38BuildRequires:  gettext
39BuildRequires:  gtk2-devel
40BuildRequires:  libICE-devel
41BuildRequires:  libSM-devel
42BuildRequires:  libX11-devel
43BuildRequires:  libXaw-devel
44BuildRequires:  libXext-devel
45BuildRequires:  libXft-devel
46BuildRequires:  libXmu-devel
47BuildRequires:  libXrender-devel
48BuildRequires:  libXt-devel
49BuildRequires:  libglade2-devel
50BuildRequires:  pcre-devel
51BuildRequires:  libpq-devel
52BuildRequires:  openssl-devel
53BuildRequires:  zlib-devel
54
55%description
56Common Lisp is a high-level, general-purpose, object-oriented, dynamic,
57functional programming language.
58
59CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
60University, and Michael Stoll, then of Munich University, both in Germany.
61It supports the Lisp described in the ANSI Common Lisp standard plus many
62extensions.
63
64CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign
65language interface, i18n, regular expressions, a socket interface, and more.
66An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line
67editing is provided by readline. CLISP runs Maxima, ACL2 and many other
68Common Lisp packages.
69
70CLISP runs on most GNU and Unix systems (Linux, FreeBSD, NetBSD, OpenBSD,
71Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on other
72systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only 4 MB of RAM.
73
74CLISP is Free Software and may be distributed under the terms of GNU GPL.
75You may distribute commercial proprietary applications compiled with CLISP,
76see file COPYRIGHT in the CLISP distribution.
77
78The user interface comes in English, German, French, Spanish, Dutch, Russian
79and Danish, and can be changed at run time.
80
81%prep
82%setup -q
83%patch0 -p1
84%patch1 -p1 -b .glibc
85%patch2 -p0
86sed -i 's|http://www.lisp.org/HyperSpec/|http://www.lispworks.com/documentation/HyperSpec/|g' \
87    doc/* src/*.d src/*.lisp
88
89%build
90%ifarch ppc ppc64
91%define opt_flags "%{optflags} -DNO_GENERATIONAL_GC -DNO_MULTIMAP_FILE -DNO_SINGLEMAP"
92ulimit -s unlimited
93%else
94%define opt_flags "%{optflags}"
95%endif
96
97./configure --prefix=%{_prefix} \
98            --libdir=%{_libdir} \
99            --mandir=%{_mandir} \
100            --docdir=%{_docdir}/clisp-%{version} \
101            --fsstnd=redhat \
102            --hyperspec=http://www.lispworks.com/documentation/HyperSpec/ \
103            --with-module=bindings/glibc \
104            --with-module=clx/new-clx \
105            --with-module=dbus \
106            --with-module=fastcgi \
107            --with-module=gdbm \
108            --with-module=gtk2 \
109            --with-module=i18n \
110            --with-module=pcre \
111            --with-module=postgresql \
112            --with-module=rawsock \
113            --with-module=regexp \
114            --with-module=syscalls \
115            --with-module=wildcard \
116            --with-module=zlib \
117            --with-readline \
118            --cbc \
119            build CFLAGS=%opt_flags
120
121%install
122rm -rf %{buildroot}
123make -C build DESTDIR=%{buildroot} install
124rm -f %{buildroot}%{_docdir}/clisp-%{version}/doc/clisp.{dvi,1,ps}
125cp -p doc/mop-spec.pdf %{buildroot}%{_docdir}/clisp-%{version}/doc
126cp -p doc/*.png %{buildroot}%{_docdir}/clisp-%{version}/doc
127cp -p doc/Why-CLISP* %{buildroot}%{_docdir}/clisp-%{version}/doc
128cp -p doc/regexp.html %{buildroot}%{_docdir}/clisp-%{version}/doc
129find %{buildroot}%{_libdir} -name '*.dvi' | xargs rm -f
130%find_lang %{name}
131%find_lang %{name}low
132cat %{name}low.lang >> %{name}.lang
133
134## ad-hoc fix <BTS:VineLinux:825>: '--vimdir' option is broken...
135%__mkdir_p %{buildroot}%{_sysconfdir}/vim
136%__mv %{buildroot}%{_datadir}/vim/vimfiles/after %{buildroot}%{_sysconfdir}/vim
137
138%clean
139rm -rf %{buildroot}
140
141
142%files -f %{name}.lang
143%defattr(-,root,root,-)
144%{_bindir}/%{name}
145%{_bindir}/%{name}-link
146%{_mandir}/man1/*
147%{_libdir}/%{name}-%{version}
148%{_datadir}/aclocal/*.m4
149%{_datadir}/emacs/site-lisp/*
150%{_sysconfdir}/vim
151%doc %{_docdir}/clisp-%{version}
152
153%changelog
154* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.49-3
155- rebuild with readline-6.3
156- add Patch0,1,2 from suse
157- remove BuildRequires: postgresql-devel
158- add BuildRequires: libpq-devel, openssl-devel
159
160* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.49-2
161- rebuild with current ffcall
162
163* Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 2.49-1
164- new upstream release
165- ad-hoc fix <BTS:VineLinux:825>: but '--vimdir' option is broken...
166
167* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.48-2
168- rebuilt with postgresql-9.0.3
169
170* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.48-1
171- new upstream release
172- built with new toolchain, libsigsegv-2.8
173- updated build dependencies
174
175* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.43-1vl5
176- applied new versioning policy, spec in utf-8
177
178* Mon Nov 26 2007 Shu KONNO <owa@bg.wakwak.ne.jp> 2.43-0vl1
179- version up to 2.43
180- updated source url
181- changed %%{_libdir}/clisp to %%{_libdir}/clisp-%%{version}
182- added option "--libdir=%%{_libdir}" to configure for lib64
183
184* Sun Mar 18 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 2.41-0vl1
185- version up to 2.41
186- add BuildRequires : readline-devel, gettext, libsigsegv-devel
187- update %%description, %%files, configure options
188- drop hfs patch
189
190* Tue Jan  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl1
191- version up to 2.32
192- rebuild with new toolchains
193- updated hfs patch
194
195* Sun Aug 25 2002 Yoshihiro Ota <ota@j.email.ne.jp>
196- version up to 2.29
197
198* Sat Mar 9 2002 Yoshihiro Ota <ota@j.email.ne.jp>
199- version up to 2.28
200- added BuildRequires : ncurses-devel and removed groff patch
201
202* Fri Jan 18 2002 Yoshihiro Ota <ota@j.email.ne.jp>
203- create rpm for release 2.27
Note: See TracBrowser for help on using the repository browser.