source: projects/specs/trunk/c/clisp/clisp-vl.spec @ 12310

Revision 12310, 8.1 KB checked in by tomop, 4 years ago (diff)

updated 18 packages

bind-9.11.12-1

bison-3.4.2-1

clisp-2.49.93-1

exiv2-0.27.2-1

firefox-68.2.0-1

galera-26.4.3-1

gcr-3.28.1-1

glib2-2.62.2-1

golang-1.13.4-1

incron-0.5.12-3

libgexiv2-0.12.0-1

libsecret-0.18.8-2

mariadb-10.4.10-1

perl-Bit-Vector-7.4-1

perl-Class-Accessor-0.51-1

seahorse-3.34-1

thunderbird-68.2.1-1

wireshark-3.0.6-1

RevLine 
[12310]1%bcond_with check
[521]2
[12310]3Summary:        Common Lisp (ANSI CL) implementation
4Summary(ja):    関数型言語 Common Lisp (ANSI CL) の実装
5Name:           clisp
6Version:        2.49.93
7Release:        1%{?_dist_release}
8Group:          Development/Languages
[521]9
[12310]10Vendor:         Project Vine
11Distribution:   Vine Linux
[9684]12
[12310]13License:        GPL
14URL:            http://www.clisp.org/
15#Source0:         https://ftp.gnu.org/pub/gnu/clisp/release/%{version}/%{name}-%{version}.tar.bz2
16Source0:        clisp-dd40369.tar.xz
17
18# https://sourceforge.net/p/clisp/patches/35/
19Patch0:         %{name}-db.patch
20# https://sourceforge.net/p/clisp/patches/32/
21Patch1:         %{name}-format.patch
22# The encrypt and setkey functions are no longer available from glibc
23Patch2:         %{name}-setkey.patch
24# Adapt to changes in pari 2.11.0
25Patch3:         %{name}-pari.patch
26# The combination of register and volatile is nonsensical
27Patch4:         %{name}-register-volatile.patch
28
[521]29Provides:     clisp, ansi-cl
30BuildRoot:    %{_tmppath}/%{name}-%{version}-root
31BuildRequires:  imake
32BuildRequires:  libsigsegv-devel
33BuildRequires:  readline-devel
34BuildRequires:  dbus-devel
35BuildRequires:  diffutils
36BuildRequires:  fcgi-devel
37BuildRequires:  ffcall
38BuildRequires:  gdbm-devel
39BuildRequires:  gettext
40BuildRequires:  gtk2-devel
41BuildRequires:  libICE-devel
42BuildRequires:  libSM-devel
43BuildRequires:  libX11-devel
44BuildRequires:  libXaw-devel
45BuildRequires:  libXext-devel
46BuildRequires:  libXft-devel
47BuildRequires:  libXmu-devel
48BuildRequires:  libXrender-devel
49BuildRequires:  libXt-devel
50BuildRequires:  libglade2-devel
51BuildRequires:  pcre-devel
[9684]52BuildRequires:  libpq-devel
53BuildRequires:  openssl-devel
[521]54BuildRequires:  zlib-devel
55
[12310]56Requires:  vim-common
57
[521]58%description
59Common Lisp is a high-level, general-purpose, object-oriented, dynamic,
60functional programming language.
61
62CLISP is a Common Lisp implementation by Bruno Haible, then of Karlsruhe
63University, and Michael Stoll, then of Munich University, both in Germany.
64It supports the Lisp described in the ANSI Common Lisp standard plus many
65extensions.
66
67CLISP includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign
68language interface, i18n, regular expressions, a socket interface, and more.
69An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line
70editing is provided by readline. CLISP runs Maxima, ACL2 and many other
71Common Lisp packages.
72
73CLISP runs on most GNU and Unix systems (Linux, FreeBSD, NetBSD, OpenBSD,
74Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX and others) and on other
75systems (Windows NT/2000/XP, Windows 95/98/ME) and needs only 4 MB of RAM.
76
77CLISP is Free Software and may be distributed under the terms of GNU GPL.
78You may distribute commercial proprietary applications compiled with CLISP,
79see file COPYRIGHT in the CLISP distribution.
80
81The user interface comes in English, German, French, Spanish, Dutch, Russian
82and Danish, and can be changed at run time.
83
84%prep
[12310]85%setup -q -n clisp-dd40369
86
87%patch0 -p0
88%patch1 -p0
[9684]89%patch2 -p0
[12310]90%patch3 -p0
91%patch4 -p0
[521]92
[12310]93# Change URLs not affected by the --hyperspec argument to configure
94sed -i.orig 's|lisp.org/HyperSpec/Body/chap-7.html|lispworks.com/documentation/HyperSpec/Body/07_.htm|' \
95    src/clos-package.lisp
96touch -r src/clos-package.lisp.orig src/clos-package.lisp
97rm -f src/clos-package.lisp.orig
98for f in src/_README.*; do
99  sed -i.orig 's|lisp.org/HyperSpec/FrontMatter|lispworks.com/documentation/HyperSpec/Front|' $f
100  touch -r ${f}.orig $f
101  rm -f ${f}.orig
102done
103
104# We only link against libraries in system directories, so we need -L dir in
105# place of -Wl,-rpath -Wl,dir
106cp -p src/build-aux/config.rpath config.rpath.orig
107sed -i -e 's/${wl}-rpath ${wl}/-L/g' src/build-aux/config.rpath
108
109# Fix modules that need access to symbols in libgnu.a
110sed -i 's/\(${GLLIB_A}\) \(${LIBS}\)/-Wl,--whole-archive \1 -Wl,--no-whole-archive \2 -ldl/' src/makemake.in
111
112# Enable firefox to be the default browser for displaying documentation
113sed -i 's/;; \((setq \*browser\* .*)\)/\1/' src/cfgunix.lisp
114
115# Unpack the CLX manual
116tar -C modules/clx -xzf modules/clx/clx-manual.tar.gz
117chmod -R go+r modules/clx/clx-manual
118chmod a-x modules/clx/clx-manual/html/doc-index.cgi
119
120
[521]121%build
122ulimit -s unlimited
[12310]123export LC_ALL=C.UTF-8
[521]124
[12310]125# Do not need to specify base modules: i18n, readline, regexp, syscalls.
126# The dirkey module currently can only be built on Windows/Cygwin/MinGW.
127# The editor module is not in good enough shape to use.
128# The matlab, netica, and oracle modules require proprietary code to build.
129# The queens module is intended as an example only, not for actual use.
[521]130./configure --prefix=%{_prefix} \
131            --libdir=%{_libdir} \
132            --mandir=%{_mandir} \
133            --docdir=%{_docdir}/clisp-%{version} \
134            --fsstnd=redhat \
135            --hyperspec=http://www.lispworks.com/documentation/HyperSpec/ \
136            --with-module=bindings/glibc \
137            --with-module=clx/new-clx \
138            --with-module=dbus \
139            --with-module=fastcgi \
140            --with-module=gdbm \
141            --with-module=gtk2 \
142            --with-module=pcre \
143            --with-module=postgresql \
144            --with-module=rawsock \
145            --with-module=zlib \
[12310]146            --cbcx \
147            build \
148            CFLAGS="%{optflags} -Wa,--noexecstack" \
149            LDFLAGS="-Wl,--as-needed -Wl,-z,relro -Wl,-z,noexecstack" \
150%if %{with check}
151            %{nil}
152%else
153            ||:
154%endif
[521]155
[12310]156make -C build
157
[521]158%install
[12310]159ulimit -s unlimited
[5972]160rm -rf %{buildroot}
161make -C build DESTDIR=%{buildroot} install
162rm -f %{buildroot}%{_docdir}/clisp-%{version}/doc/clisp.{dvi,1,ps}
163cp -p doc/mop-spec.pdf %{buildroot}%{_docdir}/clisp-%{version}/doc
164cp -p doc/*.png %{buildroot}%{_docdir}/clisp-%{version}/doc
165cp -p doc/Why-CLISP* %{buildroot}%{_docdir}/clisp-%{version}/doc
166cp -p doc/regexp.html %{buildroot}%{_docdir}/clisp-%{version}/doc
167find %{buildroot}%{_libdir} -name '*.dvi' | xargs rm -f
[521]168%find_lang %{name}
169%find_lang %{name}low
170cat %{name}low.lang >> %{name}.lang
171
[4049]172## ad-hoc fix <BTS:VineLinux:825>: '--vimdir' option is broken...
[5972]173%__mkdir_p %{buildroot}%{_sysconfdir}/vim
174%__mv %{buildroot}%{_datadir}/vim/vimfiles/after %{buildroot}%{_sysconfdir}/vim
[521]175
176%clean
177rm -rf %{buildroot}
178
179
180%files -f %{name}.lang
181%defattr(-,root,root,-)
182%{_bindir}/%{name}
[9684]183%{_bindir}/%{name}-link
[521]184%{_mandir}/man1/*
[12310]185%{_libdir}/%{name}-%{version}+
[521]186%{_datadir}/aclocal/*.m4
187%{_datadir}/emacs/site-lisp/*
[4049]188%{_sysconfdir}/vim
[521]189%doc %{_docdir}/clisp-%{version}
190
191%changelog
[12310]192* Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.49.93-1
193- updated tarball from git (2.49.93+).
194- replaced patches from rawhide.
195
[9684]196* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.49-3
197- rebuild with readline-6.3
198- add Patch0,1,2 from suse
199- remove BuildRequires: postgresql-devel
200- add BuildRequires: libpq-devel, openssl-devel
201
[5972]202* Fri Mar 23 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.49-2
203- rebuild with current ffcall
204
[4049]205* Tue Apr 19 2011 IWAI, Masaharu <iwai@alib.jp> 2.49-1
206- new upstream release
207- ad-hoc fix <BTS:VineLinux:825>: but '--vimdir' option is broken...
208
[3418]209* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.48-2
210- rebuilt with postgresql-9.0.3
211
[521]212* Sat Mar  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.48-1
213- new upstream release
214- built with new toolchain, libsigsegv-2.8
215- updated build dependencies
216
217* Sun Sep 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.43-1vl5
218- applied new versioning policy, spec in utf-8
219
220* Mon Nov 26 2007 Shu KONNO <owa@bg.wakwak.ne.jp> 2.43-0vl1
221- version up to 2.43
222- updated source url
223- changed %%{_libdir}/clisp to %%{_libdir}/clisp-%%{version}
224- added option "--libdir=%%{_libdir}" to configure for lib64
225
226* Sun Mar 18 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 2.41-0vl1
227- version up to 2.41
228- add BuildRequires : readline-devel, gettext, libsigsegv-devel
229- update %%description, %%files, configure options
230- drop hfs patch
231
232* Tue Jan  6 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.32-0vl1
233- version up to 2.32
234- rebuild with new toolchains
235- updated hfs patch
236
[9684]237* Sun Aug 25 2002 Yoshihiro Ota <ota@j.email.ne.jp>
[521]238- version up to 2.29
239
240* Sat Mar 9 2002 Yoshihiro Ota <ota@j.email.ne.jp>
241- version up to 2.28
242- added BuildRequires : ncurses-devel and removed groff patch
243
244* Fri Jan 18 2002 Yoshihiro Ota <ota@j.email.ne.jp>
245- create rpm for release 2.27
Note: See TracBrowser for help on using the repository browser.