source: projects/specs/trunk/c/clipit/clipit-vl.spec @ 12194

Revision 12194, 3.5 KB checked in by ara_t, 5 years ago (diff)

clipit: add Patch1 to fix selecting by number at reverse history

Line 
1Name:           clipit
2Version:        1.4.4
3Release:        2%{?_dist_release}
4Summary:        lightweight GTK+ clipboard manager
5Summary(ja):    軽量な GTK+ クリップボードマネージャ
6
7Group:          Applications/Accessories
8License:        GPLv3
9URL:            http://gtk%{name}.sourceforge.net/
10
11# https://github.com/CristianHenzel/ClipIt/releases
12Source0:        ClipIt-%{version}.tar.gz
13
14#Source1:        %{name}_ja.po
15Patch0:         delete_unity.patch
16
17# fix selecting by number at reverse history
18Patch1:         clipit_select_reverse_history.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  gtk2-devel >= 2.10.0, glib2-devel >= 2.14.0
23BuildRequires:  desktop-file-utils, intltool >= 0.23
24BuildRequires:  gettext
25BuildRequires:  perl-XML-Parser
26
27Requires: xdotool
28
29%description
30ClipIt is a lightweight, fully featured GTK+ clipboard manager.
31It was forked from Parcellite (http://parcellite.sourceforge.net),
32adding additional features and bugfixes to the project.
33
34%description -l ja
35ClipIt は軽量で十分な機能を備えた GTK+ のクリップボードマネージャです。
36Parcellite (http://parcellite.sourceforge.net) からフォークし、
37プロジェクトに追加機能とバグフィックスを加えています。
38
39%prep
40%setup -q -n ClipIt-%{version}
41#cp -f %{SOURCE1} po/ja.po
42%patch0 -p1
43%patch1
44
45%build
46./autogen.sh
47%configure --enable-appindicator=no
48%{__make} %{?_smp_mflags}
49
50%install
51%{__rm} -rf $RPM_BUILD_ROOT
52%{__make} install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
53%find_lang %{name}
54
55desktop-file-install --vendor=""                     \
56  --delete-original                                        \
57  --remove-category=Application                            \
58  --dir=${RPM_BUILD_ROOT}%{_datadir}/applications          \
59  ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
60
61desktop-file-install --vendor=""                           \
62  --dir=${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart/     \
63  ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart/%{name}-startup.desktop
64
65%clean
66%{__rm} -rf $RPM_BUILD_ROOT
67
68%post
69touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
70
71
72%postun
73if [ $1 -eq 0 ] ; then
74    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
75    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
76fi
77
78%posttrans
79gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
80
81
82%files -f %{name}.lang
83%defattr(-,root,root,-)
84%doc AUTHORS ChangeLog COPYING README NEWS
85%config(noreplace) %{_sysconfdir}/xdg/autostart/%{name}-startup.desktop
86%{_bindir}/%{name}
87%{_datadir}/applications/%{name}.desktop
88%{_datadir}/icons/hicolor/
89%{_mandir}/man1/%{name}.1.gz
90
91
92%changelog
93* Sun Sep 08 2019 Toshiaki Ara <ara_t@384.jp> - 1.4.4-2
94- add Patch1 to fix selecting by number at reverse history
95
96* Sat Sep 07 2019 Toshiaki Ara <ara_t@384.jp> - 1.4.4-1
97- update to 1.4.4
98
99* Mon Jan 13 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.2-2
100- rebuilt with current toolchain
101
102* Sat Apr 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.2-1
103- new upstream release
104- dropt source1 to add Japanese translation
105- added patch0 to delete unity key in desktop file
106- added Requires: xdotool
107
108* Tue Jun 07 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.1-1
109- new upstream release
110- updated source1
111- added configure option --enable-appindicator=no
112- run gtk-update-icon-cache
113
114* Fri Jan 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.11-2
115- added source1 to translate modified Japanese
116
117* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.11-1
118- initial build for VineSeed
Note: See TracBrowser for help on using the repository browser.