source: projects/specs/trunk/c/clamav/clamav-vl.spec @ 7857

Revision 7857, 14.0 KB checked in by tomop, 11 years ago (diff)

clamav-0.98-1

Line 
1%define dbdir %{_localstatedir}/lib/clamav
2
3%if %{?_dist_release}!="vl5"
4%define milter 1
5%else
6%define milter 0
7%endif
8
9Summary: Clam AntiVirus
10Summary(ja): Clamアンチウィルススキャナ
11Name: clamav
12Version: 0.98
13Release: 1%{?_dist_release}
14License: GPL
15Group: Applications/System
16URL: http://www.clamav.net/
17Source0: http://clamav.elektrapro.com/stable/%{name}-%{version}.tar.gz
18Source1: clamd.init
19Source2: freshclam.init
20Source3: clamav-milter.init
21Source4: clamav.logrotate
22Source5: clamav-milter.logrotate
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: bzip2-devel, curl-devel > 7.10.0, gmp-devel, ncurses-devel
26BuildRequires: openssl-devel, zlib-devel
27%if %{?milter}
28BuildRequires: sendmail-devel
29%endif
30Requires: bzip2, curl > 7.10.0, gmp, ncurses, openssl, zlib, logrotate
31Requires(pre): shadow-utils, grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: tomop, inagaki
36
37%description
38Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
39AMaViS, compressed files, uses the virus database from
40OpenAntivirus.org, and includes a program for auto-updating. The scanner
41is multithreaded, written in C, and POSIX compliant.
42
43%description -l ja
44Clamアンチウィルスは強力なUNIX向けのアンチウィルススキャナです。
45AMaViS、圧縮ファイルをサポートし、OpenAntivirus.orgのウィルスデータ
46ベースを利用しています。またウィルスデータベースの自動アップデート
47プログラムを含んでいます。 このCで書かれたスキャナはマルチスレッド化
48されており、 POSIXに準拠しています。
49
50%if %{?milter}
51%package milter
52Summary: Virus scanner for sendmail/postfix
53Group: Applications/System
54
55%description milter
56clamav-milter is a milter module to scan mails using Clam AntiVirus.
57
58%endif
59
60%package devel
61Group: Development/Libraries
62Summary: headers and libraries for development using Clam AntiVirus
63Summary(ja): Clam AntiVirus を用いた開発に必要なヘッダ・ライブラリ
64Requires: %{name} = %{version}-%{release}
65Requires: zlib-devel bzip2-devel gmp-devel
66
67%description devel
68 clamav-devel provides headers and libraries for development using
69Clam AntiVirus.
70
71%description -l ja devel
72 clamav-devel パッケージは、Clam AntiVirus を用いた開発を行うための
73ヘッダファイルやライブラリファイルを提供します。
74
75%prep
76%setup -q
77
78perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamd.pid|' etc/clamd.conf
79perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamd.log|' etc/clamd.conf
80perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/freshclam.pid|' etc/freshclam.conf
81perl -pi -e 's|^#UpdateLogFile .+$|UpdateLogFile /var/log/clamav/freshclam.log|' etc/freshclam.conf
82perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamav-milter.pid|' etc/clamav-milter.conf
83perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamav-milter.log|' etc/clamav-milter.conf
84
85%build
86%if %{?milter}
87%configure --disable-clamav --enable-milter --with-dbdir=%{dbdir}
88%else
89%configure --disable-clamav --with-dbdir=%{dbdir}
90%endif
91
92make %{?_smp_mflags}
93
94%install
95rm -rf %{buildroot}
96mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
97mkdir -p %{buildroot}%{_initdir}
98mkdir -p %{buildroot}%{_localstatedir}/run/clamav
99mkdir -p %{buildroot}%{_localstatedir}/log/clamav
100make install DESTDIR=%{buildroot} transform='s,x,x,'
101install -m755 %{SOURCE1} %{buildroot}%{_initdir}/clamd
102install -m755 %{SOURCE2} %{buildroot}%{_initdir}/freshclam
103%if %{?milter}
104install -m755 %{SOURCE3} %{buildroot}%{_initdir}/clamav-milter
105install -m644 %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/clamav-milter
106mv %{buildroot}%{_sysconfdir}/clamav-milter.conf.sample %{buildroot}%{_sysconfdir}/clamav-milter.conf
107%endif
108install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/clamav
109
110mv %{buildroot}%{_sysconfdir}/clamd.conf.sample %{buildroot}%{_sysconfdir}/clamd.conf
111mv %{buildroot}%{_sysconfdir}/freshclam.conf.sample %{buildroot}%{_sysconfdir}/freshclam.conf
112
113rm -f %{buildroot}%{_libdir}/lib*a
114
115mkdir -p %{buildroot}%{dbdir}
116
117%clean
118rm -rf %{buildroot}
119
120%pre
121if ! grep -q '^clamav:' /etc/group; then
122    /usr/sbin/groupadd -r clamav
123fi
124if ! grep -q '^clamav:' /etc/passwd; then
125    /usr/sbin/useradd -M -r -s /bin/false -g clamav -c "Clam Antivirus" clamav || :
126fi
127
128%post
129/sbin/ldconfig
130/sbin/chkconfig --add clamd
131/sbin/chkconfig --add freshclam
132
133%preun
134if [ "$1" = 0 ]; then
135    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd stop
136    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam stop
137    /sbin/chkconfig --del clamd
138    /sbin/chkconfig --del freshclam
139fi
140
141%postun
142/sbin/ldconfig
143if [ "$1" = 0 ]; then
144    if [ `grep clamav /etc/passwd | wc -l` = 1 ]; then
145        /usr/sbin/userdel clamav
146    fi
147    if [ `grep clamav /etc/group | wc -l` = 1 ]; then
148        /usr/sbin/groupdel clamav
149    fi
150else
151    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd restart
152    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam restart
153fi
154
155%if %{?milter}
156%post milter
157/sbin/chkconfig --add clamav-milter
158
159%preun milter
160if [ "$1" = 0 ]; then
161    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamav-milter stop
162    /sbin/chkconfig --del clamav-milter
163fi
164
165%postun milter
166if [ "$1" -ge 1 ]; then
167    [ ! -f /var/run/clamav/clamav-milter.pid ] || /etc/init.d/clamav-milter restart
168fi
169%endif
170
171%files
172%defattr(-,root,root)
173%doc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL NEWS README examples test
174%doc README
175%doc docs/*
176%{_initdir}/clamd
177%{_initdir}/freshclam
178%config(noreplace) %{_sysconfdir}/clamd.conf
179%config(noreplace) %{_sysconfdir}/freshclam.conf
180%config(noreplace) %{_sysconfdir}/logrotate.d/clamav
181%{_bindir}/*
182%exclude %{_bindir}/clamav-config
183%{_sbindir}/*
184%{_libdir}/lib*.so.*
185%attr(-,clamav,clamav) %dir %{_localstatedir}/run/clamav
186%attr(-,clamav,clamav) %dir %{_localstatedir}/log/clamav
187%attr(0755,clamav,clamav) %dir %{dbdir}
188#%attr(-,clamav,clamav) %config(noreplace) %{dbdir}/main.cvd
189%exclude %{_mandir}/man8/clamav-milter.8*
190%{_mandir}/man*/*
191
192%if %{?milter}
193
194%files milter
195%defattr(-,root,root)
196%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
197%{_initdir}/clamav-milter
198%config(noreplace) %{_sysconfdir}/clamav-milter.conf
199%config(noreplace) %{_sysconfdir}/logrotate.d/clamav-milter
200%{_sbindir}/clamav-milter
201%{_mandir}/man8/clamav-milter.8*
202
203%endif
204
205%files devel
206%defattr(-,root,root)
207%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
208%{_bindir}/clamav-config
209%{_libdir}/lib*.so
210%{_libdir}/pkgconfig/*.pc
211%{_includedir}/*
212
213%changelog
214* Thu Oct 03 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.98-1
215- new upstream release.
216
217* Fri May 10 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.8-1
218- new upstream release.
219
220* Thu Mar 21 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.7-1
221- new upstream release.
222- fixed date of %%changelog.
223
224* Tue Sep 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-2
225- tarball was replaced on upstream.
226
227* Mon Sep 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-1
228- new upstream release.
229
230* Fri Jun 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.5-1
231- new upstream release.
232- removed /var/lib/clamav/main.cvd (by upstream).
233
234* Mon Mar 19 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.4-1
235- new upstream release.
236- removed /var/lib/clamav/daily.cvd.
237
238* Wed Dec 14 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.3-1
239- new upstream release.
240
241* Thu Aug 04 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.2-1
242- new upstream release.
243
244* Thu Jun 09 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.1-1
245- new upstream release.
246
247* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 0.97-2
248- add else routine for milter: fix building on Vine Linux 5
249
250* Tue Feb 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97-1
251- new upstream release.
252
253* Fri Dec 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.5-1
254- new upstream release.
255
256* Sat Nov 27 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-3
257- moved virus databases to /var/lib/clamav.
258
259* Wed Nov 17 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-2
260- added milter support.
261
262* Fri Nov 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-1
263- new upstream release.
264- added logrotate support.
265- fixed pre/post scripts for daemons.
266
267* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.96-2
268- rebuilt with rpm-4.8.1 for pkg-config
269
270* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.96-1
271- new upstream release.
272
273* Sat Jan 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.95.3-1
274- new upstream release.
275
276* Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.2-1
277- new upstream release.
278
279* Tue Jun  2 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.1-1
280- new upstream release.
281
282* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-2
283- dropped *.a files.
284
285* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-1
286- new upstream release.
287
288* Tue Jun 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93.1-1
289- new upstream release.
290- wrote specfile in UTF-8.
291
292* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93-1
293- new upstream release.
294- move clamd.init to /etc/rc.d/init.d/.
295- add /etc/rc.d/init.d/freshclam.
296
297* Thu Apr 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-1
298- apply new versioning policy.
299
300* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40.1
301- add missing files.
302
303* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40
304- new upstream release.
305
306* Tue Aug 21 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.2-0vl0.40
307- new upstream release.
308
309* Thu Aug  9 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.1-0vl0.40
310- new upstream release.
311
312* Fri Mar  2 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90.1-0vl0.40
313- new upstream release.
314
315* Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90-0vl0.40
316- new upstream release.
317
318* Thu Feb  1 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.7-0vl0.40
319- for Vine Linux 4.0.
320- new upstream release.
321
322* Tue Nov  7 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl1
323- built for VineSeed.
324
325* Mon Nov  6 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl0.1
326- new upstream release.
327
328* Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.5-0vl0.1
329- new upstream release.
330
331* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl0.1
332- rebuilt for Vine Linux 3.x.
333
334* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl1
335- new upstream release.
336
337* Sat Aug  5 2006 IWAI, Masaharu <iwai@alib.jp> 0.88.2-0vl3
338- add clamd.init script in doc dir
339
340* Tue Aug  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.88.2-0vl2
341- rebuilt for VineSeed (4.0)
342- added libclamav.pc to devel package
343- added Requires: gmp-devel to devel package
344
345* Mon May  1 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
346- 0.88.2-0vl1
347- new upstream release.
348
349* Wed Apr  5 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
350- 0.88.1-0vl1
351- new upstream release.
352
353* Tue Jan 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
354- 0.88-0vl1
355- new upstream release.
356
357* Fri Nov  4 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
358- 0.87.1-0vl1
359- new upstream release.
360
361* Sun Sep 18 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
362- 0.87-0vl1
363- new upstream release.
364
365* Mon Jul 25 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
366- 0.86.2-0vl1
367- new upstream release.
368
369* Sun Jun 26 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
370- 0.86.1-0vl1
371- new upstream release.
372- fix "Requires:".
373
374* Fri May 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
375- 0.85.1-0vl1
376- new upstream release.
377
378* Mon May 16 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
379- 0.85-0vl1
380- new upstream release.
381
382* Sun May  1 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
383- 0.84-0vl2
384- new upstream release.
385
386* Tue Feb 15 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
387- 0.83-0vl1
388- new upstream release.
389
390* Mon Feb 14 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
391- 0.82-0vl1
392- new upstream release.
393
394* Thu Jan 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
395- 0.81-0vl1
396- new upstream release.
397
398* Tue Nov  2 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
399- 0.80-0vl1
400- new upstream release.
401
402* Wed Aug 18 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
403- 0.75-0vl1
404- new upstream release.
405
406* Wed May  5 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
407- 0.70-0vl1
408- new upstream release.
409
410* Wed Apr 14 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
411- 0.68.1-0vl1
412- new upstream release.
413
414* Fri Feb 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
415- 0.67-0vl1
416- new upstream release.
417
418* Fri Nov 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
419- 0.65-0vl1
420- new upstream release.
421
422* Sat Aug 23 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
423- 0.60-0vl3
424- fix %%files.
425
426* Fri Aug 22 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
427- 0.60-0vl2
428- fix 'Requires:' and %%files.
429
430* Thu Aug 21 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
431- 0.60-0vl1
432- new upstream release.
433- add a sub-package 'devel'.
434
435* Mon Nov  4 2002 TORAYA Shin-ichi <shin@tora-jp.com>
436- 0.53-0vl1
437
438* Wed Oct 30 2002 TORAYA Shin-ichi <shin@tora-jp.com>
439- 0.52-0vl1
440
441* Tue Oct 22 2002 TORAYA Shin-ichi <shin@tora-jp.com>
442- 0.51-0vl1
443- port to Vine Linux from (0.51-1m)
444
445* Fri Oct 11 2002 Kazuhiko <kazuhiko@fdiary.net>
446- (0.51-1m)
447- major bugfixes
448
449* Sun Oct  6 2002 Kazuhiko <kazuhiko@fdiary.net>
450- (0.50-1m)
451- major feature enhancements
452
453* Fri Sep 20 2002 Kazuhiko <kazuhiko@fdiary.net>
454- (0.24-2m)
455- fix permission etc.
456
457* Fri Aug 23 2002 Kazuhiko <kazuhiko@fdiary.net>
458- (0.24-1m)
459- minor bugfixes
460
461* Sat Aug  3 2002 Kazuhiko <kazuhiko@fdiary.net>
462- (0.23-1m)
463- minor feature enhancements
464
465* Fri Jul 19 2002 Kazuhiko <kazuhiko@fdiary.net>
466- (0.21-1m)
467- minor bugfixes
468
469* Mon Jul 15 2002 Kazuhiko <kazuhiko@fdiary.net>
470- (0.20-1m)
471- revise URL
472- add a new program 'sigtool'
473
474* Thu Jun 13 2002 Kazuhiko <kazuhiko@kondara.org>
475- (0.15-2k)
476
477* Fri May 31 2002 Kazuhiko <kazuhiko@kondara.org>
478- (0.14-2k)
479
480* Thu May 23 2002 Kazuhiko <kazuhiko@kondara.org>
481- (0.12-2k)
482
483* Fri May 10 2002 Kazuhiko <kazuhiko@kondara.org>
484- (0.11-2k)
Note: See TracBrowser for help on using the repository browser.