source: projects/specs/trunk/c/clamav/clamav-vl.spec @ 7663

Revision 7663, 13.7 KB checked in by tomop, 11 years ago (diff)

clamav-0.97.8-1

Line 
1%define dbdir %{_localstatedir}/lib/clamav
2
3%if %{?_dist_release}!="vl5"
4%define milter 1
5%else
6%define milter 0
7%endif
8
9Summary: Clam AntiVirus
10Summary(ja): Clamアンチウィルススキャナ
11Name: clamav
12Version: 0.97.8
13Release: 1%{?_dist_release}
14License: GPL
15Group: Applications/System
16URL: http://www.clamav.net/
17Source0: http://clamav.elektrapro.com/stable/%{name}-%{version}.tar.gz
18Source1: clamd.init
19Source2: freshclam.init
20Source3: clamav-milter.init
21Source4: clamav.logrotate
22Source5: clamav-milter.logrotate
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: bzip2-devel, curl-devel > 7.10.0, gmp-devel, ncurses-devel
26BuildRequires: openssl-devel, zlib-devel
27%if %{?milter}
28BuildRequires: sendmail-devel
29%endif
30Requires: bzip2, curl > 7.10.0, gmp, ncurses, openssl, zlib, logrotate
31Requires(pre): shadow-utils, grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: tomop, inagaki
36
37%description
38Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
39AMaViS, compressed files, uses the virus database from
40OpenAntivirus.org, and includes a program for auto-updating. The scanner
41is multithreaded, written in C, and POSIX compliant.
42
43%description -l ja
44Clamアンチウィルスは強力なUNIX向けのアンチウィルススキャナです。
45AMaViS、圧縮ファイルをサポートし、OpenAntivirus.orgのウィルスデータ
46ベースを利用しています。またウィルスデータベースの自動アップデート
47プログラムを含んでいます。 このCで書かれたスキャナはマルチスレッド化
48されており、 POSIXに準拠しています。
49
50%if %{?milter}
51%package milter
52Summary: Virus scanner for sendmail/postfix
53Group: Applications/System
54
55%description milter
56clamav-milter is a milter module to scan mails using Clam AntiVirus.
57
58%endif
59
60%package devel
61Group: Development/Libraries
62Summary: headers and libraries for development using Clam AntiVirus
63Summary(ja): Clam AntiVirus を用いた開発に必要なヘッダ・ライブラリ
64Requires: %{name} = %{version}-%{release}
65Requires: zlib-devel bzip2-devel gmp-devel
66
67%description devel
68 clamav-devel provides headers and libraries for development using
69Clam AntiVirus.
70
71%description -l ja devel
72 clamav-devel パッケージは、Clam AntiVirus を用いた開発を行うための
73ヘッダファイルやライブラリファイルを提供します。
74
75%prep
76%setup -q
77
78perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamd.pid|' etc/clamd.conf
79perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamd.log|' etc/clamd.conf
80perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/freshclam.pid|' etc/freshclam.conf
81perl -pi -e 's|^#UpdateLogFile .+$|UpdateLogFile /var/log/clamav/freshclam.log|' etc/freshclam.conf
82perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamav-milter.pid|' etc/clamav-milter.conf
83perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamav-milter.log|' etc/clamav-milter.conf
84
85%build
86%if %{?milter}
87%configure --disable-clamav --enable-milter --with-dbdir=%{dbdir}
88%else
89%configure --disable-clamav --with-dbdir=%{dbdir}
90%endif
91
92make %{?_smp_mflags}
93
94%install
95rm -rf %{buildroot}
96mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
97mkdir -p %{buildroot}%{_initdir}
98mkdir -p %{buildroot}%{_localstatedir}/run/clamav
99mkdir -p %{buildroot}%{_localstatedir}/log/clamav
100make install DESTDIR=%{buildroot} transform='s,x,x,'
101install -m755 %{SOURCE1} %{buildroot}%{_initdir}/clamd
102install -m755 %{SOURCE2} %{buildroot}%{_initdir}/freshclam
103%if %{?milter}
104install -m755 %{SOURCE3} %{buildroot}%{_initdir}/clamav-milter
105install -m644 %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/clamav-milter
106%endif
107install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/clamav
108install etc/clamd.conf %{buildroot}%{_sysconfdir}
109install etc/freshclam.conf %{buildroot}%{_sysconfdir}
110
111rm -f %{buildroot}%{_libdir}/lib*a
112
113mkdir -p %{buildroot}%{dbdir}
114
115%clean
116rm -rf %{buildroot}
117
118%pre
119if ! grep -q '^clamav:' /etc/group; then
120    /usr/sbin/groupadd -r clamav
121fi
122if ! grep -q '^clamav:' /etc/passwd; then
123    /usr/sbin/useradd -M -r -s /bin/false -g clamav -c "Clam Antivirus" clamav || :
124fi
125
126%post
127/sbin/ldconfig
128/sbin/chkconfig --add clamd
129/sbin/chkconfig --add freshclam
130
131%preun
132if [ "$1" = 0 ]; then
133    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd stop
134    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam stop
135    /sbin/chkconfig --del clamd
136    /sbin/chkconfig --del freshclam
137fi
138
139%postun
140/sbin/ldconfig
141if [ "$1" = 0 ]; then
142    if [ `grep clamav /etc/passwd | wc -l` = 1 ]; then
143        /usr/sbin/userdel clamav
144    fi
145    if [ `grep clamav /etc/group | wc -l` = 1 ]; then
146        /usr/sbin/groupdel clamav
147    fi
148else
149    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd restart
150    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam restart
151fi
152
153%if %{?milter}
154%post milter
155/sbin/chkconfig --add clamav-milter
156
157%preun milter
158if [ "$1" = 0 ]; then
159    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamav-milter stop
160    /sbin/chkconfig --del clamav-milter
161fi
162
163%postun milter
164if [ "$1" -ge 1 ]; then
165    [ ! -f /var/run/clamav/clamav-milter.pid ] || /etc/init.d/clamav-milter restart
166fi
167%endif
168
169%files
170%defattr(-,root,root)
171%doc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL NEWS README examples test
172%doc README
173%doc docs/*
174%{_initdir}/clamd
175%{_initdir}/freshclam
176%config(noreplace) %{_sysconfdir}/clamd.conf
177%config(noreplace) %{_sysconfdir}/freshclam.conf
178%config(noreplace) %{_sysconfdir}/logrotate.d/clamav
179%{_bindir}/*
180%exclude %{_bindir}/clamav-config
181%{_sbindir}/*
182%{_libdir}/lib*.so.*
183%attr(-,clamav,clamav) %dir %{_localstatedir}/run/clamav
184%attr(-,clamav,clamav) %dir %{_localstatedir}/log/clamav
185%attr(0755,clamav,clamav) %dir %{dbdir}
186#%attr(-,clamav,clamav) %config(noreplace) %{dbdir}/main.cvd
187%exclude %{_mandir}/man8/clamav-milter.8*
188%{_mandir}/man*/*
189
190%if %{?milter}
191
192%files milter
193%defattr(-,root,root)
194%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
195%{_initdir}/clamav-milter
196%config(noreplace) %{_sysconfdir}/clamav-milter.conf
197%config(noreplace) %{_sysconfdir}/logrotate.d/clamav-milter
198%{_sbindir}/clamav-milter
199%{_mandir}/man8/clamav-milter.8*
200
201%endif
202
203%files devel
204%defattr(-,root,root)
205%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
206%{_bindir}/clamav-config
207%{_libdir}/lib*.so
208%{_libdir}/pkgconfig/*.pc
209%{_includedir}/*
210
211%changelog
212* Fri May 10 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.8-1
213- new upstream release.
214
215* Thu Mar 21 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.7-1
216- new upstream release.
217- fixed date of %%changelog.
218
219* Tue Sep 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-2
220- tarball was replaced on upstream.
221
222* Mon Sep 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-1
223- new upstream release.
224
225* Fri Jun 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.5-1
226- new upstream release.
227- removed /var/lib/clamav/main.cvd (by upstream).
228
229* Mon Mar 19 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.4-1
230- new upstream release.
231- removed /var/lib/clamav/daily.cvd.
232
233* Wed Dec 14 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.3-1
234- new upstream release.
235
236* Thu Aug 04 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.2-1
237- new upstream release.
238
239* Thu Jun 09 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.1-1
240- new upstream release.
241
242* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 0.97-2
243- add else routine for milter: fix building on Vine Linux 5
244
245* Tue Feb 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97-1
246- new upstream release.
247
248* Fri Dec 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.5-1
249- new upstream release.
250
251* Sat Nov 27 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-3
252- moved virus databases to /var/lib/clamav.
253
254* Wed Nov 17 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-2
255- added milter support.
256
257* Fri Nov 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-1
258- new upstream release.
259- added logrotate support.
260- fixed pre/post scripts for daemons.
261
262* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.96-2
263- rebuilt with rpm-4.8.1 for pkg-config
264
265* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.96-1
266- new upstream release.
267
268* Sat Jan 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.95.3-1
269- new upstream release.
270
271* Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.2-1
272- new upstream release.
273
274* Tue Jun  2 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.1-1
275- new upstream release.
276
277* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-2
278- dropped *.a files.
279
280* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-1
281- new upstream release.
282
283* Tue Jun 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93.1-1
284- new upstream release.
285- wrote specfile in UTF-8.
286
287* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93-1
288- new upstream release.
289- move clamd.init to /etc/rc.d/init.d/.
290- add /etc/rc.d/init.d/freshclam.
291
292* Thu Apr 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-1
293- apply new versioning policy.
294
295* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40.1
296- add missing files.
297
298* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40
299- new upstream release.
300
301* Tue Aug 21 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.2-0vl0.40
302- new upstream release.
303
304* Thu Aug  9 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.1-0vl0.40
305- new upstream release.
306
307* Fri Mar  2 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90.1-0vl0.40
308- new upstream release.
309
310* Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90-0vl0.40
311- new upstream release.
312
313* Thu Feb  1 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.7-0vl0.40
314- for Vine Linux 4.0.
315- new upstream release.
316
317* Tue Nov  7 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl1
318- built for VineSeed.
319
320* Mon Nov  6 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl0.1
321- new upstream release.
322
323* Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.5-0vl0.1
324- new upstream release.
325
326* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl0.1
327- rebuilt for Vine Linux 3.x.
328
329* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl1
330- new upstream release.
331
332* Sat Aug  5 2006 IWAI, Masaharu <iwai@alib.jp> 0.88.2-0vl3
333- add clamd.init script in doc dir
334
335* Tue Aug  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.88.2-0vl2
336- rebuilt for VineSeed (4.0)
337- added libclamav.pc to devel package
338- added Requires: gmp-devel to devel package
339
340* Mon May  1 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
341- 0.88.2-0vl1
342- new upstream release.
343
344* Wed Apr  5 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
345- 0.88.1-0vl1
346- new upstream release.
347
348* Tue Jan 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
349- 0.88-0vl1
350- new upstream release.
351
352* Fri Nov  4 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
353- 0.87.1-0vl1
354- new upstream release.
355
356* Sun Sep 18 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
357- 0.87-0vl1
358- new upstream release.
359
360* Mon Jul 25 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
361- 0.86.2-0vl1
362- new upstream release.
363
364* Sun Jun 26 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
365- 0.86.1-0vl1
366- new upstream release.
367- fix "Requires:".
368
369* Fri May 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
370- 0.85.1-0vl1
371- new upstream release.
372
373* Mon May 16 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
374- 0.85-0vl1
375- new upstream release.
376
377* Sun May  1 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
378- 0.84-0vl2
379- new upstream release.
380
381* Tue Feb 15 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
382- 0.83-0vl1
383- new upstream release.
384
385* Mon Feb 14 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
386- 0.82-0vl1
387- new upstream release.
388
389* Thu Jan 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
390- 0.81-0vl1
391- new upstream release.
392
393* Tue Nov  2 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
394- 0.80-0vl1
395- new upstream release.
396
397* Wed Aug 18 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
398- 0.75-0vl1
399- new upstream release.
400
401* Wed May  5 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
402- 0.70-0vl1
403- new upstream release.
404
405* Wed Apr 14 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
406- 0.68.1-0vl1
407- new upstream release.
408
409* Fri Feb 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
410- 0.67-0vl1
411- new upstream release.
412
413* Fri Nov 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
414- 0.65-0vl1
415- new upstream release.
416
417* Sat Aug 23 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
418- 0.60-0vl3
419- fix %%files.
420
421* Fri Aug 22 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
422- 0.60-0vl2
423- fix 'Requires:' and %%files.
424
425* Thu Aug 21 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
426- 0.60-0vl1
427- new upstream release.
428- add a sub-package 'devel'.
429
430* Mon Nov  4 2002 TORAYA Shin-ichi <shin@tora-jp.com>
431- 0.53-0vl1
432
433* Wed Oct 30 2002 TORAYA Shin-ichi <shin@tora-jp.com>
434- 0.52-0vl1
435
436* Tue Oct 22 2002 TORAYA Shin-ichi <shin@tora-jp.com>
437- 0.51-0vl1
438- port to Vine Linux from (0.51-1m)
439
440* Fri Oct 11 2002 Kazuhiko <kazuhiko@fdiary.net>
441- (0.51-1m)
442- major bugfixes
443
444* Sun Oct  6 2002 Kazuhiko <kazuhiko@fdiary.net>
445- (0.50-1m)
446- major feature enhancements
447
448* Fri Sep 20 2002 Kazuhiko <kazuhiko@fdiary.net>
449- (0.24-2m)
450- fix permission etc.
451
452* Fri Aug 23 2002 Kazuhiko <kazuhiko@fdiary.net>
453- (0.24-1m)
454- minor bugfixes
455
456* Sat Aug  3 2002 Kazuhiko <kazuhiko@fdiary.net>
457- (0.23-1m)
458- minor feature enhancements
459
460* Fri Jul 19 2002 Kazuhiko <kazuhiko@fdiary.net>
461- (0.21-1m)
462- minor bugfixes
463
464* Mon Jul 15 2002 Kazuhiko <kazuhiko@fdiary.net>
465- (0.20-1m)
466- revise URL
467- add a new program 'sigtool'
468
469* Thu Jun 13 2002 Kazuhiko <kazuhiko@kondara.org>
470- (0.15-2k)
471
472* Fri May 31 2002 Kazuhiko <kazuhiko@kondara.org>
473- (0.14-2k)
474
475* Thu May 23 2002 Kazuhiko <kazuhiko@kondara.org>
476- (0.12-2k)
477
478* Fri May 10 2002 Kazuhiko <kazuhiko@kondara.org>
479- (0.11-2k)
Note: See TracBrowser for help on using the repository browser.