source: projects/specs/trunk/c/clamav/clamav-vl.spec @ 6833

Revision 6833, 13.5 KB checked in by tomop, 12 years ago (diff)

clamav-0.97.6-2

Line 
1%define dbdir %{_localstatedir}/lib/clamav
2
3%if %{?_dist_release}!="vl5"
4%define milter 1
5%else
6%define milter 0
7%endif
8
9Summary: Clam AntiVirus
10Summary(ja): Clamアンチウィルススキャナ
11Name: clamav
12Version: 0.97.6
13Release: 2%{?_dist_release}
14License: GPL
15Group: Applications/System
16URL: http://www.clamav.net/
17Source0: http://clamav.elektrapro.com/stable/%{name}-%{version}.tar.gz
18Source1: clamd.init
19Source2: freshclam.init
20Source3: clamav-milter.init
21Source4: clamav.logrotate
22Source5: clamav-milter.logrotate
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: bzip2-devel, curl-devel > 7.10.0, gmp-devel, ncurses-devel
26BuildRequires: openssl-devel, zlib-devel
27%if %{?milter}
28BuildRequires: sendmail-devel
29%endif
30Requires: bzip2, curl > 7.10.0, gmp, ncurses, openssl, zlib, logrotate
31Requires(pre): shadow-utils, grep
32
33Vendor: Project Vine
34Distribution: Vine Linux
35Packager: tomop, inagaki
36
37%description
38Clam Antivirus is a powerful anti-virus scanner for Unix. It supports
39AMaViS, compressed files, uses the virus database from
40OpenAntivirus.org, and includes a program for auto-updating. The scanner
41is multithreaded, written in C, and POSIX compliant.
42
43%description -l ja
44Clamアンチウィルスは強力なUNIX向けのアンチウィルススキャナです。
45AMaViS、圧縮ファイルをサポートし、OpenAntivirus.orgのウィルスデータ
46ベースを利用しています。またウィルスデータベースの自動アップデート
47プログラムを含んでいます。 このCで書かれたスキャナはマルチスレッド化
48されており、 POSIXに準拠しています。
49
50%if %{?milter}
51%package milter
52Summary: Virus scanner for sendmail/postfix
53Group: Applications/System
54
55%description milter
56clamav-milter is a milter module to scan mails using Clam AntiVirus.
57
58%endif
59
60%package devel
61Group: Development/Libraries
62Summary: headers and libraries for development using Clam AntiVirus
63Summary(ja): Clam AntiVirus を用いた開発に必要なヘッダ・ライブラリ
64Requires: %{name} = %{version}-%{release}
65Requires: zlib-devel bzip2-devel gmp-devel
66
67%description devel
68 clamav-devel provides headers and libraries for development using
69Clam AntiVirus.
70
71%description -l ja devel
72 clamav-devel パッケージは、Clam AntiVirus を用いた開発を行うための
73ヘッダファイルやライブラリファイルを提供します。
74
75%prep
76%setup -q
77
78perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamd.pid|' etc/clamd.conf
79perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamd.log|' etc/clamd.conf
80perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/freshclam.pid|' etc/freshclam.conf
81perl -pi -e 's|^#UpdateLogFile .+$|UpdateLogFile /var/log/clamav/freshclam.log|' etc/freshclam.conf
82perl -pi -e 's|^#PidFile .+$|PidFile /var/run/clamav/clamav-milter.pid|' etc/clamav-milter.conf
83perl -pi -e 's|^#LogFile .+$|LogFile /var/log/clamav/clamav-milter.log|' etc/clamav-milter.conf
84
85%build
86%if %{?milter}
87%configure --disable-clamav --enable-milter --with-dbdir=%{dbdir}
88%else
89%configure --disable-clamav --with-dbdir=%{dbdir}
90%endif
91
92make %{?_smp_mflags}
93
94%install
95rm -rf %{buildroot}
96mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
97mkdir -p %{buildroot}%{_initdir}
98mkdir -p %{buildroot}%{_localstatedir}/run/clamav
99mkdir -p %{buildroot}%{_localstatedir}/log/clamav
100make install DESTDIR=%{buildroot} transform='s,x,x,'
101install -m755 %{SOURCE1} %{buildroot}%{_initdir}/clamd
102install -m755 %{SOURCE2} %{buildroot}%{_initdir}/freshclam
103%if %{?milter}
104install -m755 %{SOURCE3} %{buildroot}%{_initdir}/clamav-milter
105install -m644 %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/clamav-milter
106%endif
107install -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/clamav
108install etc/clamd.conf %{buildroot}%{_sysconfdir}
109install etc/freshclam.conf %{buildroot}%{_sysconfdir}
110
111rm -f %{buildroot}%{_libdir}/lib*a
112
113mkdir -p %{buildroot}%{dbdir}
114
115%clean
116rm -rf %{buildroot}
117
118%pre
119if ! grep -q '^clamav:' /etc/group; then
120    /usr/sbin/groupadd -r clamav
121fi
122if ! grep -q '^clamav:' /etc/passwd; then
123    /usr/sbin/useradd -M -r -s /bin/false -g clamav -c "Clam Antivirus" clamav || :
124fi
125
126%post
127/sbin/ldconfig
128/sbin/chkconfig --add clamd
129/sbin/chkconfig --add freshclam
130
131%preun
132if [ "$1" = 0 ]; then
133    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd stop
134    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam stop
135    /sbin/chkconfig --del clamd
136    /sbin/chkconfig --del freshclam
137fi
138
139%postun
140/sbin/ldconfig
141if [ "$1" = 0 ]; then
142    if [ `grep clamav /etc/passwd | wc -l` = 1 ]; then
143        /usr/sbin/userdel clamav
144    fi
145    if [ `grep clamav /etc/group | wc -l` = 1 ]; then
146        /usr/sbin/groupdel clamav
147    fi
148else
149    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamd restart
150    [ ! -f /var/run/clamav/freshclam.pid ] || /etc/init.d/freshclam restart
151fi
152
153%if %{?milter}
154%post milter
155/sbin/chkconfig --add clamav-milter
156
157%preun milter
158if [ "$1" = 0 ]; then
159    [ ! -f /var/run/clamav/clamd.pid ] || /etc/init.d/clamav-milter stop
160    /sbin/chkconfig --del clamav-milter
161fi
162
163%postun milter
164if [ "$1" -ge 1 ]; then
165    [ ! -f /var/run/clamav/clamav-milter.pid ] || /etc/init.d/clamav-milter restart
166fi
167%endif
168
169%files
170%defattr(-,root,root)
171%doc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL NEWS README examples test
172%doc README
173%doc docs/*
174%{_initdir}/clamd
175%{_initdir}/freshclam
176%config(noreplace) %{_sysconfdir}/clamd.conf
177%config(noreplace) %{_sysconfdir}/freshclam.conf
178%config(noreplace) %{_sysconfdir}/logrotate.d/clamav
179%{_bindir}/*
180%exclude %{_bindir}/clamav-config
181%{_sbindir}/*
182%{_libdir}/lib*.so.*
183%attr(-,clamav,clamav) %dir %{_localstatedir}/run/clamav
184%attr(-,clamav,clamav) %dir %{_localstatedir}/log/clamav
185%attr(0755,clamav,clamav) %dir %{dbdir}
186#%attr(-,clamav,clamav) %config(noreplace) %{dbdir}/main.cvd
187%exclude %{_mandir}/man8/clamav-milter.8*
188%{_mandir}/man*/*
189
190%if %{?milter}
191
192%files milter
193%defattr(-,root,root)
194%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
195%{_initdir}/clamav-milter
196%config(noreplace) %{_sysconfdir}/clamav-milter.conf
197%config(noreplace) %{_sysconfdir}/logrotate.d/clamav-milter
198%{_sbindir}/clamav-milter
199%{_mandir}/man8/clamav-milter.8*
200
201%endif
202
203%files devel
204%defattr(-,root,root)
205%doc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README
206%{_bindir}/clamav-config
207%{_libdir}/lib*.so
208%{_libdir}/pkgconfig/*.pc
209%{_includedir}/*
210
211%changelog
212* Tue Sep 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-2
213- tarball was replaced on upstream.
214
215* Mon Sep 17 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.6-1
216- new upstream release.
217
218* Fri Jun 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.5-1
219- new upstream release.
220- removed /var/lib/clamav/main.cvd (by upstream).
221
222* Mon Mar 19 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.4-1
223- new upstream release.
224- removed /var/lib/clamav/daily.cvd.
225
226* Wed Dec 14 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.3-1
227- new upstream release.
228
229* Thu Aug 04 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.2-1
230- new upstream release.
231
232* Thu Jun 09 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97.1-1
233- new upstream release.
234
235* Sun Mar 27 2011 IWAI, Masaharu <iwai@alib.jp> 0.97-2
236- add else routine for milter: fix building on Vine Linux 5
237
238* Tue Feb 08 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.97-1
239- new upstream release.
240
241* Fri Dec 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.5-1
242- new upstream release.
243
244* Sat Nov 27 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-3
245- moved virus databases to /var/lib/clamav.
246
247* Wed Nov 17 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-2
248- added milter support.
249
250* Fri Nov 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.96.4-1
251- new upstream release.
252- added logrotate support.
253- fixed pre/post scripts for daemons.
254
255* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.96-2
256- rebuilt with rpm-4.8.1 for pkg-config
257
258* Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.96-1
259- new upstream release.
260
261* Sat Jan 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.95.3-1
262- new upstream release.
263
264* Thu Jun 11 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.2-1
265- new upstream release.
266
267* Tue Jun  2 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95.1-1
268- new upstream release.
269
270* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-2
271- dropped *.a files.
272
273* Tue Mar 24 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.95-1
274- new upstream release.
275
276* Tue Jun 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93.1-1
277- new upstream release.
278- wrote specfile in UTF-8.
279
280* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.93-1
281- new upstream release.
282- move clamd.init to /etc/rc.d/init.d/.
283- add /etc/rc.d/init.d/freshclam.
284
285* Thu Apr 10 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-1
286- apply new versioning policy.
287
288* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40.1
289- add missing files.
290
291* Sat Mar  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.92.1-0vl0.40
292- new upstream release.
293
294* Tue Aug 21 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.2-0vl0.40
295- new upstream release.
296
297* Thu Aug  9 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.91.1-0vl0.40
298- new upstream release.
299
300* Fri Mar  2 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90.1-0vl0.40
301- new upstream release.
302
303* Mon Feb 26 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.90-0vl0.40
304- new upstream release.
305
306* Thu Feb  1 2007 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.7-0vl0.40
307- for Vine Linux 4.0.
308- new upstream release.
309
310* Tue Nov  7 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl1
311- built for VineSeed.
312
313* Mon Nov  6 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.6-0vl0.1
314- new upstream release.
315
316* Thu Oct 19 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.5-0vl0.1
317- new upstream release.
318
319* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl0.1
320- rebuilt for Vine Linux 3.x.
321
322* Wed Aug 16 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.88.4-0vl1
323- new upstream release.
324
325* Sat Aug  5 2006 IWAI, Masaharu <iwai@alib.jp> 0.88.2-0vl3
326- add clamd.init script in doc dir
327
328* Mon Aug  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.88.2-0vl2
329- rebuilt for VineSeed (4.0)
330- added libclamav.pc to devel package
331- added Requires: gmp-devel to devel package
332
333* Mon May  1 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
334- 0.88.2-0vl1
335- new upstream release.
336
337* Wed Apr  5 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
338- 0.88.1-0vl1
339- new upstream release.
340
341* Tue Jan 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
342- 0.88-0vl1
343- new upstream release.
344
345* Fri Nov  4 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
346- 0.87.1-0vl1
347- new upstream release.
348
349* Sun Sep 18 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
350- 0.87-0vl1
351- new upstream release.
352
353* Mon Jul 25 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
354- 0.86.2-0vl1
355- new upstream release.
356
357* Sun Jun 26 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
358- 0.86.1-0vl1
359- new upstream release.
360- fix "Requires:".
361
362* Fri May 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
363- 0.85.1-0vl1
364- new upstream release.
365
366* Mon May 16 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
367- 0.85-0vl1
368- new upstream release.
369
370* Sun May  1 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
371- 0.84-0vl2
372- new upstream release.
373
374* Tue Feb 15 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
375- 0.83-0vl1
376- new upstream release.
377
378* Mon Feb 14 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
379- 0.82-0vl1
380- new upstream release.
381
382* Thu Jan 27 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
383- 0.81-0vl1
384- new upstream release.
385
386* Tue Nov  2 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
387- 0.80-0vl1
388- new upstream release.
389
390* Wed Aug 18 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
391- 0.75-0vl1
392- new upstream release.
393
394* Wed May  5 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
395- 0.70-0vl1
396- new upstream release.
397
398* Wed Apr 14 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
399- 0.68.1-0vl1
400- new upstream release.
401
402* Fri Feb 20 2004 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
403- 0.67-0vl1
404- new upstream release.
405
406* Fri Nov 28 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
407- 0.65-0vl1
408- new upstream release.
409
410* Sat Aug 23 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
411- 0.60-0vl3
412- fix %%files.
413
414* Fri Aug 22 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
415- 0.60-0vl2
416- fix 'Requires:' and %%files.
417
418* Thu Aug 21 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
419- 0.60-0vl1
420- new upstream release.
421- add a sub-package 'devel'.
422
423* Mon Nov  4 2002 TORAYA Shin-ichi <shin@tora-jp.com>
424- 0.53-0vl1
425
426* Wed Oct 30 2002 TORAYA Shin-ichi <shin@tora-jp.com>
427- 0.52-0vl1
428
429* Tue Oct 22 2002 TORAYA Shin-ichi <shin@tora-jp.com>
430- 0.51-0vl1
431- port to Vine Linux from (0.51-1m)
432
433* Fri Oct 11 2002 Kazuhiko <kazuhiko@fdiary.net>
434- (0.51-1m)
435- major bugfixes
436
437* Sun Oct  6 2002 Kazuhiko <kazuhiko@fdiary.net>
438- (0.50-1m)
439- major feature enhancements
440
441* Fri Sep 20 2002 Kazuhiko <kazuhiko@fdiary.net>
442- (0.24-2m)
443- fix permission etc.
444
445* Fri Aug 23 2002 Kazuhiko <kazuhiko@fdiary.net>
446- (0.24-1m)
447- minor bugfixes
448
449* Sat Aug  3 2002 Kazuhiko <kazuhiko@fdiary.net>
450- (0.23-1m)
451- minor feature enhancements
452
453* Fri Jul 19 2002 Kazuhiko <kazuhiko@fdiary.net>
454- (0.21-1m)
455- minor bugfixes
456
457* Mon Jul 15 2002 Kazuhiko <kazuhiko@fdiary.net>
458- (0.20-1m)
459- revise URL
460- add a new program 'sigtool'
461
462* Thu Jun 13 2002 Kazuhiko <kazuhiko@kondara.org>
463- (0.15-2k)
464
465* Fri May 31 2002 Kazuhiko <kazuhiko@kondara.org>
466- (0.14-2k)
467
468* Thu May 23 2002 Kazuhiko <kazuhiko@kondara.org>
469- (0.12-2k)
470
471* Fri May 10 2002 Kazuhiko <kazuhiko@kondara.org>
472- (0.11-2k)
Note: See TracBrowser for help on using the repository browser.