source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 9769

Revision 9769, 7.0 KB checked in by tomop, 9 years ago (diff)

chrony-2.2-1

Line 
1Name:           chrony
2Version:        2.2
3Release:        1%{?_dist_release}
4Summary:        An NTP client/server
5
6Group:          System Environment/Daemons
7License:        GPLv2
8URL:            http://chrony.tuxfamily.org
9Source0:        http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
10Source1:        chrony.conf
11Source2:        chrony.dhclient
12Source3:        chronyd.sysconfig
13Source4:        chronyd.init
14Source5:        chrony.logrotate
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  libcap-devel readline-devel ncurses-devel bison texinfo
18
19Requires(pre):  shadow-utils
20Requires(post): chkconfig info
21Requires(preun): chkconfig initscripts info
22Requires(postun): initscripts
23
24Obsoletes:      ntp < 4.2.6p5
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: tomop
29
30%description
31A client/server for the Network Time Protocol, this program keeps your
32computer's clock accurate. It was specially designed to support
33systems with intermittent internet connections, but it also works well
34in permanently connected environments. It can use also hardware reference
35clocks, system real-time clock or manual input as time references.
36
37%prep
38%setup -q -n %{name}-%{version}%{?prerelease}
39
40echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
41
42# regenerate the file from getdate.y
43rm -f getdate.c
44
45%build
46#CFLAGS="$RPM_OPT_FLAGS"
47#%ifarch %{sparc}
48#CFLAGS="$CFLAGS -pie -fPIE"
49#%else
50#CFLAGS="$CFLAGS -pie -fpie"
51#%endif
52#export CFLAGS
53#export LDFLAGS="-Wl,-z,relro,-z,now"
54
55%configure \
56        --docdir=%{_docdir} \
57        --with-user=chrony \
58        --with-sendmail=%{_sbindir}/sendmail \
59        --enable-forcednsretry
60make %{?_smp_mflags} all docs
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65make install install-docs DESTDIR=$RPM_BUILD_ROOT
66
67rm -rf $RPM_BUILD_ROOT%{_docdir}
68
69mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
70mkdir -p $RPM_BUILD_ROOT%{_initrddir}
71mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
72mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
73mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
74
75install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
76install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
77install -m 755 -p examples/chrony.nm-dispatcher \
78        $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
79install -m 755 -p %{SOURCE2} \
80        $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
81
82install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
83install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
84install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
85
86touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%pre
92getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
93getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
94       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
95:
96
97%post
98/sbin/chkconfig --add chronyd
99/sbin/install-info  %{_infodir}/chrony.info.gz %{_infodir}/dir &> /dev/null
100:
101
102%preun
103if [ "$1" -eq 0 ]; then
104        /sbin/service chronyd stop &> /dev/null
105        /sbin/chkconfig --del chronyd
106        /sbin/install-info --delete %{_infodir}/chrony.info.gz \
107                %{_infodir}/dir &> /dev/null
108fi
109:
110
111%postun
112if [ "$1" -ge 1 ]; then
113        /sbin/service chronyd condrestart &> /dev/null
114fi
115:
116
117%files
118%defattr(-,root,root,-)
119%doc COPYING FAQ NEWS README chrony.txt examples/*
120%config(noreplace) %{_sysconfdir}/chrony.conf
121%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
122%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
123%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
124%{_initrddir}/chronyd
125%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
126%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
127%{_bindir}/chronyc
128%{_sbindir}/chronyd
129%{_infodir}/chrony.info*
130%{_mandir}/man[158]/%{name}*.[158]*
131%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
132%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
133%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
134%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
135
136%changelog
137* Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
138- new upstream release.
139
140* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
141- new upstream release.
142
143* Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
144- new upstream release.
145
146* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
147- new upstream release.
148- initial build for Vine Linux.
149
150* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
151- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
152- don't send uninitialized data in command replies (CVE-2012-4503)
153
154* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
155- remove timepps.h, NM and dhclient scripts
156- build with readline
157
158* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
159- update to 1.25
160- link with -Wl,-z,relro,-z,now options
161- use iburst, four pool servers, rtcsync, stratumweight in default config
162- suppress install-info errors
163
164* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
165- update to 20100428git73d775
166- replace initstepslew directive with makestep in default config
167- add NetworkManager dispatcher script
168- add dhclient script
169- retry server/peer name resolution at least once to workaround
170  NetworkManager race condition on boot
171- don't verify chrony.keys
172
173* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
174- update to snapshot 20100302git5fb555
175- compile with PPS API support
176
177* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
178- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
179- modify default config
180  - step clock on start if it is off by more than 100 seconds
181  - disable client log
182- build with -fPIE on sparc
183
184* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
185- update to 1.24-pre1
186
187* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
188- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
189
190* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
191- switch to editline
192- support arbitrary chronyc commands in init script
193
194* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
195- add patch with support for s390/s390x
196
197* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
198- fix building with broken libcap header (#483548)
199
200* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
201- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
202
203* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
204- fix info uninstall
205- generate random command key in init script
206- support cyclelogs, online, offline commands in init script
207- add logrotate script
208
209* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
210- initial release
Note: See TracBrowser for help on using the repository browser.