source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 8530

Revision 8530, 6.1 KB checked in by tomop, 10 years ago (diff)

chrony-1.29.1-1

Line 
1Name:           chrony
2Version:        1.29.1
3Release:        1%{?_dist_release}
4Summary:        An NTP client/server
5
6Group:          System Environment/Daemons
7License:        GPLv2
8URL:            http://chrony.tuxfamily.org
9Source0:        http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
10Source1:        chrony.conf
11Source2:        chrony.keys
12Source3:        chronyd.sysconfig
13Source4:        chronyd.init
14Source5:        chrony.logrotate
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  libcap-devel readline-devel ncurses-devel bison texinfo
18
19Requires(pre):  shadow-utils
20Requires(post): chkconfig info
21Requires(preun): chkconfig initscripts info
22Requires(postun): initscripts
23
24Vendor: Project Vine
25Distribution: Vine Linux
26Packager: tomop
27
28%description
29A client/server for the Network Time Protocol, this program keeps your
30computer's clock accurate. It was specially designed to support
31systems with intermittent internet connections, but it also works well
32in permanently connected environments. It can use also hardware reference
33clocks, system real-time clock or manual input as time references.
34
35%prep
36%setup -q -n %{name}-%{version}%{?prerelease}
37
38%build
39CFLAGS="$RPM_OPT_FLAGS"
40%ifarch %{sparc}
41CFLAGS="$CFLAGS -pie -fPIE"
42%else
43CFLAGS="$CFLAGS -pie -fpie"
44%endif
45export CFLAGS
46export LDFLAGS="-Wl,-z,relro,-z,now"
47
48%configure --docdir=%{_docdir} --enable-forcednsretry
49make %{?_smp_mflags} getdate all docs
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54make install install-docs DESTDIR=$RPM_BUILD_ROOT
55
56rm -rf $RPM_BUILD_ROOT%{_docdir}
57
58mkdir -p $RPM_BUILD_ROOT{%{_sysconfdir}/{sysconfig,logrotate.d},%{_initrddir}}
59mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
60
61install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
62install -m 640 -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
63install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
64install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
65install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
66
67touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%pre
73getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
74getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
75       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
76:
77
78%post
79/sbin/chkconfig --add chronyd
80/sbin/install-info  %{_infodir}/chrony.info.gz %{_infodir}/dir &> /dev/null
81:
82
83%preun
84if [ "$1" -eq 0 ]; then
85        /sbin/service chronyd stop &> /dev/null
86        /sbin/chkconfig --del chronyd
87        /sbin/install-info --delete %{_infodir}/chrony.info.gz \
88                %{_infodir}/dir &> /dev/null
89fi
90:
91
92%postun
93if [ "$1" -ge 1 ]; then
94        /sbin/service chronyd condrestart &> /dev/null
95fi
96:
97
98%files
99%defattr(-,root,root,-)
100%doc COPYING NEWS README chrony.txt faq.txt examples/*
101%config(noreplace) %{_sysconfdir}/chrony.conf
102%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
103%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
104%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
105%{_initrddir}/chronyd
106%{_bindir}/chronyc
107%{_sbindir}/chronyd
108%{_infodir}/chrony.info*
109%{_mandir}/man[158]/%{name}*.[158]*
110%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
111%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
112%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
113%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
114
115%changelog
116* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
117- new upstream release.
118- initial build for Vine Linux.
119
120* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
121- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
122- don't send uninitialized data in command replies (CVE-2012-4503)
123
124* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
125- remove timepps.h, NM and dhclient scripts
126- build with readline
127
128* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
129- update to 1.25
130- link with -Wl,-z,relro,-z,now options
131- use iburst, four pool servers, rtcsync, stratumweight in default config
132- suppress install-info errors
133
134* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
135- update to 20100428git73d775
136- replace initstepslew directive with makestep in default config
137- add NetworkManager dispatcher script
138- add dhclient script
139- retry server/peer name resolution at least once to workaround
140  NetworkManager race condition on boot
141- don't verify chrony.keys
142
143* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
144- update to snapshot 20100302git5fb555
145- compile with PPS API support
146
147* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
148- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
149- modify default config
150  - step clock on start if it is off by more than 100 seconds
151  - disable client log
152- build with -fPIE on sparc
153
154* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
155- update to 1.24-pre1
156
157* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
159
160* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
161- switch to editline
162- support arbitrary chronyc commands in init script
163
164* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
165- add patch with support for s390/s390x
166
167* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
168- fix building with broken libcap header (#483548)
169
170* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
172
173* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
174- fix info uninstall
175- generate random command key in init script
176- support cyclelogs, online, offline commands in init script
177- add logrotate script
178
179* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
180- initial release
Note: See TracBrowser for help on using the repository browser.