source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 12351

Revision 12351, 8.0 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

chrony-3.5-1

cronie-1.5.5-1

Line 
1Name:           chrony
2Version:        3.5
3Release:        1%{?_dist_release}
4Summary:        An NTP client/server
5Group:          System Environment/Daemons
6Vendor:         Project Vine
7Distribution:   Vine Linux
8Packager:       tomop
9
10License:        GPLv2
11URL:            https://chrony.tuxfamily.org/
12Source0:        https://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
13Source1:        chrony.conf
14Source2:        chrony.dhclient
15Source3:        chronyd.sysconfig
16Source4:        chronyd.init
17Source5:        chrony.logrotate
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
20
21BuildRequires:  libcap-devel readline-devel ncurses-devel bison
22
23Requires(pre):  shadow-utils
24Requires(post): chkconfig
25Requires(preun): chkconfig initscripts
26Requires(postun): initscripts
27
28%if "%{?_dist_release}" == "vl7"
29Obsoletes:      ntp < 4.2.6p5
30%endif
31Obsoletes: networkmanager-dispatcher-chrony
32
33
34%description
35A client/server for the Network Time Protocol, this program keeps your
36computer's clock accurate. It was specially designed to support
37systems with intermittent internet connections, but it also works well
38in permanently connected environments. It can use also hardware reference
39clocks, system real-time clock or manual input as time references.
40
41%prep
42%setup -q -n %{name}-%{version}%{?prerelease}
43
44echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
45
46# regenerate the file from getdate.y
47rm -f getdate.c
48
49%build
50#CFLAGS="$RPM_OPT_FLAGS"
51#%ifarch %{sparc}
52#CFLAGS="$CFLAGS -pie -fPIE"
53#%else
54#CFLAGS="$CFLAGS -pie -fpie"
55#%endif
56#export CFLAGS
57#export LDFLAGS="-Wl,-z,relro,-z,now"
58
59%configure \
60        --docdir=%{_docdir} \
61        --with-user=chrony \
62        --with-sendmail=%{_sbindir}/sendmail \
63        --enable-forcednsretry
64make %{?_smp_mflags} all docs
65
66%install
67rm -rf $RPM_BUILD_ROOT
68
69make install install-docs DESTDIR=$RPM_BUILD_ROOT
70
71rm -rf $RPM_BUILD_ROOT%{_docdir}
72
73mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
74mkdir -p $RPM_BUILD_ROOT%{_initrddir}
75mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
78
79install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
80install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
81install -m 755 -p examples/chrony.nm-dispatcher \
82        $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
83install -m 755 -p %{SOURCE2} \
84        $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
85
86install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
87install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
88install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
89
90touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%pre
96getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
97getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
98       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
99:
100
101%post
102/sbin/chkconfig --add chronyd
103:
104
105%preun
106if [ "$1" -eq 0 ]; then
107        /sbin/service chronyd stop &> /dev/null
108        /sbin/chkconfig --del chronyd
109fi
110:
111
112%postun
113if [ "$1" -ge 1 ]; then
114        /sbin/service chronyd condrestart &> /dev/null
115fi
116:
117
118%files
119%defattr(-,root,root,-)
120%license COPYING
121%doc FAQ NEWS README examples/*
122%config(noreplace) %{_sysconfdir}/chrony.conf
123%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
124%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
125%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
126%{_initrddir}/chronyd
127%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
128%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
129%{_bindir}/chronyc
130%{_sbindir}/chronyd
131%{_mandir}/man[158]/%{name}*.[158]*
132%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
133%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
134%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
135%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
136
137%changelog
138* Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5-1
139- new upstream release.
140- dropped Patch102: fixed in upstream.
141
142* Sat Aug 31 2019 Toshiaki Ara <ara_t@384.jp> 3.2-2
143- rebuild with readline-8.0 and ncurses-6.1
144
145* Sat Jun  9 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.2-1
146- update to 3.2
147- drop Patch101; upstream merged
148- add Fedora's patch (Patch102)
149 * Tue Dec 05 2017 Miroslav Lichvar <mlichvar@redhat.com> 3.2-2
150 - fix chronyc getting stuck in infinite loop after clock step (#1520884)
151- restrict obsoleting 'ntp' package to VineSeed; for Vine Linux 6
152
153* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0-1
154- update to 3.0
155- add patch to fix time smoothing in interleaved mode (Patch101); from Debian 3.0-4
156- drop chrony.txt in %%doc; upstream dropped
157- drop info file; upstream dropped
158 - drop R: info
159 - drop BR: texinfo
160 - drop scripts for info
161
162* Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
163- Obsoletes: networkmanager-dispatcher-chrony
164
165* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
166- new upstream release.
167
168* Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
169- new upstream release.
170
171* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
172- new upstream release.
173
174* Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
175- new upstream release.
176
177* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
178- new upstream release.
179- initial build for Vine Linux.
180
181* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
182- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
183- don't send uninitialized data in command replies (CVE-2012-4503)
184
185* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
186- remove timepps.h, NM and dhclient scripts
187- build with readline
188
189* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
190- update to 1.25
191- link with -Wl,-z,relro,-z,now options
192- use iburst, four pool servers, rtcsync, stratumweight in default config
193- suppress install-info errors
194
195* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
196- update to 20100428git73d775
197- replace initstepslew directive with makestep in default config
198- add NetworkManager dispatcher script
199- add dhclient script
200- retry server/peer name resolution at least once to workaround
201  NetworkManager race condition on boot
202- don't verify chrony.keys
203
204* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
205- update to snapshot 20100302git5fb555
206- compile with PPS API support
207
208* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
209- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
210- modify default config
211  - step clock on start if it is off by more than 100 seconds
212  - disable client log
213- build with -fPIE on sparc
214
215* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
216- update to 1.24-pre1
217
218* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
220
221* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
222- switch to editline
223- support arbitrary chronyc commands in init script
224
225* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
226- add patch with support for s390/s390x
227
228* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
229- fix building with broken libcap header (#483548)
230
231* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
232- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
233
234* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
235- fix info uninstall
236- generate random command key in init script
237- support cyclelogs, online, offline commands in init script
238- add logrotate script
239
240* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
241- initial release
Note: See TracBrowser for help on using the repository browser.