source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 11717

Revision 11717, 7.8 KB checked in by iwaim, 6 years ago (diff)

chrony 3.2-1

Line 
1Name:           chrony
2Version:        3.2
3Release:        1%{?_dist_release}
4Summary:        An NTP client/server
5
6Group:          System Environment/Daemons
7License:        GPLv2
8URL:            http://chrony.tuxfamily.org
9Source0:        http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
10Source1:        chrony.conf
11Source2:        chrony.dhclient
12Source3:        chronyd.sysconfig
13Source4:        chronyd.init
14Source5:        chrony.logrotate
15# Fedora's patches
16Patch102:       chrony-select-timeout.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildRequires:  libcap-devel readline-devel ncurses-devel bison
21
22Requires(pre):  shadow-utils
23Requires(post): chkconfig
24Requires(preun): chkconfig initscripts
25Requires(postun): initscripts
26
27%if "%{?_dist_release}" == "vl7"
28Obsoletes:      ntp < 4.2.6p5
29%endif
30Obsoletes: networkmanager-dispatcher-chrony
31
32Vendor: Project Vine
33Distribution: Vine Linux
34Packager: tomop
35
36%description
37A client/server for the Network Time Protocol, this program keeps your
38computer's clock accurate. It was specially designed to support
39systems with intermittent internet connections, but it also works well
40in permanently connected environments. It can use also hardware reference
41clocks, system real-time clock or manual input as time references.
42
43%prep
44%setup -q -n %{name}-%{version}%{?prerelease}
45%patch102 -p1
46
47echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
48
49# regenerate the file from getdate.y
50rm -f getdate.c
51
52%build
53#CFLAGS="$RPM_OPT_FLAGS"
54#%ifarch %{sparc}
55#CFLAGS="$CFLAGS -pie -fPIE"
56#%else
57#CFLAGS="$CFLAGS -pie -fpie"
58#%endif
59#export CFLAGS
60#export LDFLAGS="-Wl,-z,relro,-z,now"
61
62%configure \
63        --docdir=%{_docdir} \
64        --with-user=chrony \
65        --with-sendmail=%{_sbindir}/sendmail \
66        --enable-forcednsretry
67make %{?_smp_mflags} all docs
68
69%install
70rm -rf $RPM_BUILD_ROOT
71
72make install install-docs DESTDIR=$RPM_BUILD_ROOT
73
74rm -rf $RPM_BUILD_ROOT%{_docdir}
75
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
77mkdir -p $RPM_BUILD_ROOT%{_initrddir}
78mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
79mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
80mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
81
82install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
83install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
84install -m 755 -p examples/chrony.nm-dispatcher \
85        $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
86install -m 755 -p %{SOURCE2} \
87        $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
88
89install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
90install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
91install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
92
93touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
94
95%clean
96rm -rf $RPM_BUILD_ROOT
97
98%pre
99getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
100getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
101       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
102:
103
104%post
105/sbin/chkconfig --add chronyd
106:
107
108%preun
109if [ "$1" -eq 0 ]; then
110        /sbin/service chronyd stop &> /dev/null
111        /sbin/chkconfig --del chronyd
112fi
113:
114
115%postun
116if [ "$1" -ge 1 ]; then
117        /sbin/service chronyd condrestart &> /dev/null
118fi
119:
120
121%files
122%defattr(-,root,root,-)
123%doc COPYING FAQ NEWS README examples/*
124%config(noreplace) %{_sysconfdir}/chrony.conf
125%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
126%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
127%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
128%{_initrddir}/chronyd
129%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
130%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
131%{_bindir}/chronyc
132%{_sbindir}/chronyd
133%{_mandir}/man[158]/%{name}*.[158]*
134%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
135%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
136%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
137%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
138
139%changelog
140* Sat Jun  9 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.2-1
141- update to 3.2
142- drop Patch101; upstream merged
143- add Fedora's patch (Patch102)
144 * Tue Dec 05 2017 Miroslav Lichvar <mlichvar@redhat.com> 3.2-2
145 - fix chronyc getting stuck in infinite loop after clock step (#1520884)
146- restrict obsoleting 'ntp' package to VineSeed; for Vine Linux 6
147
148* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0-1
149- update to 3.0
150- add patch to fix time smoothing in interleaved mode (Patch101); from Debian 3.0-4
151- drop chrony.txt in %%doc; upstream dropped
152- drop info file; upstream dropped
153 - drop R: info
154 - drop BR: texinfo
155 - drop scripts for info
156
157* Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
158- Obsoletes: networkmanager-dispatcher-chrony
159
160* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
161- new upstream release.
162
163* Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
164- new upstream release.
165
166* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
167- new upstream release.
168
169* Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
170- new upstream release.
171
172* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
173- new upstream release.
174- initial build for Vine Linux.
175
176* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
177- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
178- don't send uninitialized data in command replies (CVE-2012-4503)
179
180* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
181- remove timepps.h, NM and dhclient scripts
182- build with readline
183
184* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
185- update to 1.25
186- link with -Wl,-z,relro,-z,now options
187- use iburst, four pool servers, rtcsync, stratumweight in default config
188- suppress install-info errors
189
190* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
191- update to 20100428git73d775
192- replace initstepslew directive with makestep in default config
193- add NetworkManager dispatcher script
194- add dhclient script
195- retry server/peer name resolution at least once to workaround
196  NetworkManager race condition on boot
197- don't verify chrony.keys
198
199* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
200- update to snapshot 20100302git5fb555
201- compile with PPS API support
202
203* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
204- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
205- modify default config
206  - step clock on start if it is off by more than 100 seconds
207  - disable client log
208- build with -fPIE on sparc
209
210* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
211- update to 1.24-pre1
212
213* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
214- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
215
216* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
217- switch to editline
218- support arbitrary chronyc commands in init script
219
220* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
221- add patch with support for s390/s390x
222
223* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
224- fix building with broken libcap header (#483548)
225
226* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
228
229* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
230- fix info uninstall
231- generate random command key in init script
232- support cyclelogs, online, offline commands in init script
233- add logrotate script
234
235* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
236- initial release
Note: See TracBrowser for help on using the repository browser.