source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 11087

Revision 11087, 7.4 KB checked in by iwaim, 7 years ago (diff)

chrony 3.0-1

Line 
1Name:           chrony
2Version:        3.0
3Release:        1%{?_dist_release}
4Summary:        An NTP client/server
5
6Group:          System Environment/Daemons
7License:        GPLv2
8URL:            http://chrony.tuxfamily.org
9Source0:        http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
10Source1:        chrony.conf
11Source2:        chrony.dhclient
12Source3:        chronyd.sysconfig
13Source4:        chronyd.init
14Source5:        chrony.logrotate
15# Debian's patches
16Patch101:       fix_time_smoothing_in_interleaved_mode.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
19
20BuildRequires:  libcap-devel readline-devel ncurses-devel bison
21
22Requires(pre):  shadow-utils
23Requires(post): chkconfig
24Requires(preun): chkconfig initscripts
25Requires(postun): initscripts
26
27Obsoletes:      ntp < 4.2.6p5
28Obsoletes: networkmanager-dispatcher-chrony
29
30Vendor: Project Vine
31Distribution: Vine Linux
32Packager: tomop
33
34%description
35A client/server for the Network Time Protocol, this program keeps your
36computer's clock accurate. It was specially designed to support
37systems with intermittent internet connections, but it also works well
38in permanently connected environments. It can use also hardware reference
39clocks, system real-time clock or manual input as time references.
40
41%prep
42%setup -q -n %{name}-%{version}%{?prerelease}
43%patch101 -p1
44
45echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
46
47# regenerate the file from getdate.y
48rm -f getdate.c
49
50%build
51#CFLAGS="$RPM_OPT_FLAGS"
52#%ifarch %{sparc}
53#CFLAGS="$CFLAGS -pie -fPIE"
54#%else
55#CFLAGS="$CFLAGS -pie -fpie"
56#%endif
57#export CFLAGS
58#export LDFLAGS="-Wl,-z,relro,-z,now"
59
60%configure \
61        --docdir=%{_docdir} \
62        --with-user=chrony \
63        --with-sendmail=%{_sbindir}/sendmail \
64        --enable-forcednsretry
65make %{?_smp_mflags} all docs
66
67%install
68rm -rf $RPM_BUILD_ROOT
69
70make install install-docs DESTDIR=$RPM_BUILD_ROOT
71
72rm -rf $RPM_BUILD_ROOT%{_docdir}
73
74mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
75mkdir -p $RPM_BUILD_ROOT%{_initrddir}
76mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
78mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
79
80install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
81install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
82install -m 755 -p examples/chrony.nm-dispatcher \
83        $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
84install -m 755 -p %{SOURCE2} \
85        $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
86
87install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
88install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
89install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
90
91touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
92
93%clean
94rm -rf $RPM_BUILD_ROOT
95
96%pre
97getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
98getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
99       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
100:
101
102%post
103/sbin/chkconfig --add chronyd
104:
105
106%preun
107if [ "$1" -eq 0 ]; then
108        /sbin/service chronyd stop &> /dev/null
109        /sbin/chkconfig --del chronyd
110fi
111:
112
113%postun
114if [ "$1" -ge 1 ]; then
115        /sbin/service chronyd condrestart &> /dev/null
116fi
117:
118
119%files
120%defattr(-,root,root,-)
121%doc COPYING FAQ NEWS README examples/*
122%config(noreplace) %{_sysconfdir}/chrony.conf
123%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
124%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
125%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
126%{_initrddir}/chronyd
127%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
128%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
129%{_bindir}/chronyc
130%{_sbindir}/chronyd
131%{_mandir}/man[158]/%{name}*.[158]*
132%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
133%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
134%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
135%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
136
137%changelog
138* Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0-1
139- update to 3.0
140- add patch to fix time smoothing in interleaved mode (Patch101); from Debian 3.0-4
141- drop chrony.txt in %%doc; upstream dropped
142- drop info file; upstream dropped
143 - drop R: info
144 - drop BR: texinfo
145 - drop scripts for info
146
147* Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
148- Obsoletes: networkmanager-dispatcher-chrony
149
150* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
151- new upstream release.
152
153* Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
154- new upstream release.
155
156* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
157- new upstream release.
158
159* Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
160- new upstream release.
161
162* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
163- new upstream release.
164- initial build for Vine Linux.
165
166* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
167- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
168- don't send uninitialized data in command replies (CVE-2012-4503)
169
170* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
171- remove timepps.h, NM and dhclient scripts
172- build with readline
173
174* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
175- update to 1.25
176- link with -Wl,-z,relro,-z,now options
177- use iburst, four pool servers, rtcsync, stratumweight in default config
178- suppress install-info errors
179
180* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
181- update to 20100428git73d775
182- replace initstepslew directive with makestep in default config
183- add NetworkManager dispatcher script
184- add dhclient script
185- retry server/peer name resolution at least once to workaround
186  NetworkManager race condition on boot
187- don't verify chrony.keys
188
189* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
190- update to snapshot 20100302git5fb555
191- compile with PPS API support
192
193* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
194- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
195- modify default config
196  - step clock on start if it is off by more than 100 seconds
197  - disable client log
198- build with -fPIE on sparc
199
200* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
201- update to 1.24-pre1
202
203* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
204- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
205
206* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
207- switch to editline
208- support arbitrary chronyc commands in init script
209
210* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
211- add patch with support for s390/s390x
212
213* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
214- fix building with broken libcap header (#483548)
215
216* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
217- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
218
219* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
220- fix info uninstall
221- generate random command key in init script
222- support cyclelogs, online, offline commands in init script
223- add logrotate script
224
225* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
226- initial release
Note: See TracBrowser for help on using the repository browser.