source: projects/specs/trunk/c/chrony/chrony-vl.spec @ 10610

Revision 10610, 7.3 KB checked in by iwaim, 8 years ago (diff)

chrony 2.2.1-2

Line 
1Name:           chrony
2Version:        2.2.1
3Release:        2%{?_dist_release}
4Summary:        An NTP client/server
5
6Group:          System Environment/Daemons
7License:        GPLv2
8URL:            http://chrony.tuxfamily.org
9Source0:        http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
10Source1:        chrony.conf
11Source2:        chrony.dhclient
12Source3:        chronyd.sysconfig
13Source4:        chronyd.init
14Source5:        chrony.logrotate
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildRequires:  libcap-devel readline-devel ncurses-devel bison texinfo
18
19Requires(pre):  shadow-utils
20Requires(post): chkconfig info
21Requires(preun): chkconfig initscripts info
22Requires(postun): initscripts
23
24Obsoletes:      ntp < 4.2.6p5
25Obsoletes: networkmanager-dispatcher-chrony
26
27Vendor: Project Vine
28Distribution: Vine Linux
29Packager: tomop
30
31%description
32A client/server for the Network Time Protocol, this program keeps your
33computer's clock accurate. It was specially designed to support
34systems with intermittent internet connections, but it also works well
35in permanently connected environments. It can use also hardware reference
36clocks, system real-time clock or manual input as time references.
37
38%prep
39%setup -q -n %{name}-%{version}%{?prerelease}
40
41echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
42
43# regenerate the file from getdate.y
44rm -f getdate.c
45
46%build
47#CFLAGS="$RPM_OPT_FLAGS"
48#%ifarch %{sparc}
49#CFLAGS="$CFLAGS -pie -fPIE"
50#%else
51#CFLAGS="$CFLAGS -pie -fpie"
52#%endif
53#export CFLAGS
54#export LDFLAGS="-Wl,-z,relro,-z,now"
55
56%configure \
57        --docdir=%{_docdir} \
58        --with-user=chrony \
59        --with-sendmail=%{_sbindir}/sendmail \
60        --enable-forcednsretry
61make %{?_smp_mflags} all docs
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66make install install-docs DESTDIR=$RPM_BUILD_ROOT
67
68rm -rf $RPM_BUILD_ROOT%{_docdir}
69
70mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
71mkdir -p $RPM_BUILD_ROOT%{_initrddir}
72mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
73mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
74mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
75
76install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
77install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
78install -m 755 -p examples/chrony.nm-dispatcher \
79        $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
80install -m 755 -p %{SOURCE2} \
81        $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
82
83install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
84install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
85install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
86
87touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%pre
93getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
94getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
95       -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
96:
97
98%post
99/sbin/chkconfig --add chronyd
100/sbin/install-info  %{_infodir}/chrony.info.gz %{_infodir}/dir &> /dev/null
101:
102
103%preun
104if [ "$1" -eq 0 ]; then
105        /sbin/service chronyd stop &> /dev/null
106        /sbin/chkconfig --del chronyd
107        /sbin/install-info --delete %{_infodir}/chrony.info.gz \
108                %{_infodir}/dir &> /dev/null
109fi
110:
111
112%postun
113if [ "$1" -ge 1 ]; then
114        /sbin/service chronyd condrestart &> /dev/null
115fi
116:
117
118%files
119%defattr(-,root,root,-)
120%doc COPYING FAQ NEWS README chrony.txt examples/*
121%config(noreplace) %{_sysconfdir}/chrony.conf
122%config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
123%config(noreplace) %{_sysconfdir}/sysconfig/chronyd
124%config(noreplace) %{_sysconfdir}/logrotate.d/chrony
125%{_initrddir}/chronyd
126%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
127%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
128%{_bindir}/chronyc
129%{_sbindir}/chronyd
130%{_infodir}/chrony.info*
131%{_mandir}/man[158]/%{name}*.[158]*
132%dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
133%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
134%ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
135%dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
136
137%changelog
138* Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
139- Obsoletes: networkmanager-dispatcher-chrony
140
141* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
142- new upstream release.
143
144* Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
145- new upstream release.
146
147* Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
148- new upstream release.
149
150* Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
151- new upstream release.
152
153* Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
154- new upstream release.
155- initial build for Vine Linux.
156
157* Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
158- fix buffer overflow when processing crafted command packets (CVE-2012-4502)
159- don't send uninitialized data in command replies (CVE-2012-4503)
160
161* Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
162- remove timepps.h, NM and dhclient scripts
163- build with readline
164
165* Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
166- update to 1.25
167- link with -Wl,-z,relro,-z,now options
168- use iburst, four pool servers, rtcsync, stratumweight in default config
169- suppress install-info errors
170
171* Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
172- update to 20100428git73d775
173- replace initstepslew directive with makestep in default config
174- add NetworkManager dispatcher script
175- add dhclient script
176- retry server/peer name resolution at least once to workaround
177  NetworkManager race condition on boot
178- don't verify chrony.keys
179
180* Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
181- update to snapshot 20100302git5fb555
182- compile with PPS API support
183
184* Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
185- update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
186- modify default config
187  - step clock on start if it is off by more than 100 seconds
188  - disable client log
189- build with -fPIE on sparc
190
191* Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
192- update to 1.24-pre1
193
194* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
195- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
196
197* Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
198- switch to editline
199- support arbitrary chronyc commands in init script
200
201* Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
202- add patch with support for s390/s390x
203
204* Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
205- fix building with broken libcap header (#483548)
206
207* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
208- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
209
210* Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
211- fix info uninstall
212- generate random command key in init script
213- support cyclelogs, online, offline commands in init script
214- add logrotate script
215
216* Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
217- initial release
Note: See TracBrowser for help on using the repository browser.