source: projects/specs/trunk/c/chromium/chromium20-vl.spec @ 6473

Revision 6473, 33.1 KB checked in by munepi, 12 years ago (diff)

updated to 20.0.1132.54

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium20
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        20.0.1132.54
37Release:        1%{?_dist_release}
38License:        BSD-3-Clause, LGPL-2.1+
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-20.0.1132.XXX.tar.bz2
44Source3:        pack_chromium20_source-vine.sh
45# Patch template which adds vendor to user agent
46##!!Source20:       chromium-vendor.patch.in
47Source20:       chromium-vendor-vine.patch.in
48# Set default prefs
49##!!Source30:       master_preferences
50Source30:       master_preferences.vine
51##!!Source31:       default_bookmarks.html
52#Source31:       default_bookmarks.html.vine
53Source99:       chrome-wrapper
54##!!Source100:      chromium-browser.sh
55Source100:      chromium-browser-vine.sh
56##!!Source101:      chromium-browser.desktop
57Source101:      chromium-browser-vine.desktop
58Source102:      chromium-browser.xml
59#Source103:      chromium-browser-rpmlintrc
60##!!Source104:      chromium-icons.tar.bz2
61
62%{?nosrc:NoSource: 0}
63
64# Provides:       chromium-unstable = %{version}-%{release}
65# Obsoletes:      chromium13 chromium14 chromium15
66# Conflicts:      chromium-stable
67Provides:       chromium-stable = %{version}-%{release}
68Conflicts:      chromium-unstable
69
70## Start Patches
71# OpenSuse and Fedora
72# Many changes to the gyp systems so we can use system libraries
73Patch1:         chromium-gcc46.patch
74Patch8:         chromium-codechanges-zlib.patch
75Patch13:        chromium-no-courgette.patch
76Patch14:        chromium-master-prefs-path.patch
77Patch17:        chromium-system-glew.patch
78Patch18:        chromium-system-expat.patch
79Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
80Patch25:        tcmalloc-factory.patch
81Patch26:        chromium-remoting-build-fix.diff
82Patch28:        chromium-7.0.500.0-system-speex.patch
83Patch32:        chromium-7.0.542.0-system-libvpx.patch
84Patch62:        chromium-norpath.patch
85Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
86Patch64:        chromium-more-codec-aliases.patch
87Patch66:        chromium-sandbox-pie.patch
88Patch67:        chromium_use_gold.patch
89Patch68:        chromium-gcc47.patch
90# Upstream Patches
91Patch500:       sqlite-3.7.6.3-fix-out-of-scope-memory-reference.patch
92
93
94# Vine
95#Patch100:       chromium-15.0.874.116-no-tests.patch
96
97
98##!!BuildRequires:  Mesa-devel
99BuildRequires:  mesa-libGLU-devel
100##!!BuildRequires:  alsa-devel
101BuildRequires:  alsa-lib-devel
102BuildRequires:  pulseaudio-libs-devel
103BuildRequires:  bison
104BuildRequires:  cups-devel
105BuildRequires:  desktop-file-utils
106BuildRequires:  fdupes
107BuildRequires:  flex
108BuildRequires:  freetype2-devel
109BuildRequires:  gcc
110BuildRequires:  gcc-c++
111BuildRequires:  gperf
112BuildRequires:  hunspell-devel
113##!!BuildRequires:  libbz2-devel
114BuildRequires:  bzip2-devel
115BuildRequires:  libevent
116##!!BuildRequires:  libexpat-devel
117BuildRequires:  expat-devel
118##!!BuildRequires:  libgnutls-devel
119BuildRequires:  gnutls-devel
120%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
121BuildRequires:  libpng-devel
122BuildRequires:  libstdc++-devel >= 4.4
123%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
124BuildRequires:  libxslt-devel
125BuildRequires:  libzip-devel
126##!!BuildRequires:  lzma
127BuildRequires:  xz
128##!!BuildRequires:  mozilla-nspr-devel
129BuildRequires:  nspr-devel
130##!!BuildRequires:  mozilla-nss-devel
131BuildRequires:  nss-devel
132BuildRequires:  krb5-devel
133BuildRequires:  openssl-devel
134BuildRequires:  pam-devel
135##!!BuildRequires:  pkg-config
136BuildRequires:  subversion
137##!!BuildRequires:  perl(Switch)
138BuildRequires:  perl
139BuildRequires:  cairo-devel >= 1.6
140BuildRequires:  dbus-devel
141BuildRequires:  dbus-glib-devel
142##!!BuildRequires:  gconf2-devel
143BuildRequires:  GConf2-devel
144BuildRequires:  glib2-devel
145BuildRequires:  gtk2-devel
146BuildRequires:  libxml2-devel
147BuildRequires:  python
148##!!BuildRequires:  python-xml
149BuildRequires:  python-pyxml
150BuildRequires:  sqlite3-devel
151##!!BuildRequires:  update-desktop-files
152%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
153##!!BuildRequires:  wdiff
154BuildRequires:  zlib-devel
155##!!BuildRequires:  libpulse-devel
156BuildRequires:  pulseaudio-libs-devel
157##!!BuildRequires:  libelf-devel
158BuildRequires:  elfutils-libelf-devel
159BuildRequires:  libgnome-keyring-devel
160BuildRequires:  python-devel
161#BuildRequires:  glew-devel
162BuildRequires:  libevent-devel
163%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
164#BuildRequires:  libjingle-devel >= 0.4.0-7
165#BuildRequires:  srtp-devel
166BuildRequires:  speex-devel
167BuildRequires:  libudev-devel
168
169##Vine Linux
170#BuildRequires:  libpaper-devel
171BuildRequires:  libXScrnSaver-devel
172BuildRequires:  libXtst-devel
173BuildRequires:  libXdamage-devel
174BuildRequires:  libXt-devel
175%ifarch x86_64
176Requires:  nspluginwrapper
177%endif
178
179##!!Requires:       alsa
180Requires:       alsa-lib
181Requires:       pulseaudio-libs
182Requires:       xdg-utils
183%{?with_system_v8:Requires:       v8 = %{v8_ver}}
184
185BuildRoot:      %{_tmppath}/%{name}-%{version}-root
186
187%description
188Chromium is the open-source project behind Google Chrome.
189We invite you to join us in our effort to help build a safer, faster,
190and more stable way for all Internet users to experience the web,
191and to create a powerful platform for developing a new generation of
192web applications.
193
194%description -l ja
195Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
196ウェブを体験しているすべてのインターネットユーザに対して
197より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
198そして、ウェブアプリケーションの新しい世代を発展させ、
199強力なプラットホームを作成するために、
200私たちの取り組みにぜひ参加してください。
201
202
203%prep
204#%setup -q
205[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
206xz -dc %{SOURCE0} | %__tar -xf - || exit 1
207%setup -D -T -n %{pkgname}-%{version}
208
209%if %{?_dist_release} == "vl7"
210%patch1 -p1
211%endif
212%patch62 -p1
213%{?with_system_v8:%patch63 -p1}
214%patch64
215#%patch65 -p1
216#%patch100 -p1 -b .vine
217%patch8 -p1
218%patch13 -p1
219%patch14 -p1
220%patch17 -p1
221%patch18 -p1
222%{?with_system_ffmpeg:%patch20 -p1}
223#%patch25 -p1
224%patch26 -p1
225%patch28 -p1
226%{?with_system_vpx:%patch32 -p1}
227%patch66 -p1
228#%patch67 -p1
229#%patch68 -p1
230%patch500 -p1
231
232
233# apply vendor patch after substitution
234%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
235
236# Make sure that the requires legal files can be found
237%__cp -a src/AUTHORS src/LICENSE . || exit 1
238
239%build
240
241## create make files
242
243PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
244for i in src/build/common.gypi; do
245        %__sed -i "s|'-march=pentium4',||g" $i
246        %__sed -i "s|'-mfpmath=sse',||g" $i
247        %__sed -i "s|'-O<(debug_optimize)',||g" $i
248        %__sed -i "s|'-m32',||g" $i
249        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
250        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
251done
252# '
253
254pushd src
255
256./build/gyp_chromium -f make build/all.gyp \
257    -Dlinux_sandbox_path=%{chrome_sandbox} \
258    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
259    -Duse_openssl=0 \
260    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
261    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
262    -Dbuild_ffmpegsumo=1 \
263    -Duse_system_zlib=1 \
264    -Duse_system_libpng=1 \
265    -Duse_system_bzip2=1 \
266    -Duse_system_libbz2=1 \
267    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
268    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
269    -Duse_system_libxml=1 \
270    -Duse_system_libxslt=1 \
271    -Duse_system_libevent=1 \
272    %{?with_system_vpx:-Duse_system_vpx=1} \
273    %{!?with_system_vpx:-Duse_system_vpx=0} \
274    -Dremove_webcore_debug_symbols=1 \
275    %{?with_system_v8:-Duse_system_v8=1} \
276    %{!?with_system_v8:-Duse_system_v8=0} \
277    %{?with_system_icu:-Duse_system_icu=1} \
278    %{!?with_system_icu:-Duse_system_icu=0} \
279    %{?_with_shared_library:-Dlibrary=shared_library} \
280    -Dproprietary_codecs=1 \
281    -Ddisable_nacl=1 \
282    -Dlinux_use_gold_flags=0 \
283    -Dlinux_use_gold_binary=0 \
284    -Djavascript_engine=v8 \
285    -Dlinux_fpic=1 \
286    -Ddisable_sse2=1 \
287    %ifarch %{ix86}
288        -Dtarget_arch=ia32 \
289    %endif
290    %ifarch x86_64
291        -Dtarget_arch=x64 \
292    %endif
293    -Dno_strict_aliasing=1 \
294    -Drelease_extra_cflags=-fPIC \
295    %if %{?_dist_release} == "vl6"
296        -Dgcc_version=44 \
297    %endif
298    ;
299
300%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
301
302# Build the required SUID_SANDBOX helper
303%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
304
305# Build the ChromeDriver test suite
306%__make -r %{?_smp_mflags} chromedriver V=1 BUILDTYPE=Release disable_nacl=1
307popd
308
309%install
310%{__rm} -rf %{buildroot}
311
312%__mkdir_p %{buildroot}%{_bindir}
313%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
314%ifarch x86_64
315%__mkdir_p %{buildroot}%{_prefix}/lib/
316%endif
317# x86_64 capable systems need this
318%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
319%__mkdir_p %{buildroot}%{_libdir}/chromium/
320%__mkdir_p %{buildroot}%{_mandir}/man1/
321pushd src/out/Release
322%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/ || exit 1
323%__cp -a chrome.pak ui_resources_standard.pak theme_resources_standard.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/ || exit 1
324%__cp -a chromedriver %{buildroot}%{_libdir}/chromium/ || exit 1
325%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/ || exit 1
326%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium || exit 1
327%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/ || exit 1}
328%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/ || exit 1}
329%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1 || exit 1
330%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1 || exit 1
331fdupes %{buildroot}%{_mandir}/man1/
332popd
333
334%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
335%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
336for i in 16 22 24 32 48 64 128 256; do
337    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
338    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
339done
340
341%__mkdir_p %{buildroot}%{_datadir}/applications/
342desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
343
344%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
345%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
346
347# # link to browser plugin path.  Plugin patch doesn't work. Why?
348# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
349# pushd %{buildroot}%{_libdir}/%{pkgname}
350# %{__ln_s} %{_libdir}/browser-plugins plugins
351# popd
352pushd %{buildroot}%{_libdir}/%{pkgname}
353%ifarch x86_64
354%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
355%else
356%{__ln_s} %{_libdir}/mozilla/plugins plugins
357%endif
358popd
359
360# Install the master_preferences file
361%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
362#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
363%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
364#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
365
366%clean
367%{__rm} -rf %{buildroot}
368
369%post
370touch --no-create %{_datadir}/icons/hicolor
371if [ -x %{_bindir}/gtk-update-icon-cache ]; then
372  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
373fi
374%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
375
376%postun
377%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
378touch --no-create %{_datadir}/icons/hicolor
379if [ -x %{_bindir}/gtk-update-icon-cache ]; then
380  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
381fi || :
382
383
384%files
385%defattr(-,root,root,-)
386%config %{_sysconfdir}/%{pkgname}
387%dir %{_datadir}/gnome-control-center
388%dir %{_datadir}/gnome-control-center/default-apps
389%dir %{_libdir}/chromium/
390%{_bindir}/chromium
391%{_libdir}/chromium/chromium
392%{_libdir}/chromium/plugins/
393%{_libdir}/chromium/locales/
394%{_libdir}/chromium/resources/
395#%{_libdir}/chromium/nacl_*
396#%{_libdir}/chromium/libppGoogleNaClPluginChrome.so
397%attr(755,root,root) %{_libdir}/chromium/xdg-settings
398%attr(755,root,root) %{_libdir}/chromium/xdg-mime
399%{_libdir}/chromium/*.pak
400%{_mandir}/man1/chrom*
401%{_datadir}/applications/*.desktop
402%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
403%{_datadir}/pixmaps/chromium-browser.png
404%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
405%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
406%attr(4755,root,root) %{chrome_sandbox}
407%{_libdir}/chromium/chromedriver
408
409
410%changelog
411* Thu Jun 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 20.0.1132.54-1
412- updated to 20.0.1132.54
413
414* Sun Jun 10 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.57-1
415- updated to 19.0.1084.57
416
417* Sat Jun  2 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.53-1
418- updated to 19.0.1084.53
419
420* Tue May 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 19.0.1084.50-1
421- updated to 19.0.1084.50
422
423* Tue May  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.169-1
424- updated to 18.0.1025.169
425
426* Sat Apr 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.166-1
427- updated to 18.0.1025.166
428
429* Sat Apr 14 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.163-1
430- updated to 18.0.1025.163
431
432* Tue Apr  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.148-1
433- updated to 18.0.1025.148
434
435* Wed Mar 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.145-1
436- updated to 18.0.1025.145
437
438* Sun Mar 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.140-1
439- updated to 18.0.1025.140
440
441* Thu Mar 22 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.130-1
442- updated to 18.0.1025.130
443
444* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 18.0.1025.114-1
445- updated to 18.0.1025.114
446
447* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.81-1
448- updated to 17.0.963.81
449
450* Fri Mar  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.78-1
451- updated to 17.0.963.78
452
453* Sat Mar  3 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.65-1
454- updated to 17.0.963.65
455
456* Wed Feb 29 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.60-1
457- updated to 17.0.963.60
458
459* Fri Feb 17 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.57-1
460- updated to 17.0.963.57
461
462* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
463- updated to 17.0.963.54
464
465* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
466- updated to 17.0.963.52
467
468* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
469- updated to 16.0.912.77
470
471* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
472- updated to 16.0.912.75
473
474* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
475- updated to 16.0.912.63
476
477* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
478- updated to 16.0.912.57
479
480* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
481- updated to 15.0.874.116
482
483* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
484- updated to 14.0.835.204
485- added BuildRequires: dbus-glib-devel
486
487* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
488- updated to 14.0.835.186
489
490* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
491- updated to 14.0.835.163
492
493* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
494- updated to 14.0.835.157
495
496* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
497- updated to 14.0.835.102
498
499* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
500- updated to 14.0.835.89
501- added Obsoletes: chromium-unstable < %{version}-%{release}
502
503* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
504- updated to 14.0.835.35
505- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
506- changed to Name: chromium14
507  - Provides:  chromium-unstable = %%{version}
508  - Conflicts: chromium-stable
509
510* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
511- changed to Name: chromium
512- updated to 13.0.782.107
513
514* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
515- updated to 13.0.782.88
516- added BuildRequires: libzip-devel
517- added Provides: chromium-unstable = %%{version}
518- added Conflicts: chromium-stable
519
520* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
521- fix user-agent string (chromium-vendor-vine.patch.in)
522  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
523
524* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
525- updated to 12.0.742.93
526- fixed icon field of chromium-browser-vine.desktop
527
528* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
529- updated to 12.0.742.91
530
531* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
532- updated to 12.0.742.77
533
534* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
535- updated to 12.0.742.63
536
537* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
538- updated to 12.0.742.42
539
540* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
541- updated to 12.0.742.6
542- dropped/upstreamed patches
543- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
544
545* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
546- updated to 11.0.696.50
547- dropped some Patches for MeeGo Netbook
548
549* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
550- updated to 11.0.696.35
551
552* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
553- updated to 11.0.696.29
554- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
555
556* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
557- updated to 11.0.696.22
558- improved chromium-browser-vine.sh
559  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
560
561* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
562- updated to 11.0.696.20
563- improved chromium-browser-vine.desktop
564
565* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
566- updated to 11.0.696.17
567
568* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
569- updated to 11.0.696.15
570  - ready for Vine Linux 6 release
571- dropped BuildRequires: v8-devel, libicu-devel
572
573* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
574- updated to 11.0.696.5 with v8 3.2.0
575- added BuildRequires: pam-devel
576
577* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
578- rebuilt with libevent-2.0.10
579
580* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
581- updated to 10.0.651.0 with v8 3.0.12
582- added BuildRequires:
583  - libpaper-devel
584  - python-devel
585- added built header file: libavutil/avconfig.h %%prep
586- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
587
588* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
589- updated to 10.0.622.0
590- added BuildRequires: libXt-devel
591
592* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
593- updated to 10.0.605.0
594- added BuildRequires:
595  - libXdamage-devel
596  - hunspell-devel
597
598* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
599- updated to 9.0.598
600
601* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
602- updated to 9.0.593
603
604* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
605- updated to 9.0.582
606- added Requires: xdg-utils
607
608* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
609- updated to 9.0.578
610
611* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
612- updated to 9.0.569
613
614  * Mon Oct 25 2010 tittiatcoke@gmail.com
615  - Update to 9.0.564 build
616    * Added specific patches for MeeGo.
617    * We are now using shared libraries for Chromium
618    * Spec-file cleanup (Thanks to prusnak)
619
620* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
621- updated to snapshot 8.0.556
622
623* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
624- updated to snapshot 8.0.551
625
626* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
627- updated to snapshot 7.0.527
628
629* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
630- updated to snapshot 7.0.519
631
632* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
633- updated to snapshot 7.0.513
634  - updated chromium-vendor-vine.patch.in
635
636* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
637- updated to snapshot 7.0.507
638
639* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
640- updated to snapshot 7.0.498
641
642* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
643- updated to snapshot 6.0.493
644- used with_system_icu (for vl6)
645  - added BuildRequires: libicu-devel
646
647* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
648- build for Vine Linux 5.x
649  - add BuildRequires: gnome-keyring-devel
650
651* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
652- updated to snapshot 6.0.454
653- added BuildRequires:
654  - sqlite3-devel
655  - gnutls-devel
656  - libgnome-keyring-devel
657
658* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
659- updated to snapshot 6.0.431.0 r49253
660- added BuildRequires: cups-devel
661
662* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
663- updated to snapshot 6.0.405.0 r47263
664
665* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
666- unused with_system_icu (for vl6)
667  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
668
669* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
670- updated to snapshot 5.0.378.0 r44472
671  - used with_system_icu (for vl6)
672  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
673
674* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
675- updated to snapshot 5.0.372.0 r43947
676- added BuildRequires: glew-devel
677- changed Group tag to Applications/Internet
678- added Summary(ja) and %%description -l ja
679
680* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
681- updated to snapshot 5.0.365.0 r42966
682- merged 5.0.353.0-4vl5
683 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
684 - build on Vine Linux 5.1
685   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
686
687* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
688- updated to snapshot 5.0.364.0 r42779
689
690* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
691- updated to snapshot 5.0.359.0 r42116
692- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
693
694* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
695- fixed master_preferences.vine, little
696
697* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
698- fixed to install master_preferences
699- dropped chromium-5.0.353-no-ffmpeg-vine.patch
700
701* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
702- applied chromium-5.0.353-no-ffmpeg-vine.patch
703
704* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
705- updated to snapshot 5.0.353.0 r41449
706  * Wed Mar 10 2010 bgmerrell@novell.com
707  - Add master_preferences source file and install it to /etc/chromium.
708  - Create a new patch (chromium-master-prefs-path.patch) which tells
709    chromium to look in /etc/chromium for the master_preferences file
710    (instead of looking in the default directory, which is the same
711    directory as the 'chrome' binary).
712
713* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
714- updated to snapshot 5.0.335.0 r39556
715
716* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
717- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
718
719* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
720- updated to snapshot 5.0.330.0 r39074
721
722* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
723- use_system_ffmpeg
724
725* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
726- added Requires:  nspluginwrapper
727- fixed a symbolic link of plugins directory with nspluginwrapper
728
729* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
730- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
731
732* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
733- added BuildRequires: mesa-libGLU-devel
734- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
735
736* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
737- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
738
739  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
740  - Update to 4.0.260
741  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
742  - Update to 4.0.259
743  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
744  - Update to 4.0.258
745  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
746  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
747    changed to having an built-in v8
748  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
749  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
750  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
751  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
752  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
753  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
754  - update to newer svn snapshot
755    + Obsoletes fwrite patch (included upstream)
756  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
757  - update to newer svn snapshot
758    + Requires newer version of v8
759  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
760  - do not force SSE on x86 (drop-sse.patch)
761  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
762  - Update to newer svn snapshot
763  - Fixed spec file in order to build
764  - Included patch to build with system zlib
765  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
766  - package renamed to chromium
767  - cleaned up spec file
768  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
769  - v8 is now built as a separate package, and is required
770  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
771  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
772  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
773  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
774  - initial build
775
776#% changelog
777* Sun Jan 24 2010 prusnak@suse.cz
778- added vendor to user agent (chromium-vendor.patch.in)
779* Sun Nov 29 2009 prusnak@suse.cz
780- added --enable-sync to wrapper to enable bookmark sync
781* Sun Nov 29 2009 tittiatcoke@gmail.com 
782- Update to 4.0.260
783* Fri Nov 27 2009 tittiatcoke@gmail.com 
784- Update to 4.0.259
785* Thu Nov 26 2009 tittiatcoke@gmail.com 
786- Update to 4.0.258
787* Tue Nov 24 2009 tittatcoke@gmai.com 
788- In order to complete prevent the wrong v8 version to be used,
789  the Chromium build has been changed to having an built-in v8
790* Tue Nov 24 2009 dbuck@example.com 
791- Re-base patches.
792- Fixed a few patch errors.
793- Rename some patches to better correspond with function.
794- Removed some patches.
795- Minor SPEC changes.
796- I changed the v8 requirement to be exact, instead of greater than a specific version.
797* Fri Nov 13 2009 tittiatcoke@gmail.com
798- update to 247.0 svn 31928
799* Fri Oct 30 2009 tittiatcoke@gmail.com
800- update to 229.0 svn 30454
801  + Fix regression where popups and app frames lost their titlebars.
802  + Makes it so that when a folder is open on the bookmark bar
803    and the mouse moves over another folder, the menu for that
804    folder is shown.
805  + Lazily create the find bar.
806  + Polish to the gmail checker sample.
807  * New, crisper icons that are exactly 19x19
808  * Add a loading animation at the beginning before Gmail
809    responds.
810  * Fix a bug where we sometimes don't update the UI after a
811    logout/login cycle.
812  + Refactor widget methods to support desktop notifications,
813    including GTK stubs.
814  + Find-in-page should not ding while deleting characters.
815  + Add SSL wrapper for linux and mac.  This allows notifier to
816    use chrome's SSL layer instead of OpenSSL.
817  + Add three of the six extensions to PAC that Internet Explorer supports.
818  + WebSocket support in chromium. (Run with --enable-web-sockets
819    enables WebSocket features.)
820  + Do not allow GTK File Chooser dialogs to return directories.
821  + Fix the notifier SSL layer to make notifications work for
822    Linux Bookmark sync.
823  + linux: don't override mouse selection behavior in omnibox
824* Sun Oct 25 2009 tittiatcoke@gmail.com
825- Update to 224.4 svn 30027
826  + First cut at new page and browser action docs based
827    on new API. Deleted old stuff.
828  + Add suppression for new memory leak caused by WebKit merge 49830:49844
829  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
830  + Minimize dependency of user scripts
831  + Fixup the flip_framer eof-handling semantics now that we have
832    the FIN bit in place
833  + app depends on x11 because of active_window_watcher_x
834  + Adding two images for the new Extension managment UI
835  + Removing hard-coded Chrome Frame output path
836  + Rearrange clipboard code
837  + Fix crash bug when attempting to download a url with unsupported scheme,
838    e.g. 'data:', by 'Alt + Click'
839  + GTK: Change text for extension download UI
840  + Ignore invalid urls on command line
841  + Make dropped tabs animate from where they were dropped.
842  + Make room for the full width of the tab placeholder.
843  + Make tab dragging as smooth as glass.
844  + Remove an annoying NOTIMPLEMNETED
845  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
846  + If we're in the middle of a drag, don't allow the user to middle
847    click to close or right click for the context menu
848  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
849  + Remove +x bit from files that shouldn't have it
850  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
851  + Adding new image needed for the managment UI
852  + Fix a race bug where content scripts would not apply to the first page load
853  + Make escape remove a bookmark if it's just been added (but not if it already existed)
854  + Fix bubbles deactivating the opaque frame
855  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
856  + ake all pepper plugins default to windowless and transparent
857  + Add styles for printing
858  + Implement the new extension management UI
859  + Add support for to automation interface load install and load extensions
860  + GTK: theme the info bar border
861  + Update V8 to version 1.3.16.1
862  + Introduce WebSecurityPolicy for security related methods
863  + New button scheme...borders are separate from the inner contents so
864    that they can be highlighted / depressed independently
865  + When opening Chrome maximized with an application window already
866    running, the Chrome window was not activated
867  + Fix compatibility problems with FileZilla FTP Server
868  + Remove the extension shelf on Linux
869  + Fix the proxy host and port string to start with http:// if it does not already
870  + Enable HTML5 databases for all extension renderer processes
871* Sat Oct 24 2009 prusnak@opensuse.org 
872- don't create desktop files in wrapper
873- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
874* Tue Oct 20 2009 tittiatcoke@gmail.com 
875- update to newer svn snapshot
876  + Obsoletes fwrite patch (included upstream)
877* Fri Oct 16 2009 tittiatcoke@gmail.com 
878- update to newer svn snapshot
879  + Requires newer version of v8
880* Thu Oct 15 2009 prusnak@suse.cz 
881- do not force SSE on x86 (drop-sse.patch)
882* Tue Oct 13 2009 tittiatcoke@gmail.com 
883- Update to newer svn snapshot
884- Fixed spec file in order to build
885- Included patch to build with system zlib
886* Mon Oct 12 2009 prusnak@suse.cz 
887- package renamed to chromium
888- cleaned up spec file
889* Tue Oct  6 2009 dbuck@example.com 
890- v8 is now built as a separate package, and is required
891- included many patches to use system libraries:
892    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
893* Thu Oct  1 2009 dbuck@example.com 
894- included a newer DEP than is in svn, native_client@823
895- things should compile cleanly now
896* Mon Aug 31 2009 dbuck@example.com 
897- initial build
Note: See TracBrowser for help on using the repository browser.