source: projects/specs/trunk/c/chromium/chromium17-vl.spec @ 5624

Revision 5624, 31.0 KB checked in by munepi, 12 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_jpeg 1
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11%define with_system_vpx 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14# There's a couple key GYP variables that control how FFmpeg is built:
15#   ffmpeg_branding
16#     Controls whether we build the Chromium or Google Chrome version of
17#     FFmpeg.  The Google Chrome version contains additional codecs.
18#     Typical values are Chromium, Chrome, ChromiumOS, and ChromeOS.
19#   use_system_ffmpeg
20#     When set to non-zero will build Chromium against the system FFmpeg
21#     headers via pkg-config.  When Chromium is launched it will assume that
22#     FFmpeg is present in the system library path.  Default value is 0.
23#   build_ffmpegsumo
24#     When set to zero will build Chromium against the patched ffmpegsumo
25#     headers, but not build ffmpegsumo itself.  Users are expected to build
26#     and provide their own version of ffmpegsumo.  Default value is 1.
27%define with_system_ffmpeg 1
28
29%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
30
31#Name:           chromium17
32Name:           chromium
33Summary:        Google's opens source browser project
34Summary(ja):    Googleのオープンソースウェブブラウザ
35#'
36Version:        17.0.963.54
37Release:        1%{?_dist_release}
38License:        BSD
39Group:          Applications/Internet
40Source0:        %{pkgname}-%{version}.tar.xz
41# Script used to create the %{pkgname}-%{version}.tar.xz archive from
42# a official tarball:
43# http://gsdview.appspot.com/chromium-browser-official/chromium-17.0.963.XXX.tar.bz2
44Source3:        pack_chromium17_source-vine.sh
45# Official ffmpeg headers
46Source8:        ffmpeg-0.6-headers.tar.xz
47#Source8:        ffmpeg-0.9-headers.tar.xz
48# Patch template which adds vendor to user agent
49##!!Source20:       chromium-vendor.patch.in
50Source20:       chromium-vendor-vine.patch.in
51# Set default prefs
52##!!Source30:       master_preferences
53Source30:       master_preferences.vine
54##!!Source31:       default_bookmarks.html
55#Source31:       default_bookmarks.html.vine
56Source99:       chrome-wrapper
57##!!Source100:      chromium-browser.sh
58Source100:      chromium-browser-vine.sh
59##!!Source101:      chromium-browser.desktop
60Source101:      chromium-browser-vine.desktop
61Source102:      chromium-browser.xml
62#Source103:      chromium-browser-rpmlintrc
63##!!Source104:      chromium-icons.tar.bz2
64
65%{?nosrc:NoSource: 0}
66
67# Provides:       chromium-unstable = %{version}-%{release}
68# Obsoletes:      chromium13 chromium14 chromium15
69# Conflicts:      chromium-stable
70Provides:       chromium-stable = %{version}-%{release}
71Conflicts:      chromium-unstable
72
73## Start Patches
74# OpenSuse and Fedora
75# Many changes to the gyp systems so we can use system libraries
76Patch1:         chromium-gcc46.patch
77Patch4:         chromium-no-sqlite-debug.patch
78Patch8:         chromium-codechanges-zlib.patch
79Patch13:        chromium-no-courgette.patch
80Patch14:        chromium-master-prefs-path.patch
81Patch17:        chromium-system-glew.patch
82Patch18:        chromium-system-expat.patch
83Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
84Patch25:        tcmalloc-factory.patch
85Patch26:        chromium-remoting-build-fix.diff
86Patch28:        chromium-7.0.500.0-system-speex.patch
87Patch32:        chromium-7.0.542.0-system-libvpx.patch
88Patch62:        chromium-norpath.patch
89Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
90Patch64:        chromium-more-codec-aliases.patch
91
92# Vine
93#Patch100:       chromium-15.0.874.116-no-tests.patch
94
95
96##!!BuildRequires:  Mesa-devel
97BuildRequires:  mesa-libGLU-devel
98##!!BuildRequires:  alsa-devel
99BuildRequires:  alsa-lib-devel
100BuildRequires:  pulseaudio-libs-devel
101BuildRequires:  bison
102BuildRequires:  cups-devel
103BuildRequires:  desktop-file-utils
104BuildRequires:  fdupes
105BuildRequires:  flex
106BuildRequires:  freetype2-devel
107BuildRequires:  gcc gcc-c++
108BuildRequires:  gperf
109BuildRequires:  hunspell-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112BuildRequires:  libevent
113##!!BuildRequires:  libexpat-devel
114BuildRequires:  expat-devel
115##!!BuildRequires:  libgnutls-devel
116BuildRequires:  gnutls-devel
117%{?with_system_jpeg:BuildRequires:  libjpeg-devel}
118BuildRequires:  libpng-devel
119BuildRequires:  libstdc++-devel >= 4.4
120%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
121BuildRequires:  libxslt-devel
122BuildRequires:  libzip-devel
123##!!BuildRequires:  lzma
124BuildRequires:  xz
125##!!BuildRequires:  mozilla-nspr-devel
126BuildRequires:  nspr-devel
127##!!BuildRequires:  mozilla-nss-devel
128BuildRequires:  nss-devel
129BuildRequires:  openssl-devel
130BuildRequires:  pam-devel
131##!!BuildRequires:  perl(Switch)
132BuildRequires:  perl
133##!!BuildRequires:  pkg-config
134BuildRequires:  cairo-devel >= 1.6
135BuildRequires:  dbus-devel
136BuildRequires:  dbus-glib-devel
137##!!BuildRequires:  gconf2-devel
138BuildRequires:  GConf2-devel
139BuildRequires:  glib2-devel
140BuildRequires:  gtk2-devel
141BuildRequires:  libxml2-devel
142BuildRequires:  python
143##!!BuildRequires:  python-xml
144BuildRequires:  python-pyxml
145BuildRequires:  sqlite3-devel
146##!!BuildRequires:  update-desktop-files
147%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
148##!!BuildRequires:  wdiff
149BuildRequires:  zlib-devel
150
151BuildRequires:  libgnome-keyring-devel
152BuildRequires:  python-devel
153
154#BuildRequires:  glew-devel
155BuildRequires:  libevent-devel
156%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
157#BuildRequires:  libjingle-devel >= 0.4.0-7
158#BuildRequires:  srtp-devel
159BuildRequires:  speex-devel
160
161##Vine Linux
162#BuildRequires:  libpaper-devel
163BuildRequires:  libXScrnSaver-devel
164BuildRequires:  libXtst-devel
165BuildRequires:  libXdamage-devel
166BuildRequires:  libXt-devel
167%ifarch x86_64
168Requires:  nspluginwrapper
169%endif
170
171##!!Requires:       alsa
172Requires:       alsa-lib
173Requires:       pulseaudio-libs
174Requires:       xdg-utils
175%{?with_system_v8:Requires:       v8 = %{v8_ver}}
176
177BuildRoot:      %{_tmppath}/%{name}-%{version}-root
178
179%description
180Chromium is the open-source project behind Google Chrome.
181We invite you to join us in our effort to help build a safer, faster,
182and more stable way for all Internet users to experience the web,
183and to create a powerful platform for developing a new generation of
184web applications.
185
186%description -l ja
187Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
188ウェブを体験しているすべてのインターネットユーザに対して
189より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
190そして、ウェブアプリケーションの新しい世代を発展させ、
191強力なプラットホームを作成するために、
192私たちの取り組みにぜひ参加してください。
193
194
195%prep
196#%setup -q
197[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
198xz -dc %{SOURCE0} | %__tar -xf - || exit 1
199%setup -D -T -n %{pkgname}-%{version}
200
201%if %{?_dist_release} == "vl7"
202%patch1 -p1
203%endif
204%patch62 -p1
205%{?with_system_v8:%patch63 -p1}
206%patch64
207#%patch100 -p1 -b .vine
208%patch8 -p1
209%patch13 -p1
210%patch14 -p1
211%patch17 -p1
212%patch18 -p1
213%patch20 -p1
214#%patch25 -p1
215%patch26 -p1
216%patch28 -p1
217%{?with_system_vpx:%patch32 -p1}
218%patch4 -p1
219
220
221pushd src/third_party/ffmpeg/
222%__tar xf %{SOURCE8} || exit 1
223## built header file: avconfig.h
224[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
225cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
226/* Generated by ffconf */
227#ifndef AVUTIL_AVCONFIG_H
228#define AVUTIL_AVCONFIG_H
229#define AV_HAVE_BIGENDIAN 0
230#define AV_HAVE_FAST_UNALIGNED 1
231#endif /* AVUTIL_AVCONFIG_H */
232EOF
233popd
234
235# apply vendor patch after substitution
236%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
237
238# Make sure that the requires legal files can be found
239%__cp -a src/AUTHORS src/LICENSE . || exit 1
240
241%build
242
243## create make files
244
245PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
246for i in src/build/common.gypi; do
247        %__sed -i "s|'-march=pentium4',||g" $i
248%ifnarch x86_64
249        %__sed -i "s|'-mfpmath=sse',||g" $i
250%endif
251        %__sed -i "s|'-O<(debug_optimize)',||g" $i
252        %__sed -i "s|'-m32',||g" $i
253        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
254        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
255done
256# '
257
258pushd src
259
260./build/gyp_chromium -f make build/all.gyp \
261    -Dlinux_sandbox_path=%{chrome_sandbox} \
262    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
263    -Duse_openssl=0 \
264    %{?with_system_ffmpeg:-Duse_system_ffmpeg=1} \
265    %{!?with_system_ffmpeg:-Duse_system_ffmpeg=0} \
266    -Dbuild_ffmpegsumo=0 \
267    -Duse_system_zlib=1 \
268    -Duse_system_libpng=1 \
269    -Duse_system_bzip2=1 \
270    -Duse_system_libbz2=1 \
271    %{?with_system_jpeg:-Duse_system_libjpeg=1} \
272    %{!?with_system_jpeg:-Duse_system_libjpeg=0} \
273    -Duse_system_libxml=1 \
274    -Duse_system_libxslt=1 \
275    -Duse_system_libevent=1 \
276    %{?with_system_vpx:-Duse_system_vpx=1} \
277    %{!?with_system_vpx:-Duse_system_vpx=0} \
278    -Dremove_webcore_debug_symbols=1 \
279    %{?with_system_v8:-Duse_system_v8=1} \
280    %{!?with_system_v8:-Duse_system_v8=0} \
281    %{?with_system_icu:-Duse_system_icu=1} \
282    %{!?with_system_icu:-Duse_system_icu=0} \
283    %{?_with_shared_library:-Dlibrary=shared_library} \
284    -Dproprietary_codecs=1 \
285    -Ddisable_nacl=1 \
286    -Djavascript_engine=v8 \
287    -Dlinux_fpic=1 \
288    %ifarch %{ix86}
289        -Dtarget_arch=ia32 \
290    %endif
291    %ifarch x86_64
292        -Ddisable_sse2=1 \
293        -Dtarget_arch=x64 \
294    %endif
295    -Dno_strict_aliasing=1 \
296    -Drelease_extra_cflags=-fPIC \
297    %if %{?_dist_release} == "vl6"
298        -Dgcc_version=44 \
299    %endif
300    ;
301
302%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
303
304# Build the required SUID_SANDBOX helper
305%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
306
307popd
308
309%install
310%{__rm} -rf %{buildroot}
311
312%__mkdir -p %{buildroot}%{_bindir}
313%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
314%ifarch x86_64
315mkdir -p %{buildroot}%{_prefix}/lib/
316%endif
317# x86_64 capable systems need this
318%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
319%__mkdir -p %{buildroot}%{_libdir}/chromium/
320%__mkdir -p %{buildroot}%{_mandir}/man1/
321pushd src/out/Release
322%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
323%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
324%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
325%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
326%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
327%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
328%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
329%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
330fdupes %{buildroot}%{_mandir}/man1/
331popd
332
333%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
334%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
335for i in 16 22 24 32 48 64 128 256; do
336    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
337    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
338done
339
340%__mkdir_p %{buildroot}%{_datadir}/applications/
341desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
342
343%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
344%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
345
346# # link to browser plugin path.  Plugin patch doesn't work. Why?
347# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
348# pushd %{buildroot}%{_libdir}/%{pkgname}
349# %{__ln_s} %{_libdir}/browser-plugins plugins
350# popd
351pushd %{buildroot}%{_libdir}/%{pkgname}
352%ifarch x86_64
353%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
354%else
355%{__ln_s} %{_libdir}/mozilla/plugins plugins
356%endif
357popd
358
359# Install the master_preferences file
360%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
361#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
362%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
363#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
364
365%clean
366%{__rm} -rf %{buildroot}
367
368%post
369touch --no-create %{_datadir}/icons/hicolor
370if [ -x %{_bindir}/gtk-update-icon-cache ]; then
371  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
372fi
373%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
374
375%postun
376%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
377touch --no-create %{_datadir}/icons/hicolor
378if [ -x %{_bindir}/gtk-update-icon-cache ]; then
379  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
380fi || :
381
382
383%files
384%defattr(-,root,root,-)
385%config %{_sysconfdir}/%{pkgname}
386%dir %{_datadir}/gnome-control-center
387%dir %{_datadir}/gnome-control-center/default-apps
388%dir %{_libdir}/chromium/
389%{_bindir}/chromium
390%{_libdir}/chromium/chromium
391%{_libdir}/chromium/plugins/
392%{_libdir}/chromium/resources/
393%attr(755,root,root) %{_libdir}/chromium/xdg-settings
394%attr(755,root,root) %{_libdir}/chromium/xdg-mime
395%{_mandir}/man1/chrom*
396%{_datadir}/pixmaps/chromium-browser.png
397%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
398%{_datadir}/applications/*.desktop
399%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
400#%{_datadir}/icons/oxygen/
401%{_libdir}/chromium/chrome.pak
402%{_libdir}/chromium/resources.pak
403%{_libdir}/chromium/locales/
404%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
405%attr(4755,root,root) %{chrome_sandbox}
406
407%changelog
408* Sun Feb 12 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.54-1
409- updated to 17.0.963.54
410
411* Sat Feb 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 17.0.963.52-1
412- updated to 17.0.963.52
413
414* Sat Feb  4 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.77-1
415- updated to 16.0.912.77
416
417* Sun Jan  8 2012 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.75-1
418- updated to 16.0.912.75
419
420* Fri Dec 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.63-1
421- updated to 16.0.912.63
422
423* Thu Dec  1 2011 Munehiro Yamamoto <munepi@vinelinux.org> 16.0.912.57-1
424- updated to 16.0.912.57
425
426* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
427- updated to 15.0.874.116
428
429* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
430- updated to 14.0.835.204
431- added BuildRequires: dbus-glib-devel
432
433* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
434- updated to 14.0.835.186
435
436* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
437- updated to 14.0.835.163
438
439* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
440- updated to 14.0.835.157
441
442* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
443- updated to 14.0.835.102
444
445* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
446- updated to 14.0.835.89
447- added Obsoletes: chromium-unstable < %{version}-%{release}
448
449* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
450- updated to 14.0.835.35
451- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
452- changed to Name: chromium14
453  - Provides:  chromium-unstable = %%{version}
454  - Conflicts: chromium-stable
455
456* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
457- changed to Name: chromium
458- updated to 13.0.782.107
459
460* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
461- updated to 13.0.782.88
462- added BuildRequires: libzip-devel
463- added Provides: chromium-unstable = %%{version}
464- added Conflicts: chromium-stable
465
466* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
467- fix user-agent string (chromium-vendor-vine.patch.in)
468  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
469
470* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
471- updated to 12.0.742.93
472- fixed icon field of chromium-browser-vine.desktop
473
474* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
475- updated to 12.0.742.91
476
477* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
478- updated to 12.0.742.77
479
480* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
481- updated to 12.0.742.63
482
483* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
484- updated to 12.0.742.42
485
486* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
487- updated to 12.0.742.6
488- dropped/upstreamed patches
489- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
490
491* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
492- updated to 11.0.696.50
493- dropped some Patches for MeeGo Netbook
494
495* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
496- updated to 11.0.696.35
497
498* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
499- updated to 11.0.696.29
500- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
501
502* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
503- updated to 11.0.696.22
504- improved chromium-browser-vine.sh
505  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
506
507* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
508- updated to 11.0.696.20
509- improved chromium-browser-vine.desktop
510
511* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
512- updated to 11.0.696.17
513
514* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
515- updated to 11.0.696.15
516  - ready for Vine Linux 6 release
517- dropped BuildRequires: v8-devel, libicu-devel
518
519* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
520- updated to 11.0.696.5 with v8 3.2.0
521- added BuildRequires: pam-devel
522
523* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
524- rebuilt with libevent-2.0.10
525
526* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
527- updated to 10.0.651.0 with v8 3.0.12
528- added BuildRequires:
529  - libpaper-devel
530  - python-devel
531- added built header file: libavutil/avconfig.h %%prep
532- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
533
534* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
535- updated to 10.0.622.0
536- added BuildRequires: libXt-devel
537
538* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
539- updated to 10.0.605.0
540- added BuildRequires:
541  - libXdamage-devel
542  - hunspell-devel
543
544* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
545- updated to 9.0.598
546
547* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
548- updated to 9.0.593
549
550* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
551- updated to 9.0.582
552- added Requires: xdg-utils
553
554* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
555- updated to 9.0.578
556
557* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
558- updated to 9.0.569
559
560  * Mon Oct 25 2010 tittiatcoke@gmail.com
561  - Update to 9.0.564 build
562    * Added specific patches for MeeGo.
563    * We are now using shared libraries for Chromium
564    * Spec-file cleanup (Thanks to prusnak)
565
566* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
567- updated to snapshot 8.0.556
568
569* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
570- updated to snapshot 8.0.551
571
572* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
573- updated to snapshot 7.0.527
574
575* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
576- updated to snapshot 7.0.519
577
578* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
579- updated to snapshot 7.0.513
580  - updated chromium-vendor-vine.patch.in
581
582* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
583- updated to snapshot 7.0.507
584
585* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
586- updated to snapshot 7.0.498
587
588* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
589- updated to snapshot 6.0.493
590- used with_system_icu (for vl6)
591  - added BuildRequires: libicu-devel
592
593* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
594- build for Vine Linux 5.x
595  - add BuildRequires: gnome-keyring-devel
596
597* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
598- updated to snapshot 6.0.454
599- added BuildRequires:
600  - sqlite3-devel
601  - gnutls-devel
602  - libgnome-keyring-devel
603
604* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
605- updated to snapshot 6.0.431.0 r49253
606- added BuildRequires: cups-devel
607
608* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
609- updated to snapshot 6.0.405.0 r47263
610
611* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
612- unused with_system_icu (for vl6)
613  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
614
615* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
616- updated to snapshot 5.0.378.0 r44472
617  - used with_system_icu (for vl6)
618  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
619
620* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
621- updated to snapshot 5.0.372.0 r43947
622- added BuildRequires: glew-devel
623- changed Group tag to Applications/Internet
624- added Summary(ja) and %%description -l ja
625
626* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
627- updated to snapshot 5.0.365.0 r42966
628- merged 5.0.353.0-4vl5
629 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
630 - build on Vine Linux 5.1
631   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
632
633* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
634- updated to snapshot 5.0.364.0 r42779
635
636* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
637- updated to snapshot 5.0.359.0 r42116
638- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
639
640* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
641- fixed master_preferences.vine, little
642
643* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
644- fixed to install master_preferences
645- dropped chromium-5.0.353-no-ffmpeg-vine.patch
646
647* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
648- applied chromium-5.0.353-no-ffmpeg-vine.patch
649
650* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
651- updated to snapshot 5.0.353.0 r41449
652  * Wed Mar 10 2010 bgmerrell@novell.com
653  - Add master_preferences source file and install it to /etc/chromium.
654  - Create a new patch (chromium-master-prefs-path.patch) which tells
655    chromium to look in /etc/chromium for the master_preferences file
656    (instead of looking in the default directory, which is the same
657    directory as the 'chrome' binary).
658
659* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
660- updated to snapshot 5.0.335.0 r39556
661
662* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
663- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
664
665* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
666- updated to snapshot 5.0.330.0 r39074
667
668* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
669- use_system_ffmpeg
670
671* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
672- added Requires:  nspluginwrapper
673- fixed a symbolic link of plugins directory with nspluginwrapper
674
675* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
676- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
677
678* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
679- added BuildRequires: mesa-libGLU-devel
680- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
681
682* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
683- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
684
685  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
686  - Update to 4.0.260
687  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
688  - Update to 4.0.259
689  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
690  - Update to 4.0.258
691  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
692  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
693    changed to having an built-in v8
694  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
695  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
696  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
697  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
698  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
699  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
700  - update to newer svn snapshot
701    + Obsoletes fwrite patch (included upstream)
702  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
703  - update to newer svn snapshot
704    + Requires newer version of v8
705  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
706  - do not force SSE on x86 (drop-sse.patch)
707  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
708  - Update to newer svn snapshot
709  - Fixed spec file in order to build
710  - Included patch to build with system zlib
711  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
712  - package renamed to chromium
713  - cleaned up spec file
714  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
715  - v8 is now built as a separate package, and is required
716  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
717  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
718  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
719  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
720  - initial build
721
722#% changelog
723* Sun Jan 24 2010 prusnak@suse.cz
724- added vendor to user agent (chromium-vendor.patch.in)
725* Sun Nov 29 2009 prusnak@suse.cz
726- added --enable-sync to wrapper to enable bookmark sync
727* Sun Nov 29 2009 tittiatcoke@gmail.com 
728- Update to 4.0.260
729* Fri Nov 27 2009 tittiatcoke@gmail.com 
730- Update to 4.0.259
731* Thu Nov 26 2009 tittiatcoke@gmail.com 
732- Update to 4.0.258
733* Tue Nov 24 2009 tittatcoke@gmai.com 
734- In order to complete prevent the wrong v8 version to be used,
735  the Chromium build has been changed to having an built-in v8
736* Tue Nov 24 2009 dbuck@example.com 
737- Re-base patches.
738- Fixed a few patch errors.
739- Rename some patches to better correspond with function.
740- Removed some patches.
741- Minor SPEC changes.
742- I changed the v8 requirement to be exact, instead of greater than a specific version.
743* Fri Nov 13 2009 tittiatcoke@gmail.com
744- update to 247.0 svn 31928
745* Fri Oct 30 2009 tittiatcoke@gmail.com
746- update to 229.0 svn 30454
747  + Fix regression where popups and app frames lost their titlebars.
748  + Makes it so that when a folder is open on the bookmark bar
749    and the mouse moves over another folder, the menu for that
750    folder is shown.
751  + Lazily create the find bar.
752  + Polish to the gmail checker sample.
753  * New, crisper icons that are exactly 19x19
754  * Add a loading animation at the beginning before Gmail
755    responds.
756  * Fix a bug where we sometimes don't update the UI after a
757    logout/login cycle.
758  + Refactor widget methods to support desktop notifications,
759    including GTK stubs.
760  + Find-in-page should not ding while deleting characters.
761  + Add SSL wrapper for linux and mac.  This allows notifier to
762    use chrome's SSL layer instead of OpenSSL.
763  + Add three of the six extensions to PAC that Internet Explorer supports.
764  + WebSocket support in chromium. (Run with --enable-web-sockets
765    enables WebSocket features.)
766  + Do not allow GTK File Chooser dialogs to return directories.
767  + Fix the notifier SSL layer to make notifications work for
768    Linux Bookmark sync.
769  + linux: don't override mouse selection behavior in omnibox
770* Sun Oct 25 2009 tittiatcoke@gmail.com
771- Update to 224.4 svn 30027
772  + First cut at new page and browser action docs based
773    on new API. Deleted old stuff.
774  + Add suppression for new memory leak caused by WebKit merge 49830:49844
775  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
776  + Minimize dependency of user scripts
777  + Fixup the flip_framer eof-handling semantics now that we have
778    the FIN bit in place
779  + app depends on x11 because of active_window_watcher_x
780  + Adding two images for the new Extension managment UI
781  + Removing hard-coded Chrome Frame output path
782  + Rearrange clipboard code
783  + Fix crash bug when attempting to download a url with unsupported scheme,
784    e.g. 'data:', by 'Alt + Click'
785  + GTK: Change text for extension download UI
786  + Ignore invalid urls on command line
787  + Make dropped tabs animate from where they were dropped.
788  + Make room for the full width of the tab placeholder.
789  + Make tab dragging as smooth as glass.
790  + Remove an annoying NOTIMPLEMNETED
791  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
792  + If we're in the middle of a drag, don't allow the user to middle
793    click to close or right click for the context menu
794  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
795  + Remove +x bit from files that shouldn't have it
796  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
797  + Adding new image needed for the managment UI
798  + Fix a race bug where content scripts would not apply to the first page load
799  + Make escape remove a bookmark if it's just been added (but not if it already existed)
800  + Fix bubbles deactivating the opaque frame
801  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
802  + ake all pepper plugins default to windowless and transparent
803  + Add styles for printing
804  + Implement the new extension management UI
805  + Add support for to automation interface load install and load extensions
806  + GTK: theme the info bar border
807  + Update V8 to version 1.3.16.1
808  + Introduce WebSecurityPolicy for security related methods
809  + New button scheme...borders are separate from the inner contents so
810    that they can be highlighted / depressed independently
811  + When opening Chrome maximized with an application window already
812    running, the Chrome window was not activated
813  + Fix compatibility problems with FileZilla FTP Server
814  + Remove the extension shelf on Linux
815  + Fix the proxy host and port string to start with http:// if it does not already
816  + Enable HTML5 databases for all extension renderer processes
817* Sat Oct 24 2009 prusnak@opensuse.org 
818- don't create desktop files in wrapper
819- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
820* Tue Oct 20 2009 tittiatcoke@gmail.com 
821- update to newer svn snapshot
822  + Obsoletes fwrite patch (included upstream)
823* Fri Oct 16 2009 tittiatcoke@gmail.com 
824- update to newer svn snapshot
825  + Requires newer version of v8
826* Thu Oct 15 2009 prusnak@suse.cz 
827- do not force SSE on x86 (drop-sse.patch)
828* Tue Oct 13 2009 tittiatcoke@gmail.com 
829- Update to newer svn snapshot
830- Fixed spec file in order to build
831- Included patch to build with system zlib
832* Mon Oct 12 2009 prusnak@suse.cz 
833- package renamed to chromium
834- cleaned up spec file
835* Tue Oct  6 2009 dbuck@example.com 
836- v8 is now built as a separate package, and is required
837- included many patches to use system libraries:
838    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
839* Thu Oct  1 2009 dbuck@example.com 
840- included a newer DEP than is in svn, native_client@823
841- things should compile cleanly now
842* Mon Aug 31 2009 dbuck@example.com 
843- initial build
Note: See TracBrowser for help on using the repository browser.