source: projects/specs/trunk/c/chromium/chromium16-vl.spec @ 5230

Revision 5230, 30.4 KB checked in by munepi, 13 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5%define pkgname chromium
6
7#% define with_system_icu 1
8#% define with_system_v8 1
9
10#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
11#     libvpx doesn't currently supply a pkg-config file, so we assume that
12#     -lvpx is sufficient.
13%define with_system_vpx 1
14
15%global chrome_sandbox %{_prefix}/lib/chrome_sandbox
16
17#Name:           chromium15
18Name:           chromium
19Summary:        Google's opens source browser project
20Summary(ja):    Googleのオープンソースウェブブラウザ
21#'
22Version:        16.0.912.57
23Release:        1%{?_dist_release}
24License:        BSD
25Group:          Applications/Internet
26Source0:        %{pkgname}-%{version}.tar.xz
27# Script used to create the %{pkgname}-%{version}.tar.xz archive from
28# a official tarball:
29# http://gsdview.appspot.com/chromium-browser-official/chromium-16.0.910.XXX.tar.bz2
30Source3:        pack_chromium16_source-vine.sh
31# Official ffmpeg headers
32Source8:        ffmpeg-0.6-headers.tar.xz
33# Patch template which adds vendor to user agent
34##!!Source20:       chromium-vendor.patch.in
35Source20:       chromium-vendor-vine.patch.in
36# Set default prefs
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39##!!Source31:       default_bookmarks.html
40#Source31:       default_bookmarks.html.vine
41Source99:       chrome-wrapper
42##!!Source100:      chromium-browser.sh
43Source100:      chromium-browser-vine.sh
44##!!Source101:      chromium-browser.desktop
45Source101:      chromium-browser-vine.desktop
46Source102:      chromium-browser.xml
47#Source103:      chromium-browser-rpmlintrc
48##!!Source104:      chromium-icons.tar.bz2
49
50%{?nosrc:NoSource: 0}
51
52# Provides:       chromium-unstable = %{version}-%{release}
53# Obsoletes:      chromium13 chromium14 chromium15
54# Conflicts:      chromium-stable
55Provides:       chromium-stable = %{version}-%{release}
56Conflicts:      chromium-unstable
57
58## Start Patches
59# OpenSuse and Fedora
60# Many changes to the gyp systems so we can use system libraries
61#Patch1:         chromium-gcc46.patch
62Patch4:         chromium-no-sqlite-debug.patch
63Patch8:         chromium-codechanges-zlib.patch
64#Patch12:        chromium-no-test-sources.patch
65Patch13:        chromium-no-courgette.patch
66Patch14:        chromium-master-prefs-path.patch
67Patch17:        chromium-system-glew.patch
68Patch18:        chromium-system-expat.patch
69#Patch19:        chromium-system-zlib.patch
70Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
71Patch21:        chromium-7.0.542.0-media-probe.patch
72Patch25:        tcmalloc-factory.patch
73Patch26:        chromium-remoting-build-fix.diff
74Patch28:        chromium-7.0.500.0-system-speex.patch
75#Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
76Patch32:        chromium-7.0.542.0-system-libvpx.patch
77#Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
78Patch62:        chromium-norpath.patch
79Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
80
81# Vine
82#Patch100:       chromium-15.0.874.116-no-tests.patch
83
84
85##!!BuildRequires:  Mesa-devel
86BuildRequires:  mesa-libGLU-devel
87##!!BuildRequires:  alsa-devel
88BuildRequires:  alsa-lib-devel
89BuildRequires:  pulseaudio-libs-devel
90BuildRequires:  bison
91BuildRequires:  cups-devel
92BuildRequires:  desktop-file-utils
93BuildRequires:  fdupes
94BuildRequires:  flex
95BuildRequires:  freetype2-devel
96BuildRequires:  gcc gcc-c++
97BuildRequires:  gperf
98BuildRequires:  hunspell-devel
99##!!BuildRequires:  libbz2-devel
100BuildRequires:  bzip2-devel
101BuildRequires:  libevent
102##!!BuildRequires:  libexpat-devel
103BuildRequires:  expat-devel
104##!!BuildRequires:  libgnutls-devel
105BuildRequires:  gnutls-devel
106BuildRequires:  libjpeg-devel
107BuildRequires:  libpng-devel
108BuildRequires:  libstdc++-devel >= 4.4
109%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
110BuildRequires:  libxslt-devel
111BuildRequires:  libzip-devel
112##!!BuildRequires:  lzma
113BuildRequires:  xz
114##!!BuildRequires:  mozilla-nspr-devel
115BuildRequires:  nspr-devel
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118BuildRequires:  openssl-devel
119BuildRequires:  pam-devel
120##!!BuildRequires:  perl(Switch)
121BuildRequires:  perl
122##!!BuildRequires:  pkg-config
123BuildRequires:  cairo-devel >= 1.6
124BuildRequires:  dbus-devel
125BuildRequires:  dbus-glib-devel
126##!!BuildRequires:  gconf2-devel
127BuildRequires:  GConf2-devel
128BuildRequires:  glib2-devel
129BuildRequires:  gtk2-devel
130BuildRequires:  libxml2-devel
131BuildRequires:  python
132##!!BuildRequires:  python-xml
133BuildRequires:  python-pyxml
134BuildRequires:  sqlite3-devel
135##!!BuildRequires:  update-desktop-files
136%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
137##!!BuildRequires:  wdiff
138BuildRequires:  zlib-devel
139
140BuildRequires:  libgnome-keyring-devel
141BuildRequires:  python-devel
142
143#BuildRequires:  glew-devel
144BuildRequires:  libevent-devel
145%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
146#BuildRequires:  libjingle-devel >= 0.4.0-7
147#BuildRequires:  srtp-devel
148BuildRequires:  speex-devel
149
150##Vine Linux
151#BuildRequires:  libpaper-devel
152BuildRequires:  libXScrnSaver-devel
153BuildRequires:  libXtst-devel
154BuildRequires:  libXdamage-devel
155BuildRequires:  libXt-devel
156%ifarch x86_64
157Requires:  nspluginwrapper
158%endif
159
160##!!Requires:       alsa
161Requires:       alsa-lib
162Requires:       pulseaudio-libs
163Requires:       xdg-utils
164%{?with_system_v8:Requires:       v8 = %{v8_ver}}
165
166BuildRoot:      %{_tmppath}/%{name}-%{version}-root
167
168%description
169Chromium is the open-source project behind Google Chrome.
170We invite you to join us in our effort to help build a safer, faster,
171and more stable way for all Internet users to experience the web,
172and to create a powerful platform for developing a new generation of
173web applications.
174
175%description -l ja
176Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
177ウェブを体験しているすべてのインターネットユーザに対して
178より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
179そして、ウェブアプリケーションの新しい世代を発展させ、
180強力なプラットホームを作成するために、
181私たちの取り組みにぜひ参加してください。
182
183
184%prep
185#%setup -q
186[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
187xz -dc %{SOURCE0} | %__tar -xf - || exit 1
188%setup -D -T -n %{pkgname}-%{version}
189
190#%patch1 -p1
191%patch62 -p1
192%{?with_system_v8:%patch63 -p1}
193#%patch100 -p1 -b .vine
194%patch8 -p1
195#%patch12 -p1
196%patch13 -p1
197%patch14 -p1
198%patch17 -p1
199%patch18 -p1
200#%patch19 -p1
201%patch20 -p1
202%patch21 -p1
203%patch25 -p1
204%patch26 -p1
205%patch28 -p1
206#%patch29 -p1
207%{?with_system_vpx:%patch32 -p1}
208%{?with_system_v8:%patch34 -p1}
209%patch4 -p1
210
211
212pushd src/third_party/ffmpeg/
213%__tar xf %{SOURCE8} || exit 1
214## built header file: avconfig.h
215[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
216cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
217/* Generated by ffconf */
218#ifndef AVUTIL_AVCONFIG_H
219#define AVUTIL_AVCONFIG_H
220#define AV_HAVE_BIGENDIAN 0
221#endif /* AVUTIL_AVCONFIG_H */
222EOF
223popd
224
225#%__rm -rf src/third_party/libvpx/
226%__rm -rf src/third_party/speex/
227%__rm -rf src/third_party/nss src/third_party/nspr
228
229# apply vendor patch after substitution
230%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
231
232# Make sure that the requires legal files can be found
233%__cp -a src/AUTHORS src/LICENSE . || exit 1
234
235%build
236
237## create make files
238
239PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
240for i in src/build/common.gypi; do
241        %__sed -i "s|'-march=pentium4',||g" $i
242        %__sed -i "s|'-mfpmath=sse',||g" $i
243        %__sed -i "s|'-O<(debug_optimize)',||g" $i
244        %__sed -i "s|'-m32',||g" $i
245        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
246        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
247done
248# '
249
250pushd src
251
252./build/gyp_chromium -f make build/all.gyp \
253    -Dlinux_sandbox_path=%{chrome_sandbox} \
254    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium \
255    -Duse_openssl=0 \
256    -Duse_system_ffmpeg=1 \
257    -Duse_system_zlib=1 \
258    -Duse_system_libpng=1 \
259    -Duse_system_bzip2=1 \
260    -Duse_system_libbz2=1 \
261    -Duse_system_libjpeg=1 \
262    -Duse_system_libxml=1 \
263    -Duse_system_libxslt=1 \
264    -Duse_system_libevent=1 \
265    %{?with_system_vpx:-Duse_system_vpx=1} \
266    %{!?with_system_vpx:-Duse_system_vpx=0} \
267    -Dremove_webcore_debug_symbols=1 \
268    %{?with_system_v8:-Duse_system_v8=1} \
269    %{!?with_system_v8:-Duse_system_v8=0} \
270    %{?with_system_icu:-Duse_system_icu=1} \
271    %{!?with_system_icu:-Duse_system_icu=0} \
272    %{?_with_shared_library:-Dlibrary=shared_library} \
273    -Dproprietary_codecs=1 \
274    -Ddisable_nacl=1 \
275    -Djavascript_engine=v8 \
276    -Dlinux_fpic=1 \
277    -Ddisable_sse2=1 \
278    %ifarch %{ix86}
279        -Dtarget_arch=ia32 \
280    %endif
281    %ifarch x86_64
282        -Dtarget_arch=x64 \
283    %endif
284    -Dno_strict_aliasing=1 \
285    -Drelease_extra_cflags=-fPIC \
286    %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl7"
287        -Dgcc_version=44 \
288    %endif
289    ;
290
291%__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release disable_nacl=1
292
293# Build the required SUID_SANDBOX helper
294%__make -r %{?_smp_mflags} chrome_sandbox V=1 BUILDTYPE=Release disable_nacl=1
295
296popd
297
298%install
299%{__rm} -rf %{buildroot}
300
301%__mkdir -p %{buildroot}%{_bindir}
302%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
303%ifarch x86_64
304mkdir -p %{buildroot}%{_prefix}/lib/
305%endif
306# x86_64 capable systems need this
307%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
308%__mkdir -p %{buildroot}%{_libdir}/chromium/
309%__mkdir -p %{buildroot}%{_mandir}/man1/
310pushd src/out/Release
311%__cp -a chrome_sandbox %{buildroot}%{_prefix}/lib/
312%__cp -a chrome.pak locales resources xdg-mime xdg-settings %{buildroot}%{_libdir}/chromium/
313%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
314%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
315%{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
316%{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
317%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
318%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
319fdupes %{buildroot}%{_mandir}/man1/
320popd
321
322%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
323%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
324for i in 16 22 24 32 48 64 128 256; do
325    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
326    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
327done
328
329%__mkdir_p %{buildroot}%{_datadir}/applications/
330desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
331
332%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
333%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
334
335# # link to browser plugin path.  Plugin patch doesn't work. Why?
336# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
337# pushd %{buildroot}%{_libdir}/%{pkgname}
338# %{__ln_s} %{_libdir}/browser-plugins plugins
339# popd
340pushd %{buildroot}%{_libdir}/%{pkgname}
341%ifarch x86_64
342%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
343%else
344%{__ln_s} %{_libdir}/mozilla/plugins plugins
345%endif
346
347## support ffmpeg libs
348touch %{buildroot}%{_libdir}/libavcodec.so.52
349%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
350touch %{buildroot}%{_libdir}/libavformat.so.52
351%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
352touch %{buildroot}%{_libdir}/libavutil.so.50
353%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
354popd
355
356# Install the master_preferences file
357%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
358#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
359%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
360#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
361
362%clean
363%{__rm} -rf %{buildroot}
364
365%post
366touch --no-create %{_datadir}/icons/hicolor
367if [ -x %{_bindir}/gtk-update-icon-cache ]; then
368  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
369fi
370%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
371
372%postun
373%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
374touch --no-create %{_datadir}/icons/hicolor
375if [ -x %{_bindir}/gtk-update-icon-cache ]; then
376  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
377fi || :
378
379
380%files
381%defattr(-,root,root,-)
382%config %{_sysconfdir}/%{pkgname}
383%dir %{_datadir}/gnome-control-center
384%dir %{_datadir}/gnome-control-center/default-apps
385%dir %{_libdir}/chromium/
386%{_bindir}/chromium
387%{_libdir}/chromium/chromium
388%{_libdir}/chromium/plugins/
389%{_libdir}/chromium/resources/
390%attr(755,root,root) %{_libdir}/chromium/xdg-settings
391%attr(755,root,root) %{_libdir}/chromium/xdg-mime
392%{_mandir}/man1/chrom*
393%{_datadir}/pixmaps/chromium-browser.png
394%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
395%{_datadir}/applications/*.desktop
396%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
397#%{_datadir}/icons/oxygen/
398%{_libdir}/chromium/chrome.pak
399%{_libdir}/chromium/resources.pak
400%{_libdir}/chromium/locales/
401%{?_with_shared_library:%{_libdir}/chromium/lib*.so}
402%{_libdir}/chromium/libavcodec.so.52
403%{_libdir}/chromium/libavutil.so.50
404%{_libdir}/chromium/libavformat.so.52
405%exclude %{_libdir}/libavcodec.so.52
406%exclude %{_libdir}/libavutil.so.50
407%exclude %{_libdir}/libavformat.so.52
408%attr(4755,root,root) %{chrome_sandbox}
409
410%changelog
411* Sat Oct 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 15.0.874.116-1
412- updated to 15.0.874.116
413
414* Wed Oct 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.204-1
415- updated to 14.0.835.204
416- added BuildRequires: dbus-glib-devel
417
418* Sat Sep 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.186-1
419- updated to 14.0.835.186
420
421* Sun Sep 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.163-1
422- updated to 14.0.835.163
423
424* Tue Sep 06 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.157-1
425- updated to 14.0.835.157
426
427* Sat Aug 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.102-1
428- updated to 14.0.835.102
429
430* Sat Aug 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.89-1
431- updated to 14.0.835.89
432- added Obsoletes: chromium-unstable < %{version}-%{release}
433
434* Wed Aug 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 14.0.835.35-1
435- updated to 14.0.835.35
436- added BuildRequires: pulseaudio-libs-devel, Requires: pulseaudio-libs
437- changed to Name: chromium14
438  - Provides:  chromium-unstable = %%{version}
439  - Conflicts: chromium-stable
440
441* Wed Aug 03 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.107-1
442- changed to Name: chromium
443- updated to 13.0.782.107
444
445* Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
446- updated to 13.0.782.88
447- added BuildRequires: libzip-devel
448- added Provides: chromium-unstable = %%{version}
449- added Conflicts: chromium-stable
450
451* Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
452- fix user-agent string (chromium-vendor-vine.patch.in)
453  - move vendor string (Vine/12.0.742.91-1vl6) to the end.
454
455* Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
456- updated to 12.0.742.93
457- fixed icon field of chromium-browser-vine.desktop
458
459* Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
460- updated to 12.0.742.91
461
462* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
463- updated to 12.0.742.77
464
465* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
466- updated to 12.0.742.63
467
468* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
469- updated to 12.0.742.42
470
471* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
472- updated to 12.0.742.6
473- dropped/upstreamed patches
474- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
475
476* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
477- updated to 11.0.696.50
478- dropped some Patches for MeeGo Netbook
479
480* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
481- updated to 11.0.696.35
482
483* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
484- updated to 11.0.696.29
485- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
486
487* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
488- updated to 11.0.696.22
489- improved chromium-browser-vine.sh
490  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
491
492* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
493- updated to 11.0.696.20
494- improved chromium-browser-vine.desktop
495
496* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
497- updated to 11.0.696.17
498
499* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
500- updated to 11.0.696.15
501  - ready for Vine Linux 6 release
502- dropped BuildRequires: v8-devel, libicu-devel
503
504* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
505- updated to 11.0.696.5 with v8 3.2.0
506- added BuildRequires: pam-devel
507
508* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
509- rebuilt with libevent-2.0.10
510
511* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
512- updated to 10.0.651.0 with v8 3.0.12
513- added BuildRequires:
514  - libpaper-devel
515  - python-devel
516- added built header file: libavutil/avconfig.h %%prep
517- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
518
519* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
520- updated to 10.0.622.0
521- added BuildRequires: libXt-devel
522
523* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
524- updated to 10.0.605.0
525- added BuildRequires:
526  - libXdamage-devel
527  - hunspell-devel
528
529* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
530- updated to 9.0.598
531
532* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
533- updated to 9.0.593
534
535* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
536- updated to 9.0.582
537- added Requires: xdg-utils
538
539* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
540- updated to 9.0.578
541
542* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
543- updated to 9.0.569
544
545  * Mon Oct 25 2010 tittiatcoke@gmail.com
546  - Update to 9.0.564 build
547    * Added specific patches for MeeGo.
548    * We are now using shared libraries for Chromium
549    * Spec-file cleanup (Thanks to prusnak)
550
551* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
552- updated to snapshot 8.0.556
553
554* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
555- updated to snapshot 8.0.551
556
557* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
558- updated to snapshot 7.0.527
559
560* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
561- updated to snapshot 7.0.519
562
563* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
564- updated to snapshot 7.0.513
565  - updated chromium-vendor-vine.patch.in
566
567* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
568- updated to snapshot 7.0.507
569
570* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
571- updated to snapshot 7.0.498
572
573* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
574- updated to snapshot 6.0.493
575- used with_system_icu (for vl6)
576  - added BuildRequires: libicu-devel
577
578* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
579- build for Vine Linux 5.x
580  - add BuildRequires: gnome-keyring-devel
581
582* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
583- updated to snapshot 6.0.454
584- added BuildRequires:
585  - sqlite3-devel
586  - gnutls-devel
587  - libgnome-keyring-devel
588
589* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
590- updated to snapshot 6.0.431.0 r49253
591- added BuildRequires: cups-devel
592
593* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
594- updated to snapshot 6.0.405.0 r47263
595
596* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
597- unused with_system_icu (for vl6)
598  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
599
600* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
601- updated to snapshot 5.0.378.0 r44472
602  - used with_system_icu (for vl6)
603  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
604
605* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
606- updated to snapshot 5.0.372.0 r43947
607- added BuildRequires: glew-devel
608- changed Group tag to Applications/Internet
609- added Summary(ja) and %%description -l ja
610
611* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
612- updated to snapshot 5.0.365.0 r42966
613- merged 5.0.353.0-4vl5
614 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
615 - build on Vine Linux 5.1
616   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
617
618* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
619- updated to snapshot 5.0.364.0 r42779
620
621* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
622- updated to snapshot 5.0.359.0 r42116
623- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
624
625* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
626- fixed master_preferences.vine, little
627
628* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
629- fixed to install master_preferences
630- dropped chromium-5.0.353-no-ffmpeg-vine.patch
631
632* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
633- applied chromium-5.0.353-no-ffmpeg-vine.patch
634
635* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
636- updated to snapshot 5.0.353.0 r41449
637  * Wed Mar 10 2010 bgmerrell@novell.com
638  - Add master_preferences source file and install it to /etc/chromium.
639  - Create a new patch (chromium-master-prefs-path.patch) which tells
640    chromium to look in /etc/chromium for the master_preferences file
641    (instead of looking in the default directory, which is the same
642    directory as the 'chrome' binary).
643
644* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
645- updated to snapshot 5.0.335.0 r39556
646
647* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
648- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
649
650* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
651- updated to snapshot 5.0.330.0 r39074
652
653* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
654- use_system_ffmpeg
655
656* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
657- added Requires:  nspluginwrapper
658- fixed a symbolic link of plugins directory with nspluginwrapper
659
660* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
661- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
662
663* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
664- added BuildRequires: mesa-libGLU-devel
665- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
666
667* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
668- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
669
670  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
671  - Update to 4.0.260
672  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
673  - Update to 4.0.259
674  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
675  - Update to 4.0.258
676  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
677  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
678    changed to having an built-in v8
679  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
680  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
681  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
682  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
683  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
684  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
685  - update to newer svn snapshot
686    + Obsoletes fwrite patch (included upstream)
687  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
688  - update to newer svn snapshot
689    + Requires newer version of v8
690  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
691  - do not force SSE on x86 (drop-sse.patch)
692  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
693  - Update to newer svn snapshot
694  - Fixed spec file in order to build
695  - Included patch to build with system zlib
696  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
697  - package renamed to chromium
698  - cleaned up spec file
699  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
700  - v8 is now built as a separate package, and is required
701  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
702  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
703  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
704  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
705  - initial build
706
707#% changelog
708* Sun Jan 24 2010 prusnak@suse.cz
709- added vendor to user agent (chromium-vendor.patch.in)
710* Sun Nov 29 2009 prusnak@suse.cz
711- added --enable-sync to wrapper to enable bookmark sync
712* Sun Nov 29 2009 tittiatcoke@gmail.com 
713- Update to 4.0.260
714* Fri Nov 27 2009 tittiatcoke@gmail.com 
715- Update to 4.0.259
716* Thu Nov 26 2009 tittiatcoke@gmail.com 
717- Update to 4.0.258
718* Tue Nov 24 2009 tittatcoke@gmai.com 
719- In order to complete prevent the wrong v8 version to be used,
720  the Chromium build has been changed to having an built-in v8
721* Tue Nov 24 2009 dbuck@example.com 
722- Re-base patches.
723- Fixed a few patch errors.
724- Rename some patches to better correspond with function.
725- Removed some patches.
726- Minor SPEC changes.
727- I changed the v8 requirement to be exact, instead of greater than a specific version.
728* Fri Nov 13 2009 tittiatcoke@gmail.com
729- update to 247.0 svn 31928
730* Fri Oct 30 2009 tittiatcoke@gmail.com
731- update to 229.0 svn 30454
732  + Fix regression where popups and app frames lost their titlebars.
733  + Makes it so that when a folder is open on the bookmark bar
734    and the mouse moves over another folder, the menu for that
735    folder is shown.
736  + Lazily create the find bar.
737  + Polish to the gmail checker sample.
738  * New, crisper icons that are exactly 19x19
739  * Add a loading animation at the beginning before Gmail
740    responds.
741  * Fix a bug where we sometimes don't update the UI after a
742    logout/login cycle.
743  + Refactor widget methods to support desktop notifications,
744    including GTK stubs.
745  + Find-in-page should not ding while deleting characters.
746  + Add SSL wrapper for linux and mac.  This allows notifier to
747    use chrome's SSL layer instead of OpenSSL.
748  + Add three of the six extensions to PAC that Internet Explorer supports.
749  + WebSocket support in chromium. (Run with --enable-web-sockets
750    enables WebSocket features.)
751  + Do not allow GTK File Chooser dialogs to return directories.
752  + Fix the notifier SSL layer to make notifications work for
753    Linux Bookmark sync.
754  + linux: don't override mouse selection behavior in omnibox
755* Sun Oct 25 2009 tittiatcoke@gmail.com
756- Update to 224.4 svn 30027
757  + First cut at new page and browser action docs based
758    on new API. Deleted old stuff.
759  + Add suppression for new memory leak caused by WebKit merge 49830:49844
760  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
761  + Minimize dependency of user scripts
762  + Fixup the flip_framer eof-handling semantics now that we have
763    the FIN bit in place
764  + app depends on x11 because of active_window_watcher_x
765  + Adding two images for the new Extension managment UI
766  + Removing hard-coded Chrome Frame output path
767  + Rearrange clipboard code
768  + Fix crash bug when attempting to download a url with unsupported scheme,
769    e.g. 'data:', by 'Alt + Click'
770  + GTK: Change text for extension download UI
771  + Ignore invalid urls on command line
772  + Make dropped tabs animate from where they were dropped.
773  + Make room for the full width of the tab placeholder.
774  + Make tab dragging as smooth as glass.
775  + Remove an annoying NOTIMPLEMNETED
776  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
777  + If we're in the middle of a drag, don't allow the user to middle
778    click to close or right click for the context menu
779  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
780  + Remove +x bit from files that shouldn't have it
781  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
782  + Adding new image needed for the managment UI
783  + Fix a race bug where content scripts would not apply to the first page load
784  + Make escape remove a bookmark if it's just been added (but not if it already existed)
785  + Fix bubbles deactivating the opaque frame
786  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
787  + ake all pepper plugins default to windowless and transparent
788  + Add styles for printing
789  + Implement the new extension management UI
790  + Add support for to automation interface load install and load extensions
791  + GTK: theme the info bar border
792  + Update V8 to version 1.3.16.1
793  + Introduce WebSecurityPolicy for security related methods
794  + New button scheme...borders are separate from the inner contents so
795    that they can be highlighted / depressed independently
796  + When opening Chrome maximized with an application window already
797    running, the Chrome window was not activated
798  + Fix compatibility problems with FileZilla FTP Server
799  + Remove the extension shelf on Linux
800  + Fix the proxy host and port string to start with http:// if it does not already
801  + Enable HTML5 databases for all extension renderer processes
802* Sat Oct 24 2009 prusnak@opensuse.org 
803- don't create desktop files in wrapper
804- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
805* Tue Oct 20 2009 tittiatcoke@gmail.com 
806- update to newer svn snapshot
807  + Obsoletes fwrite patch (included upstream)
808* Fri Oct 16 2009 tittiatcoke@gmail.com 
809- update to newer svn snapshot
810  + Requires newer version of v8
811* Thu Oct 15 2009 prusnak@suse.cz 
812- do not force SSE on x86 (drop-sse.patch)
813* Tue Oct 13 2009 tittiatcoke@gmail.com 
814- Update to newer svn snapshot
815- Fixed spec file in order to build
816- Included patch to build with system zlib
817* Mon Oct 12 2009 prusnak@suse.cz 
818- package renamed to chromium
819- cleaned up spec file
820* Tue Oct  6 2009 dbuck@example.com 
821- v8 is now built as a separate package, and is required
822- included many patches to use system libraries:
823    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
824* Thu Oct  1 2009 dbuck@example.com 
825- included a newer DEP than is in svn, native_client@823
826- things should compile cleanly now
827* Mon Aug 31 2009 dbuck@example.com 
828- initial build
Note: See TracBrowser for help on using the repository browser.