source: projects/specs/trunk/c/chromium/chromium12-vl.spec @ 4058

Revision 4058, 28.8 KB checked in by munepi, 13 years ago (diff)

updated chromium12-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%define pkgname chromium
8
9#% define with_system_icu 1
10#% define with_system_v8 1
11
12#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
13#     libvpx doesn't currently supply a pkg-config file, so we assume that
14#     -lvpx is sufficient.
15%define with_system_vpx 1
16
17#Name:           chromium12
18Name:           chromium
19Summary:        Google's opens source browser project
20Summary(ja):    Googleのオープンソースウェブブラウザ
21#'
22Version:        12.0.742.77
23Release:        1%{?_dist_release}
24License:        BSD
25Group:          Applications/Internet
26#Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
27#Source0:        %{name}-%{version}.svn%{svn_rev}.tar.xz
28Source0:        %{pkgname}-%{version}.tar.xz
29## The following are included for source reasons only
30# Custom build tools for chromium, hammer is a fancy front-end for scons
31Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
32# # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
33# Source2:        repack_chromium_archive.sh
34# # Script used to create the tar.lzma archive from a checked out source
35# Source3:        pack_chromium_source.sh
36# Script used to create the %{pkgname}-%{version}.tar.xz archive from
37# a official tarball:
38# http://build.chromium.org/official/chromium-10.0.644.0.tar.bz2
39Source3:        pack_chromium12_source-vine.sh
40# Official ffmpeg headers
41Source8:        ffmpeg-0.6-headers.tar.xz
42#Source10:       chromium.desktop
43#Source10:       chromium-vine.desktop
44# Patch template which adds vendor to user agent
45##!!Source20:       chromium-vendor.patch.in
46Source20:       chromium-vendor-vine.patch.in
47# Set default prefs
48##!!Source30:       master_preferences
49Source30:       master_preferences.vine
50#Source31:       default_bookmarks.html
51#Source31:       default_bookmarks.html.vine
52Source99:       chrome-wrapper
53##!!Source100:      chromium-browser.sh
54Source100:      chromium-browser-vine.sh
55##!!Source101:      chromium-browser.desktop
56Source101:      chromium-browser-vine.desktop
57Source102:      chromium-browser.xml
58Source103:      chromium-browser-rpmlintrc
59##!!Source104:      chromium-icons.tar.bz2
60
61%{?nosrc:NoSource: 0}
62%{?nosrc:NoSource: 1}
63
64Provides:       chromium-browser = %{version}
65##Provides:     chromium-based-browser = %{version}
66##Obsoletes:      chromium-browser < %{version}
67##Conflicts:      chromium
68
69## Start Patches
70# Many changes to the gyp systems so we can use system libraries
71Patch4:         chromium-no-sqlite-debug.patch
72Patch8:         chromium-codechanges-zlib.patch
73Patch12:        chromium-no-test-sources.patch
74Patch13:        chromium-no-courgette.patch
75Patch14:        chromium-master-prefs-path.patch
76Patch17:        chromium-system-glew.patch
77Patch18:        chromium-system-expat.patch
78Patch19:        chromium-system-zlib.patch
79Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
80Patch21:        chromium-7.0.542.0-media-probe.patch
81Patch25:        tcmalloc-factory.patch
82Patch26:        chromium-remoting-build-fix.diff
83Patch28:        chromium-7.0.500.0-system-speex.patch
84Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
85Patch32:        chromium-7.0.542.0-system-libvpx.patch
86Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
87Patch62:        chromium-norpath.patch
88Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
89
90# Vine
91Patch100:       chromium-12.0.742.6-no-tests.patch
92
93
94BuildRequires:  gcc gcc-c++
95BuildRequires:  libstdc++ libstdc++-devel
96BuildRequires:  libevent
97##!!BuildRequires:  pkg-config
98BuildRequires:  python
99##!!BuildRequires:  python-xml
100BuildRequires:  python-pyxml
101BuildRequires:  perl bison flex gperf
102##!!BuildRequires:  wdiff
103##!!BuildRequires:  update-desktop-files
104#BuildRequires:  lzma
105BuildRequires:  xz
106##!!BuildRequires:  mozilla-nss-devel
107BuildRequires:  nss-devel
108##!!BuildRequires:  alsa-devel
109BuildRequires:  alsa-lib-devel
110BuildRequires:  gtk2-devel
111BuildRequires:  glib2-devel
112BuildRequires:  cairo-devel >= 1.6
113##!!BuildRequires:  mozilla-nspr-devel
114BuildRequires:  nspr-devel
115##!!BuildRequires:  gconf2-devel
116BuildRequires:  GConf2-devel
117BuildRequires:  freetype2-devel
118##!!BuildRequires:  dbus-1-devel
119BuildRequires:  dbus-devel
120BuildRequires:  libxslt-devel
121BuildRequires:  libxml2-devel
122BuildRequires:  libjpeg-devel
123BuildRequires:  zlib-devel
124##!!BuildRequires:  libbz2-devel
125BuildRequires:  bzip2-devel
126BuildRequires:  cups-devel
127BuildRequires:  fdupes
128##!!BuildRequires:  libexpat-devel
129BuildRequires:  expat-devel
130BuildRequires:  libpng-devel
131BuildRequires:  sqlite3-devel
132BuildRequires:  gnutls-devel
133BuildRequires:  desktop-file-utils
134%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
135%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
136BuildRequires:  pam-devel
137BuildRequires:  libgnome-keyring-devel
138BuildRequires:  python-devel
139BuildRequires:  glew-devel
140##!!BuildRequires:  Mesa-devel
141BuildRequires:  mesa-libGLU-devel
142BuildRequires:  hunspell-devel
143
144%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
145BuildRequires:  libevent-devel
146#BuildRequires:  libjingle-devel >= 0.4.0-7
147#BuildRequires:  srtp-devel
148BuildRequires:  speex-devel
149
150##Vine Linux
151%{?with_system_v8:Requires:       v8 = %{v8_ver}}
152BuildRequires:  libpaper-devel
153BuildRequires:  libXScrnSaver-devel
154BuildRequires:  libXtst-devel
155BuildRequires:  libXdamage-devel
156BuildRequires:  libXt-devel
157#BuildRequires:  gle-devel
158#BuildRequires:  webkit-gtk-devel
159#BuildRequires:  scons
160%ifarch x86_64
161Requires:  nspluginwrapper
162%endif
163
164##!!Requires:       alsa
165Requires:       alsa-lib
166Requires:       xdg-utils
167# shouldn't be required to name all dependencies
168# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
169
170BuildRoot:      %{_tmppath}/%{name}-%{version}-root
171
172%description
173Chromium is the open-source project behind Google Chrome.
174We invite you to join us in our effort to help build a safer, faster,
175and more stable way for all Internet users to experience the web,
176and to create a powerful platform for developing a new generation of
177web applications.
178
179%description -l ja
180Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
181ウェブを体験しているすべてのインターネットユーザに対して
182より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
183そして、ウェブアプリケーションの新しい世代を発展させ、
184強力なプラットホームを作成するために、
185私たちの取り組みにぜひ参加してください。
186
187
188%package devel
189Summary:        Header file for chromium browser
190Group:          Development/Libraries
191Requires:       chromium = %{version}-%{release}
192
193%description devel
194This package contains the header files and pc file of chromium browser for
195applications which will use chromium browser APIs.
196
197
198%prep
199#%setup -q
200[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
201xz -dc %{SOURCE0} | %__tar -xf - || exit 1
202%setup -D -T -n %{pkgname}-%{version}
203
204%patch62 -p1
205%{?with_system_v8:%patch63 -p1}
206%patch100 -p1 -b .vine
207%patch4 -p1
208%patch8 -p1
209%patch12 -p1
210%patch13 -p1
211%patch14 -p1
212%patch17 -p1
213%patch18 -p1
214%patch19 -p1
215%patch20 -p1
216%patch21 -p1
217%patch25 -p1
218%patch26 -p1
219%patch28 -p1
220%patch29 -p1
221%{?with_system_vpx:%patch32 -p1}
222%{?with_system_v8:%patch34 -p1}
223
224pushd src/third_party/ffmpeg/
225%__tar Jxf %{SOURCE8} || exit 1
226## built header file: avconfig.h
227[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
228cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
229/* Generated by ffconf */
230#ifndef AVUTIL_AVCONFIG_H
231#define AVUTIL_AVCONFIG_H
232#define AV_HAVE_BIGENDIAN 0
233#endif /* AVUTIL_AVCONFIG_H */
234EOF
235popd
236
237#%__rm -rf src/third_party/libvpx/
238%__rm -rf src/third_party/speex/
239%__rm -rf src/third_party/nss src/third_party/nspr
240
241# apply vendor patch after substitution
242%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
243
244%build
245
246## create make files
247
248PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
249for i in src/build/common.gypi; do
250        %__sed -i "s|'-march=pentium4',||g" $i
251        %__sed -i "s|'-mfpmath=sse',||g" $i
252        %__sed -i "s|'-O<(debug_optimize)',||g" $i
253        %__sed -i "s|'-m32',||g" $i
254        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
255        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
256done
257# '
258
259pushd src
260
261./build/gyp_chromium -f make build/all.gyp \
262    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
263    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
264    -Duse_openssl=0 \
265    -Duse_system_ffmpeg=1 \
266    -Duse_system_zlib=1 \
267    -Duse_system_libpng=1 \
268    -Duse_system_bzip2=1 \
269    -Duse_system_libbz2=1 \
270    -Duse_system_libjpeg=1 \
271    -Duse_system_libxml=1 \
272    -Duse_system_libxslt=1 \
273    -Duse_system_libevent=1 \
274    %{?with_system_vpx:-Duse_system_vpx=1} \
275    %{!?with_system_vpx:-Duse_system_vpx=0} \
276    -Dproprietary_codecs=1 \
277    -Dlibrary=shared_library \
278    -Djavascript_engine=v8 \
279    -Dlinux_fpic=1 \
280    %{?with_system_v8:-Duse_system_v8=1} \
281    %{!?with_system_v8:-Duse_system_v8=0} \
282    %{?with_system_icu:-Duse_system_icu=1} \
283    %{!?with_system_icu:-Duse_system_icu=0} \
284    %ifarch %{ix86}
285        -Dtarget_arch=ia32 \
286         -Ddisable_sse2=1 \
287    %endif
288    %ifarch x86_64
289        -Dtarget_arch=x64 \
290    %endif
291    %if %{?_dist_release} == "vl6"
292        -Dno_strict_aliasing=1 -Dgcc_version=44 \
293    %endif
294    -Drelease_extra_cflags=-fPIC \
295    ;
296
297#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
298#%__make -r -j5 chrome BUILDTYPE=Release
299%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
300
301popd
302
303%install
304%{__rm} -rf %{buildroot}
305
306%__mkdir -p %{buildroot}%{_bindir}
307%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
308# x86_64 capable systems need this
309%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
310%__mkdir -p %{buildroot}%{_libdir}/chromium/
311%__mkdir -p %{buildroot}%{_mandir}/man1/
312pushd src/out/Release
313%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
314%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
315%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
316%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
317%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
318%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
319%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
320fdupes %{buildroot}%{_mandir}/man1/
321popd
322
323# %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
324# %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
325for i in 16 22 24 32 48 64 128 256; do
326    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
327    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
328done
329
330%__mkdir_p %{buildroot}%{_datadir}/applications/
331desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
332
333%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
334%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
335
336# # link to browser plugin path.  Plugin patch doesn't work. Why?
337# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
338# pushd %{buildroot}%{_libdir}/%{pkgname}
339# %{__ln_s} %{_libdir}/browser-plugins plugins
340# popd
341pushd %{buildroot}%{_libdir}/%{pkgname}
342%ifarch x86_64
343%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
344%else
345%{__ln_s} %{_libdir}/mozilla/plugins plugins
346%endif
347
348## support ffmpeg libs
349touch %{buildroot}%{_libdir}/libavcodec.so.52
350%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
351touch %{buildroot}%{_libdir}/libavformat.so.52
352%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
353touch %{buildroot}%{_libdir}/libavutil.so.50
354%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
355popd
356
357# Install the master_preferences file
358%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
359#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
360%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
361#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
362
363%clean
364%{__rm} -rf %{buildroot}
365
366%post
367touch --no-create %{_datadir}/icons/hicolor
368if [ -x %{_bindir}/gtk-update-icon-cache ]; then
369  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
370fi
371%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
372
373%postun
374%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
375touch --no-create %{_datadir}/icons/hicolor
376if [ -x %{_bindir}/gtk-update-icon-cache ]; then
377  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
378fi || :
379
380
381%files
382%defattr(-,root,root,-)
383%config %{_sysconfdir}/%{pkgname}
384%dir %{_datadir}/gnome-control-center
385%dir %{_datadir}/gnome-control-center/default-apps
386%{_bindir}/chromium
387%{_libdir}/chromium/chromium
388%{_libdir}/chromium/plugins/
389%{_libdir}/chromium/resources/
390%{_libdir}/chromium/xdg-settings
391%{_mandir}/man1/chrom*
392#%{_datadir}/pixmaps/chromium-browser.png
393%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
394%{_datadir}/applications/*.desktop
395%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
396%{_libdir}/chromium/libavcodec.so.52
397%{_libdir}/chromium/libavutil.so.50
398%{_libdir}/chromium/libavformat.so.52
399%exclude %{_libdir}/libavcodec.so.52
400%exclude %{_libdir}/libavutil.so.50
401%exclude %{_libdir}/libavformat.so.52
402## libs
403%dir %{_libdir}/chromium/
404%{_libdir}/chromium/chrome.pak
405%{_libdir}/chromium/resources.pak
406%{_libdir}/chromium/locales/
407%{_libdir}/chromium/lib*.so
408
409%changelog
410* Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
411- updated to 12.0.742.77
412
413* Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
414- updated to 12.0.742.63
415
416* Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
417- updated to 12.0.742.42
418
419* Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
420- updated to 12.0.742.6
421- dropped/upstreamed patches
422- updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
423
424* Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
425- updated to 11.0.696.50
426- dropped some Patches for MeeGo Netbook
427
428* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
429- updated to 11.0.696.35
430
431* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
432- updated to 11.0.696.29
433- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
434
435* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
436- updated to 11.0.696.22
437- improved chromium-browser-vine.sh
438  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
439
440* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
441- updated to 11.0.696.20
442- improved chromium-browser-vine.desktop
443
444* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
445- updated to 11.0.696.17
446
447* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
448- updated to 11.0.696.15
449  - ready for Vine Linux 6 release
450- dropped BuildRequires: v8-devel, libicu-devel
451
452* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
453- updated to 11.0.696.5 with v8 3.2.0
454- added BuildRequires: pam-devel
455
456* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
457- rebuilt with libevent-2.0.10
458
459* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
460- updated to 10.0.651.0 with v8 3.0.12
461- added BuildRequires:
462  - libpaper-devel
463  - python-devel
464- added built header file: libavutil/avconfig.h %%prep
465- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
466
467* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
468- updated to 10.0.622.0
469- added BuildRequires: libXt-devel
470
471* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
472- updated to 10.0.605.0
473- added BuildRequires:
474  - libXdamage-devel
475  - hunspell-devel
476
477* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
478- updated to 9.0.598
479
480* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
481- updated to 9.0.593
482
483* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
484- updated to 9.0.582
485- added Requires: xdg-utils
486
487* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
488- updated to 9.0.578
489
490* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
491- updated to 9.0.569
492
493  * Mon Oct 25 2010 tittiatcoke@gmail.com
494  - Update to 9.0.564 build
495    * Added specific patches for MeeGo.
496    * We are now using shared libraries for Chromium
497    * Spec-file cleanup (Thanks to prusnak)
498
499* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
500- updated to snapshot 8.0.556
501
502* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
503- updated to snapshot 8.0.551
504
505* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
506- updated to snapshot 7.0.527
507
508* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
509- updated to snapshot 7.0.519
510
511* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
512- updated to snapshot 7.0.513
513  - updated chromium-vendor-vine.patch.in
514
515* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
516- updated to snapshot 7.0.507
517
518* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
519- updated to snapshot 7.0.498
520
521* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
522- updated to snapshot 6.0.493
523- used with_system_icu (for vl6)
524  - added BuildRequires: libicu-devel
525
526* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
527- build for Vine Linux 5.x
528  - add BuildRequires: gnome-keyring-devel
529
530* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
531- updated to snapshot 6.0.454
532- added BuildRequires:
533  - sqlite3-devel
534  - gnutls-devel
535  - libgnome-keyring-devel
536
537* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
538- updated to snapshot 6.0.431.0 r49253
539- added BuildRequires: cups-devel
540
541* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
542- updated to snapshot 6.0.405.0 r47263
543
544* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
545- unused with_system_icu (for vl6)
546  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
547
548* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
549- updated to snapshot 5.0.378.0 r44472
550  - used with_system_icu (for vl6)
551  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
552
553* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
554- updated to snapshot 5.0.372.0 r43947
555- added BuildRequires: glew-devel
556- changed Group tag to Applications/Internet
557- added Summary(ja) and %%description -l ja
558
559* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
560- updated to snapshot 5.0.365.0 r42966
561- merged 5.0.353.0-4vl5
562 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
563 - build on Vine Linux 5.1
564   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
565
566* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
567- updated to snapshot 5.0.364.0 r42779
568
569* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
570- updated to snapshot 5.0.359.0 r42116
571- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
572
573* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
574- fixed master_preferences.vine, little
575
576* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
577- fixed to install master_preferences
578- dropped chromium-5.0.353-no-ffmpeg-vine.patch
579
580* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
581- applied chromium-5.0.353-no-ffmpeg-vine.patch
582
583* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
584- updated to snapshot 5.0.353.0 r41449
585  * Wed Mar 10 2010 bgmerrell@novell.com
586  - Add master_preferences source file and install it to /etc/chromium.
587  - Create a new patch (chromium-master-prefs-path.patch) which tells
588    chromium to look in /etc/chromium for the master_preferences file
589    (instead of looking in the default directory, which is the same
590    directory as the 'chrome' binary).
591
592* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
593- updated to snapshot 5.0.335.0 r39556
594
595* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
596- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
597
598* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
599- updated to snapshot 5.0.330.0 r39074
600
601* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
602- use_system_ffmpeg
603
604* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
605- added Requires:  nspluginwrapper
606- fixed a symbolic link of plugins directory with nspluginwrapper
607
608* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
609- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
610
611* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
612- added BuildRequires: mesa-libGLU-devel
613- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
614
615* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
616- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
617
618  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
619  - Update to 4.0.260
620  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
621  - Update to 4.0.259
622  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
623  - Update to 4.0.258
624  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
625  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
626    changed to having an built-in v8
627  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
628  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
629  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
630  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
631  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
632  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
633  - update to newer svn snapshot
634    + Obsoletes fwrite patch (included upstream)
635  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
636  - update to newer svn snapshot
637    + Requires newer version of v8
638  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
639  - do not force SSE on x86 (drop-sse.patch)
640  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
641  - Update to newer svn snapshot
642  - Fixed spec file in order to build
643  - Included patch to build with system zlib
644  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
645  - package renamed to chromium
646  - cleaned up spec file
647  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
648  - v8 is now built as a separate package, and is required
649  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
650  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
651  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
652  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
653  - initial build
654
655#% changelog
656* Sun Jan 24 2010 prusnak@suse.cz
657- added vendor to user agent (chromium-vendor.patch.in)
658* Sun Nov 29 2009 prusnak@suse.cz
659- added --enable-sync to wrapper to enable bookmark sync
660* Sun Nov 29 2009 tittiatcoke@gmail.com 
661- Update to 4.0.260
662* Fri Nov 27 2009 tittiatcoke@gmail.com 
663- Update to 4.0.259
664* Thu Nov 26 2009 tittiatcoke@gmail.com 
665- Update to 4.0.258
666* Tue Nov 24 2009 tittatcoke@gmai.com 
667- In order to complete prevent the wrong v8 version to be used,
668  the Chromium build has been changed to having an built-in v8
669* Tue Nov 24 2009 dbuck@example.com 
670- Re-base patches.
671- Fixed a few patch errors.
672- Rename some patches to better correspond with function.
673- Removed some patches.
674- Minor SPEC changes.
675- I changed the v8 requirement to be exact, instead of greater than a specific version.
676* Fri Nov 13 2009 tittiatcoke@gmail.com
677- update to 247.0 svn 31928
678* Fri Oct 30 2009 tittiatcoke@gmail.com
679- update to 229.0 svn 30454
680  + Fix regression where popups and app frames lost their titlebars.
681  + Makes it so that when a folder is open on the bookmark bar
682    and the mouse moves over another folder, the menu for that
683    folder is shown.
684  + Lazily create the find bar.
685  + Polish to the gmail checker sample.
686  * New, crisper icons that are exactly 19x19
687  * Add a loading animation at the beginning before Gmail
688    responds.
689  * Fix a bug where we sometimes don't update the UI after a
690    logout/login cycle.
691  + Refactor widget methods to support desktop notifications,
692    including GTK stubs.
693  + Find-in-page should not ding while deleting characters.
694  + Add SSL wrapper for linux and mac.  This allows notifier to
695    use chrome's SSL layer instead of OpenSSL.
696  + Add three of the six extensions to PAC that Internet Explorer supports.
697  + WebSocket support in chromium. (Run with --enable-web-sockets
698    enables WebSocket features.)
699  + Do not allow GTK File Chooser dialogs to return directories.
700  + Fix the notifier SSL layer to make notifications work for
701    Linux Bookmark sync.
702  + linux: don't override mouse selection behavior in omnibox
703* Sun Oct 25 2009 tittiatcoke@gmail.com
704- Update to 224.4 svn 30027
705  + First cut at new page and browser action docs based
706    on new API. Deleted old stuff.
707  + Add suppression for new memory leak caused by WebKit merge 49830:49844
708  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
709  + Minimize dependency of user scripts
710  + Fixup the flip_framer eof-handling semantics now that we have
711    the FIN bit in place
712  + app depends on x11 because of active_window_watcher_x
713  + Adding two images for the new Extension managment UI
714  + Removing hard-coded Chrome Frame output path
715  + Rearrange clipboard code
716  + Fix crash bug when attempting to download a url with unsupported scheme,
717    e.g. 'data:', by 'Alt + Click'
718  + GTK: Change text for extension download UI
719  + Ignore invalid urls on command line
720  + Make dropped tabs animate from where they were dropped.
721  + Make room for the full width of the tab placeholder.
722  + Make tab dragging as smooth as glass.
723  + Remove an annoying NOTIMPLEMNETED
724  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
725  + If we're in the middle of a drag, don't allow the user to middle
726    click to close or right click for the context menu
727  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
728  + Remove +x bit from files that shouldn't have it
729  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
730  + Adding new image needed for the managment UI
731  + Fix a race bug where content scripts would not apply to the first page load
732  + Make escape remove a bookmark if it's just been added (but not if it already existed)
733  + Fix bubbles deactivating the opaque frame
734  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
735  + ake all pepper plugins default to windowless and transparent
736  + Add styles for printing
737  + Implement the new extension management UI
738  + Add support for to automation interface load install and load extensions
739  + GTK: theme the info bar border
740  + Update V8 to version 1.3.16.1
741  + Introduce WebSecurityPolicy for security related methods
742  + New button scheme...borders are separate from the inner contents so
743    that they can be highlighted / depressed independently
744  + When opening Chrome maximized with an application window already
745    running, the Chrome window was not activated
746  + Fix compatibility problems with FileZilla FTP Server
747  + Remove the extension shelf on Linux
748  + Fix the proxy host and port string to start with http:// if it does not already
749  + Enable HTML5 databases for all extension renderer processes
750* Sat Oct 24 2009 prusnak@opensuse.org 
751- don't create desktop files in wrapper
752- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
753* Tue Oct 20 2009 tittiatcoke@gmail.com 
754- update to newer svn snapshot
755  + Obsoletes fwrite patch (included upstream)
756* Fri Oct 16 2009 tittiatcoke@gmail.com 
757- update to newer svn snapshot
758  + Requires newer version of v8
759* Thu Oct 15 2009 prusnak@suse.cz 
760- do not force SSE on x86 (drop-sse.patch)
761* Tue Oct 13 2009 tittiatcoke@gmail.com 
762- Update to newer svn snapshot
763- Fixed spec file in order to build
764- Included patch to build with system zlib
765* Mon Oct 12 2009 prusnak@suse.cz 
766- package renamed to chromium
767- cleaned up spec file
768* Tue Oct  6 2009 dbuck@example.com 
769- v8 is now built as a separate package, and is required
770- included many patches to use system libraries:
771    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
772* Thu Oct  1 2009 dbuck@example.com 
773- included a newer DEP than is in svn, native_client@823
774- things should compile cleanly now
775* Mon Aug 31 2009 dbuck@example.com 
776- initial build
Note: See TracBrowser for help on using the repository browser.