source: projects/specs/trunk/c/chromium/chromium11-vl.spec @ 3328

Revision 3328, 31.6 KB checked in by munepi, 13 years ago (diff)

updated chromium11-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6%define with_devel_pkg 0
7
8%define pkgname chromium
9
10#% define with_system_icu 1
11#% define with_system_v8 1
12
13#NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
14#     libvpx doesn't currently supply a pkg-config file, so we assume that
15#     -lvpx is sufficient.
16%define with_system_vpx 1
17
18#% define v8_ver 3.2.0
19
20#Name:           chromium11
21Name:           chromium
22Summary:        Google's opens source browser project
23Summary(ja):    Googleのオープンソースウェブブラウザ
24#'
25Version:        11.0.696.35
26Release:        1%{?_dist_release}
27License:        BSD
28Group:          Applications/Internet
29#Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
30#Source0:        %{name}-%{version}.svn%{svn_rev}.tar.xz
31Source0:        %{pkgname}-%{version}.tar.xz
32## The following are included for source reasons only
33# Custom build tools for chromium, hammer is a fancy front-end for scons
34Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
35# # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
36# Source2:        repack_chromium_archive.sh
37# # Script used to create the tar.lzma archive from a checked out source
38# Source3:        pack_chromium_source.sh
39# Script used to create the %{pkgname}-%{version}.tar.xz archive from
40# a official tarball:
41# http://build.chromium.org/official/chromium-10.0.644.0.tar.bz2
42Source3:        pack_chromium11_source-vine.sh
43# Official ffmpeg headers
44Source8:        ffmpeg-0.6-headers.tar.xz
45#Source10:       chromium.desktop
46#Source10:       chromium-vine.desktop
47# Patch template which adds vendor to user agent
48##!!Source20:       chromium-vendor.patch.in
49Source20:       chromium-vendor-vine.patch.in
50# Set default prefs
51##!!Source30:       master_preferences
52Source30:       master_preferences.vine
53#Source31:       default_bookmarks.html
54#Source31:       default_bookmarks.html.vine
55Source99:       chrome-wrapper
56##!!Source100:      chromium-browser.sh
57Source100:      chromium-browser-vine.sh
58##!!Source101:      chromium-browser.desktop
59Source101:      chromium-browser-vine.desktop
60Source102:      chromium-browser.xml
61Source103:      chromium-browser-rpmlintrc
62
63%{?nosrc:NoSource: 0}
64%{?nosrc:NoSource: 1}
65
66Provides:       chromium-browser = %{version}
67##Provides:     chromium-based-browser = %{version}
68##Obsoletes:      chromium-browser < %{version}
69##Conflicts:      chromium
70
71## Start Patches
72# Many changes to the gyp systems so we can use system libraries
73# My first ever patch set.  I hope I did well.
74Patch4:         chromium-no-sqlite-debug.patch
75Patch5:         chromium-gyp-system-04-nss-nspr.patch
76Patch7:         chromium-codechanges-nss-nspr.patch
77Patch8:         chromium-codechanges-zlib.patch
78Patch12:        chromium-no-test-sources.patch
79Patch13:        chromium-no-courgette.patch
80Patch14:        chromium-master-prefs-path.patch
81Patch17:        chromium-system-glew.patch
82Patch18:        chromium-system-expat.patch
83Patch19:        chromium-system-zlib.patch
84Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
85Patch21:        chromium-7.0.542.0-media-probe.patch
86Patch25:        tcmalloc-factory.patch
87Patch26:        chromium-remoting-build-fix.diff
88Patch28:        chromium-7.0.500.0-system-speex.patch
89Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
90Patch32:        chromium-7.0.542.0-system-libvpx.patch
91Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
92Patch62:        chromium-norpath.patch
93Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
94# Patches for MeeGo Netbook
95Patch80:        chromium-browser-window-focus.patch
96Patch83:        chromium-fix-toolbar-icon-size.patch
97
98# Vine
99Patch100:       chromium-11.0.696.15-no-tests.patch
100
101
102BuildRequires:  gcc gcc-c++
103BuildRequires:  libstdc++ libstdc++-devel
104BuildRequires:  libevent
105##!!BuildRequires:  pkg-config
106BuildRequires:  python
107##!!BuildRequires:  python-xml
108BuildRequires:  python-pyxml
109BuildRequires:  perl bison flex gperf
110##!!BuildRequires:  wdiff
111##!!BuildRequires:  update-desktop-files
112#BuildRequires:  lzma
113BuildRequires:  xz
114##!!BuildRequires:  mozilla-nss-devel
115BuildRequires:  nss-devel
116##!!BuildRequires:  alsa-devel
117BuildRequires:  alsa-lib-devel
118BuildRequires:  gtk2-devel
119BuildRequires:  glib2-devel
120BuildRequires:  cairo-devel >= 1.6
121##!!BuildRequires:  mozilla-nspr-devel
122BuildRequires:  nspr-devel
123##!!BuildRequires:  gconf2-devel
124BuildRequires:  GConf2-devel
125BuildRequires:  freetype2-devel
126##!!BuildRequires:  dbus-1-devel
127BuildRequires:  dbus-devel
128BuildRequires:  libxslt-devel
129BuildRequires:  libxml2-devel
130BuildRequires:  libjpeg-devel
131BuildRequires:  zlib-devel
132##!!BuildRequires:  libbz2-devel
133BuildRequires:  bzip2-devel
134BuildRequires:  cups-devel
135BuildRequires:  fdupes
136##!!BuildRequires:  libexpat-devel
137BuildRequires:  expat-devel
138BuildRequires:  libpng-devel
139BuildRequires:  sqlite3-devel
140BuildRequires:  gnutls-devel
141BuildRequires:  desktop-file-utils
142%{?with_system_v8:BuildRequires:  v8-devel = %{v8_ver}}
143%{?with_system_vpx:BuildRequires:  libvpx-devel >= 0.9.5}
144BuildRequires:  pam-devel
145BuildRequires:  libgnome-keyring-devel
146BuildRequires:  python-devel
147BuildRequires:  glew-devel
148##!!BuildRequires:  Mesa-devel
149BuildRequires:  mesa-libGLU-devel
150BuildRequires:  hunspell-devel
151
152%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
153BuildRequires:  libevent-devel
154#BuildRequires:  libjingle-devel >= 0.4.0-7
155#BuildRequires:  srtp-devel
156BuildRequires:  speex-devel
157
158##Vine Linux
159%{?with_system_v8:Requires:       v8 = %{v8_ver}}
160BuildRequires:  libpaper-devel
161BuildRequires:  libXScrnSaver-devel
162BuildRequires:  libXtst-devel
163BuildRequires:  libXdamage-devel
164BuildRequires:  libXt-devel
165#BuildRequires:  gle-devel
166#BuildRequires:  webkit-gtk-devel
167#BuildRequires:  scons
168%ifarch x86_64
169Requires:  nspluginwrapper
170%endif
171
172##!!Requires:       alsa
173Requires:       alsa-lib
174Requires:       xdg-utils
175# shouldn't be required to name all dependencies
176# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
177
178BuildRoot:      %{_tmppath}/%{name}-%{version}-root
179
180%description
181Chromium is the open-source project behind Google Chrome.
182We invite you to join us in our effort to help build a safer, faster,
183and more stable way for all Internet users to experience the web,
184and to create a powerful platform for developing a new generation of
185web applications.
186
187%description -l ja
188Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
189ウェブを体験しているすべてのインターネットユーザに対して
190より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
191そして、ウェブアプリケーションの新しい世代を発展させ、
192強力なプラットホームを作成するために、
193私たちの取り組みにぜひ参加してください。
194
195
196%package devel
197Summary:        Header file for chromium browser
198Group:          Development/Libraries
199Requires:       chromium = %{version}-%{release}
200
201%description devel
202This package contains the header files and pc file of chromium browser for
203applications which will use chromium browser APIs.
204
205
206%prep
207#%setup -q
208[ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
209xz -dc %{SOURCE0} | %__tar -xf - || exit 1
210%setup -D -T -n %{pkgname}-%{version}
211
212%patch62 -p1
213%{?with_system_v8:%patch63 -p1}
214%patch100 -p1 -b .vine
215%patch80 -p1
216%patch83 -p1
217%patch4 -p1
218%patch5 -p1
219%patch7 -p1
220%patch8 -p1
221%patch12 -p1
222%patch13 -p1
223%patch14 -p1
224%patch17 -p1
225%patch18 -p1
226%patch19 -p1
227%patch20 -p1
228%patch21 -p1
229%patch25 -p1
230%patch26 -p1
231%patch28 -p1
232%patch29 -p1
233%{?with_system_vpx:%patch32 -p1}
234%{?with_system_v8:%patch34 -p1}
235
236pushd src/third_party/ffmpeg/
237%__tar Jxf %{SOURCE8} || exit 1
238## built header file: avconfig.h
239[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
240cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
241/* Generated by ffconf */
242#ifndef AVUTIL_AVCONFIG_H
243#define AVUTIL_AVCONFIG_H
244#define AV_HAVE_BIGENDIAN 0
245#endif /* AVUTIL_AVCONFIG_H */
246EOF
247popd
248
249#%__rm -rf src/third_party/libvpx/
250%__rm -rf src/third_party/speex/
251%__rm -rf src/third_party/nss src/third_party/nspr
252
253# apply vendor patch after substitution
254%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
255
256%build
257
258## create make files
259
260PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
261for i in src/build/common.gypi; do
262        %__sed -i "s|'-march=pentium4',||g" $i
263        %__sed -i "s|'-msse2',||g" $i
264        %__sed -i "s|'-mfpmath=sse',||g" $i
265        %__sed -i "s|'-O<(debug_optimize)',||g" $i
266        %__sed -i "s|'-m32',||g" $i
267        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
268        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
269done
270# '
271
272pushd src
273
274./build/gyp_chromium -f make build/all.gyp \
275    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
276    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
277    -Duse_openssl=0 \
278    -Duse_system_ffmpeg=1 \
279    -Duse_system_zlib=1 \
280    -Duse_system_libpng=1 \
281    -Duse_system_bzip2=1 \
282    -Duse_system_libbz2=1 \
283    -Duse_system_libjpeg=1 \
284    -Duse_system_libxml=1 \
285    -Duse_system_libxslt=1 \
286    -Duse_system_libevent=1 \
287    %{?with_system_vpx:-Duse_system_vpx=1} \
288    %{!?with_system_vpx:-Duse_system_vpx=0} \
289    -Dproprietary_codecs=1 \
290    -Dlibrary=shared_library \
291    -Djavascript_engine=v8 \
292    -Dlinux_fpic=1 \
293    %{?with_system_v8:-Duse_system_v8=1} \
294    %{!?with_system_v8:-Duse_system_v8=0} \
295    %{?with_system_icu:-Duse_system_icu=1} \
296    %{!?with_system_icu:-Duse_system_icu=0} \
297    %ifarch %{ix86}
298        -Dtarget_arch=ia32 \
299         -Ddisable_sse2=1 \
300    %endif
301    %ifarch x86_64
302        -Dtarget_arch=x64 \
303    %endif
304    %if %{?_dist_release} == "vl6"
305        -Dno_strict_aliasing=1 -Dgcc_version=44 \
306    %endif
307    -Drelease_extra_cflags=-fPIC \
308    ;
309
310#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
311#%__make -r -j5 chrome BUILDTYPE=Release
312%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
313
314popd
315
316%install
317%{__rm} -rf %{buildroot}
318
319%__mkdir -p %{buildroot}%{_bindir}
320%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
321# x86_64 capable systems need this
322%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
323%__mkdir -p %{buildroot}%{_libdir}/chromium/
324%__mkdir -p %{buildroot}%{_mandir}/man1/
325pushd src/out/Release
326%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
327%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
328%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
329%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
330%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
331#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
332%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
333%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
334fdupes %{buildroot}%{_mandir}/man1/
335popd
336
337# devel package install
338%if %{with_devel_pkg}
339mkdir -p %{buildroot}%{_libdir}/chromium/include
340pushd src
341find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
342find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
343find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
344find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
345find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
346find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
347find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
348find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
349find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
350find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
351find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
352find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
353#find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
354popd
355find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
356fdupes %{buildroot}%{_libdir}/chromium/include
357
358%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
359cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
360Name: Chromium browser
361Description: Chromium browser development package
362Version: 1.0.1
363Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
364Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
365EOF
366%endif
367
368
369# %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
370# %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
371for i in 16 22 24 32 48 64 128 256; do
372    %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
373    %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
374done
375
376%__mkdir_p %{buildroot}%{_datadir}/applications/
377desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
378
379%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
380%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
381
382# # link to browser plugin path.  Plugin patch doesn't work. Why?
383# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
384# pushd %{buildroot}%{_libdir}/%{pkgname}
385# %{__ln_s} %{_libdir}/browser-plugins plugins
386# popd
387pushd %{buildroot}%{_libdir}/%{pkgname}
388%ifarch x86_64
389%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
390%else
391%{__ln_s} %{_libdir}/mozilla/plugins plugins
392%endif
393
394## support ffmpeg libs
395touch %{buildroot}%{_libdir}/libavcodec.so.52
396%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
397touch %{buildroot}%{_libdir}/libavformat.so.52
398%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
399touch %{buildroot}%{_libdir}/libavutil.so.50
400%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
401popd
402
403# Install the master_preferences file
404%__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
405#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
406%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
407#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
408
409%clean
410%{__rm} -rf %{buildroot}
411
412%post
413touch --no-create %{_datadir}/icons/hicolor
414if [ -x %{_bindir}/gtk-update-icon-cache ]; then
415  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
416fi
417%{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
418
419%postun
420%{_bindir}/update-desktop-database --quiet %{_datadir}/applications
421touch --no-create %{_datadir}/icons/hicolor
422if [ -x %{_bindir}/gtk-update-icon-cache ]; then
423  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
424fi || :
425
426
427%files
428%defattr(-,root,root,-)
429%config %{_sysconfdir}/%{pkgname}
430%dir %{_datadir}/gnome-control-center
431%dir %{_datadir}/gnome-control-center/default-apps
432%{_bindir}/chromium
433%{_libdir}/chromium/chromium
434# These unique permissions are intentional and necessary for the sandboxing
435#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
436%{_libdir}/chromium/plugins/
437%{_libdir}/chromium/resources/
438%{_libdir}/chromium/xdg-settings
439%{_mandir}/man1/chrom*
440#%{_datadir}/pixmaps/chromium-browser.png
441%{_datadir}/icons/hicolor/*/apps/chromium-browser.png
442%{_datadir}/applications/*.desktop
443%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
444%{_libdir}/chromium/libavcodec.so.52
445%{_libdir}/chromium/libavutil.so.50
446%{_libdir}/chromium/libavformat.so.52
447%exclude %{_libdir}/libavcodec.so.52
448%exclude %{_libdir}/libavutil.so.50
449%exclude %{_libdir}/libavformat.so.52
450## libs
451%dir %{_libdir}/chromium/
452%{_libdir}/chromium/chrome.pak
453%{_libdir}/chromium/resources.pak
454%{_libdir}/chromium/locales/
455%{_libdir}/chromium/lib*.so
456
457%if %{with_devel_pkg}
458%files devel
459%defattr(-,root,root,-)
460%{_libdir}/chromium/include/
461%{_libdir}/pkgconfig/chromium-browser.pc
462%endif
463
464%changelog
465* Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
466- updated to 11.0.696.35
467
468* Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
469- updated to 11.0.696.29
470- dropped "--no-first-run" in command line options of chromium-browser-vine.sh
471
472* Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
473- updated to 11.0.696.22
474- improved chromium-browser-vine.sh
475  - merged from chromium-browser-vine.desktop of 11.0.696.17-1
476
477* Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
478- updated to 11.0.696.20
479- improved chromium-browser-vine.desktop
480
481* Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
482- updated to 11.0.696.17
483
484* Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
485- updated to 11.0.696.15
486  - ready for Vine Linux 6 release
487- dropped BuildRequires: v8-devel, libicu-devel
488
489* Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
490- updated to 11.0.696.5 with v8 3.2.0
491- added BuildRequires: pam-devel
492
493* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
494- rebuilt with libevent-2.0.10
495
496* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
497- updated to 10.0.651.0 with v8 3.0.12
498- added BuildRequires:
499  - libpaper-devel
500  - python-devel
501- added built header file: libavutil/avconfig.h %%prep
502- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
503
504* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
505- updated to 10.0.622.0
506- added BuildRequires: libXt-devel
507
508* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
509- updated to 10.0.605.0
510- added BuildRequires:
511  - libXdamage-devel
512  - hunspell-devel
513
514* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
515- updated to 9.0.598
516
517* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
518- updated to 9.0.593
519
520* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
521- updated to 9.0.582
522- added Requires: xdg-utils
523
524* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
525- updated to 9.0.578
526
527* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
528- updated to 9.0.569
529
530  * Mon Oct 25 2010 tittiatcoke@gmail.com
531  - Update to 9.0.564 build
532    * Added specific patches for MeeGo.
533    * We are now using shared libraries for Chromium
534    * Spec-file cleanup (Thanks to prusnak)
535
536* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
537- updated to snapshot 8.0.556
538
539* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
540- updated to snapshot 8.0.551
541
542* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
543- updated to snapshot 7.0.527
544
545* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
546- updated to snapshot 7.0.519
547
548* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
549- updated to snapshot 7.0.513
550  - updated chromium-vendor-vine.patch.in
551
552* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
553- updated to snapshot 7.0.507
554
555* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
556- updated to snapshot 7.0.498
557
558* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
559- updated to snapshot 6.0.493
560- used with_system_icu (for vl6)
561  - added BuildRequires: libicu-devel
562
563* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
564- build for Vine Linux 5.x
565  - add BuildRequires: gnome-keyring-devel
566
567* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
568- updated to snapshot 6.0.454
569- added BuildRequires:
570  - sqlite3-devel
571  - gnutls-devel
572  - libgnome-keyring-devel
573
574* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
575- updated to snapshot 6.0.431.0 r49253
576- added BuildRequires: cups-devel
577
578* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
579- updated to snapshot 6.0.405.0 r47263
580
581* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
582- unused with_system_icu (for vl6)
583  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
584
585* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
586- updated to snapshot 5.0.378.0 r44472
587  - used with_system_icu (for vl6)
588  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
589
590* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
591- updated to snapshot 5.0.372.0 r43947
592- added BuildRequires: glew-devel
593- changed Group tag to Applications/Internet
594- added Summary(ja) and %%description -l ja
595
596* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
597- updated to snapshot 5.0.365.0 r42966
598- merged 5.0.353.0-4vl5
599 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
600 - build on Vine Linux 5.1
601   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
602
603* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
604- updated to snapshot 5.0.364.0 r42779
605
606* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
607- updated to snapshot 5.0.359.0 r42116
608- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
609
610* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
611- fixed master_preferences.vine, little
612
613* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
614- fixed to install master_preferences
615- dropped chromium-5.0.353-no-ffmpeg-vine.patch
616
617* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
618- applied chromium-5.0.353-no-ffmpeg-vine.patch
619
620* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
621- updated to snapshot 5.0.353.0 r41449
622  * Wed Mar 10 2010 bgmerrell@novell.com
623  - Add master_preferences source file and install it to /etc/chromium.
624  - Create a new patch (chromium-master-prefs-path.patch) which tells
625    chromium to look in /etc/chromium for the master_preferences file
626    (instead of looking in the default directory, which is the same
627    directory as the 'chrome' binary).
628
629* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
630- updated to snapshot 5.0.335.0 r39556
631
632* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
633- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
634
635* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
636- updated to snapshot 5.0.330.0 r39074
637
638* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
639- use_system_ffmpeg
640
641* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
642- added Requires:  nspluginwrapper
643- fixed a symbolic link of plugins directory with nspluginwrapper
644
645* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
646- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
647
648* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
649- added BuildRequires: mesa-libGLU-devel
650- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
651
652* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
653- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
654
655  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
656  - Update to 4.0.260
657  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
658  - Update to 4.0.259
659  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
660  - Update to 4.0.258
661  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
662  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
663    changed to having an built-in v8
664  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
665  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
666  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
667  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
668  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
669  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
670  - update to newer svn snapshot
671    + Obsoletes fwrite patch (included upstream)
672  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
673  - update to newer svn snapshot
674    + Requires newer version of v8
675  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
676  - do not force SSE on x86 (drop-sse.patch)
677  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
678  - Update to newer svn snapshot
679  - Fixed spec file in order to build
680  - Included patch to build with system zlib
681  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
682  - package renamed to chromium
683  - cleaned up spec file
684  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
685  - v8 is now built as a separate package, and is required
686  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
687  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
688  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
689  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
690  - initial build
691
692#% changelog
693* Sun Jan 24 2010 prusnak@suse.cz
694- added vendor to user agent (chromium-vendor.patch.in)
695* Sun Nov 29 2009 prusnak@suse.cz
696- added --enable-sync to wrapper to enable bookmark sync
697* Sun Nov 29 2009 tittiatcoke@gmail.com 
698- Update to 4.0.260
699* Fri Nov 27 2009 tittiatcoke@gmail.com 
700- Update to 4.0.259
701* Thu Nov 26 2009 tittiatcoke@gmail.com 
702- Update to 4.0.258
703* Tue Nov 24 2009 tittatcoke@gmai.com 
704- In order to complete prevent the wrong v8 version to be used,
705  the Chromium build has been changed to having an built-in v8
706* Tue Nov 24 2009 dbuck@example.com 
707- Re-base patches.
708- Fixed a few patch errors.
709- Rename some patches to better correspond with function.
710- Removed some patches.
711- Minor SPEC changes.
712- I changed the v8 requirement to be exact, instead of greater than a specific version.
713* Fri Nov 13 2009 tittiatcoke@gmail.com
714- update to 247.0 svn 31928
715* Fri Oct 30 2009 tittiatcoke@gmail.com
716- update to 229.0 svn 30454
717  + Fix regression where popups and app frames lost their titlebars.
718  + Makes it so that when a folder is open on the bookmark bar
719    and the mouse moves over another folder, the menu for that
720    folder is shown.
721  + Lazily create the find bar.
722  + Polish to the gmail checker sample.
723  * New, crisper icons that are exactly 19x19
724  * Add a loading animation at the beginning before Gmail
725    responds.
726  * Fix a bug where we sometimes don't update the UI after a
727    logout/login cycle.
728  + Refactor widget methods to support desktop notifications,
729    including GTK stubs.
730  + Find-in-page should not ding while deleting characters.
731  + Add SSL wrapper for linux and mac.  This allows notifier to
732    use chrome's SSL layer instead of OpenSSL.
733  + Add three of the six extensions to PAC that Internet Explorer supports.
734  + WebSocket support in chromium. (Run with --enable-web-sockets
735    enables WebSocket features.)
736  + Do not allow GTK File Chooser dialogs to return directories.
737  + Fix the notifier SSL layer to make notifications work for
738    Linux Bookmark sync.
739  + linux: don't override mouse selection behavior in omnibox
740* Sun Oct 25 2009 tittiatcoke@gmail.com
741- Update to 224.4 svn 30027
742  + First cut at new page and browser action docs based
743    on new API. Deleted old stuff.
744  + Add suppression for new memory leak caused by WebKit merge 49830:49844
745  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
746  + Minimize dependency of user scripts
747  + Fixup the flip_framer eof-handling semantics now that we have
748    the FIN bit in place
749  + app depends on x11 because of active_window_watcher_x
750  + Adding two images for the new Extension managment UI
751  + Removing hard-coded Chrome Frame output path
752  + Rearrange clipboard code
753  + Fix crash bug when attempting to download a url with unsupported scheme,
754    e.g. 'data:', by 'Alt + Click'
755  + GTK: Change text for extension download UI
756  + Ignore invalid urls on command line
757  + Make dropped tabs animate from where they were dropped.
758  + Make room for the full width of the tab placeholder.
759  + Make tab dragging as smooth as glass.
760  + Remove an annoying NOTIMPLEMNETED
761  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
762  + If we're in the middle of a drag, don't allow the user to middle
763    click to close or right click for the context menu
764  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
765  + Remove +x bit from files that shouldn't have it
766  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
767  + Adding new image needed for the managment UI
768  + Fix a race bug where content scripts would not apply to the first page load
769  + Make escape remove a bookmark if it's just been added (but not if it already existed)
770  + Fix bubbles deactivating the opaque frame
771  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
772  + ake all pepper plugins default to windowless and transparent
773  + Add styles for printing
774  + Implement the new extension management UI
775  + Add support for to automation interface load install and load extensions
776  + GTK: theme the info bar border
777  + Update V8 to version 1.3.16.1
778  + Introduce WebSecurityPolicy for security related methods
779  + New button scheme...borders are separate from the inner contents so
780    that they can be highlighted / depressed independently
781  + When opening Chrome maximized with an application window already
782    running, the Chrome window was not activated
783  + Fix compatibility problems with FileZilla FTP Server
784  + Remove the extension shelf on Linux
785  + Fix the proxy host and port string to start with http:// if it does not already
786  + Enable HTML5 databases for all extension renderer processes
787* Sat Oct 24 2009 prusnak@opensuse.org 
788- don't create desktop files in wrapper
789- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
790* Tue Oct 20 2009 tittiatcoke@gmail.com 
791- update to newer svn snapshot
792  + Obsoletes fwrite patch (included upstream)
793* Fri Oct 16 2009 tittiatcoke@gmail.com 
794- update to newer svn snapshot
795  + Requires newer version of v8
796* Thu Oct 15 2009 prusnak@suse.cz 
797- do not force SSE on x86 (drop-sse.patch)
798* Tue Oct 13 2009 tittiatcoke@gmail.com 
799- Update to newer svn snapshot
800- Fixed spec file in order to build
801- Included patch to build with system zlib
802* Mon Oct 12 2009 prusnak@suse.cz 
803- package renamed to chromium
804- cleaned up spec file
805* Tue Oct  6 2009 dbuck@example.com 
806- v8 is now built as a separate package, and is required
807- included many patches to use system libraries:
808    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
809* Thu Oct  1 2009 dbuck@example.com 
810- included a newer DEP than is in svn, native_client@823
811- things should compile cleanly now
812* Mon Aug 31 2009 dbuck@example.com 
813- initial build
Note: See TracBrowser for help on using the repository browser.