source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 832

Revision 832, 19.8 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8#% define with_system_icu 1
9%endif
10
11%define svn_rev 44472
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        5.0.378.0
18Release:        2%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25%{?nosrc:NoSource: 0}
26%{?nosrc:NoSource: 1}
27# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28Source2:        repack_chromium_archive.sh
29# Script used to create the tar.lzma archive from a checked out source
30#Source3:        pack_chromium_source.sh
31Source3:        pack_chromium_source-vine.sh
32#Source10:       chromium.desktop
33Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37##!!Source30:       master_preferences
38Source30:       master_preferences.vine
39# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
40Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
41Provides:       chromium-browser = %{version}
42#Obsoletes:      chromium-browser < %{version}
43
44## Start Patches
45# Many changes to the gyp system so we can use system libraries
46# My first ever patch set.  I hope I did well.
47Patch3:         chromium-gyp-system-02-icu.patch
48Patch4:         chromium-no-sqlite-debug.patch
49Patch5:         chromium-gyp-system-04-nss-nspr.patch
50Patch7:         chromium-codechanges-nss-nspr.patch
51Patch8:         chromium-codechanges-zlib.patch
52Patch9:         chromium-drop-sse.patch
53Patch10:        chromium-fix-wrapper.patch
54#Patch11:        chromium-fix-home-kde4-path.patch
55Patch12:        chromium-no-test-sources.patch
56Patch13:        chromium-no-courgette.patch
57Patch14:        chromium-master-prefs-path.patch
58Patch15:        chromium-media-probe.patch
59Patch16:        chromium-icu-code-changes.patch
60Patch17:        chromium-system-glew.patch
61Patch18:        chromium-system-expat.patch
62Patch19:        chromium-system-zlib.patch
63Patch20:        chromium-noffmpeg.patch
64Patch21:        chromium-system-old-ffmpeg-way.patch
65Patch22:        chromium-libpng14.patch
66Patch23:        chromium-disable-mmx.patch
67
68# Vine
69#Patch40:       chromium-5.0.353-no-ffmpeg-vine.patch
70
71## Gentoo patches
72# Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
73#Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
74
75BuildRequires:  gcc gcc-c++
76%if %{?_dist_release} == "vl5"
77BuildRequires:  libstdc++34 libstdc++34-devel
78%elseif %{?_dist_release} == "vl6"
79BuildRequires:  libstdc++ libstdc++-devel
80%endif
81BuildRequires:  libevent
82##!!BuildRequires:  pkg-config
83BuildRequires:  python
84##!!BuildRequires:  python-xml
85BuildRequires:  python-pyxml
86BuildRequires:  perl bison flex gperf
87##!!BuildRequires:  wdiff
88##!!BuildRequires:  update-desktop-files
89BuildRequires:  desktop-file-utils
90BuildRequires:  lzma
91##!!BuildRequires:  mozilla-nss-devel
92BuildRequires:  nss-devel
93##!!BuildRequires:  alsa-devel
94BuildRequires:  alsa-lib-devel
95BuildRequires:  gtk2-devel
96BuildRequires:  glib2-devel
97BuildRequires:  cairo-devel >= 1.6
98##!!BuildRequires:  mozilla-nspr-devel
99BuildRequires:  nspr-devel
100##!!BuildRequires:  gconf2-devel
101BuildRequires:  GConf2-devel
102BuildRequires:  freetype2-devel
103##!!BuildRequires:  dbus-1-devel
104BuildRequires:  dbus-devel
105BuildRequires:  libxslt-devel
106BuildRequires:  libxml2-devel
107BuildRequires:  libjpeg-devel
108BuildRequires:  zlib-devel
109BuildRequires:  libpng-devel
110##!!BuildRequires:  libbz2-devel
111BuildRequires:  bzip2-devel
112%if %{?_dist_release} == "vl6"
113BuildRequires:  fdupes
114%endif
115##!!BuildRequires:  libexpat-devel
116BuildRequires:  expat-devel
117BuildRequires:  glew-devel
118##!!BuildRequires:  Mesa-devel
119BuildRequires:  mesa-libGLU-devel
120
121%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
122BuildRequires:  libevent-devel
123
124##Vine Linux
125BuildRequires:  libXScrnSaver-devel
126#BuildRequires:  gle-devel
127#BuildRequires:  webkit-gtk-devel
128#BuildRequires:  scons
129%ifarch x86_64
130Requires:  nspluginwrapper
131%endif
132
133##!!Requires:       alsa
134Requires:       alsa-lib
135# shouldn't be required to name all dependencies
136# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
137## Recommends the ffmpeg libraries (available from packman)
138#Recommends:     libavcodec52 libavformat52 libavutil50
139
140BuildRoot:      %{_tmppath}/%{name}-%{version}-root
141
142%description
143Chromium is the open-source project behind Google Chrome.
144We invite you to join us in our effort to help build a safer, faster,
145and more stable way for all Internet users to experience the web,
146and to create a powerful platform for developing a new generation of
147web applications.
148
149%description -l ja
150Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
151私たちは、ウェブを体験しているすべてのインターネットユーザに対して
152より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
153ウェブアプリケーションの新しい世代を発展させるように
154強力なプラットホームを作成するために、
155私たちの取り組みで私たちに加わるようにあなたを誘います。
156
157
158%prep
159[ -d %{name} ] && %__rm -rf %{name}
160lzma -cd %{SOURCE0} | tar xf -
161%setup -D -T -n %{name}
162
163# use static libicu
164#%if %{?_dist_release} == "vl5"
165cd src/third_party || exit 1
166    %__rm -rf icu || exit 1
167    tar jxvf %{SOURCE100} || exit 1
168    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
169cd - || exit 1
170#%endif
171
172# use system libicu only if >= 4.0
173%{?with_system_icu:%patch3 -p1}
174
175%patch4 -p1
176%patch5 -p1
177%patch7 -p1
178%patch8 -p1
179%patch9 -p1
180%patch10 -p1
181#%patch11 -p1
182%patch12 -p1
183%patch13 -p1
184%patch14 -p1
185%patch15 -p0
186%{?with_system_icu:%patch16 -p1}
187%patch17 -p1
188%patch18 -p1
189%patch19 -p1
190%patch20 -p1
191%patch21 -p1
192%patch22 -p1
193%ifarch %ix86
194%patch23 -p1
195%endif
196
197# apply vendor patch after substitution
198%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
199
200%build
201## create make files
202
203PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
204for i in src/build/common.gypi; do
205        %__sed -i "s|'-march=pentium4',||g" $i
206        %__sed -i "s|'-msse2',||g" $i
207        %__sed -i "s|'-mfpmath=sse',||g" $i
208        %__sed -i "s|'-O<(debug_optimize)',||g" $i
209        %__sed -i "s|'-m32',||g" $i
210        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
211        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
212done
213# '
214
215pushd src
216
217./build/gyp_chromium -f make build/all.gyp \
218    -Duse_system_ffmpeg=1 \
219    -Duse_system_zlib=1 \
220    -Duse_system_libpng=1 \
221    -Duse_system_bzip2=1 \
222    -Duse_system_libjpeg=1 \
223    -Duse_system_libxml=1 \
224    -Duse_system_libxslt=1 \
225    -Duse_system_libevent=1 \
226    %{?with_system_icu:-Duse_system_icu=1} \
227    %{!?with_system_icu:-Duse_system_icu=0} \
228    %ifarch %{ix86}
229        -Dtarget_arch=ia32 \
230    %endif
231    %ifarch x86_64
232        -Dtarget_arch=x64 \
233    %endif
234    %if %{?_dist_release} == "vl6"
235        -Dno_strict_aliasing=1 -Dgcc_version=44 \
236    %endif
237    -Drelease_extra_cflags=-fPIC \
238    ;
239
240#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
241#%__make -r -j5 chrome BUILDTYPE=Release
242%__make %{?_smp_mflags} chrome BUILDTYPE=Release
243
244popd
245
246%install
247%{__rm} -rf %{buildroot}
248
249## Create install directories
250%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
251%{__mkdir_p} %{buildroot}%{_bindir}
252%{__mkdir_p} %{buildroot}%{_datadir}/applications
253%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
254%{__mkdir_p} %{buildroot}%{_mandir}/man1
255%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
256
257# chromium 'make' deposits us back at the top level build directory
258pushd src/out/Release
259ls -l
260
261# clean somechromium-codechanges-zlib.patch
262# clean debug junk
263%{__rm} -rf obj/ mksnapshot obj.target obj.host
264find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
265# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
266%{__rm} -f ncdecode_table ncdecode_tablegen
267# clean other temporary binaries used in the compilation of chromium
268%{__rm} -f protoc xdg-settings
269
270%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
271
272# Man page
273[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
274%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
275
276# Add startup file with plugins enabled
277%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
278#!/bin/bash
279%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
280EOF
281
282# # link to browser plugin path.  Plugin patch doesn't work. Why?
283# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
284# pushd %{buildroot}%{_libdir}/%{name}
285# %{__ln_s} %{_libdir}/browser-plugins plugins
286# popd
287pushd %{buildroot}%{_libdir}/%{name}
288%ifarch x86_64
289%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
290%else
291%{__ln_s} %{_libdir}/mozilla/plugins plugins
292%endif
293
294#touch %{buildroot}%{_libdir}/libavcodec.so.52
295#%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
296#touch %{buildroot}%{_libdir}/libavformat.so.52
297#%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
298#touch %{buildroot}%{_libdir}/libavutil.so.50
299#%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
300popd
301
302# Install desktop-related files
303%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
304%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
305desktop-file-install --vendor Vine                      \
306        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
307        --delete-original                               \
308        --mode 644                                      \
309        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
310
311# Install the master_preferences file
312#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
313%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
314
315## install o3d plugin
316#pushd src/o3d/build/out/Release
317#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
318
319%clean
320%{__rm} -rf %{buildroot}
321
322
323%files
324%defattr(-,root,root)
325%doc src/AUTHORS src/LICENSE
326%dir %{_libdir}/%{name}
327%attr(0755,root,root) %{_bindir}/%{name}
328%{_mandir}/man1/*
329%{_datadir}/applications/*%{name}.desktop
330%{_datadir}/pixmaps/%{name}.png
331%{_libdir}/%{name}/*
332%config %{_sysconfdir}/%{name}
333#%{_libdir}/browser-plugins/*
334#%exclude %{_libdir}/libavcodec.so.52
335#%exclude %{_libdir}/libavutil.so.50
336#%exclude %{_libdir}/libavformat.so.52
337
338%changelog
339* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
340- unused with_system_icu (for vl6)
341  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
342
343* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
344- updated to snapshot 5.0.378.0 r44472
345  - used with_system_icu (for vl6)
346  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
347
348* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
349- updated to snapshot 5.0.372.0 r43947
350- added BuildRequires: glew-devel
351- changed Group tag to Applications/Internet
352- added Summary(ja) and %%description -l ja
353
354* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
355- updated to snapshot 5.0.365.0 r42966
356- merged 5.0.353.0-4vl5
357 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
358 - build on Vine Linux 5.1
359   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
360
361* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
362- updated to snapshot 5.0.364.0 r42779
363
364* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
365- updated to snapshot 5.0.359.0 r42116
366- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
367
368* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
369- fixed master_preferences.vine, little
370
371* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
372- fixed to install master_preferences
373- dropped chromium-5.0.353-no-ffmpeg-vine.patch
374
375* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
376- applied chromium-5.0.353-no-ffmpeg-vine.patch
377
378* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
379- updated to snapshot 5.0.353.0 r41449
380  * Wed Mar 10 2010 bgmerrell@novell.com
381  - Add master_preferences source file and install it to /etc/chromium.
382  - Create a new patch (chromium-master-prefs-path.patch) which tells
383    chromium to look in /etc/chromium for the master_preferences file
384    (instead of looking in the default directory, which is the same
385    directory as the 'chrome' binary).
386
387* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
388- updated to snapshot 5.0.335.0 r39556
389
390* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
391- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
392
393* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
394- updated to snapshot 5.0.330.0 r39074
395
396* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
397- use_system_ffmpeg
398
399* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
400- added Requires:  nspluginwrapper
401- fixed a symbolic link of plugins directory with nspluginwrapper
402
403* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
404- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
405
406* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
407- added BuildRequires: mesa-libGLU-devel
408- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
409
410* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
411- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
412
413  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
414  - Update to 4.0.260
415  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
416  - Update to 4.0.259
417  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
418  - Update to 4.0.258
419  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
420  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
421    changed to having an built-in v8
422  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
423  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
424  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
425  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
426  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
427  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
428  - update to newer svn snapshot
429    + Obsoletes fwrite patch (included upstream)
430  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
431  - update to newer svn snapshot
432    + Requires newer version of v8
433  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
434  - do not force SSE on x86 (drop-sse.patch)
435  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
436  - Update to newer svn snapshot
437  - Fixed spec file in order to build
438  - Included patch to build with system zlib
439  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
440  - package renamed to chromium
441  - cleaned up spec file
442  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
443  - v8 is now built as a separate package, and is required
444  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
445  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
446  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
447  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
448  - initial build
449
450#% changelog
451* Sun Jan 24 2010 prusnak@suse.cz
452- added vendor to user agent (chromium-vendor.patch.in)
453* Sun Nov 29 2009 prusnak@suse.cz
454- added --enable-sync to wrapper to enable bookmark sync
455* Fri Nov 13 2009 tittiatcoke@gmail.com
456- update to 247.0 svn 31928
457* Fri Oct 30 2009 tittiatcoke@gmail.com
458- update to 229.0 svn 30454
459  + Fix regression where popups and app frames lost their titlebars.
460  + Makes it so that when a folder is open on the bookmark bar
461    and the mouse moves over another folder, the menu for that
462    folder is shown.
463  + Lazily create the find bar.
464  + Polish to the gmail checker sample.
465  * New, crisper icons that are exactly 19x19
466  * Add a loading animation at the beginning before Gmail
467    responds.
468  * Fix a bug where we sometimes don't update the UI after a
469    logout/login cycle.
470  + Refactor widget methods to support desktop notifications,
471    including GTK stubs.
472  + Find-in-page should not ding while deleting characters.
473  + Add SSL wrapper for linux and mac.  This allows notifier to
474    use chrome's SSL layer instead of OpenSSL.
475  + Add three of the six extensions to PAC that Internet Explorer supports.
476  + WebSocket support in chromium. (Run with --enable-web-sockets
477    enables WebSocket features.)
478  + Do not allow GTK File Chooser dialogs to return directories.
479  + Fix the notifier SSL layer to make notifications work for
480    Linux Bookmark sync.
481  + linux: don't override mouse selection behavior in omnibox
482* Sun Oct 25 2009 tittiatcoke@gmail.com
483- Update to 224.4 svn 30027
484  + First cut at new page and browser action docs based
485    on new API. Deleted old stuff.
486  + Add suppression for new memory leak caused by WebKit merge 49830:49844
487  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
488  + Minimize dependency of user scripts
489  + Fixup the flip_framer eof-handling semantics now that we have
490    the FIN bit in place
491  + app depends on x11 because of active_window_watcher_x
492  + Adding two images for the new Extension managment UI
493  + Removing hard-coded Chrome Frame output path
494  + Rearrange clipboard code
495  + Fix crash bug when attempting to download a url with unsupported scheme,
496    e.g. 'data:', by 'Alt + Click'
497  + GTK: Change text for extension download UI
498  + Ignore invalid urls on command line
499  + Make dropped tabs animate from where they were dropped.
500  + Make room for the full width of the tab placeholder.
501  + Make tab dragging as smooth as glass.
502  + Remove an annoying NOTIMPLEMNETED
503  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
504  + If we're in the middle of a drag, don't allow the user to middle
505    click to close or right click for the context menu
506  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
507  + Remove +x bit from files that shouldn't have it
508  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
509  + Adding new image needed for the managment UI
510  + Fix a race bug where content scripts would not apply to the first page load
511  + Make escape remove a bookmark if it's just been added (but not if it already existed)
512  + Fix bubbles deactivating the opaque frame
513  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
514  + ake all pepper plugins default to windowless and transparent
515  + Add styles for printing
516  + Implement the new extension management UI
517  + Add support for to automation interface load install and load extensions
518  + GTK: theme the info bar border
519  + Update V8 to version 1.3.16.1
520  + Introduce WebSecurityPolicy for security related methods
521  + New button scheme...borders are separate from the inner contents so
522    that they can be highlighted / depressed independently
523  + When opening Chrome maximized with an application window already
524    running, the Chrome window was not activated
525  + Fix compatibility problems with FileZilla FTP Server
526  + Remove the extension shelf on Linux
527  + Fix the proxy host and port string to start with http:// if it does not already
528  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.