source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2689

Revision 2689, 29.7 KB checked in by kudoh, 13 years ago (diff)
Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define v8_ver 3.0.12
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        10.0.651.0
18Release:        2%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21#Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22#Source0:        %{name}-%{version}.svn%{svn_rev}.tar.xz
23Source0:        %{name}-%{version}.tar.xz
24## The following are included for source reasons only
25# Custom build tools for chromium, hammer is a fancy front-end for scons
26Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
27# # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
28# Source2:        repack_chromium_archive.sh
29# # Script used to create the tar.lzma archive from a checked out source
30# Source3:        pack_chromium_source.sh
31# Script used to create the %{name}-%{version}.tar.xz archive from
32# a official tarball:
33# http://build.chromium.org/official/chromium-10.0.644.0.tar.bz2
34Source3:        pack_chromium_source-vine.sh
35# Official ffmpeg headers
36Source8:        ffmpeg-0.6-headers.tar.xz
37#Source10:       chromium.desktop
38#Source10:       chromium-vine.desktop
39# Patch template which adds vendor to user agent
40##!!Source20:       chromium-vendor.patch.in
41Source20:       chromium-vendor-vine.patch.in
42# Set default prefs
43##!!Source30:       master_preferences
44Source30:       master_preferences.vine
45#Source31:       default_bookmarks.html
46#Source31:       default_bookmarks.html.vine
47Source99:       chrome-wrapper
48##!!Source100:      chromium-browser.sh
49Source100:      chromium-browser-vine.sh
50##!!Source101:      chromium-browser.desktop
51Source101:      chromium-browser-vine.desktop
52Source102:      chromium-browser.xml
53Source103:      chromium-browser-rpmlintrc
54
55%{?nosrc:NoSource: 0}
56%{?nosrc:NoSource: 1}
57
58Provides:       chromium-browser = %{version}
59##Provides:     chromium-based-browser = %{version}
60##Obsoletes:      chromium-browser < %{version}
61
62## Start Patches
63# Many changes to the gyp systems so we can use system libraries
64# My first ever patch set.  I hope I did well.
65Patch3:         chromium-gyp-system-icu.patch
66Patch4:         chromium-no-sqlite-debug.patch
67Patch5:         chromium-gyp-system-04-nss-nspr.patch
68Patch7:         chromium-codechanges-nss-nspr.patch
69Patch8:         chromium-codechanges-zlib.patch
70Patch12:        chromium-no-test-sources.patch
71Patch13:        chromium-no-courgette.patch
72Patch14:        chromium-master-prefs-path.patch
73Patch17:        chromium-system-glew.patch
74Patch18:        chromium-system-expat.patch
75Patch19:        chromium-system-zlib.patch
76Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
77Patch21:        chromium-7.0.542.0-media-probe.patch
78Patch23:        chromium-disable-mmx.patch
79Patch25:        tcmalloc-factory.patch
80Patch26:        chromium-remoting-build-fix.diff
81Patch28:        chromium-7.0.500.0-system-speex.patch
82Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
83Patch30:        chromium-7.0.510.0-fstat.patch
84Patch32:        chromium-7.0.542.0-system-libvpx.patch
85Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
86# Shared Library patches
87Patch60:        chromium-sharedlibfixes.patch
88#Patch61:        chromium-shared-chromiumthreading.patch
89Patch62:        chromium-norpath.patch
90Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
91# Patches for MeeGo Netbook
92Patch80:        chromium-browser-window-focus.patch
93Patch81:        chromium-20100319-default-browser-setting.patch
94Patch82:        chromium-20100506-expose-chromium-browser-api.patch
95Patch83:        chromium-fix-toolbar-icon-size.patch
96
97Patch98:        chromium-gyp-external-icu.patch
98
99# Vine
100
101
102BuildRequires:  gcc gcc-c++
103%if %{?_dist_release} == "vl5"
104BuildRequires:  libstdc++34 libstdc++34-devel
105%elseif %{?_dist_release} == "vl6"
106BuildRequires:  libstdc++ libstdc++-devel
107%endif
108BuildRequires:  libevent
109##!!BuildRequires:  pkg-config
110BuildRequires:  python
111##!!BuildRequires:  python-xml
112BuildRequires:  python-pyxml
113BuildRequires:  perl bison flex gperf
114##!!BuildRequires:  wdiff
115##!!BuildRequires:  update-desktop-files
116BuildRequires:  lzma
117##!!BuildRequires:  mozilla-nss-devel
118BuildRequires:  nss-devel
119##!!BuildRequires:  alsa-devel
120BuildRequires:  alsa-lib-devel
121BuildRequires:  gtk2-devel
122BuildRequires:  glib2-devel
123BuildRequires:  cairo-devel >= 1.6
124##!!BuildRequires:  mozilla-nspr-devel
125BuildRequires:  nspr-devel
126##!!BuildRequires:  gconf2-devel
127BuildRequires:  GConf2-devel
128BuildRequires:  freetype2-devel
129##!!BuildRequires:  dbus-1-devel
130BuildRequires:  dbus-devel
131BuildRequires:  libxslt-devel
132BuildRequires:  libxml2-devel
133BuildRequires:  libjpeg-devel
134BuildRequires:  zlib-devel
135##!!BuildRequires:  libbz2-devel
136BuildRequires:  bzip2-devel
137BuildRequires:  cups-devel
138%if %{?_dist_release} == "vl6"
139BuildRequires:  fdupes
140%endif
141##!!BuildRequires:  libexpat-devel
142BuildRequires:  expat-devel
143BuildRequires:  libpng-devel
144BuildRequires:  sqlite3-devel
145BuildRequires:  gnutls-devel
146BuildRequires:  desktop-file-utils
147BuildRequires:  v8-devel = %{v8_ver}
148BuildRequires:  libvpx-devel >= 0.9.5
149%if %{?_dist_release} == "vl5"
150BuildRequires:  gnome-keyring-devel
151%elseif %{?_dist_release} == "vl6"
152BuildRequires:  libgnome-keyring-devel
153%endif
154BuildRequires:  python-devel
155BuildRequires:  glew-devel
156##!!BuildRequires:  Mesa-devel
157BuildRequires:  mesa-libGLU-devel
158BuildRequires:  hunspell-devel
159
160%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
161BuildRequires:  libevent-devel
162#BuildRequires:  libjingle-devel >= 0.4.0-7
163#BuildRequires:  srtp-devel
164BuildRequires:  speex-devel
165
166##Vine Linux
167Requires:       v8 = %{v8_ver}
168BuildRequires:  libpaper-devel
169BuildRequires:  libXScrnSaver-devel
170BuildRequires:  libXtst-devel
171BuildRequires:  libXdamage-devel
172BuildRequires:  libXt-devel
173#BuildRequires:  gle-devel
174#BuildRequires:  webkit-gtk-devel
175#BuildRequires:  scons
176%ifarch x86_64
177Requires:  nspluginwrapper
178%endif
179
180##!!Requires:       alsa
181Requires:       alsa-lib
182Requires:       xdg-utils
183# shouldn't be required to name all dependencies
184# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
185
186BuildRoot:      %{_tmppath}/%{name}-%{version}-root
187
188%description
189Chromium is the open-source project behind Google Chrome.
190We invite you to join us in our effort to help build a safer, faster,
191and more stable way for all Internet users to experience the web,
192and to create a powerful platform for developing a new generation of
193web applications.
194
195%description -l ja
196Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
197ウェブを体験しているすべてのインターネットユーザに対して
198より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
199そして、ウェブアプリケーションの新しい世代を発展させ、
200強力なプラットホームを作成するために、
201私たちの取り組みにぜひ参加してください。
202
203
204%package devel
205Summary:        Header file for chromium browser
206Group:          Development/Libraries
207Requires:       chromium = %{version}-%{release}
208
209%description devel
210This package contains the header files and pc file of chromium browser for
211applications which will use chromium browser APIs.
212
213
214%prep
215%setup -q
216
217#%patch60 -p1
218#%patch61 -p1
219%patch62 -p1
220%patch63 -p1
221%patch80 -p1
222#%patch81 -p1
223%patch82 -p1
224%patch83 -p1
225
226# use system libicu only if >= 4.0
227%{?with_system_icu:%patch3 -p1}
228
229%patch4 -p1
230%patch5 -p1
231%patch7 -p1
232%patch8 -p1
233%patch12 -p1
234%patch13 -p1
235%patch14 -p1
236%patch17 -p1
237%patch18 -p1
238%patch19 -p1
239%patch20 -p1
240%patch21 -p1
241%patch25 -p1
242%ifarch %ix86
243%patch23 -p1
244%endif
245%patch26 -p1
246%patch28 -p1
247%patch29 -p1
248%patch30 -p1
249%patch32 -p1
250%patch34 -p1
251
252pushd src/third_party/ffmpeg/
253%__tar Jxf %{SOURCE8} || exit 1
254## built header file: avconfig.h
255[ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
256cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
257/* Generated by ffconf */
258#ifndef AVUTIL_AVCONFIG_H
259#define AVUTIL_AVCONFIG_H
260#define AV_HAVE_BIGENDIAN 0
261#endif /* AVUTIL_AVCONFIG_H */
262EOF
263popd
264
265%__rm -rf src/third_party/libvpx/ src/third_party/speex/
266
267# apply vendor patch after substitution
268%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
269
270%build
271
272## create make files
273
274PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
275for i in src/build/common.gypi; do
276        %__sed -i "s|'-march=pentium4',||g" $i
277        %__sed -i "s|'-msse2',||g" $i
278        %__sed -i "s|'-mfpmath=sse',||g" $i
279        %__sed -i "s|'-O<(debug_optimize)',||g" $i
280        %__sed -i "s|'-m32',||g" $i
281        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
282        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
283done
284# '
285
286pushd src
287
288./build/gyp_chromium -f make build/all.gyp \
289    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
290    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
291    -Duse_system_ffmpeg=1 \
292    -Duse_system_zlib=1 \
293    -Duse_system_libpng=1 \
294    -Duse_system_bzip2=1 \
295    -Duse_system_libbz2=1 \
296    -Duse_system_libjpeg=1 \
297    -Duse_system_libxml=1 \
298    -Duse_system_libxslt=1 \
299    -Duse_system_libevent=1 \
300    -Duse_system_vpx=1 \
301    -Dproprietary_codecs=1 \
302    -Dlibrary=shared_library \
303    -Djavascript_engine=v8 \
304    -Dlinux_fpic=1 \
305    %{?with_system_icu:-Duse_system_icu=1} \
306    %{!?with_system_icu:-Duse_system_icu=0} \
307    %ifarch %{ix86}
308        -Dtarget_arch=ia32 \
309         -Ddisable_sse2=1 \
310    %endif
311    %ifarch x86_64
312        -Dtarget_arch=x64 \
313    %endif
314    %if %{?_dist_release} == "vl6"
315        -Dno_strict_aliasing=1 -Dgcc_version=44 \
316    %endif
317    -Drelease_extra_cflags=-fPIC \
318    ;
319
320#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
321#%__make -r -j5 chrome BUILDTYPE=Release
322%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
323
324popd
325
326%install
327%{__rm} -rf %{buildroot}
328
329%__mkdir -p %{buildroot}%{_bindir}
330%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
331# x86_64 capable systems need this
332%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
333%__mkdir -p %{buildroot}%{_libdir}/chromium/
334%__mkdir -p %{buildroot}%{_mandir}/man1/
335pushd src/out/Release
336%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
337%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
338%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
339%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
340%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
341#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
342%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
343%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
344%if %{?_dist_release} == "vl6"
345fdupes %{buildroot}%{_mandir}/man1/
346%endif
347popd
348
349# devel package install
350mkdir -p %{buildroot}%{_libdir}/chromium/include
351pushd src
352find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
353find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
354find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
355find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
356find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
357find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
358find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
359find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
360find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
361find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
362find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
363find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
364find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
365popd
366find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
367%if %{?_dist_release} == "vl6"
368fdupes %{buildroot}%{_libdir}/chromium/include
369%endif
370
371%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
372cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
373Name: Chromium browser
374Description: Chromium browser development package
375Version: 1.0.1
376Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
377Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
378EOF
379
380%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
381%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
382
383%__mkdir_p %{buildroot}%{_datadir}/applications/
384desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
385
386%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
387%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
388
389# # link to browser plugin path.  Plugin patch doesn't work. Why?
390# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
391# pushd %{buildroot}%{_libdir}/%{name}
392# %{__ln_s} %{_libdir}/browser-plugins plugins
393# popd
394pushd %{buildroot}%{_libdir}/%{name}
395%ifarch x86_64
396%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
397%else
398%{__ln_s} %{_libdir}/mozilla/plugins plugins
399%endif
400
401## support ffmpeg libs
402touch %{buildroot}%{_libdir}/libavcodec.so.52
403%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
404touch %{buildroot}%{_libdir}/libavformat.so.52
405%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
406touch %{buildroot}%{_libdir}/libavutil.so.50
407%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
408popd
409
410# Install the master_preferences file
411%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
412#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
413%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
414#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
415
416%clean
417%{__rm} -rf %{buildroot}
418
419
420%files
421%defattr(-,root,root,-)
422%config %{_sysconfdir}/%{name}
423%dir %{_datadir}/gnome-control-center
424%dir %{_datadir}/gnome-control-center/default-apps
425%{_bindir}/chromium
426%{_libdir}/chromium/chromium
427# These unique permissions are intentional and necessary for the sandboxing
428#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
429%{_libdir}/chromium/plugins/
430%{_libdir}/chromium/resources/
431%{_libdir}/chromium/xdg-settings
432%{_mandir}/man1/chrom*
433%{_datadir}/pixmaps/chromium-browser.png
434%{_datadir}/applications/*.desktop
435%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
436%{_libdir}/chromium/libavcodec.so.52
437%{_libdir}/chromium/libavutil.so.50
438%{_libdir}/chromium/libavformat.so.52
439%exclude %{_libdir}/libavcodec.so.52
440%exclude %{_libdir}/libavutil.so.50
441%exclude %{_libdir}/libavformat.so.52
442## libs
443%dir %{_libdir}/chromium/
444%{_libdir}/chromium/chrome.pak
445%{_libdir}/chromium/resources.pak
446%{_libdir}/chromium/locales/
447%{_libdir}/chromium/lib*.so
448
449%files devel
450%defattr(-,root,root,-)
451%{_libdir}/chromium/include/
452%{_libdir}/pkgconfig/chromium-browser.pc
453
454%changelog
455* Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
456- rebuilt with libevent-2.0.10
457
458* Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
459- updated to 10.0.651.0 with v8 3.0.12
460- added BuildRequires:
461  - libpaper-devel
462  - python-devel
463- added built header file: libavutil/avconfig.h %%prep
464- unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
465
466* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
467- updated to 10.0.622.0
468- added BuildRequires: libXt-devel
469
470* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
471- updated to 10.0.605.0
472- added BuildRequires:
473  - libXdamage-devel
474  - hunspell-devel
475
476* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
477- updated to 9.0.598
478
479* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
480- updated to 9.0.593
481
482* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
483- updated to 9.0.582
484- added Requires: xdg-utils
485
486* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
487- updated to 9.0.578
488
489* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
490- updated to 9.0.569
491
492  * Mon Oct 25 2010 tittiatcoke@gmail.com
493  - Update to 9.0.564 build
494    * Added specific patches for MeeGo.
495    * We are now using shared libraries for Chromium
496    * Spec-file cleanup (Thanks to prusnak)
497
498* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
499- updated to snapshot 8.0.556
500
501* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
502- updated to snapshot 8.0.551
503
504* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
505- updated to snapshot 7.0.527
506
507* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
508- updated to snapshot 7.0.519
509
510* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
511- updated to snapshot 7.0.513
512  - updated chromium-vendor-vine.patch.in
513
514* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
515- updated to snapshot 7.0.507
516
517* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
518- updated to snapshot 7.0.498
519
520* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
521- updated to snapshot 6.0.493
522- used with_system_icu (for vl6)
523  - added BuildRequires: libicu-devel
524
525* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
526- build for Vine Linux 5.x
527  - add BuildRequires: gnome-keyring-devel
528
529* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
530- updated to snapshot 6.0.454
531- added BuildRequires:
532  - sqlite3-devel
533  - gnutls-devel
534  - libgnome-keyring-devel
535
536* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
537- updated to snapshot 6.0.431.0 r49253
538- added BuildRequires: cups-devel
539
540* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
541- updated to snapshot 6.0.405.0 r47263
542
543* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
544- unused with_system_icu (for vl6)
545  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
546
547* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
548- updated to snapshot 5.0.378.0 r44472
549  - used with_system_icu (for vl6)
550  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
551
552* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
553- updated to snapshot 5.0.372.0 r43947
554- added BuildRequires: glew-devel
555- changed Group tag to Applications/Internet
556- added Summary(ja) and %%description -l ja
557
558* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
559- updated to snapshot 5.0.365.0 r42966
560- merged 5.0.353.0-4vl5
561 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
562 - build on Vine Linux 5.1
563   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
564
565* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
566- updated to snapshot 5.0.364.0 r42779
567
568* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
569- updated to snapshot 5.0.359.0 r42116
570- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
571
572* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
573- fixed master_preferences.vine, little
574
575* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
576- fixed to install master_preferences
577- dropped chromium-5.0.353-no-ffmpeg-vine.patch
578
579* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
580- applied chromium-5.0.353-no-ffmpeg-vine.patch
581
582* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
583- updated to snapshot 5.0.353.0 r41449
584  * Wed Mar 10 2010 bgmerrell@novell.com
585  - Add master_preferences source file and install it to /etc/chromium.
586  - Create a new patch (chromium-master-prefs-path.patch) which tells
587    chromium to look in /etc/chromium for the master_preferences file
588    (instead of looking in the default directory, which is the same
589    directory as the 'chrome' binary).
590
591* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
592- updated to snapshot 5.0.335.0 r39556
593
594* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
595- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
596
597* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
598- updated to snapshot 5.0.330.0 r39074
599
600* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
601- use_system_ffmpeg
602
603* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
604- added Requires:  nspluginwrapper
605- fixed a symbolic link of plugins directory with nspluginwrapper
606
607* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
608- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
609
610* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
611- added BuildRequires: mesa-libGLU-devel
612- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
613
614* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
615- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
616
617  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
618  - Update to 4.0.260
619  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
620  - Update to 4.0.259
621  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
622  - Update to 4.0.258
623  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
624  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
625    changed to having an built-in v8
626  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
627  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
628  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
629  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
630  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
631  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
632  - update to newer svn snapshot
633    + Obsoletes fwrite patch (included upstream)
634  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
635  - update to newer svn snapshot
636    + Requires newer version of v8
637  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
638  - do not force SSE on x86 (drop-sse.patch)
639  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
640  - Update to newer svn snapshot
641  - Fixed spec file in order to build
642  - Included patch to build with system zlib
643  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
644  - package renamed to chromium
645  - cleaned up spec file
646  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
647  - v8 is now built as a separate package, and is required
648  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
649  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
650  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
651  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
652  - initial build
653
654#% changelog
655* Sun Jan 24 2010 prusnak@suse.cz
656- added vendor to user agent (chromium-vendor.patch.in)
657* Sun Nov 29 2009 prusnak@suse.cz
658- added --enable-sync to wrapper to enable bookmark sync
659* Sun Nov 29 2009 tittiatcoke@gmail.com 
660- Update to 4.0.260
661* Fri Nov 27 2009 tittiatcoke@gmail.com 
662- Update to 4.0.259
663* Thu Nov 26 2009 tittiatcoke@gmail.com 
664- Update to 4.0.258
665* Tue Nov 24 2009 tittatcoke@gmai.com 
666- In order to complete prevent the wrong v8 version to be used,
667  the Chromium build has been changed to having an built-in v8
668* Tue Nov 24 2009 dbuck@example.com 
669- Re-base patches.
670- Fixed a few patch errors.
671- Rename some patches to better correspond with function.
672- Removed some patches.
673- Minor SPEC changes.
674- I changed the v8 requirement to be exact, instead of greater than a specific version.
675* Fri Nov 13 2009 tittiatcoke@gmail.com
676- update to 247.0 svn 31928
677* Fri Oct 30 2009 tittiatcoke@gmail.com
678- update to 229.0 svn 30454
679  + Fix regression where popups and app frames lost their titlebars.
680  + Makes it so that when a folder is open on the bookmark bar
681    and the mouse moves over another folder, the menu for that
682    folder is shown.
683  + Lazily create the find bar.
684  + Polish to the gmail checker sample.
685  * New, crisper icons that are exactly 19x19
686  * Add a loading animation at the beginning before Gmail
687    responds.
688  * Fix a bug where we sometimes don't update the UI after a
689    logout/login cycle.
690  + Refactor widget methods to support desktop notifications,
691    including GTK stubs.
692  + Find-in-page should not ding while deleting characters.
693  + Add SSL wrapper for linux and mac.  This allows notifier to
694    use chrome's SSL layer instead of OpenSSL.
695  + Add three of the six extensions to PAC that Internet Explorer supports.
696  + WebSocket support in chromium. (Run with --enable-web-sockets
697    enables WebSocket features.)
698  + Do not allow GTK File Chooser dialogs to return directories.
699  + Fix the notifier SSL layer to make notifications work for
700    Linux Bookmark sync.
701  + linux: don't override mouse selection behavior in omnibox
702* Sun Oct 25 2009 tittiatcoke@gmail.com
703- Update to 224.4 svn 30027
704  + First cut at new page and browser action docs based
705    on new API. Deleted old stuff.
706  + Add suppression for new memory leak caused by WebKit merge 49830:49844
707  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
708  + Minimize dependency of user scripts
709  + Fixup the flip_framer eof-handling semantics now that we have
710    the FIN bit in place
711  + app depends on x11 because of active_window_watcher_x
712  + Adding two images for the new Extension managment UI
713  + Removing hard-coded Chrome Frame output path
714  + Rearrange clipboard code
715  + Fix crash bug when attempting to download a url with unsupported scheme,
716    e.g. 'data:', by 'Alt + Click'
717  + GTK: Change text for extension download UI
718  + Ignore invalid urls on command line
719  + Make dropped tabs animate from where they were dropped.
720  + Make room for the full width of the tab placeholder.
721  + Make tab dragging as smooth as glass.
722  + Remove an annoying NOTIMPLEMNETED
723  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
724  + If we're in the middle of a drag, don't allow the user to middle
725    click to close or right click for the context menu
726  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
727  + Remove +x bit from files that shouldn't have it
728  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
729  + Adding new image needed for the managment UI
730  + Fix a race bug where content scripts would not apply to the first page load
731  + Make escape remove a bookmark if it's just been added (but not if it already existed)
732  + Fix bubbles deactivating the opaque frame
733  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
734  + ake all pepper plugins default to windowless and transparent
735  + Add styles for printing
736  + Implement the new extension management UI
737  + Add support for to automation interface load install and load extensions
738  + GTK: theme the info bar border
739  + Update V8 to version 1.3.16.1
740  + Introduce WebSecurityPolicy for security related methods
741  + New button scheme...borders are separate from the inner contents so
742    that they can be highlighted / depressed independently
743  + When opening Chrome maximized with an application window already
744    running, the Chrome window was not activated
745  + Fix compatibility problems with FileZilla FTP Server
746  + Remove the extension shelf on Linux
747  + Fix the proxy host and port string to start with http:// if it does not already
748  + Enable HTML5 databases for all extension renderer processes
749* Sat Oct 24 2009 prusnak@opensuse.org 
750- don't create desktop files in wrapper
751- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
752* Tue Oct 20 2009 tittiatcoke@gmail.com 
753- update to newer svn snapshot
754  + Obsoletes fwrite patch (included upstream)
755* Fri Oct 16 2009 tittiatcoke@gmail.com 
756- update to newer svn snapshot
757  + Requires newer version of v8
758* Thu Oct 15 2009 prusnak@suse.cz 
759- do not force SSE on x86 (drop-sse.patch)
760* Tue Oct 13 2009 tittiatcoke@gmail.com 
761- Update to newer svn snapshot
762- Fixed spec file in order to build
763- Included patch to build with system zlib
764* Mon Oct 12 2009 prusnak@suse.cz 
765- package renamed to chromium
766- cleaned up spec file
767* Tue Oct  6 2009 dbuck@example.com 
768- v8 is now built as a separate package, and is required
769- included many patches to use system libraries:
770    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
771* Thu Oct  1 2009 dbuck@example.com 
772- included a newer DEP than is in svn, native_client@823
773- things should compile cleanly now
774* Mon Aug 31 2009 dbuck@example.com 
775- initial build
Note: See TracBrowser for help on using the repository browser.