source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2405

Revision 2405, 29.4 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec, v8-vl.spec: chromium-10.0.622.0 with v8-3.0.4, libvpx-0.9.5

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 70166
12%define v8_ver 3.0.4
13
14Name:           chromium
15Summary:        Google's opens source browser project
16Summary(ja):    Googleのオープンソースウェブブラウザ
17#'
18Version:        10.0.622.0
19Release:        1%{?_dist_release}
20License:        BSD
21Group:          Applications/Internet
22Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
23## The following are included for source reasons only
24# Custom build tools for chromium, hammer is a fancy front-end for scons
25Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
26# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
27Source2:        repack_chromium_archive.sh
28# Script used to create the tar.lzma archive from a checked out source
29Source3:        pack_chromium_source.sh
30# Official ffmpeg headers
31Source8:        ffmpeg-0.6-headers.tar.bz2
32#Source10:       chromium.desktop
33#Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37# Set default prefs
38##!!Source30:       master_preferences
39Source30:       master_preferences.vine
40#Source31:       default_bookmarks.html
41#Source31:       default_bookmarks.html.vine
42# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
43Source50:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
44Source99:       chrome-wrapper
45##!!Source100:      chromium-browser.sh
46Source100:      chromium-browser-vine.sh
47##!!Source101:      chromium-browser.desktop
48Source101:      chromium-browser-vine.desktop
49Source102:      chromium-browser.xml
50Source103:      chromium-browser-rpmlintrc
51
52%{?nosrc:NoSource: 0}
53%{?nosrc:NoSource: 1}
54%{?nosrc:NoSource: 50}
55
56Provides:       chromium-browser = %{version}
57##Provides:     chromium-based-browser = %{version}
58##Obsoletes:      chromium-browser < %{version}
59
60## Start Patches
61# Many changes to the gyp systems so we can use system libraries
62# My first ever patch set.  I hope I did well.
63Patch3:         chromium-gyp-system-icu.patch
64Patch4:         chromium-no-sqlite-debug.patch
65Patch5:         chromium-gyp-system-04-nss-nspr.patch
66Patch7:         chromium-codechanges-nss-nspr.patch
67Patch8:         chromium-codechanges-zlib.patch
68Patch12:        chromium-no-test-sources.patch
69Patch13:        chromium-no-courgette.patch
70Patch14:        chromium-master-prefs-path.patch
71Patch17:        chromium-system-glew.patch
72Patch18:        chromium-system-expat.patch
73Patch19:        chromium-system-zlib.patch
74Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
75Patch21:        chromium-7.0.542.0-media-probe.patch
76Patch23:        chromium-disable-mmx.patch
77Patch25:        tcmalloc-factory.patch
78Patch26:        chromium-remoting-build-fix.diff
79#Patch27:        chromium-7.0.542.0-system-libjingle.patch
80Patch28:        chromium-7.0.500.0-system-speex.patch
81Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
82Patch30:        chromium-7.0.510.0-fstat.patch
83#Patch31:        chromium-7.0.542.0-system-srtp.patch
84Patch32:        chromium-7.0.542.0-system-libvpx.patch
85#Patch33:        chromium-20090807-gyp-system-minizip.patch
86Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
87# Shared Library patches
88Patch60:        chromium-sharedlibfixes.patch
89Patch61:        chromium-shared-chromiumthreading.patch
90Patch62:        chromium-norpath.patch
91Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
92# Patches for MeeGo Netbook
93Patch80:        chromium-browser-window-focus.patch
94Patch81:        chromium-20100319-default-browser-setting.patch
95Patch82:        chromium-20100506-expose-chromium-browser-api.patch
96Patch83:        chromium-fix-toolbar-icon-size.patch
97
98# Vine
99
100
101BuildRequires:  gcc gcc-c++
102%if %{?_dist_release} == "vl5"
103BuildRequires:  libstdc++34 libstdc++34-devel
104%elseif %{?_dist_release} == "vl6"
105BuildRequires:  libstdc++ libstdc++-devel
106%endif
107BuildRequires:  libevent
108##!!BuildRequires:  pkg-config
109BuildRequires:  python
110##!!BuildRequires:  python-xml
111BuildRequires:  python-pyxml
112BuildRequires:  perl bison flex gperf
113##!!BuildRequires:  wdiff
114##!!BuildRequires:  update-desktop-files
115BuildRequires:  lzma
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118##!!BuildRequires:  alsa-devel
119BuildRequires:  alsa-lib-devel
120BuildRequires:  gtk2-devel
121BuildRequires:  glib2-devel
122BuildRequires:  cairo-devel >= 1.6
123##!!BuildRequires:  mozilla-nspr-devel
124BuildRequires:  nspr-devel
125##!!BuildRequires:  gconf2-devel
126BuildRequires:  GConf2-devel
127BuildRequires:  freetype2-devel
128##!!BuildRequires:  dbus-1-devel
129BuildRequires:  dbus-devel
130BuildRequires:  libxslt-devel
131BuildRequires:  libxml2-devel
132BuildRequires:  libjpeg-devel
133BuildRequires:  zlib-devel
134##!!BuildRequires:  libbz2-devel
135BuildRequires:  bzip2-devel
136BuildRequires:  cups-devel
137%if %{?_dist_release} == "vl6"
138BuildRequires:  fdupes
139%endif
140##!!BuildRequires:  libexpat-devel
141BuildRequires:  expat-devel
142BuildRequires:  libpng-devel
143BuildRequires:  sqlite3-devel
144BuildRequires:  gnutls-devel
145BuildRequires:  desktop-file-utils
146BuildRequires:  v8-devel = %{v8_ver}
147BuildRequires:  libvpx-devel >= 0.9.5
148%if %{?_dist_release} == "vl5"
149BuildRequires:  gnome-keyring-devel
150%elseif %{?_dist_release} == "vl6"
151BuildRequires:  libgnome-keyring-devel
152%endif
153BuildRequires:  glew-devel
154##!!BuildRequires:  Mesa-devel
155BuildRequires:  mesa-libGLU-devel
156BuildRequires:  hunspell-devel
157
158%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
159BuildRequires:  libevent-devel
160#BuildRequires:  libjingle-devel >= 0.4.0-7
161#BuildRequires:  srtp-devel
162BuildRequires:  speex-devel
163
164##Vine Linux
165Requires:       v8 = %{v8_ver}
166BuildRequires:  libXScrnSaver-devel
167BuildRequires:  libXtst-devel
168BuildRequires:  libXdamage-devel
169BuildRequires:  libXt-devel
170#BuildRequires:  gle-devel
171#BuildRequires:  webkit-gtk-devel
172#BuildRequires:  scons
173%ifarch x86_64
174Requires:  nspluginwrapper
175%endif
176
177##!!Requires:       alsa
178Requires:       alsa-lib
179Requires:       xdg-utils
180# shouldn't be required to name all dependencies
181# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
182
183BuildRoot:      %{_tmppath}/%{name}-%{version}-root
184
185%description
186Chromium is the open-source project behind Google Chrome.
187We invite you to join us in our effort to help build a safer, faster,
188and more stable way for all Internet users to experience the web,
189and to create a powerful platform for developing a new generation of
190web applications.
191
192%description -l ja
193Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
194私たちは、ウェブを体験しているすべてのインターネットユーザに対して
195より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
196そして、ウェブアプリケーションの新しい世代を発展させるように
197強力なプラットホームを作成するために、
198私たちの取り組みで私たちに加わるようにあなたを誘います。
199
200%package devel
201Summary:        Header file for chromium browser
202Group:          Development/Libraries
203Requires:       chromium = %{version}-%{release}
204
205%description devel
206This package contains the header files and pc file of chromium browser for
207applications which will use chromium browser APIs.
208
209
210%prep
211[ -d %{name} ] && %__rm -rf %{name}
212lzma -cd %{SOURCE0} | tar xf -
213%setup -D -T -n %{name}
214
215# use static libicu
216%if %{?_dist_release} == "vl5"
217cd src/third_party || exit 1
218    %__rm -rf icu || exit 1
219    tar jxvf %{SOURCE50} || exit 1
220    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
221cd - || exit 1
222%endif
223
224%patch60 -p1
225%patch61 -p1
226%patch62 -p1
227%patch63 -p1
228%patch80 -p1
229%patch81 -p1
230%patch82 -p1
231%patch83 -p1
232
233# use system libicu only if >= 4.0
234%{?with_system_icu:%patch3 -p1}
235
236%patch4 -p1
237%patch5 -p1
238%patch7 -p1
239%patch8 -p1
240%patch12 -p1
241%patch13 -p1
242%patch14 -p1
243%patch17 -p1
244%patch18 -p1
245%patch19 -p1
246%patch20 -p1
247%patch21 -p1
248%patch25 -p1
249%ifarch %ix86
250%patch23 -p1
251%endif
252%patch26 -p1
253#%patch27 -p1
254%patch28 -p1
255%patch29 -p1
256%patch30 -p1
257#%patch31 -p1
258%patch32 -p1
259#%patch33 -p1
260%patch34 -p1
261
262pushd src/third_party/ffmpeg/
263tar xf %{SOURCE8}
264popd
265
266%__rm -rf src/third_party/libvpx/ src/third_party/speex/
267
268# apply vendor patch after substitution
269%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
270
271%build
272
273## create make files
274
275PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
276for i in src/build/common.gypi; do
277        %__sed -i "s|'-march=pentium4',||g" $i
278        %__sed -i "s|'-msse2',||g" $i
279        %__sed -i "s|'-mfpmath=sse',||g" $i
280        %__sed -i "s|'-O<(debug_optimize)',||g" $i
281        %__sed -i "s|'-m32',||g" $i
282        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
283        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
284done
285# '
286
287pushd src
288
289./build/gyp_chromium -f make build/all.gyp \
290    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
291    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
292    -Duse_system_ffmpeg=1 \
293    -Duse_system_zlib=1 \
294    -Duse_system_libpng=1 \
295    -Duse_system_bzip2=1 \
296    -Duse_system_libbz2=1 \
297    -Duse_system_libjpeg=1 \
298    -Duse_system_libxml=1 \
299    -Duse_system_libxslt=1 \
300    -Duse_system_libevent=1 \
301    -Duse_system_vpx=1 \
302    -Dproprietary_codecs=1 \
303    -Dlibrary=shared_library \
304    -Djavascript_engine=v8 \
305    -Dlinux_fpic=1 \
306    %{?with_system_icu:-Duse_system_icu=1} \
307    %{!?with_system_icu:-Duse_system_icu=0} \
308    %ifarch %{ix86}
309        -Dtarget_arch=ia32 \
310         -Ddisable_sse2=1 \
311    %endif
312    %ifarch x86_64
313        -Dtarget_arch=x64 \
314    %endif
315    %if %{?_dist_release} == "vl6"
316        -Dno_strict_aliasing=1 -Dgcc_version=44 \
317    %endif
318    -Drelease_extra_cflags=-fPIC \
319    ;
320
321#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
322#%__make -r -j5 chrome BUILDTYPE=Release
323%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
324
325popd
326
327%install
328%{__rm} -rf %{buildroot}
329
330%__mkdir -p %{buildroot}%{_bindir}
331%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
332# x86_64 capable systems need this
333%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
334%__mkdir -p %{buildroot}%{_libdir}/chromium/
335%__mkdir -p %{buildroot}%{_mandir}/man1/
336pushd src/out/Release
337%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
338%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
339%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
340%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
341%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
342#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
343%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
344%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
345%if %{?_dist_release} == "vl6"
346fdupes %{buildroot}%{_mandir}/man1/
347%endif
348popd
349
350# devel package install
351mkdir -p %{buildroot}%{_libdir}/chromium/include
352pushd src
353find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
354find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
355find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
356find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
357find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
358find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
359find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
360find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
361find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
362find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
363find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
364find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
365find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
366popd
367find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
368%if %{?_dist_release} == "vl6"
369fdupes %{buildroot}%{_libdir}/chromium/include
370%endif
371
372%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
373cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
374Name: Chromium browser
375Description: Chromium browser development package
376Version: 1.0.1
377Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
378Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
379EOF
380
381%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
382%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
383
384%__mkdir_p %{buildroot}%{_datadir}/applications/
385desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
386
387%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
388%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
389
390# # link to browser plugin path.  Plugin patch doesn't work. Why?
391# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
392# pushd %{buildroot}%{_libdir}/%{name}
393# %{__ln_s} %{_libdir}/browser-plugins plugins
394# popd
395pushd %{buildroot}%{_libdir}/%{name}
396%ifarch x86_64
397%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
398%else
399%{__ln_s} %{_libdir}/mozilla/plugins plugins
400%endif
401
402## support ffmpeg libs
403touch %{buildroot}%{_libdir}/libavcodec.so.52
404%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
405touch %{buildroot}%{_libdir}/libavformat.so.52
406%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
407touch %{buildroot}%{_libdir}/libavutil.so.50
408%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
409popd
410
411# Install the master_preferences file
412%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
413#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
414%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
415#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
416
417%clean
418%{__rm} -rf %{buildroot}
419
420
421%files
422%defattr(-,root,root,-)
423%config %{_sysconfdir}/%{name}
424%dir %{_datadir}/gnome-control-center
425%dir %{_datadir}/gnome-control-center/default-apps
426%{_bindir}/chromium
427%{_libdir}/chromium/chromium
428# These unique permissions are intentional and necessary for the sandboxing
429#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
430%{_libdir}/chromium/plugins/
431%{_libdir}/chromium/resources/
432%{_libdir}/chromium/xdg-settings
433%{_mandir}/man1/chrom*
434%{_datadir}/pixmaps/chromium-browser.png
435%{_datadir}/applications/*.desktop
436%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
437%{_libdir}/chromium/libavcodec.so.52
438%{_libdir}/chromium/libavutil.so.50
439%{_libdir}/chromium/libavformat.so.52
440%exclude %{_libdir}/libavcodec.so.52
441%exclude %{_libdir}/libavutil.so.50
442%exclude %{_libdir}/libavformat.so.52
443## libs
444%dir %{_libdir}/chromium/
445%{_libdir}/chromium/chrome.pak
446%{_libdir}/chromium/resources.pak
447%{_libdir}/chromium/locales/
448%{_libdir}/chromium/lib*.so
449
450%files devel
451%defattr(-,root,root,-)
452%{_libdir}/chromium/include/
453%{_libdir}/pkgconfig/chromium-browser.pc
454
455%changelog
456* Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
457- updated to 10.0.622.0
458- added BuildRequires: libXt-devel
459
460* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
461- updated to 10.0.605.0
462- added BuildRequires:
463  - libXdamage-devel
464  - hunspell-devel
465
466* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
467- updated to 9.0.598
468
469* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
470- updated to 9.0.593
471
472* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
473- updated to 9.0.582
474- added Requires: xdg-utils
475
476* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
477- updated to 9.0.578
478
479* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
480- updated to 9.0.569
481
482  * Mon Oct 25 2010 tittiatcoke@gmail.com
483  - Update to 9.0.564 build
484    * Added specific patches for MeeGo.
485    * We are now using shared libraries for Chromium
486    * Spec-file cleanup (Thanks to prusnak)
487
488* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
489- updated to snapshot 8.0.556
490
491* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
492- updated to snapshot 8.0.551
493
494* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
495- updated to snapshot 7.0.527
496
497* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
498- updated to snapshot 7.0.519
499
500* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
501- updated to snapshot 7.0.513
502  - updated chromium-vendor-vine.patch.in
503
504* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
505- updated to snapshot 7.0.507
506
507* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
508- updated to snapshot 7.0.498
509
510* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
511- updated to snapshot 6.0.493
512- used with_system_icu (for vl6)
513  - added BuildRequires: libicu-devel
514
515* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
516- build for Vine Linux 5.x
517  - add BuildRequires: gnome-keyring-devel
518
519* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
520- updated to snapshot 6.0.454
521- added BuildRequires:
522  - sqlite3-devel
523  - gnutls-devel
524  - libgnome-keyring-devel
525
526* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
527- updated to snapshot 6.0.431.0 r49253
528- added BuildRequires: cups-devel
529
530* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
531- updated to snapshot 6.0.405.0 r47263
532
533* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
534- unused with_system_icu (for vl6)
535  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
536
537* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
538- updated to snapshot 5.0.378.0 r44472
539  - used with_system_icu (for vl6)
540  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
541
542* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
543- updated to snapshot 5.0.372.0 r43947
544- added BuildRequires: glew-devel
545- changed Group tag to Applications/Internet
546- added Summary(ja) and %%description -l ja
547
548* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
549- updated to snapshot 5.0.365.0 r42966
550- merged 5.0.353.0-4vl5
551 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
552 - build on Vine Linux 5.1
553   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
554
555* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
556- updated to snapshot 5.0.364.0 r42779
557
558* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
559- updated to snapshot 5.0.359.0 r42116
560- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
561
562* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
563- fixed master_preferences.vine, little
564
565* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
566- fixed to install master_preferences
567- dropped chromium-5.0.353-no-ffmpeg-vine.patch
568
569* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
570- applied chromium-5.0.353-no-ffmpeg-vine.patch
571
572* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
573- updated to snapshot 5.0.353.0 r41449
574  * Wed Mar 10 2010 bgmerrell@novell.com
575  - Add master_preferences source file and install it to /etc/chromium.
576  - Create a new patch (chromium-master-prefs-path.patch) which tells
577    chromium to look in /etc/chromium for the master_preferences file
578    (instead of looking in the default directory, which is the same
579    directory as the 'chrome' binary).
580
581* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
582- updated to snapshot 5.0.335.0 r39556
583
584* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
585- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
586
587* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
588- updated to snapshot 5.0.330.0 r39074
589
590* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
591- use_system_ffmpeg
592
593* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
594- added Requires:  nspluginwrapper
595- fixed a symbolic link of plugins directory with nspluginwrapper
596
597* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
598- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
599
600* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
601- added BuildRequires: mesa-libGLU-devel
602- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
603
604* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
605- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
606
607  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
608  - Update to 4.0.260
609  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
610  - Update to 4.0.259
611  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
612  - Update to 4.0.258
613  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
614  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
615    changed to having an built-in v8
616  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
617  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
618  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
619  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
620  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
621  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
622  - update to newer svn snapshot
623    + Obsoletes fwrite patch (included upstream)
624  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
625  - update to newer svn snapshot
626    + Requires newer version of v8
627  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
628  - do not force SSE on x86 (drop-sse.patch)
629  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
630  - Update to newer svn snapshot
631  - Fixed spec file in order to build
632  - Included patch to build with system zlib
633  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
634  - package renamed to chromium
635  - cleaned up spec file
636  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
637  - v8 is now built as a separate package, and is required
638  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
639  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
640  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
641  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
642  - initial build
643
644#% changelog
645* Sun Jan 24 2010 prusnak@suse.cz
646- added vendor to user agent (chromium-vendor.patch.in)
647* Sun Nov 29 2009 prusnak@suse.cz
648- added --enable-sync to wrapper to enable bookmark sync
649* Sun Nov 29 2009 tittiatcoke@gmail.com 
650- Update to 4.0.260
651* Fri Nov 27 2009 tittiatcoke@gmail.com 
652- Update to 4.0.259
653* Thu Nov 26 2009 tittiatcoke@gmail.com 
654- Update to 4.0.258
655* Tue Nov 24 2009 tittatcoke@gmai.com 
656- In order to complete prevent the wrong v8 version to be used,
657  the Chromium build has been changed to having an built-in v8
658* Tue Nov 24 2009 dbuck@example.com 
659- Re-base patches.
660- Fixed a few patch errors.
661- Rename some patches to better correspond with function.
662- Removed some patches.
663- Minor SPEC changes.
664- I changed the v8 requirement to be exact, instead of greater than a specific version.
665* Fri Nov 13 2009 tittiatcoke@gmail.com
666- update to 247.0 svn 31928
667* Fri Oct 30 2009 tittiatcoke@gmail.com
668- update to 229.0 svn 30454
669  + Fix regression where popups and app frames lost their titlebars.
670  + Makes it so that when a folder is open on the bookmark bar
671    and the mouse moves over another folder, the menu for that
672    folder is shown.
673  + Lazily create the find bar.
674  + Polish to the gmail checker sample.
675  * New, crisper icons that are exactly 19x19
676  * Add a loading animation at the beginning before Gmail
677    responds.
678  * Fix a bug where we sometimes don't update the UI after a
679    logout/login cycle.
680  + Refactor widget methods to support desktop notifications,
681    including GTK stubs.
682  + Find-in-page should not ding while deleting characters.
683  + Add SSL wrapper for linux and mac.  This allows notifier to
684    use chrome's SSL layer instead of OpenSSL.
685  + Add three of the six extensions to PAC that Internet Explorer supports.
686  + WebSocket support in chromium. (Run with --enable-web-sockets
687    enables WebSocket features.)
688  + Do not allow GTK File Chooser dialogs to return directories.
689  + Fix the notifier SSL layer to make notifications work for
690    Linux Bookmark sync.
691  + linux: don't override mouse selection behavior in omnibox
692* Sun Oct 25 2009 tittiatcoke@gmail.com
693- Update to 224.4 svn 30027
694  + First cut at new page and browser action docs based
695    on new API. Deleted old stuff.
696  + Add suppression for new memory leak caused by WebKit merge 49830:49844
697  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
698  + Minimize dependency of user scripts
699  + Fixup the flip_framer eof-handling semantics now that we have
700    the FIN bit in place
701  + app depends on x11 because of active_window_watcher_x
702  + Adding two images for the new Extension managment UI
703  + Removing hard-coded Chrome Frame output path
704  + Rearrange clipboard code
705  + Fix crash bug when attempting to download a url with unsupported scheme,
706    e.g. 'data:', by 'Alt + Click'
707  + GTK: Change text for extension download UI
708  + Ignore invalid urls on command line
709  + Make dropped tabs animate from where they were dropped.
710  + Make room for the full width of the tab placeholder.
711  + Make tab dragging as smooth as glass.
712  + Remove an annoying NOTIMPLEMNETED
713  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
714  + If we're in the middle of a drag, don't allow the user to middle
715    click to close or right click for the context menu
716  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
717  + Remove +x bit from files that shouldn't have it
718  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
719  + Adding new image needed for the managment UI
720  + Fix a race bug where content scripts would not apply to the first page load
721  + Make escape remove a bookmark if it's just been added (but not if it already existed)
722  + Fix bubbles deactivating the opaque frame
723  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
724  + ake all pepper plugins default to windowless and transparent
725  + Add styles for printing
726  + Implement the new extension management UI
727  + Add support for to automation interface load install and load extensions
728  + GTK: theme the info bar border
729  + Update V8 to version 1.3.16.1
730  + Introduce WebSecurityPolicy for security related methods
731  + New button scheme...borders are separate from the inner contents so
732    that they can be highlighted / depressed independently
733  + When opening Chrome maximized with an application window already
734    running, the Chrome window was not activated
735  + Fix compatibility problems with FileZilla FTP Server
736  + Remove the extension shelf on Linux
737  + Fix the proxy host and port string to start with http:// if it does not already
738  + Enable HTML5 databases for all extension renderer processes
739* Sat Oct 24 2009 prusnak@opensuse.org 
740- don't create desktop files in wrapper
741- fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
742* Tue Oct 20 2009 tittiatcoke@gmail.com 
743- update to newer svn snapshot
744  + Obsoletes fwrite patch (included upstream)
745* Fri Oct 16 2009 tittiatcoke@gmail.com 
746- update to newer svn snapshot
747  + Requires newer version of v8
748* Thu Oct 15 2009 prusnak@suse.cz 
749- do not force SSE on x86 (drop-sse.patch)
750* Tue Oct 13 2009 tittiatcoke@gmail.com 
751- Update to newer svn snapshot
752- Fixed spec file in order to build
753- Included patch to build with system zlib
754* Mon Oct 12 2009 prusnak@suse.cz 
755- package renamed to chromium
756- cleaned up spec file
757* Tue Oct  6 2009 dbuck@example.com 
758- v8 is now built as a separate package, and is required
759- included many patches to use system libraries:
760    v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
761* Thu Oct  1 2009 dbuck@example.com 
762- included a newer DEP than is in svn, native_client@823
763- things should compile cleanly now
764* Mon Aug 31 2009 dbuck@example.com 
765- initial build
Note: See TracBrowser for help on using the repository browser.