source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 2346

Revision 2346, 27.6 KB checked in by munepi, 14 years ago (diff)

updated chromium-vl.spec, v8-vl.spec

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 68964
12%define v8_ver 3.0.0
13
14Name:           chromium
15Summary:        Google's opens source browser project
16Summary(ja):    Googleのオープンソースウェブブラウザ
17#'
18Version:        10.0.610.0
19Release:        1%{?_dist_release}
20License:        BSD
21Group:          Applications/Internet
22Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
23## The following are included for source reasons only
24# Custom build tools for chromium, hammer is a fancy front-end for scons
25Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
26# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
27Source2:        repack_chromium_archive.sh
28# Script used to create the tar.lzma archive from a checked out source
29Source3:        pack_chromium_source.sh
30# Official ffmpeg headers
31Source8:        ffmpeg-0.6-headers.tar.bz2
32#Source10:       chromium.desktop
33#Source10:       chromium-vine.desktop
34# Patch template which adds vendor to user agent
35##!!Source20:       chromium-vendor.patch.in
36Source20:       chromium-vendor-vine.patch.in
37# Set default prefs
38##!!Source30:       master_preferences
39Source30:       master_preferences.vine
40#Source31:       default_bookmarks.html
41#Source31:       default_bookmarks.html.vine
42# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
43Source50:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
44Source99:       chrome-wrapper
45##!!Source100:      chromium-browser.sh
46Source100:      chromium-browser-vine.sh
47##!!Source101:      chromium-browser.desktop
48Source101:      chromium-browser-vine.desktop
49Source102:      chromium-browser.xml
50Source103:      chromium-browser-rpmlintrc
51
52%{?nosrc:NoSource: 0}
53%{?nosrc:NoSource: 1}
54%{?nosrc:NoSource: 50}
55
56Provides:       chromium-browser = %{version}
57##Provides:     chromium-based-browser
58##Obsoletes:      chromium-browser < %{version}
59
60## Start Patches
61# Many changes to the gyp systems so we can use system libraries
62# My first ever patch set.  I hope I did well.
63Patch3:         chromium-gyp-system-icu.patch
64Patch4:         chromium-no-sqlite-debug.patch
65Patch5:         chromium-gyp-system-04-nss-nspr.patch
66Patch7:         chromium-codechanges-nss-nspr.patch
67Patch8:         chromium-codechanges-zlib.patch
68Patch12:        chromium-no-test-sources.patch
69Patch13:        chromium-no-courgette.patch
70Patch14:        chromium-master-prefs-path.patch
71Patch17:        chromium-system-glew.patch
72Patch18:        chromium-system-expat.patch
73Patch19:        chromium-system-zlib.patch
74Patch20:        chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
75Patch21:        chromium-7.0.542.0-media-probe.patch
76Patch23:        chromium-disable-mmx.patch
77Patch25:        tcmalloc-factory.patch
78Patch26:        chromium-remoting-build-fix.diff
79#Patch27:        chromium-7.0.542.0-system-libjingle.patch
80Patch28:        chromium-7.0.500.0-system-speex.patch
81Patch29:        chromium-7.0.510.0-system-ffmpeg.patch
82Patch30:        chromium-7.0.510.0-fstat.patch
83#Patch31:        chromium-7.0.542.0-system-srtp.patch
84Patch32:        chromium-7.0.542.0-system-libvpx.patch
85#Patch33:        chromium-20090807-gyp-system-minizip.patch
86Patch34:        chromium-7.0.542.0-codechanges-system-minizip-v8.patch
87# Shared Library patches
88Patch60:        chromium-sharedlibfixes.patch
89Patch61:        chromium-shared-chromiumthreading.patch
90Patch62:        chromium-norpath.patch
91Patch63:        chromium-6.0.406.0-system-gyp-v8.patch
92# Patches for MeeGo Netbook
93Patch80:        chromium-browser-window-focus.patch
94Patch81:        chromium-20100319-default-browser-setting.patch
95Patch82:        chromium-20100506-expose-chromium-browser-api.patch
96Patch83:        chromium-fix-toolbar-icon-size.patch
97
98# Vine
99
100
101BuildRequires:  gcc gcc-c++
102%if %{?_dist_release} == "vl5"
103BuildRequires:  libstdc++34 libstdc++34-devel
104%elseif %{?_dist_release} == "vl6"
105BuildRequires:  libstdc++ libstdc++-devel
106%endif
107BuildRequires:  libevent
108##!!BuildRequires:  pkg-config
109BuildRequires:  python
110##!!BuildRequires:  python-xml
111BuildRequires:  python-pyxml
112BuildRequires:  perl bison flex gperf
113##!!BuildRequires:  wdiff
114##!!BuildRequires:  update-desktop-files
115BuildRequires:  lzma
116##!!BuildRequires:  mozilla-nss-devel
117BuildRequires:  nss-devel
118##!!BuildRequires:  alsa-devel
119BuildRequires:  alsa-lib-devel
120BuildRequires:  gtk2-devel
121BuildRequires:  glib2-devel
122BuildRequires:  cairo-devel >= 1.6
123##!!BuildRequires:  mozilla-nspr-devel
124BuildRequires:  nspr-devel
125##!!BuildRequires:  gconf2-devel
126BuildRequires:  GConf2-devel
127BuildRequires:  freetype2-devel
128##!!BuildRequires:  dbus-1-devel
129BuildRequires:  dbus-devel
130BuildRequires:  libxslt-devel
131BuildRequires:  libxml2-devel
132BuildRequires:  libjpeg-devel
133BuildRequires:  zlib-devel
134##!!BuildRequires:  libbz2-devel
135BuildRequires:  bzip2-devel
136BuildRequires:  cups-devel
137%if %{?_dist_release} == "vl6"
138BuildRequires:  fdupes
139%endif
140##!!BuildRequires:  libexpat-devel
141BuildRequires:  expat-devel
142BuildRequires:  libpng-devel
143BuildRequires:  sqlite3-devel
144BuildRequires:  gnutls-devel
145BuildRequires:  desktop-file-utils
146BuildRequires:  v8-devel = %{v8_ver}
147BuildRequires:  libvpx-devel
148%if %{?_dist_release} == "vl5"
149BuildRequires:  gnome-keyring-devel
150%elseif %{?_dist_release} == "vl6"
151BuildRequires:  libgnome-keyring-devel
152%endif
153BuildRequires:  glew-devel
154##!!BuildRequires:  Mesa-devel
155BuildRequires:  mesa-libGLU-devel
156BuildRequires:  hunspell-devel
157
158%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
159BuildRequires:  libevent-devel
160#BuildRequires:  libjingle-devel >= 0.4.0-7
161#BuildRequires:  srtp-devel
162BuildRequires:  speex-devel
163
164##Vine Linux
165Requires:       v8 = %{v8_ver}
166BuildRequires:  libXScrnSaver-devel
167BuildRequires:  libXtst-devel
168BuildRequires:  libXdamage-devel
169#BuildRequires:  gle-devel
170#BuildRequires:  webkit-gtk-devel
171#BuildRequires:  scons
172%ifarch x86_64
173Requires:  nspluginwrapper
174%endif
175
176##!!Requires:       alsa
177Requires:       alsa-lib
178Requires:       xdg-utils
179# shouldn't be required to name all dependencies
180# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
181
182BuildRoot:      %{_tmppath}/%{name}-%{version}-root
183
184%description
185Chromium is the open-source project behind Google Chrome.
186We invite you to join us in our effort to help build a safer, faster,
187and more stable way for all Internet users to experience the web,
188and to create a powerful platform for developing a new generation of
189web applications.
190
191%description -l ja
192Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
193私たちは、ウェブを体験しているすべてのインターネットユーザに対して
194より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
195そして、ウェブアプリケーションの新しい世代を発展させるように
196強力なプラットホームを作成するために、
197私たちの取り組みで私たちに加わるようにあなたを誘います。
198
199%package devel
200Summary:        Header file for chromium browser
201Group:          Development/Libraries
202Requires:       chromium = %{version}-%{release}
203
204%description devel
205This package contains the header files and pc file of chromium browser for
206applications which will use chromium browser APIs.
207
208
209%prep
210[ -d %{name} ] && %__rm -rf %{name}
211lzma -cd %{SOURCE0} | tar xf -
212%setup -D -T -n %{name}
213
214# use static libicu
215%if %{?_dist_release} == "vl5"
216cd src/third_party || exit 1
217    %__rm -rf icu || exit 1
218    tar jxvf %{SOURCE50} || exit 1
219    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
220cd - || exit 1
221%endif
222
223%patch60 -p1
224%patch61 -p1
225%patch62 -p1
226%patch63 -p1
227%patch80 -p1
228%patch81 -p1
229%patch82 -p1
230%patch83 -p1
231
232# use system libicu only if >= 4.0
233%{?with_system_icu:%patch3 -p1}
234
235%patch4 -p1
236%patch5 -p1
237%patch7 -p1
238%patch8 -p1
239%patch12 -p1
240%patch13 -p1
241%patch14 -p1
242%patch17 -p1
243%patch18 -p1
244%patch19 -p1
245%patch20 -p1
246%patch21 -p1
247%patch25 -p1
248%ifarch %ix86
249%patch23 -p1
250%endif
251%patch26 -p1
252#%patch27 -p1
253%patch28 -p1
254%patch29 -p1
255%patch30 -p1
256#%patch31 -p1
257%patch32 -p1
258#%patch33 -p1
259%patch34 -p1
260
261pushd src/third_party/ffmpeg/
262tar xf %{SOURCE8}
263popd
264
265%__rm -rf src/third_party/libvpx/ src/third_party/speex/
266
267# apply vendor patch after substitution
268%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
269
270%build
271
272## create make files
273
274PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
275for i in src/build/common.gypi; do
276        %__sed -i "s|'-march=pentium4',||g" $i
277        %__sed -i "s|'-msse2',||g" $i
278        %__sed -i "s|'-mfpmath=sse',||g" $i
279        %__sed -i "s|'-O<(debug_optimize)',||g" $i
280        %__sed -i "s|'-m32',||g" $i
281        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
282        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
283done
284# '
285
286pushd src
287
288./build/gyp_chromium -f make build/all.gyp \
289    -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
290    -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
291    -Duse_system_ffmpeg=1 \
292    -Duse_system_zlib=1 \
293    -Duse_system_libpng=1 \
294    -Duse_system_bzip2=1 \
295    -Duse_system_libbz2=1 \
296    -Duse_system_libjpeg=1 \
297    -Duse_system_libxml=1 \
298    -Duse_system_libxslt=1 \
299    -Duse_system_libevent=1 \
300    -Duse_system_vpx=1 \
301    -Dproprietary_codecs=1 \
302    -Dlibrary=shared_library \
303    -Djavascript_engine=v8 \
304    -Dlinux_fpic=1 \
305    %{?with_system_icu:-Duse_system_icu=1} \
306    %{!?with_system_icu:-Duse_system_icu=0} \
307    %ifarch %{ix86}
308        -Dtarget_arch=ia32 \
309         -Ddisable_sse2=1 \
310    %endif
311    %ifarch x86_64
312        -Dtarget_arch=x64 \
313    %endif
314    %if %{?_dist_release} == "vl6"
315        -Dno_strict_aliasing=1 -Dgcc_version=44 \
316    %endif
317    -Drelease_extra_cflags=-fPIC \
318    ;
319
320#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
321#%__make -r -j5 chrome BUILDTYPE=Release
322%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
323
324popd
325
326%install
327%{__rm} -rf %{buildroot}
328
329%__mkdir -p %{buildroot}%{_bindir}
330%__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
331# x86_64 capable systems need this
332%__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
333%__mkdir -p %{buildroot}%{_libdir}/chromium/
334%__mkdir -p %{buildroot}%{_mandir}/man1/
335pushd src/out/Release
336%__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
337%__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
338%__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
339%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/
340%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/
341#%__cp -a chrome_sandbox %{buildroot}%{_libdir}/chromium/chrome-sandbox
342%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
343%__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
344%if %{?_dist_release} == "vl6"
345fdupes %{buildroot}%{_mandir}/man1/
346%endif
347popd
348
349# devel package install
350mkdir -p %{buildroot}%{_libdir}/chromium/include
351pushd src
352find base -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
353find app -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
354find chrome -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
355find skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
356find build -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
357find googleurl -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
358find ipc -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
359find testing -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
360find net -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
361find third_party/skia -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
362find third_party/WebKit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
363find webkit -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
364find gfx -name "*.h" -exec %__cp --parents {} %{buildroot}%{_libdir}/chromium/include \;
365popd
366find %{buildroot}%{_libdir}/chromium/include -name "*.h" -exec chmod 644 {} \;
367%if %{?_dist_release} == "vl6"
368fdupes %{buildroot}%{_libdir}/chromium/include
369%endif
370
371%__mkdir_p %{buildroot}/%{_libdir}/pkgconfig
372cat <<EOF > %{buildroot}/%{_libdir}/pkgconfig/chromium-browser.pc
373Name: Chromium browser
374Description: Chromium browser development package
375Version: 1.0.1
376Libs: -L%{_libdir}/chromium -lapp_base -lappcache -lbase_i18n -lbase -lblob -lbrowser -lcacheinvalidation -lchrome_gpu -lchromoting_base -lchromoting_client -lchromoting_host -lchromoting_jingle_glue -lchromoting_protocol -lchromotocol_proto_lib -lcld -lcommon_constants -lcommon_net -lcommon -ldatabase -ldebugger -ldefault_plugin -ldynamic_annotations -lffmpeg -lfileapi -lgfx -lglue -lgoogleurl -lgtest -lharfbuzz_interface -lharfbuzz -lhttp_listen_socket -lhunspell -liccjpeg -lil -linstaller_util -lipc -ljingle_p2p -ljingle -lmedia -lmodp_b64 -lnet_base -lnet -lnotifier -lomx_wrapper -lots -lpcre -lppapi_plugin -lplugin -lprinting -lprofile_import -lprotobuf_lite -lrenderer -lsandbox -lsdch -lservice -lskia_opts -lskia -lsqlite3 -lsrtp -lssl_host_info -lssl -lsymbolize -lsyncapi -lsync_notifier -lsync -ltrace_proto_lib -lundoview -lutility -lwebcore_bindings -lwebcore_html -lwebcore_platform -lwebcore_remaining -lwebcore_svg -lwebkit -lwebkit_user_agent -lwebp -lworker -lwtf -lxdg_mime -lzlib
377Cflags: -I%{_libdir}/chromium/include -I%{_libdir}/chromium/include/skia/config
378EOF
379
380%__mkdir_p %{buildroot}%{_datadir}/pixmaps/
381%__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
382
383%__mkdir_p %{buildroot}%{_datadir}/applications/
384desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
385
386%__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
387%__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
388
389# # link to browser plugin path.  Plugin patch doesn't work. Why?
390# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
391# pushd %{buildroot}%{_libdir}/%{name}
392# %{__ln_s} %{_libdir}/browser-plugins plugins
393# popd
394pushd %{buildroot}%{_libdir}/%{name}
395%ifarch x86_64
396%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
397%else
398%{__ln_s} %{_libdir}/mozilla/plugins plugins
399%endif
400
401## support ffmpeg libs
402touch %{buildroot}%{_libdir}/libavcodec.so.52
403%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
404touch %{buildroot}%{_libdir}/libavformat.so.52
405%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
406touch %{buildroot}%{_libdir}/libavutil.so.50
407%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
408popd
409
410# Install the master_preferences file
411%__mkdir_p %{buildroot}%{_sysconfdir}/%{name}
412#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
413%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
414#%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{name}
415
416%clean
417%{__rm} -rf %{buildroot}
418
419
420%files
421%defattr(-,root,root,-)
422%config %{_sysconfdir}/%{name}
423%dir %{_datadir}/gnome-control-center
424%dir %{_datadir}/gnome-control-center/default-apps
425%{_bindir}/chromium
426%{_libdir}/chromium/chromium
427# These unique permissions are intentional and necessary for the sandboxing
428#%attr(4555, root, root) %{_libdir}/chromium/chrome-sandbox
429%{_libdir}/chromium/plugins/
430%{_libdir}/chromium/resources/
431%{_libdir}/chromium/xdg-settings
432%{_mandir}/man1/chrom*
433%{_datadir}/pixmaps/chromium-browser.png
434%{_datadir}/applications/*.desktop
435%{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
436%{_libdir}/chromium/libavcodec.so.52
437%{_libdir}/chromium/libavutil.so.50
438%{_libdir}/chromium/libavformat.so.52
439%exclude %{_libdir}/libavcodec.so.52
440%exclude %{_libdir}/libavutil.so.50
441%exclude %{_libdir}/libavformat.so.52
442## libs
443%dir %{_libdir}/chromium/
444%{_libdir}/chromium/chrome.pak
445%{_libdir}/chromium/resources.pak
446%{_libdir}/chromium/locales/
447%{_libdir}/chromium/lib*.so
448
449%files devel
450%defattr(-,root,root,-)
451%{_libdir}/chromium/include/
452%{_libdir}/pkgconfig/chromium-browser.pc
453
454%changelog
455* Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.610.0-1
456- updated to 10.0.610.0
457
458* Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
459- updated to 10.0.605.0
460- added BuildRequires:
461  - libXdamage-devel
462  - hunspell-devel
463
464* Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
465- updated to 9.0.598
466
467* Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
468- updated to 9.0.593
469
470* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
471- updated to 9.0.582
472- added Requires: xdg-utils
473
474* Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
475- updated to 9.0.578
476
477* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
478- updated to 9.0.569
479
480  * Mon Oct 25 2010 tittiatcoke@gmail.com
481  - Update to 9.0.564 build
482    * Added specific patches for MeeGo.
483    * We are now using shared libraries for Chromium
484    * Spec-file cleanup (Thanks to prusnak)
485
486* Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
487- updated to snapshot 8.0.556
488
489* Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
490- updated to snapshot 8.0.551
491
492* Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
493- updated to snapshot 7.0.527
494
495* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
496- updated to snapshot 7.0.519
497
498* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
499- updated to snapshot 7.0.513
500  - updated chromium-vendor-vine.patch.in
501
502* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
503- updated to snapshot 7.0.507
504
505* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
506- updated to snapshot 7.0.498
507
508* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
509- updated to snapshot 6.0.493
510- used with_system_icu (for vl6)
511  - added BuildRequires: libicu-devel
512
513* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
514- build for Vine Linux 5.x
515  - add BuildRequires: gnome-keyring-devel
516
517* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
518- updated to snapshot 6.0.454
519- added BuildRequires:
520  - sqlite3-devel
521  - gnutls-devel
522  - libgnome-keyring-devel
523
524* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
525- updated to snapshot 6.0.431.0 r49253
526- added BuildRequires: cups-devel
527
528* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
529- updated to snapshot 6.0.405.0 r47263
530
531* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
532- unused with_system_icu (for vl6)
533  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
534
535* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
536- updated to snapshot 5.0.378.0 r44472
537  - used with_system_icu (for vl6)
538  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
539
540* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
541- updated to snapshot 5.0.372.0 r43947
542- added BuildRequires: glew-devel
543- changed Group tag to Applications/Internet
544- added Summary(ja) and %%description -l ja
545
546* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
547- updated to snapshot 5.0.365.0 r42966
548- merged 5.0.353.0-4vl5
549 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
550 - build on Vine Linux 5.1
551   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
552
553* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
554- updated to snapshot 5.0.364.0 r42779
555
556* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
557- updated to snapshot 5.0.359.0 r42116
558- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
559
560* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
561- fixed master_preferences.vine, little
562
563* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
564- fixed to install master_preferences
565- dropped chromium-5.0.353-no-ffmpeg-vine.patch
566
567* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
568- applied chromium-5.0.353-no-ffmpeg-vine.patch
569
570* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
571- updated to snapshot 5.0.353.0 r41449
572  * Wed Mar 10 2010 bgmerrell@novell.com
573  - Add master_preferences source file and install it to /etc/chromium.
574  - Create a new patch (chromium-master-prefs-path.patch) which tells
575    chromium to look in /etc/chromium for the master_preferences file
576    (instead of looking in the default directory, which is the same
577    directory as the 'chrome' binary).
578
579* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
580- updated to snapshot 5.0.335.0 r39556
581
582* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
583- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
584
585* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
586- updated to snapshot 5.0.330.0 r39074
587
588* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
589- use_system_ffmpeg
590
591* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
592- added Requires:  nspluginwrapper
593- fixed a symbolic link of plugins directory with nspluginwrapper
594
595* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
596- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
597
598* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
599- added BuildRequires: mesa-libGLU-devel
600- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
601
602* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
603- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
604
605  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
606  - Update to 4.0.260
607  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
608  - Update to 4.0.259
609  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
610  - Update to 4.0.258
611  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
612  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
613    changed to having an built-in v8
614  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
615  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
616  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
617  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
618  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
619  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
620  - update to newer svn snapshot
621    + Obsoletes fwrite patch (included upstream)
622  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
623  - update to newer svn snapshot
624    + Requires newer version of v8
625  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
626  - do not force SSE on x86 (drop-sse.patch)
627  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
628  - Update to newer svn snapshot
629  - Fixed spec file in order to build
630  - Included patch to build with system zlib
631  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
632  - package renamed to chromium
633  - cleaned up spec file
634  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
635  - v8 is now built as a separate package, and is required
636  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
637  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
638  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
639  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
640  - initial build
641
642#% changelog
643* Sun Jan 24 2010 prusnak@suse.cz
644- added vendor to user agent (chromium-vendor.patch.in)
645* Sun Nov 29 2009 prusnak@suse.cz
646- added --enable-sync to wrapper to enable bookmark sync
647* Fri Nov 13 2009 tittiatcoke@gmail.com
648- update to 247.0 svn 31928
649* Fri Oct 30 2009 tittiatcoke@gmail.com
650- update to 229.0 svn 30454
651  + Fix regression where popups and app frames lost their titlebars.
652  + Makes it so that when a folder is open on the bookmark bar
653    and the mouse moves over another folder, the menu for that
654    folder is shown.
655  + Lazily create the find bar.
656  + Polish to the gmail checker sample.
657  * New, crisper icons that are exactly 19x19
658  * Add a loading animation at the beginning before Gmail
659    responds.
660  * Fix a bug where we sometimes don't update the UI after a
661    logout/login cycle.
662  + Refactor widget methods to support desktop notifications,
663    including GTK stubs.
664  + Find-in-page should not ding while deleting characters.
665  + Add SSL wrapper for linux and mac.  This allows notifier to
666    use chrome's SSL layer instead of OpenSSL.
667  + Add three of the six extensions to PAC that Internet Explorer supports.
668  + WebSocket support in chromium. (Run with --enable-web-sockets
669    enables WebSocket features.)
670  + Do not allow GTK File Chooser dialogs to return directories.
671  + Fix the notifier SSL layer to make notifications work for
672    Linux Bookmark sync.
673  + linux: don't override mouse selection behavior in omnibox
674* Sun Oct 25 2009 tittiatcoke@gmail.com
675- Update to 224.4 svn 30027
676  + First cut at new page and browser action docs based
677    on new API. Deleted old stuff.
678  + Add suppression for new memory leak caused by WebKit merge 49830:49844
679  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
680  + Minimize dependency of user scripts
681  + Fixup the flip_framer eof-handling semantics now that we have
682    the FIN bit in place
683  + app depends on x11 because of active_window_watcher_x
684  + Adding two images for the new Extension managment UI
685  + Removing hard-coded Chrome Frame output path
686  + Rearrange clipboard code
687  + Fix crash bug when attempting to download a url with unsupported scheme,
688    e.g. 'data:', by 'Alt + Click'
689  + GTK: Change text for extension download UI
690  + Ignore invalid urls on command line
691  + Make dropped tabs animate from where they were dropped.
692  + Make room for the full width of the tab placeholder.
693  + Make tab dragging as smooth as glass.
694  + Remove an annoying NOTIMPLEMNETED
695  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
696  + If we're in the middle of a drag, don't allow the user to middle
697    click to close or right click for the context menu
698  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
699  + Remove +x bit from files that shouldn't have it
700  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
701  + Adding new image needed for the managment UI
702  + Fix a race bug where content scripts would not apply to the first page load
703  + Make escape remove a bookmark if it's just been added (but not if it already existed)
704  + Fix bubbles deactivating the opaque frame
705  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
706  + ake all pepper plugins default to windowless and transparent
707  + Add styles for printing
708  + Implement the new extension management UI
709  + Add support for to automation interface load install and load extensions
710  + GTK: theme the info bar border
711  + Update V8 to version 1.3.16.1
712  + Introduce WebSecurityPolicy for security related methods
713  + New button scheme...borders are separate from the inner contents so
714    that they can be highlighted / depressed independently
715  + When opening Chrome maximized with an application window already
716    running, the Chrome window was not activated
717  + Fix compatibility problems with FileZilla FTP Server
718  + Remove the extension shelf on Linux
719  + Fix the proxy host and port string to start with http:// if it does not already
720  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.