source: projects/specs/trunk/c/chromium/chromium-vl.spec @ 1811

Revision 1811, 21.1 KB checked in by munepi, 14 years ago (diff)

updated chromium

Line 
1# Thanks to malcolmlewis for help with this script
2# Thanks to Tom "spot" Callaway for much of the patchwork
3# Thanks to jhaygood for most of the icu patch
4
5# norootforbuild
6
7%if %{?_dist_release} == "vl6"
8%define with_system_icu 1
9%endif
10
11%define svn_rev 58728
12
13Name:           chromium
14Summary:        Google's opens source browser project
15Summary(ja):    Googleのオープンソースウェブブラウザ
16#'
17Version:        7.0.519.0
18Release:        1%{?_dist_release}
19License:        BSD
20Group:          Applications/Internet
21Source0:        %{name}.%{version}.svn%{svn_rev}.tar.lzma
22## The following are included for source reasons only
23# Custom build tools for chromium, hammer is a fancy front-end for scons
24Source1:        http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
25# Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
26Source2:        repack_chromium_archive.sh
27# Script used to create the tar.lzma archive from a checked out source
28Source3:        pack_chromium_source.sh
29#Source10:       chromium.desktop
30Source10:       chromium-vine.desktop
31# Patch template which adds vendor to user agent
32##!!Source20:       chromium-vendor.patch.in
33Source20:       chromium-vendor-vine.patch.in
34##!!Source30:       master_preferences
35Source30:       master_preferences.vine
36#Source31:       default_bookmarks.html
37#Source31:       default_bookmarks.html.vine
38# icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
39Source100:      icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
40
41%{?nosrc:NoSource: 0}
42%{?nosrc:NoSource: 1}
43%{?nosrc:NoSource: 100}
44
45Provides:       chromium-browser = %{version}
46#Obsoletes:      chromium-browser < %{version}
47
48## Start Patches
49# Many changes to the gyp system so we can use system libraries
50# My first ever patch set.  I hope I did well.
51Patch3:         chromium-gyp-system-icu.patch
52Patch4:         chromium-no-sqlite-debug.patch
53Patch5:         chromium-gyp-system-04-nss-nspr.patch
54Patch7:         chromium-codechanges-nss-nspr.patch
55Patch8:         chromium-codechanges-zlib.patch
56#Patch9:         chromium-drop-sse.patch
57Patch10:        chromium-fix-wrapper.patch
58Patch12:        chromium-no-test-sources.patch
59Patch13:        chromium-no-courgette.patch
60Patch14:        chromium-master-prefs-path.patch
61#Patch15:        chromium-media-probe.patch
62Patch17:        chromium-system-glew.patch
63Patch18:        chromium-system-expat.patch
64Patch19:        chromium-system-zlib.patch
65Patch20:        chromium-noffmpeg.patch
66Patch21:        chromium-system-old-ffmpeg-way.patch
67Patch23:        chromium-disable-mmx.patch
68#Patch24:       chromium-fix-yuv_row_posix-shared.patch
69Patch25:        tcmalloc-factory.patch
70
71# Vine
72
73
74BuildRequires:  gcc gcc-c++
75%if %{?_dist_release} == "vl5"
76BuildRequires:  libstdc++34 libstdc++34-devel
77%elseif %{?_dist_release} == "vl6"
78BuildRequires:  libstdc++ libstdc++-devel
79%endif
80BuildRequires:  libevent
81##!!BuildRequires:  pkg-config
82BuildRequires:  python
83##!!BuildRequires:  python-xml
84BuildRequires:  python-pyxml
85BuildRequires:  perl bison flex gperf
86##!!BuildRequires:  wdiff
87##!!BuildRequires:  update-desktop-files
88BuildRequires:  desktop-file-utils
89BuildRequires:  lzma
90##!!BuildRequires:  mozilla-nss-devel
91BuildRequires:  nss-devel
92##!!BuildRequires:  alsa-devel
93BuildRequires:  alsa-lib-devel
94BuildRequires:  gtk2-devel
95BuildRequires:  glib2-devel
96BuildRequires:  cairo-devel >= 1.6
97##!!BuildRequires:  mozilla-nspr-devel
98BuildRequires:  nspr-devel
99##!!BuildRequires:  gconf2-devel
100BuildRequires:  GConf2-devel
101BuildRequires:  freetype2-devel
102##!!BuildRequires:  dbus-1-devel
103BuildRequires:  dbus-devel
104BuildRequires:  libxslt-devel
105BuildRequires:  libxml2-devel
106BuildRequires:  libjpeg-devel
107BuildRequires:  zlib-devel
108##!!BuildRequires:  libbz2-devel
109BuildRequires:  bzip2-devel
110BuildRequires:  cups-devel
111%if %{?_dist_release} == "vl6"
112BuildRequires:  fdupes
113%endif
114##!!BuildRequires:  libexpat-devel
115BuildRequires:  expat-devel
116BuildRequires:  libpng-devel
117BuildRequires:  sqlite3-devel
118BuildRequires:  gnutls-devel
119%if %{?_dist_release} == "vl5"
120BuildRequires:  gnome-keyring-devel
121%elseif %{?_dist_release} == "vl6"
122BuildRequires:  libgnome-keyring-devel
123%endif
124BuildRequires:  glew-devel
125##!!BuildRequires:  Mesa-devel
126BuildRequires:  mesa-libGLU-devel
127
128%{?with_system_icu:BuildRequires:  libicu-devel >= 4.0}
129BuildRequires:  libevent-devel
130
131##Vine Linux
132BuildRequires:  libXScrnSaver-devel
133#BuildRequires:  gle-devel
134#BuildRequires:  webkit-gtk-devel
135#BuildRequires:  scons
136%ifarch x86_64
137Requires:  nspluginwrapper
138%endif
139
140##!!Requires:       alsa
141Requires:       alsa-lib
142# shouldn't be required to name all dependencies
143# Requires:       mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
144## Recommends the ffmpeg libraries (available from packman)
145#Recommends:     libavcodec52 libavformat52 libavutil50
146
147BuildRoot:      %{_tmppath}/%{name}-%{version}-root
148
149%description
150Chromium is the open-source project behind Google Chrome.
151We invite you to join us in our effort to help build a safer, faster,
152and more stable way for all Internet users to experience the web,
153and to create a powerful platform for developing a new generation of
154web applications.
155
156%description -l ja
157Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
158私たちは、ウェブを体験しているすべてのインターネットユーザに対して
159より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
160ウェブアプリケーションの新しい世代を発展させるように
161強力なプラットホームを作成するために、
162私たちの取り組みで私たちに加わるようにあなたを誘います。
163
164
165%prep
166[ -d %{name} ] && %__rm -rf %{name}
167lzma -cd %{SOURCE0} | tar xf -
168%setup -D -T -n %{name}
169
170# use static libicu
171%if %{?_dist_release} == "vl5"
172cd src/third_party || exit 1
173    %__rm -rf icu || exit 1
174    tar jxvf %{SOURCE100} || exit 1
175    %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
176cd - || exit 1
177%endif
178
179# use system libicu only if >= 4.0
180%{?with_system_icu:%patch3 -p1}
181
182%patch4 -p1
183%patch5 -p1
184%patch7 -p1
185%patch8 -p1
186#%patch9 -p1
187%patch10 -p1
188%patch12 -p1
189%patch13 -p1
190%patch14 -p1
191#%patch15 -p0
192%patch17 -p1
193%patch18 -p1
194%patch19 -p1
195%patch20 -p1
196%patch21 -p1
197%patch25 -p1
198%ifarch %ix86
199%patch23 -p1
200%endif
201#%patch24 -p1
202
203
204# apply vendor patch after substitution
205%__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
206
207%build
208## create make files
209
210PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
211for i in src/build/common.gypi; do
212        %__sed -i "s|'-march=pentium4',||g" $i
213        %__sed -i "s|'-msse2',||g" $i
214        %__sed -i "s|'-mfpmath=sse',||g" $i
215        %__sed -i "s|'-O<(debug_optimize)',||g" $i
216        %__sed -i "s|'-m32',||g" $i
217        %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
218        %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
219done
220# '
221
222pushd src
223
224./build/gyp_chromium -f make build/all.gyp \
225    -Duse_system_ffmpeg=1 \
226    -Duse_system_zlib=1 \
227    -Duse_system_libpng=1 \
228    -Duse_system_bzip2=1 \
229    -Duse_system_libbz2=1 \
230    -Duse_system_libjpeg=1 \
231    -Duse_system_libxml=1 \
232    -Duse_system_libxslt=1 \
233    -Duse_system_libevent=1 \
234    -Dproprietary_codecs=1 \
235    -Dlinux_fpic=1 \
236    %{?with_system_icu:-Duse_system_icu=1} \
237    %{!?with_system_icu:-Duse_system_icu=0} \
238    %ifarch %{ix86}
239        -Dtarget_arch=ia32 \
240         -Ddisable_sse2=1 \
241    %endif
242    %ifarch x86_64
243        -Dtarget_arch=x64 \
244    %endif
245    %if %{?_dist_release} == "vl6"
246        -Dno_strict_aliasing=1 -Dgcc_version=44 \
247    %endif
248    -Drelease_extra_cflags=-fPIC \
249    ;
250
251#make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
252#%__make -r -j5 chrome BUILDTYPE=Release
253%__make %{?_smp_mflags} chrome BUILDTYPE=Release
254
255popd
256
257%install
258%{__rm} -rf %{buildroot}
259
260## Create install directories
261%{__mkdir_p} %{buildroot}%{_libdir}/%{name}
262%{__mkdir_p} %{buildroot}%{_bindir}
263%{__mkdir_p} %{buildroot}%{_datadir}/applications
264%{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
265%{__mkdir_p} %{buildroot}%{_mandir}/man1
266%{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
267
268# chromium 'make' deposits us back at the top level build directory
269pushd src/out/Release
270ls -l
271
272# clean somechromium-codechanges-zlib.patch
273# clean debug junk
274%{__rm} -rf obj/ mksnapshot obj.target obj.host
275find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
276# clean NaCl stuff...  maybe NaCl will be in its own package in the future.
277%{__rm} -f ncdecode_table ncdecode_tablegen
278# clean other temporary binaries used in the compilation of chromium
279%{__rm} -f protoc xdg-settings
280
281%{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
282
283# Man page
284[ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
285%__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
286
287# Add startup file with plugins enabled
288%{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
289#!/bin/bash
290%{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl --enable-nacl "\$@"
291EOF
292
293# # link to browser plugin path.  Plugin patch doesn't work. Why?
294# %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
295# pushd %{buildroot}%{_libdir}/%{name}
296# %{__ln_s} %{_libdir}/browser-plugins plugins
297# popd
298pushd %{buildroot}%{_libdir}/%{name}
299%ifarch x86_64
300%{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
301%else
302%{__ln_s} %{_libdir}/mozilla/plugins plugins
303%endif
304
305## support ffmpeg libs
306touch %{buildroot}%{_libdir}/libavcodec.so.52
307%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
308touch %{buildroot}%{_libdir}/libavformat.so.52
309%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
310touch %{buildroot}%{_libdir}/libavutil.so.50
311%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
312popd
313
314# Install desktop-related files
315%__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
316%__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
317desktop-file-install --vendor Vine                      \
318        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
319        --delete-original                               \
320        --mode 644                                      \
321        $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
322
323# Install the master_preferences file
324#%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
325%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
326
327## install o3d plugin
328#pushd src/o3d/build/out/Release
329#%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
330
331%clean
332%{__rm} -rf %{buildroot}
333
334
335%files
336%defattr(-,root,root)
337%doc src/AUTHORS src/LICENSE
338%dir %{_libdir}/%{name}
339%attr(0755,root,root) %{_bindir}/%{name}
340%{_mandir}/man1/*
341%{_datadir}/applications/*%{name}.desktop
342%{_datadir}/pixmaps/%{name}.png
343%{_libdir}/%{name}/*
344%config %{_sysconfdir}/%{name}
345#%{_libdir}/browser-plugins/*
346%exclude %{_libdir}/libavcodec.so.52
347%exclude %{_libdir}/libavutil.so.50
348%exclude %{_libdir}/libavformat.so.52
349
350%changelog
351* Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
352- updated to snapshot 7.0.519
353
354* Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
355- updated to snapshot 7.0.513
356  - updated chromium-vendor-vine.patch.in
357
358* Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
359- updated to snapshot 7.0.507
360
361* Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
362- updated to snapshot 7.0.498
363
364* Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
365- updated to snapshot 6.0.493
366- used with_system_icu (for vl6)
367  - added BuildRequires: libicu-devel
368
369* Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
370- build for Vine Linux 5.x
371  - add BuildRequires: gnome-keyring-devel
372
373* Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
374- updated to snapshot 6.0.454
375- added BuildRequires:
376  - sqlite3-devel
377  - gnutls-devel
378  - libgnome-keyring-devel
379
380* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
381- updated to snapshot 6.0.431.0 r49253
382- added BuildRequires: cups-devel
383
384* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
385- updated to snapshot 6.0.405.0 r47263
386
387* Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
388- unused with_system_icu (for vl6)
389  - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
390
391* Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
392- updated to snapshot 5.0.378.0 r44472
393  - used with_system_icu (for vl6)
394  - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
395
396* Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
397- updated to snapshot 5.0.372.0 r43947
398- added BuildRequires: glew-devel
399- changed Group tag to Applications/Internet
400- added Summary(ja) and %%description -l ja
401
402* Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
403- updated to snapshot 5.0.365.0 r42966
404- merged 5.0.353.0-4vl5
405 * Fri Apr  2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
406 - build on Vine Linux 5.1
407   - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
408
409* Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
410- updated to snapshot 5.0.364.0 r42779
411
412* Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
413- updated to snapshot 5.0.359.0 r42116
414- dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
415
416* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
417- fixed master_preferences.vine, little
418
419* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
420- fixed to install master_preferences
421- dropped chromium-5.0.353-no-ffmpeg-vine.patch
422
423* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
424- applied chromium-5.0.353-no-ffmpeg-vine.patch
425
426* Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
427- updated to snapshot 5.0.353.0 r41449
428  * Wed Mar 10 2010 bgmerrell@novell.com
429  - Add master_preferences source file and install it to /etc/chromium.
430  - Create a new patch (chromium-master-prefs-path.patch) which tells
431    chromium to look in /etc/chromium for the master_preferences file
432    (instead of looking in the default directory, which is the same
433    directory as the 'chrome' binary).
434
435* Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
436- updated to snapshot 5.0.335.0 r39556
437
438* Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
439- applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
440
441* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
442- updated to snapshot 5.0.330.0 r39074
443
444* Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
445- use_system_ffmpeg
446
447* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
448- added Requires:  nspluginwrapper
449- fixed a symbolic link of plugins directory with nspluginwrapper
450
451* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
452- replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
453
454* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
455- added BuildRequires: mesa-libGLU-devel
456- added BuildRequires: libstdc++34 libstdc++34-devel for vl5
457
458* Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
459- built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
460
461  * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
462  - Update to 4.0.260
463  * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
464  - Update to 4.0.259
465  * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
466  - Update to 4.0.258
467  * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
468  - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
469    changed to having an built-in v8
470  * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
471  - Re-base patches.  Fixed a few patch errors.  Rename some patches to better correspond with function.  Removed some patches.
472  - Minor SPEC changes.  I changed the v8 requirement to be exact, instead of greater than a specific version.
473  * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
474  - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
475  * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
476  - update to newer svn snapshot
477    + Obsoletes fwrite patch (included upstream)
478  * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
479  - update to newer svn snapshot
480    + Requires newer version of v8
481  * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
482  - do not force SSE on x86 (drop-sse.patch)
483  * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
484  - Update to newer svn snapshot
485  - Fixed spec file in order to build
486  - Included patch to build with system zlib
487  * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
488  - package renamed to chromium
489  - cleaned up spec file
490  * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
491  - v8 is now built as a separate package, and is required
492  - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
493  * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
494  - included a newer DEP than is in svn, native_client@823.  So things should compile cleanly now
495  * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
496  - initial build
497
498#% changelog
499* Sun Jan 24 2010 prusnak@suse.cz
500- added vendor to user agent (chromium-vendor.patch.in)
501* Sun Nov 29 2009 prusnak@suse.cz
502- added --enable-sync to wrapper to enable bookmark sync
503* Fri Nov 13 2009 tittiatcoke@gmail.com
504- update to 247.0 svn 31928
505* Fri Oct 30 2009 tittiatcoke@gmail.com
506- update to 229.0 svn 30454
507  + Fix regression where popups and app frames lost their titlebars.
508  + Makes it so that when a folder is open on the bookmark bar
509    and the mouse moves over another folder, the menu for that
510    folder is shown.
511  + Lazily create the find bar.
512  + Polish to the gmail checker sample.
513  * New, crisper icons that are exactly 19x19
514  * Add a loading animation at the beginning before Gmail
515    responds.
516  * Fix a bug where we sometimes don't update the UI after a
517    logout/login cycle.
518  + Refactor widget methods to support desktop notifications,
519    including GTK stubs.
520  + Find-in-page should not ding while deleting characters.
521  + Add SSL wrapper for linux and mac.  This allows notifier to
522    use chrome's SSL layer instead of OpenSSL.
523  + Add three of the six extensions to PAC that Internet Explorer supports.
524  + WebSocket support in chromium. (Run with --enable-web-sockets
525    enables WebSocket features.)
526  + Do not allow GTK File Chooser dialogs to return directories.
527  + Fix the notifier SSL layer to make notifications work for
528    Linux Bookmark sync.
529  + linux: don't override mouse selection behavior in omnibox
530* Sun Oct 25 2009 tittiatcoke@gmail.com
531- Update to 224.4 svn 30027
532  + First cut at new page and browser action docs based
533    on new API. Deleted old stuff.
534  + Add suppression for new memory leak caused by WebKit merge 49830:49844
535  + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
536  + Minimize dependency of user scripts
537  + Fixup the flip_framer eof-handling semantics now that we have
538    the FIN bit in place
539  + app depends on x11 because of active_window_watcher_x
540  + Adding two images for the new Extension managment UI
541  + Removing hard-coded Chrome Frame output path
542  + Rearrange clipboard code
543  + Fix crash bug when attempting to download a url with unsupported scheme,
544    e.g. 'data:', by 'Alt + Click'
545  + GTK: Change text for extension download UI
546  + Ignore invalid urls on command line
547  + Make dropped tabs animate from where they were dropped.
548  + Make room for the full width of the tab placeholder.
549  + Make tab dragging as smooth as glass.
550  + Remove an annoying NOTIMPLEMNETED
551  + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
552  + If we're in the middle of a drag, don't allow the user to middle
553    click to close or right click for the context menu
554  + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
555  + Remove +x bit from files that shouldn't have it
556  + Fold first 3 channels of multichannel instead of 5.  Use fixed point
557  + Adding new image needed for the managment UI
558  + Fix a race bug where content scripts would not apply to the first page load
559  + Make escape remove a bookmark if it's just been added (but not if it already existed)
560  + Fix bubbles deactivating the opaque frame
561  + Allow ESC to cancel ALT+SHIFT+T in Toolbar
562  + ake all pepper plugins default to windowless and transparent
563  + Add styles for printing
564  + Implement the new extension management UI
565  + Add support for to automation interface load install and load extensions
566  + GTK: theme the info bar border
567  + Update V8 to version 1.3.16.1
568  + Introduce WebSecurityPolicy for security related methods
569  + New button scheme...borders are separate from the inner contents so
570    that they can be highlighted / depressed independently
571  + When opening Chrome maximized with an application window already
572    running, the Chrome window was not activated
573  + Fix compatibility problems with FileZilla FTP Server
574  + Remove the extension shelf on Linux
575  + Fix the proxy host and port string to start with http:// if it does not already
576  + Enable HTML5 databases for all extension renderer processes
Note: See TracBrowser for help on using the repository browser.